WRT54G v5 loses static IP

Discussion in 'Cisco/Linksys Wireless Routers' started by WestonFire22, Dec 20, 2005.

  1. WestonFire22

    WestonFire22 Network Guru Member

    I have a WRT54G v5 with the 1.00.4 firmware and it like to sporadically lose the static IP address on the WAN side. When I go into the setup screen, the address and such is there but when I click on the status screen, it shows for the ip. I just have to go to the basic setup screen and re-apply the settings, they are all their just not being used apparently. It has also lost the netmask and gateway a couple times along with the static ip.

    Has anyone else ran into this? I know I should probably power off and reset that way, but I am hesitant to do that since I also have a WRE54 running with it and don't want to lose that setup (what a pain to get working).

    Anyways, looking for suggestions or other hints if anyone else has run across this.

  2. jot7

    jot7 Network Guru Member

    losing static ip??

    Just curious if you are using Bellsouth/SBC for your ADSL. I was having a similar problem with my ADSL line. I was keeping my static ip address and dns addresses, but the default gateway would disappear after a few hours and I would have to tell the router to reconnect to re-establish the connection. I am using the WRT54Gv5 router with the firmware upgrade 1.00.4. After many calls to Linksys and Bellsouth, Bellsouth decided that my modem may be to blame. I had a Westell 2100 modem that was three years old. They sent me a Westell 6100 with the latest firmware and after some fiddling around, I was able to get everything working. It is set to bridged ethernet mode and the router is still set to PPPoE even with a static ip (Bellsouth reccommended this setup). So far, so good. The connection has been stable for over 12 hours now without dropping out. I am hoping this fixed the problem, but after reading so many posts about problems with the Linksys router, I am wondering if I should look for another brand of router to use. I have a neighbor that is using a D-Link router and she is having the same problem with it dropping the connection and having to reset it. Both of our setups have the connection set to Keep Alive. If my setup stays up now, I will tell her to get her modem switched out too (she is using the old Westell 2100). Hope this helps.... :)
  3. WestonFire22

    WestonFire22 Network Guru Member

    No, I am on a wireless service (microlnk.com), I have an antenna outside and it goes into some sort of bridge then converts it to ethernet that goes right into my router. Mine seems to lose its settings after around 24 hours, then I may have to re-apply them a couple times in a couple hour time span, then I am good until the next evening. I had to unplug it today so I will see if the re-set helps it any.

  4. jot7

    jot7 Network Guru Member

    Well, I thought my setup was fixed, but this morning I had to pull the power plug and and reinstall it to get it back up. I have the UPnP device box enabled, so when I went to network places on my PC, the router icon was missing and it said it could not find the router. AS soon as I reinstalled the power plug, everything reconnected and I was able to get to the internet and the router setup page. The problem is definitely with the router and I will be calling Linksys today about this. I may try to find a v4 router in a local store in the next few days and install 3rd party software on it as it seems the LInksys software is too buggy and this new VxWorks software with the new firmware is still not right on the v5. I will let you know how things go once I do this. I do now from experience that the speed booster models do not have this problem as I have set up a few networks with those. Maybe I will buy one of those models instead. Good luck and happy holidays...
  5. zapp

    zapp Network Guru Member

    I have experienced the same problem with static ip set in the wrt54g v5, Have seen this occur on two of the v5, replaced them with wrt54gl's
  6. dlmcmurr

    dlmcmurr Network Guru Member

    I picked up a WRT54Gv5 last week to replace a dying off-brand. Upgraded it to 1.00.4. Am having similar Internet problems, but with loss of gateway setting. Still works locally, both wired and wireless. Also seems to be when I'm inactive, but I need more experience to know for sure. I login to router and do a disconnect and connect using IE, then all is well. Also have had the router's web interface to lockup on saving a change several times. The change gets saved, but web interface will never work again until I power it down. Wish I had known about v5 before I bought this one! :thumbdown:
  7. dlmcmurr

    dlmcmurr Network Guru Member

    BTW, I for got to say I'm a Bellsouth DSL user and using dynamic IP.
  8. d_kopf

    d_kopf Network Guru Member

    I have a WRT54G v5 router and ADSL with PPPoE and I'm experiencing problems with the router dropping the Default gateway periodically.
    After browsing this forum for similar problems and hopefully solutions with no luck on the solution part I decided to chat with Linksys.
    The guy I chatted with suggested that I should try changing the router's IP address to instead of which I had set it to before. In my ears the tip sounded like rubbish, but I gave it a try and it actually seems to be working. A sufficient amount of time hasn't passed yet to deem the connection 100% stable, but the improvement so far is still remarkable. Now the router hasn't dropped the gateway for, oh say a couple of hours, as opposed to before when it dropped every 15-30 minutes perhaps.
    Perhaps this is something for you guys as well?

    The other tip he shared with me was to set up the PPPoE connection in the modem instead of the router if the above procedure didn't work, but I'm hoping it won't come to that.

    If the procedure with changing the router's IP-address should prove itself to be a working solution, it will of course raise the question: Why?
    Is it a glitch in the firmware perhaps, and will it be fixed to allow freedom of choice pertaining to IP-address selection in the future?
  9. d_kopf

    d_kopf Network Guru Member

    Alas, I may have jumped to conclusions. It seems the router still drops the gateway, even though I changed the IP to

    DAMMIT!!!! :(
  10. d_kopf

    d_kopf Network Guru Member

    I may have solved the issue by my own, as it seems. Before I used the Secure Easy Setup feature, but now I have deactivated that feature in Wireless > Advanced wireless settings in the router's web interface, and set up everything manually. I did a reset to factory defaults, retained the default IP-address of and I'm using WEP-encryption.
    Perhaps it's the SES-feature that is simply crap? If so, I can live with it since I feel much more comfortable having full control anyway.

    UPDATE: Ten hours has passed and the router still works. I guess this problem is solved!
  11. sdewitti

    sdewitti Guest

    Same here. After 4 days and 3 times of it doing it I return to the store for a version4. Good Luck. I wish I would not have wasted my time on it.
  12. jot7

    jot7 Network Guru Member

    Well, I am still having the problem as is every one else who has a v5 router. I have played with so many different settings, that I know all of the above suggestions do not work. As for the post on the LAN addressing, I do know for a fact that the Bellsouth ADSL will have connections issues when using 192.168.1.x addressing, so use anything 2.x or higher. As for the gateway issue, that seems to be the common problem with v5 router. I know everyone who has posted here has set there connection to keep alive and NOT on demand, so that is not the issue. I spoke with someone at Linksys the other night about another problem I was having with a friend's WRT54GSv2 routers, and they said that VxWorks was working on a new firmware upgrade again. No time was given for a new patch, but it is obvious they are aware of the problem. I guess we will all just have to reset our connection every two to three days until they come out with a patch or until someone comes out with a third party firmware upgrade like our Linux brothers with older versions....
  13. spongebob

    spongebob Guest

    I've got the same problem, but my router gets itself a new IP from a DHCP on the network after losing the manually assigned one.
    I emailed the Linksys Support about it before christmas. In the reply i was told that they would send me a new beta firmware with a fix to this problem, but i never recieved that piece of software!
    So i still hope, they will get this fixed firmware from beta to public soon....
  14. zapp

    zapp Network Guru Member

    I have experienced the same problem on several v5 routers.

    wan ip adress shows on status page.

    Noticed a tip on another forum:

    back up and download the config-settings, then upload it up again.

    Try this and see if it helps.
  15. andrescasta

    andrescasta Network Guru Member

    Hello, i have the same problem, somes spec and an hypothesis:

    router wrt54g v5 1.00.4 (
    I am using a wifi b with static ip and have the same problem.....

    There is a setting that is called: Client Lease Time, it is in the DHCP settings, but probably the problem is that the router try ro renew all the ip's in the lan, and then not reconnect to ISP.
  16. muldereric

    muldereric Guest

    I have some other problems (...i think).
    Once in the hour (approx.) my WRT54G-v5 (f/w 1.00.4) router drops all local connections. Every wired and wireless connection loses it's connection with the router, resulting in Windows saying that the network connection is not fully operational (can't aquire an IP address).
    Anyone having experiences with that?
  17. jot7

    jot7 Network Guru Member

    I am pretty sure it is not a setting on the router as my router is only acting as that, a router. I have a Windows 2003 Server handling my DHCP request and DNS forwarding. The firmware is still not right yet is all.....
  18. Special_K

    Special_K Network Guru Member

    Try to flash it with new 1.00.6 firmware.

    Firmware 1.00.6
    - Resolves issues with WAP54G repeater mode
    - Resolves issues with certain PPPoE connection
    - Resolves issues with SES turning back on when applying settings
    - Resolves issues with WPA allowing Shared key selection
    - Resolves issues with web GUI ping function
    - Resolves issues with using MSN whiteboard
    - Resolves issues with instability when using Bittorent
    - Resolves issues with using certain ATA phone adapters
    - Resolves issues with connecting to NNTP news servers

  19. jot7

    jot7 Network Guru Member

    Well, gentlemen, as we have all probably have noticed, this latest firmware revision has done nothing to solve the connection isssue to the internet and we are still having to reset our router every few days. As soon as I can afford to, I am going to go look for some v3 and v4 routers to purchase. I am also going to purchase a Cisco 871W through my Cisco class at college. After reading many posts of this problem and seeing how Linksys is determined to use VxWorks on all of its new routers, I will now recommend to my clients to look at another brand. It is said when a company is more concerned about the bottom line and not customer service. I wish all of you luck in resolving your issues as Linksys is surely not going to do this for us!!!! :thumbdown:
  20. StuRowe

    StuRowe Guest

    Only just now tuning in. Bought a brand new WRT54G v5 a couple of weeks ago because VPN pasthru works with it and not with the RTP300 I got from Vonage. Anyway, I've been having the same drops of connections and my static IP address (I'm on a business account, cable modem) changes to a seemingly random address and the gateway changes as well. Quite a drag. I also have the most recent .6 firmware upgrade and it did not help. Linksys support gave me some instruction for flashing it that crippled the router, would not even come online. Luckily v5 has that Management Mode (apply power with reset button held in for 5 seconds) and I was able to reflash and get it working again. Now I'm coming here for help and news instead of Linksys!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice