WRT54G v5 *NEW* BETA firmware.

Discussion in 'Cisco/Linksys Wireless Routers' started by Special_K, Dec 6, 2005.

  1. Special_K

    Special_K Network Guru Member

    From Linksys Product Engineer:

    Please be aware that this is a beta firmware and is still under testing. I have only verified that this resolves issues that have been reported. Although it should not affect other functionalities, there are no guarantees until full testing is done. Please do not use this firmware if you do not feel comfortable with these terms. Thanks.


    Linksys, A division of Cisco Systems, Inc.

    Product: WRT54G

    Classification: Firmware Release History

    Firmware Date: 12/2/2005

    Release Date: 12/6/2005

    Last Firmware Version: 1.00.2
    Firmware 1.00.3 Build 006 BETA
    - Resolves issue with slow downstream speed
    - Resolves issue where certain websites do not load, or load slowly
    - Resolves issue with obtaining IP address from Windows 2000 DHCP server

    Firmware 1.00.2 Build 004 BETA
    - Resovles issue where the router will issue "update_request" to DDnS_Server when IP address is renewed even it is not changed.
    - Stops all "update_request" after get "ABUSE" from DDns_Server
    1. IP change
    2. power recycle
    3. user press "APPLY" at DDNS_PAGE (Route's UI)

    Firmware 1.00.2 BETA
    - Resolves issue with SES and interoperability with other adapters
    - Resolves issue with DynDNS abusive updates

    Firmware 1.00.1 BETA
    - Resolves issue with enabling remote management
    - Resolves issue with unstable device boot up
    - Resolves issue with International country codes

    Firmware 1.00.0
    - Initial Release

    ** NOTE ** This firmware is only compatible with WRT54G v.5 or above. Please check the bottom of your router for the router's hardware version.


  2. jdepew

    jdepew Administrator Staff Member Member

    Anybody with a v5 with slow download speeds willing to give this a shot and report back to us?
  3. Bazzek

    Bazzek Network Guru Member

    Going to try this in a bit, who knows it may work
  4. Bazzek

    Bazzek Network Guru Member

    Okay, first impression, connection seems faster and uploading (FTP connection from office to server at home) is running for over 9 min at max speed now. well over 40Mb downloaded (never reached 20Mb before).

    Will keep you all posted to the results on this one.
  5. Bazzek

    Bazzek Network Guru Member

    Okay, after 18 min and 35 sec the connection hung again and the router rebooted. Although the download speeds on the lan are much better, the upload issues are not 100% gone. In this case i managed to upload 78Mb of a 1.4Gig file.

    This firmware is a step in the right direction but does not solve all issues.
  6. Special_K

    Special_K Network Guru Member

    I reported your upload issues to my Linksys contact. :)
  7. Diavonex

    Diavonex Network Guru Member

    May I know what is your MTU setting.
  8. Special_K

    Special_K Network Guru Member

    He said that he will test upload and let me know about it. But as far he knows they didn't have any upload issues.
  9. moorekyl

    moorekyl Guest

    speeds are faster, but SES Light no longer works.
  10. gaogi

    gaogi Network Guru Member

    I was able to upload a 700MB file to an external FTP servers with no problems.
  11. gaogi

    gaogi Network Guru Member

    I just read your post here: http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=2601&start=580

    I'll try to recreate the environment and test again.
  12. Bazzek

    Bazzek Network Guru Member

    I currently use the default of 1460

    It's not only happening with FTP uploads btw, i have the same issue when me and my GF play EverQuest over wireless (both machines that play are wireless). Sometimes the router just has a huge hickup. No fixed time though and i can't really measure the amount of data being transmitted.
  13. MrMerc

    MrMerc Network Guru Member

    This is way better than the latest official one, my router used to drop the connection every 2 minutes, going on 25 minutes now. Still have my fingers crossed.
  14. MrMerc

    MrMerc Network Guru Member

    So far so good, although cant get a high id in emule :sad:

    edit: connection died at 3.00, needed to reset router to get internet back :sad: :sad:
  15. NateHoy

    NateHoy Network Guru Member

    Time to call Linksys and trade in that V5 for a V4 or earlier...

    If not, well, best of luck (seriously, I mean that) in getting it to work. Hope it works out for you.
  16. Special_K

    Special_K Network Guru Member

    You must forward ports that eMule use: 4662 TCP and 4672 UDP. Then you will get High ID :)
  17. MrMerc

    MrMerc Network Guru Member

    Switched back to the old BEFW11S4 :rockon:
  18. gaogi

    gaogi Network Guru Member

    I re-created your setup:

    FTP server -> WRT54G v.5 -> Internet -> WRT54G -> Remote PC

    forwarded port 21 to the FTP server, and started a 2GB download on the remote PC. I was able to download the entire file successfully at around 500kbps (due to upstream bandwidth on the v.5 side).
  19. Bazzek

    Bazzek Network Guru Member

    Strange, i seem to get reboots on the firewall all the time. Just now i started eMule, and let people DL from me at max 27KBps, after about 12 min the router hickupped and i almost got disconnected from the game i was playing on another machine.

    I have another firewall, a Linux based computer, with that one i have no issues whatsoever (Pentium 200 with 64MB ram). I just want to switch to a easier to manage setup and the linksys seemed to be the trick.

    If this keeps going i will return the product and get my money back though.
  20. Special_K

    Special_K Network Guru Member

    I run eMule all the time.. and i didn't get a single reboot with WRT54G v.5
  21. Tuork

    Tuork Network Guru Member

    I've actually installed this firmware, but I am having problems with my PPPoE connection being established.

    It just won't work. Any ideas?

    Oh, and getting a v.4 or v.3 is out of the question. The bastards at the store I bought it have to "take it into revision for 5 days in order to check what I'm saying is true".... ugh.
  22. Tuork

    Tuork Network Guru Member


    Pretty please?
  23. gaogi

    gaogi Network Guru Member

    What have you tried so far?

    I would do this:

    1) Reset the router to factory defaults. Re-enter PPPoE settings.
    2) Unplug the power to the router and modem
    3) Plug in the power to the modem
    4) Plug in the power to the router
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice