WRT54G V5 Problems

Discussion in 'Cisco/Linksys Wireless Routers' started by Chappy316, Jan 24, 2007.

  1. Chappy316

    Chappy316 LI Guru Member

    sorry guys but i just cant find a straight answer on this one...

    i have a Linksys WRT54G v5 Wireless Router and having some major connectivity problems with it... when i first installed it i didnt have any problems, then randomly one day i started going down and losing connectivity on my laptop all the time... so i looked up some stuff here and traced the problem (most likely) to my bit torrent software which i have since stopped using wirelessly... now i am having problems even connecting to the router... i can associate to it fine but it wont give me an IP in my range, just gives me a random number and tells me there is limited to no connectivity and that i may not be able to access the web... my laptop is set to DHCP and the router has that enabled and im still not getting an IP thats in my range i have set... i just upgraded the firmware from 1.00.1 to 1.01.1 and it didnt do anything... my wired connections work fine but i am having issues connecting with 2 different laptops (Dell Inspiron E1405 and a Gateway laptop with an Orinoco card)...

    any help would be greatly appreciated...

    im actually thinking about taking the WRT54G back and getting a WRT54GS or WRT54GL if that would be worth my time and effort but after reading on here the GS seems like just as much of a hassle...

    thanks for helping the n00b and sorry in advance if its a dumb mistake somewhere on my part....
  2. GhaladReam

    GhaladReam Network Guru Member

    Take it back and get the GL. Put Tomato on it. Your problems will be solved :)
  3. Chappy316

    Chappy316 LI Guru Member

    whats Tomato and what are my benefits?

    and if i atleast switch to the WRT54GL will my problems go away for now? i may not do an upgrade of firmware right away as i have never run 3rd party firmware before...

    i just need to get myself back up and running ASAP and if the GL is my best option then i have to order one soon...
  4. GhaladReam

    GhaladReam Network Guru Member

    I have a freind who had a WRT54G v5 for about a year, and just recently trashed it for a WRT54GL. They keep telling me how much less of a headache the thing is. Especially when Tomato is put on it. Tomato is a 3rd party custom firmware made by a highly skilled firmware programmer, Jonathan (tofu).

    When they used to have the v5, they were plagued by the problems that you are describing as well. The upgrade they made was the best decision ever, according to them.
  5. ka9yhd

    ka9yhd LI Guru Member

    If you search the forums you will find a lot of posts from people complaining about the version 5, 6, and 7.

    I had a version 5 and I could not get it to pass VoIP through it. I could make phone calls but not receive them. I went round and round with Linksys tech support and the ended up doing an RMA return and they sent me a WRT54GL.

    Do yourself a favor and get the WRT54GL. Then you can use 3rd party firmwares if you choose to. The version 5 has limited amount of memory that will not allow you to put any 3rd party firmwares on it.

    Also the WRT54GS starting with version 5 has also been reduced on the amount of memory in it and is running VxWorks not Linux. And the same goes for the WRT54G versions 5, 6, and 7 they are running VxWorks too.
  6. rakeshjmd

    rakeshjmd LI Guru Member

    please reset the router for 30 sec & reconfigure the configure
  7. HennieM

    HennieM Network Guru Member

    Go for the GL. However, in the mean time, here's something to check:

    If you have any software running anywhere on your network that continually sends small packets, it may saturate the wireless, so the DHCP can not talk to your PC - the wired will be functioning normally, maybe slightly slower only. I get this behaviour when I run a multicast video server, even at low bitrates.

    If you are running Windoze, check the TCP/IP settings. Also go to your adapter's properties > Wireless networks, and delete all defined nets, then re-connect.

    If you have done that and it does not help, try, at a DOS prompt.

    ipconfig -release
    ipconfig -renew
  8. Chappy316

    Chappy316 LI Guru Member

    i cant even see the preferred wireless networks...

    and the release - renew didnt do anything but grab another random 169.254.x.x IP...


    (this is driving me nuts, i havent had wireless for almost 2 weeks now...)
  9. HennieM

    HennieM Network Guru Member

    The 169.254... IP address is shorthand for "I don't know what my IP address is", and it gets assigned by your PC (not by a DHCP server).

    What do you mean by
    You mean you don't see them when going to "View available Wireless Networks"? If so, that's why you should do

    Start > Control Panel > Network Connections

    then go into the properties of your wireless card, find the tab labelled "Wireless networks" and delete all defined networks there.

    If you now go to "View Available Wireless Networks", and you still don't see your wireless net, I think it's time you reset the router to defaults.

    Do this by holding the reset button at the back of the router in for 30 seconds; this will reset your router to pretty much defaults.
  10. Chappy316

    Chappy316 LI Guru Member

    problem solved.....
  11. HennieM

    HennieM Network Guru Member

    Do tell how, so we can all learn from it please.
  12. Chappy316

    Chappy316 LI Guru Member

    there was something going on with my wireless card in my laptop...

    we re-installed it and the connection came up (with other problems) and that was the only thing i hadnt tried...

    i made another thread about my new problems with speed though...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice