wrt54G V5 stops working and firmware update problems

Discussion in 'Cisco/Linksys Wireless Routers' started by sbiner, Jun 22, 2006.

  1. sbiner

    sbiner LI Guru Member


    I bought a wrt54G V5 about a month ago. I use it to split my cable modem between a desktop (via ethernet cable) and a laptop via wi-fi.

    At first, I used the provided software to set it up (thankfully, the desktop is an XP machine). It worked and after that I could hook the MacBook on the wi-fi signal.

    After the initial set-up, I noticed the set-up page was broken (like in this post). It was broken on both machine, using different browser (i.e. Safari, Firefox and Explorer). I tried to update the firmware, using the "managment mode" of the router but I ended up with a "update fail" message (without more info). I did not mind the broken page so much because it was working and I could set-up the router using the software on the XP desktop. Still I wonder what I would have done if I had only Macs (note : maybe there is a set-up program that runs on a Mac, I don't know)

    Now, since a few days, I do not know why but the router stops working sometimes. It happened twice in 3 days. I usually first notice it on my laptop where I have no signal and cannot hook up with the router or the broken set-up page. I then go to my Desktop and have the same problem, no internet, no set-up page, nothing. I end up unplugging the router and go through the router set-up program on the desktop.

    Since the router seems to have problems, yesterdays I tried again to update the firmware following the same path (hard reset + management mode) and it failed again. I tried to use the tftp.exe program but could not download it.

    At this point I managed to downoad the tftp.exe programm and will try to use it to update my firmware hoping this will fix the router and the set-up page.

    I am wondering ...

    1) why is my firmware update from the management mode failing? What can cause that?
    2) what can cause my router to stop working suddenly like it did in the last few days.

    Any help/pointer would be appreciated.

  2. sbiner

    sbiner LI Guru Member

    changed the router, works better but still intermitent prob.


    just in case it is useful to anybody.

    I gave up with my problems and exchanged (luckily on the last day that was possible) my faulty wrt54g for a new one.

    I pluged the new one, the set-up page was fine, I was able to upgrade the firmware and all seems fine.


    For some reasons, every once in a while (I use my laptop almost every evening for 1-2h and it happens every 2-3 days) I cannot log to router, and I do not get internet on the ethernet attached desktop either (so it is not a wi-fi interference problem). I then just take the power cord off the router for 1-2 sec and plug it again. After 30 sec it works again.

    I do not know what can cause that. Two bad hardware mean I would be really unlucky. Can my cable-modem be the problem? Power fluctuation?

    any (and I mean any because faulty hardware really makes me mad)
    pointer would be welcomed.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice