WRT54g v5 what now?

Discussion in 'Cisco/Linksys Wireless Routers' started by compfixr2, Jan 25, 2006.

  1. compfixr2

    compfixr2 Network Guru Member

    I just bought a wrt54gv5 router that one of our software vendors perfers. I've used linksys in the past with very good sucess, but this router is BAD! I keep loosing my internet connection every ten minutes or so. The hub(switch) connection stays good, but the connection with my dsl modem goes out repeatedly.

    If anyone can help me with this it would be great. I see where others are having a lot of problems with this box. I probably would have bought another brand if I had not had our software vendor ask for Linksys. If I can just get and keep a steady connection, I would be very pleased.

  2. NateHoy

    NateHoy Network Guru Member

    Well, you can try the latest firmware. The unit was originally plagued with huge amounts of bugs, but later firmware seems to have fixed many (though maybe not all) of them.

    Linksys was also offering an exchange for an older version upon request for the cost of shipping. You can call them and see if they are still doing this.
  3. sd2001

    sd2001 Network Guru Member

    I had a V3 for a few months that was atrocious. I took it back and what I got in exchange was a V5. I didn't know that these were supposedly worse until I found this site. I am having the EXACT same problem the OP is having even after I installed the latest firmware.

    I always heard that Linksys was the best. This router has really shown me otherwise!

    Would I really need to work out an exchange with Linksys or is there something else I could do?
  4. NateHoy

    NateHoy Network Guru Member

    Well, you can pick up a WRT54GL, which is a WRT54G V4 (Linux). You can also look for a WRT54GS that is before the V5 version, they may still be in stores. The new WRT54GS V5 is VXWORKS, just like the WRT54G V5, so if you want the tried-and-true Linux versions, AVOID:

    WRT54G: Serial number with "B" in the 4th position (CDFB...)
    WRT54GS: Serial number with "7" in the 4th position (CGN7...)

    Serial numbers are on the box. So you can go through store stock and maybe you'll hit pay dirt. Anything with serial numbers LOWER than the above should be Linux boxes, and take third party firmware, and have the old tried-and-true Linksys router capability. If you mail order these, you'll PROBABLY end up with a V5.

    WRT54GL: Any version is fine. Mail order only, though. They are not available in stores.
  5. sd2001

    sd2001 Network Guru Member

    Well, here is what I did:

    The connection seemed to be fine for a little while, but then it went out. For the record, I was running totally unencrypted just to make sure that the problem wasn't with an "advanced" function.

    When the connection went out this time, I did like I always do: I unplugged the router, plugged it back in, pulled up "Network Connections," disabled and then enabled the "Wireless Internet Connection." I did this 2 or 3 times, which has been the standard operating procedure to get my "trusty" router to get up and running again.

    So then I got cocky...

    I pulled up the interface, and switched channels from default channel 6 to 11. I figured that maybe changing to another channel wouldn't hurt and may even help. Everything was still fine.

    Then I enabled WEP.

    Christ wept.

    I knew that I had messed up as soon as I clicked the button to save settings. The interface went totally black and my connection was instantly dropped.

    I go through my usual routine to get it back up and running (unplug, plug, disabled, enable, wash, rinse, repeat...). Well, the connection came back up with a screaming 1.0 Mbps. Nice.

    So, I go back to the interface. Same place I have always gone before. When it pulls up, however, it is NOT the same. I double-check the address: Yup, that's right. It has similar features, but looks TOTALLY different. To top it all off, the Host name is now "Lauren." I never named my host before. Who the hell is Lauren?

    Desperate, I run to linksys.com to see if there is newer firmware. There is a 1.00.6 that was released Jan.17th. I don't have that. I rejoice.

    I download it quickly. I read the "read_me" file and it informs me that I must be wired into the router. No problem...

    Problem. I plug into the router and...nothing. I check everything. Local Area Connection should be working right? Nope.

    I do the ritual ((unplug, plug, disabled, enable, wash, rinse, repeat...). No dice. Lauren has me in a stranglehold now.

    I go back to the interface with the plan of disabling the WEP. Funny thing is, this interface says it's disabled.

    Before I got cocky and changed the channel/enabled WEP I was running at 54Mbphs. I was unencrypted and dropping signal every hour or so, but I was at least speedy. Now my connection is intemittent at best. I'll be surprised if I am able to post this. Once in a while my speed will "turbocharge" up to 2Mbphs, but those moments are fleeting.

    I haven't even shared the best part:

    I tried to call technical support. If, for nothig else, to start the ball rolling on a warranty return (the site says you need to get a case ID # to start the process). I get a:

    "Boop-beep-beeep! Your call cannot be connected as dialed. Please hang up and try your call again. If you feel you have reached this message in error..."

    Here is the number: (1-800-326-7114) Try it for yourself.

    I try the "Live Help" on the site. This part kills me. I cannot keep a connection long enough for someone to come up to speak to me.

    What I will probably end up doing is trying the tech support number a few more times tonight. If I dont get through, I'll try again tomorrow during business hours until I get SOMEONE. In the meantime, I'll probably just wire myself into my modem.


    Anyone had any luck getting a warranty return/exchange? What is the absolute best thing that I could get in exchange for this black and blue POS? An older version? 4 perhaps? Suggestions?
  6. NateHoy

    NateHoy Network Guru Member

    Sounds like you've been running unencrypted long enough that someone else got into your router. If you've been running "open" for a while, probably for P2P or some other purpose. Either that or you accidentally found another access point that has been interfering with yours all along. That might explain your problems - the router is either overloaded, or you're being knocked off by another router in the area that is interfering with yours.

    Press and hold the reset button on the router for 30 seconds to reset it to factory settings. Plug a computer directly into the router, with nothing else plugged in but power (especially no Internet). Reset the router config password to something secure and secure wireless immediately.

    From a laptop or other wireless computer, do a site survey to fine all other access points in the area. Pick a channel as far away from any other channels in use as possible.
  7. sd2001

    sd2001 Network Guru Member

    Normally I would agree that there may be another router interfering or that another user may be tampering, but I have to take into account of where I live: There isn't another home within a half mile and my driveway is over 300 yards long. Unless someone can be sitting out at my mail box at night tampering 300 yards away I don't think that is the issue.

    I am going to take your advice on just resetting the router with the button. I'll then just start from scratch the way I set it up in the first place: calling Knowledgy and letting them do it. That will get me through the night.

    I don't run P2P software and I have only had this router for about 2 weeks.

    Any suggestions on what router I should ask Linksys to replace this one with?
  8. NateHoy

    NateHoy Network Guru Member

    Ask for a V4 or prior, if they agree to the swap. Tried and true stuff, and you can load aftermarket firmware to make it sing and dance.
  9. sd2001

    sd2001 Network Guru Member

    Yeah, that's what I was thinking. Thanks for the help.
  10. compfixr2

    compfixr2 Network Guru Member

    Thanks all!

    I'm on my way to the store to see if there are other versions available. I did try to talk to Linksys and although the CSR I spoke to would not admit to a problem, she did not deny it either. They would not help until I exhausted my chances with the store, which may be logical or not.

    Anyway wish me luck to find another serial # under the shelves. Otherwise, I will have to go back to Linksys and give them another shot at swapping this unit for on e that actually works!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice