WRT54G v8 DHCP Client - Error with specific ISPs

Discussion in 'Cisco/Linksys Wireless Routers' started by samir.bot, Jan 18, 2008.

  1. samir.bot

    samir.bot Guest

    I have a new WRT54G v8 router. My ISP gives out DHCP addresses, which are NOT tied to specific MAC addresses (I can connect it to any of my home computers and it gets it DHCP address fine).

    Things were fine with the WRT54G for about a month, but suddenly the linksys router stopped getting DHCP-issued addresses from the ISP (no use of dhcp-release/renew buttons, resets, power cycles etc).
    But, when i connect the ISP's cable directly to my PC, all works fine. (Btw, the DHCP server within the linksys seems fine, as it issues IP addresses to my computers properly)

    Thinking there was a problem with the router, I checked it at my friend's place (served by different ISP) and it worked fine. It works fine in my office LAN as well.

    Contacted my ISP, but the best answer they can give is ...that "we haven't received any similar compliants from other customers...so must be something wrong with your router !!"

    So, what is this weird compatibility problem between the V8 dhcp client and my network's DHCP server ? I thought those things were pretty standardized by now.

    Any help ? (other than shifting to DD-wrt, which I am slightly worried since I did not see any links about ppl saying that they shifted v8 to dd-wrt nicely..infact read more about errors and reduced speed etc) ...

    Thanks in advance..

    PS - i upgraded the firmware to the latest available from linksys..i think v8.002 date d jun/jul 2007 ..(dont rem exactly now).
  2. tsberry901

    tsberry901 LI Guru Member

    One's man educated guess

    Someone with more knowledge than me is going to have to verify this, but I suspect that those with operating systems that are using tcpiv6 (instead of v4) may be the ones with the problem. In order for the operating system to communicate with the router it has to "fake" the existence v4 protocol. It does this by using the virtual ethernet adapter called "Teredo Tunneling Pseudo-Interface". Since this technology is somewhat new, I suspect the problem is actually in the operating system's handling of the protocol. Since the router is confused, it refuses to hand out IPs. (Is there someone out there with a detailed knowledge of pseudo interfaced network adapters?)

    If you think we all are having problems now, wait untill the tcpipv6 routers hit the mass market.

    Tom Berry
  3. tsberry901

    tsberry901 LI Guru Member

    Addition to my previous reply

    I also noticed that if you have bridged connections using tcpipv6 that you are even MORE likely to have DHCP problems. If you have a mix of v4 and v6 protocols on your network, try shutting down the v6 computers to see if they are the problem. If one of them is, then go into network properties and disable the v6 protocol on that computer. I would try disabling any bridges, first, though.

    Tom Berry
  4. btevdo

    btevdo Guest

    Samir, Try using the cd supplied with the router, I had the same problem but with a different version (v6) which wont acquire the IP from my isp which is comcast. I finally ended up buying a new linksys wrt54g v8.
    When I tried the new cd to setup my old faulty router (v6), instead of manually doing it, it started working. I'm keeping the new router though, since it has a faster processor.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice