WRT54G V8 Wireless Connected But No Internet

Discussion in 'Cisco/Linksys Wireless Routers' started by violagirl23, Dec 16, 2007.

  1. violagirl23

    violagirl23 LI Guru Member

    I recently purchased a WRT54G router and hooked it up to my home computer through ethernet, following the instructions on the install CD. It is running Windows XP. Our internet provider is AT&T's SBC DSL, which is PPPoE, so I appropriately set the connection type to PPPoE and entered the master screen name and password. The internet works fine on the computer connected via ethernet, but I also have a Windows Vista laptop (fairly new) which can detect the network and claims to be connected to it, but I cannot actually access web pages.
    I can ping the router but cannot ping, say www.yahoo.com. I also tried ipconfig /release and then ipconfig /renew. ipconfig shows that it appears to be giving the vista laptop an ip address (via DHCP). Here is all the configurations under ipconfig under the wireless stuff:

    Wireless LAN adapter Wireless Network Connection
    Connection-specific DNS Suffix:
    Link-local IPv6 Address: fe80:554d:4a2d:77cf:4608%10
    IPv4 Address:
    Subnet Mask:
    Default Gateway:

    The IPv4 Address I am assuming is the IP address assigned via DHCP, as the other computer has the address

    I tried SES under the router's settings and it didn't change anything.

    I just find it so stange that the laptop IS connecting to the router but not giving me internet access.

    If it helps, the modem is a SpeedStream 5100, and on the home computer (the ethernet connection), I often have to manually connect to the internet by going to "Connect To..." and then selecting the connection, under Broadband (dsl2). I'm not sure if this would be what is creating problems for the laptop, but it doesn't even work when the internet is up on this computer. Either way, it is claiming to be connected to the router even though I cannnot access webpages. I do not think it is a DNS issue, as I couldn't ping Yahoo's IP adderss either, and both IPv4 and v6 are set to get an ip address and DNS automatically.
    Any suggestions?
    Also, the modem is NOT currently set up into bridged mode, but I am assuming this is not necessary because the computer attached to the router via ethernet is getting internet. I did not do this because it seems like almost a point-of-no-return, because I do not know how to get a modem out of bridged mode without having to reset it. The default address for the modem is while Linksys's is, so I wouldn't imagine that the conflict is there.
    I have read some people having problems that are solved once they put the Linksys CD in their laptop as well to install the drivers. However, I cannot figure out how to use the CD to install the drivers and am not sure if this is the problem or not.
    Also, all security is currently disabled on the router to better enable me to troubleshoot this.
  2. Toxic

    Toxic Administrator Staff Member

    since you cannot ping a website address DNS maybe your issue. what is the DNS entry of your Vista computer and what DNS setting do you have on your WRT54G?

    is your DSL modem in bridge mode?
  3. violagirl23

    violagirl23 LI Guru Member

    I tried finding the IP address for Yahoo.com ( to see if it would work and check if it was DNS. Assuming I got the address right, it still did not work, which it would have if DNS was the problem, correct?
    Also, the modem is not in bridged mode, but the ethernet connection from the router to the home computer IS working.

    The DNS was set to automatically on the Vista computer. It appears to be set to the factory defaults on the router.
  4. violagirl23

    violagirl23 LI Guru Member

    So does no one have any idea? I consider myself generally pretty computer savvy, but whenever it comes to networking, none of my knowledge seems to work, because there's always some problem that just won't right itself, something that just isn't working. If I can't figure this out by tomorrow, my parents are making me return this router and buy the official one for our ISP, and it costs 40 dollars more!!!!!!!!!!!! I really don't want to have to pay 40 extra dollars, so does anyone have any ideas on what to do, as to why I'm just getting signal strength but no internet?
  5. 0nova

    0nova LI Guru Member

    Try this out just for ruling out sakes...

    1. Set your DSL modem in 'bridged' mode. For this you have to connect your DSL modem via cable to your computer.
    2. Set WRT54G in PPPoE and enter your username and password given by your ISP.
    3. Disable DHCP for the moment.
    4. Set the router's IP/Mask to
    5. Set the DNS to and ( this is the IP of opendns.com )
    6. On your Vista, open up TCPIP properties for the network card and set it's IP to
    7. Check and ensure that MAC of Vista's Wifi card is not blocked on the router.
    8. Make your Wifi "Open" for the time being (but do enable security later)

    As Toxic said earlier, probably the only reason why Vista can't get internet access but able to ping the router is because of a bad DNS entry.
  6. PeterT

    PeterT Network Guru Member

    I seem to remember some networking issue with Vista, some NIC drivers, and certain routers... Maybe related to blackhole discovery..

    Darned if I can remember exactly WHAT it was though! :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice