WRT54G Ver. 3.03.6

Discussion in 'Cisco/Linksys Wireless Routers' started by brymo, Apr 11, 2005.

  1. brymo

    brymo Network Guru Member

    Well i recently got one of these for my new psp.

    I got it from bestbuy, and i now have a problem.

    Everything was up and running in minutes and i was quite happy.. even the psp was online in just a few minutes.

    I have it wired to all my computers, but the wireless is only for psp at the moment.

    but now my internet drops out all the time, even if i am not downloading.. i will be in some irc chats, and it will slow down, and drop the connection, on my local direct connect server here on my campus, it drops out all the time..

    i am not downloading and it still does it - but it also does it around the same time when i am downloading..

    do i need to take this back now?

    or what should i do?

  2. Partizan

    Partizan Network Guru Member

    Having the same problem, it seems that the whole v2.2. series is malfunctionig. I got my second v2.2 and it is having the same symptoms. Hopefully it is only a firmware bug.

    Regards, Partizan
  3. -Dutch-

    -Dutch- Network Guru Member

    This looks the problem I am having, see this thread http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=4114
    However no answers to my problems yet, and I am therefore hoping to get a new device from the shop.
  4. brymo

    brymo Network Guru Member

    yeah i been going through the loops

    my downloads go normal than drop..

    i am on the phone with a linksys person now..

    they told me to change my MTU to around 1350 - which worked for a little bit - then it went back to its old ways..
  5. JohnnyCat

    JohnnyCat Network Guru Member

    I think its a firmware issue. I had a problem where I would lose my internet connection. I could ping the computers connected to the router (wired or wireless). But timed out when I pinged the router. If I power cycled the router, it would be fixed for antoher 24 hours or so. I got the Seasoft firmware no problems anymore.

    The Linksys tech support had me do the same thing -- lower the MTU's. Never worked for me.
  6. Burn

    Burn Network Guru Member

    I have the same problem and have just came to the forums.

    Guys I have a v2.2 and have the exact same problem. I have the latest 3.03.6 firmware from linksys but the problem still happens. I have not noticed it in wireless mode but my main pc witch is wired to it definately has the problem.

    I am connecting PPoE to Bellsouth DSL here in atlanta. What really pisses me off if I had a perfectly fine BEFSR41 and it worked flawlessly without problem. Now I buy a new one, give to old one to a friend just to inherit problems.

    I think linksys should recall all of the v2.2's because I have seen so many articles with this happening.

    Does anyone have a solution to this specific problem? I have only searched for the last couple of hours but I'm getting disconnected here and there.

    Thanks in Advance.
  7. jdepew

    jdepew Administrator Staff Member Member

    I'm going to push this back up to the top so that more people can chime in on this - I got an email about this late friday as well - seems to be a problem that 'all of a sudden' popped up. Both the v2.2 hardware and 3.03.6 firmware have been out for a while, lets see if we can get everyone with these problems to post their ISP/connection/network setup/non-default firmware settings/environment and see if we can narrow down a common cause.
  8. jdepew

    jdepew Administrator Staff Member Member

    hrmm... one solution that someone had on the linked thread was to lower wireless beacon from 100 to 50 to address the wireless issues (I suggest this as default, esp with WinXP clients), but you guys seem to be having problems with either just wired or both.

    I'm interested to see how this unfolds.
  9. -Dutch-

    -Dutch- Network Guru Member

    I have got this problem wired, however I sent mine back last week. I will make a call to the shop tomorrow and ask whether there is any news on my router.....
  10. linkybinky

    linkybinky Network Guru Member

    Same problem here with a WRT54G v 1.1

    Hi All!

    I've got the same problem since my ISP (Chello, (UPC, Netherlands)) replaced Com21 cable modem for a Motorola Surfboard 5100E.

    Modem to Networkcard on my PC, no problem. But when I connect the router to the internet an my PC to the router I am unable to surf / download. I've cloned the mac address and so on. When looking at the status on the Linksys router everything looks just fine (Ip (dynamic), Gateway, DNS) but the download is terrible. Tried different MTU setting, alternative firmware (sveasoft), changed the CAT5 cable from the router to the modem but no luck yet.

    Someone at Linksys ( in a chat) advised me to reset the router (hold the rest button for 30 sec. Disconnect power and hold the reset button for another 30 sec. and than power up holding the reset button for again 30 sec.) Well, again no luck.

    Since I've got a Edimax wireless router aswell, I tried that one to. Even though I prefer the Linksys it would be better as no router at all. So I configured the Edimax. This routers also appeared to be working when looking at the status. I connected my PC to the router but got the same problem. So I am starting to wonder whether there is anyone out there using a wireless router in combination with a Motorola SB5100 cable modem that works or not?

    Will let you all know when I find something out.


  11. gotamd

    gotamd Network Guru Member

    I've got a version 2.0 WRT54G at my house running Satori that is as stable as they get using wired and wireless connections connected to a Motorolla SB5100 and Comcast HSI. It stays connected with no drops or anything for months on end. When it does disconnect, it's usually due to Comcast fiddling with the network as far as I can tell. Try setting your Wireless Beacon Interval to 50ms instead of the default 100ms. After I made that part of the default config for my two WRT54G v2's they've never experienced any problems. This is with the Satori, Alchemy, and DD-WRT firmwares.
  12. linkybinky

    linkybinky Network Guru Member

    Hi Gotamd,

    Ive changed the setting to 50 but it didnt work for me. I havent got to wireless part yet. Im having this problem when wired to the router.

    Nevertheless, thanks for your reply! It sure made one thing clear, the WRT54G should work with the Motorola SB5100.

    PS: I am using a version 1.1 WRT54G Linksys.


  13. linkybinky

    linkybinky Network Guru Member

    Now I think I've got it! Finally!

    The configuratie was:

    Modem (motorola) --> about 10 mtr UTP Cat5 --> WRT54G --> 3 mtr UTP Cat5 --> PC.

    Replaced the router and now it is:

    Modem (motorola) --> 1 mtr UTP Patch Cat5 --> WRT54G --> about 10 mtr UTP Cat 5 --> PC.

    Haven't configured the wireless part yet.

    One problem left: I cant configure my network card to a speed of 100Mbps otherwise I'm not getting an IP address from the DHPC server in the router. I think one of the connectors on the 10 mtr UTP cable is not working proparly. Since I havent got a connector at the moment I'll have to get one and see how it works.
  14. gotamd

    gotamd Network Guru Member

    Yeah, that definitely sounds like a cable problem if just switching the cables around "fixed" it (though you're still having problems with the 10m one).
  15. Burn

    Burn Network Guru Member

    New Router Still Problems

    I spent some time to work out the issues with Linksys Tech support but they simply told me to replaces the router with a new one at the store. So in doing this I upgraded to the WRT54GS V2 from the WRT54G V2.2. But I still experiance the same problem with the new router. It's not as often but I've only had it for about 5 days, and I still get disconnected from my PPoE wether or not i'm wired or wireless. I have both.

    I have a total of 5 Wired Connections. 3 Direct to Router / 1 5-Port linksys Switch with the other 2 wired connections. We have two laptops that me and my fiance use.

    I notice this problem when most of the comptuers are working simultaneously at the same time. I also have this problem when moving files from one PC to a wired PC through the router. This problem seems to happen more often when I use WEP 128bit encryption. But i'm not whoring my internet out to anyone so I'm not letting go of that one.

    Anyone have a ture answer on what the problem is.
    Is it firmware? (I have the latest official Linksys 3.37.6)
    Is it the bandwidth? (How much can the router support and how can I monitor what actually goes through it?)
    Is it heat from the router CPU? (I live in Georgia and it's going to get a lot hotter, I've heard from others in the forum that it's heat and adding air cooling solves the problem?)

    Does anyone have D-Link and if so do they have this problem, because I can assure you that I will not buy another Linksys until they come up with some kind of fix to this problem. I had a wired BEFSR41 before switching to wireless and it worked flawlessly with no problems.
  16. m00n

    m00n Network Guru Member

    Same problem here,

    I've got the WRT54G V2.2 and i'm wired connected to the router and the connection drops so now and then, first about every hour, but now i can download voor 3 / 4 hours without problems.

    Im using the latest official linksys firmware and not switching again to beta firmwares after bricking it twice :).

    I bought it 2 weeks ago, should i return it and get a refund or wait for a firmware upgrade?


    I never tried pusing the limits out of the wireless part to do so by sending a lot of data form a wired pc to a wireless one. So i will test it tonight when i'm back from work. And let you guys know.
  17. Nimdae

    Nimdae Network Guru Member

    This is not just with the 2.2 hardware. I have 2.0 hardware (got it today, sale at radio shack) and experienced the problem out of the box. I upgraded the firmware hoping it would fix it, and no go. When I buy a product from a big name in networking such as Cisco (Linksys is owned by Cisco), even in home products, I expect a fully functional product.

    You know, with all the bad luck I've had with Linksys products, I can't say I will buy any more. I've heard so much "Oh, but their routers are good!" and I just traded one problem for another (failing uplink cable from one room to another traded for dropping connections randomly).

    I'm about to try one of these 3rd party firmwares. If it doesn't work, the router gets returned for refund, my old $20 microsoft router goes back in its place, and I start looking at other brands (netgear hasn't let me down yet, time to check out their routers).

    With these responses to this thread, I'm not gonna bother contacting Linksys support.
  18. -Dutch-

    -Dutch- Network Guru Member

    I have received a new one today, and will install it tomorrow or Saturday. Let's hope my problems are gone by then......I will keep you informed!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice