WRT54G ver 7.00.x : Wireless Connection Nightmare

Discussion in 'Networking Issues' started by Aquafire, Apr 28, 2007.

  1. Aquafire

    Aquafire LI Guru Member

    Hello All, (Calling the Wireless Gurus Help )

    My laptop is a HP Pavillion Dv1000, running Windows XP SP2. The built in wireless card is "Intel PRO/BG 2200 Wireless LAN Adapter" with the HP Provided drivers. I just bought yesterday Linksys router WRT54G to share my Cable Internet connection over the wireless, hence enjoying the freedom of mobility in the house. It is not working at all though, I have spent hours now trying to figure out a clue, but in vain, I am a total newbie to Wireless networking.

    My CableNet provider is running an I.S.A. Proxy Server on his side (which runs NTLM based authetication, the Microsoft bitten ones know that). A usual CAT-5 Ethernet wire from a standard ethernet switch is running to my home, which I used to connect to my Laptop ethernet port. Obviously I had to give the Proxy Server IP Address ( and Port address (8080) the web-browser settings. My laptop Local Area Wired connection was on DHCP configuration, it gets an automatic IP address when logged in (172.16.x.x).

    Now I have followed all the guides and intructions as provided by the accompanying CD and online website with WRT54G. I have used the web configuration interface ( to check and changed a couple of very basic settings on the router which are ;

    I have connected the CAT-5 Ethernet coming from my Cable Internet Service provider, into the "Internet" Port of the router. I connected the boxed and supplied blue ethernet cable to one of the Ports (1,2,3,4) on the router and to my laptop ethernet wired connection socket for RJ-45.

    After logging on to the router's interface using default username/password (admin/admin), I configured only Host Name / Domain Name (to the same which my laptop had existing in the local area connection and network settings, since I am assuming that now the router would be talking to the ISA Proxy server, I dont know if I am correct in it ). I also changed the SSID to a unique name. Rest of the settings are left to factory defaults, which means there is no security and encryption mode enabled WEP or WPA(1 or 2). No SES (Linksys specific) security configured since it is only supposed to work with Linksys based laptop adapters and mine is Intel.

    In WIRED mode my laptop now gets an IP address of the range (192.168.1.x) as configured on the first page of web based configurtion of the router. Even though I still have the Proxy Server IP Address ( and Port address (8080) in the web-browser settings, the web-browsing and everything else is running fine. But its for checking only, as with everyone else, my goal was to go wireless with all these things running.

    The WIRELESS mode is not running at all. I have tried updating the Intel PRO/BG 2200 Wireless LAN Adapter drivers both from HP and Intel website. In the "View Available Wireless Networks" option of the Windows configuration, I can see the Wireless network by the name which I had given in the SSID field of the router configuration. But when I click the connect button, there is no activity and the wireless device does not connects to the network. This is bothering even when I have enabled no security or encryption or network key in order to connect.

    In one occasion the wireless device is able to connect, but in the connection status (in the Windows Start Menu Task Bar), I can see that there is no IP address given to the wireless connection. Hence even when it is connected, no internet browsing is working. Do i have to disconnect the WIRED connection to the same router, before attempting to connect the WIRELESS option ? Do they conflict ? . This is a question confusing me however I have tried it both the ways and the wireless is still unable to get an IP address and connect properly.

    I have noted that in the Windows Device Manager, when i select the properties of "Intel PRO/BG 2200 Wireless LAN Adapter" the MAC address of this device is 00:00:00:00:00:00, which is kinda confusing for me again, since in the tab it says Device Installed and working properly. Is it ok? can it be the reason of the wirless connection not getting an IP when trying to connect to the wireless network. I have tried re-installing the latest Intel and HP drivers again , but it still reads the same for the MAC address of the wireless adapter.

    Thank you for reading my detailed scenario. I just want to know that ;

    Given the structure and topology of my Cable Internet provider, what settings should I have in the router's configuration. Should I choose DHCP or PPPoE and any other related settings?

    What should be the way for me to connect my wireless LAN adapter to the wireless network successfully and enjoy browsing and all other connection capabilities just as they are with the WIRED network. Is it something with the laptop adapter or the router's settings ? The router however is working fine when I am connected to it using the ethernet cable and when it gives my laptop a default address of (192.168.1.x). It means it is accepting and forwarding requests to my CableNet's network which is of the order of (172.16.x.x).

    Do I need to change the Proxy Address and Port in Web Browser configuration (which is currently as it was with the existing WIRED network).?

    Any ideas or tips would be highly appreciated since now it has been straight 48 hours with minimal sleep trying to find out a way, and my nerves are giving up now, or maybe its my limited knowledge of the wireless LAN configuration.

    Best Regards,

  2. glaciuspts

    glaciuspts LI Guru Member

    To configure the handle first modem: It catches laptop and it sails directly for the modem, verifies if it has Internet, without yes ok! Admin†Now for handle enters in the interface of router typing password “modem the configurations is the following ones only: To leave qualified DHCP! e to clonar the MAC address of its plate of net physical address the guide of the interface of router is “Clone MAC address†where before you it will have to go to prompt of the MS-DOS and digital “ipconfig /all†to verify which is the physical address of its plate of net, where it cannot be thus 00:00: 00: 00: 00: 00 as you specified, but it has that to be letters and numbers for being hexadecimal values ex 00:A1: DE: F6: E0: 1B. ok?

    After the configurations incapacitate its PROXY, it disconnect the modem and router binds first the modem waits until it synchronizes 15 seconds more or less and after he binds router! it tries to connect itself for handle and wireless.
  3. glaciuspts

    glaciuspts LI Guru Member

    It verifies the image of interface of its router and what vc must configure in router the circles in red must be modified remembering that the DHCP of router comes activated of plant is not necessary to move in this configuration to only clonar the MAC address remembering that after this you also have that to configure the security of its net without wire as SSID, canal and password. If this option of configuration not to function, you can try to use for Wireless MAC Filter.

    Attached Files:

  4. Aquafire

    Aquafire LI Guru Member

    Thank You ! But not working

    Dear Friend,

    Thank you for your suggestions and tips, but from whatever I tried to understand , these settings have already been checked by me. And they are still not working.

    Any other suggestions are always welcome.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice