WRT54G Version 3 hardware

Discussion in 'Sveasoft Firmware' started by windsurfer, Apr 1, 2005.

  1. windsurfer

    windsurfer Network Guru Member

    I have been playing with WRT54G version 3 hardware and have run into a problem. There is a new switch on the front left corner of this device that I have found no information about. Here is a picture of the board:

    WRT54G Version 3

    I flashed this device to Firmware_Satori-4.0G and now I have lost my connection to the LAN ports. It still runs from the radio and I have full access to the administration pages.

    Where should I go from here?

    Has anyone loaded another version of software on V3 hardware and had it work correctly?


  2. Toxic

    Toxic Administrator Staff Member

    version 3 is not supported by Satori.

    afaik only a few firmwares are supported by this firmware

    if you downloading satori from Linksysinfo you will see the is NO support for the wrt54g v3.0

    i am honestly not too sure if anyone has been able to reflash their v3.0 router sucessfully over wireless connection.

    HyperWRT and Linksys v 3.03.6 are the only safe firmwares to use at the moment.
  3. windsurfer

    windsurfer Network Guru Member

    My router is now back from the dead. I had tried tftp with no success unitl I read the following from Matt. Davies:

    Matt. Davies
    Thanks to everyone.

    I set my IP address on the hardwired system to

    Pinged using -t and reset the WRT54G which allowed me to
    see that it received pings for a few seconds as it booted up. Due to
    Boot_wait being enabled.

    I then opened a new command window and set up the following
    instruction ready to press :

    tftp -i put c:\code.bin

    Where c:\code.bin was a renamed firmware that i had previously

    I reset the WRT54G and then ran across the room to my system and
    waited for pings to be received....and hit return to send my tftp

    Success! The bin uploaded successfully...hooray!

  4. jagboy

    jagboy Network Guru Member

    was the router replying to the pings
  5. windsurfer

    windsurfer Network Guru Member

    The router would NOT respond to a ping as the LAN ports were dead. The neat thing about using ping -t is that the computer keeps pinging the router. You get this stream of time outs.

    You then reset the router with the switch on the back. I used a long reset of 10 to 20 seconds. After some number of seconds the time outs turn into good pings. There are usually 4 or 5 good pings and then it goes back to time outs. If you start the tftp after you see the first good ping the system takes the software just fine. Give it plenty of time to finish as the transfer gets done long before the flash is finished being written. Give it another long reset and you should be good to go.

    I flashed mine back to the current Linksys software but now that I know how to fix a brick, I will be a lot more bold in playing with this stuff.

  6. jdepew

    jdepew Administrator Staff Member Member

    Hehehe, a little bit of knowledge is a dangerous thing isn't it? Although where would any hacker be without the risk of breaking something! Good job bringing the -G back from the dead.

    BTW, I hope you don't mind, I'm going to use that board shot you posted in the Autopsy as I haven't seen a v3 anywhere yet, and this is the first internal shot I've seen. I will attribute it to you as well.

    Thanks and welcome to LinksysInfo!!!

  7. windsurfer

    windsurfer Network Guru Member

    You are welcome to the picture. I will leave it on my server for a while so that the link at the top of this thread does not break.

    The angle of the picture blocks your view of a two LEDs that are just below the black actuator of the new switch. They are surface mount LEDs and one is white and the other red. The white one is quite bright compared to the others. You do not see it much when it is in the box but out on the table it would really light up a dark room.

    It seems to me that someone should create a "Fix a Brick" thread and put it at the top level of this forum which includes the ping -i infomation. It took me 4 or 5 hours to figure out how this works. There are a lot of partial instructions floating around the net but I have not seen all the information in one place and I did read just about everything available on the subject.

    If anyone figures out what this new switch is, please let us know.


  8. jagboy

    jagboy Network Guru Member

    what happens when you press it?
  9. jdepew

    jdepew Administrator Staff Member Member

    We've got a bunch of answers to the fix a brick floating around.

    I'm going to try to compress it all into one FAQ.

    Thanks for the picture!

    Oh, and the switch is for the Secure EZ Setup, which we still have not seem demonstrated
  10. Xyse

    Xyse Network Guru Member

    Thanks for the great pics wilton. Too bad the v3 is using the piece of s**t mips.
  11. windsurfer

    windsurfer Network Guru Member

    There is one other chart that is missing on the net and I can understand why it is not available so here is my one little piece that might be helpful to someone else. I have been trying to get my WRT54G with version 3 hardware to run in Client Mode. I have a WAP11 currently and want to do a replace with the WRT54G.

    I have tried the following software with the listed result.

    DD-WRTv21c Loads okay but the routing table does not look right in client mode.

    Alchemy.pre7a Loads okay but again the routing table does not look right in client mode.

    Satori-4.0G This makes a brick out of the V3 hardware.

    Hyperwrt_2.1b1_G This loads but does not include a Client Mode option.

    In case anyone cares, I Paid my dues on the Sveasoft site and posted my question and the picture, in both places. I got lots more help from this site so that is where all follow up is being posted.

    The router seems to ignore the button totally but I have not tried it under all of the above versions of software. I did not know where it was until I opened the box and by that time it was a brick. It is behind the Cisco Systems label.

    If someone wants an outside shot of the box, let me know and I will post that also.

    If anyone gets Client Mode working on V3 hardware please post a note on how you did it.


  12. t4thfavor

    t4thfavor Network Guru Member

    why have the button there if it is covered up by the cisco logo i was also unaware that the v3 hardware even existed..

    also dont all the wrt's after the 1.0 have the MIPS proc??
    it works for the application doesnt it?
  13. jagboy

    jagboy Network Guru Member

    hey maybe linksys will do something with that button in the future. who knews :?
  14. tl511

    tl511 Network Guru Member

    The new button is described by this article, I believe

    I believe it is supposed to be an auto-configure for wireless. It is something Broadcom and Linksys have been working. Trying to make it so easy anyone can do it.
  15. jasonl

    jasonl Network Guru Member


    ive been trying to do the same on my V1 WRT54G, i followed your instructions and try to send the fw thru tftp once i get that ping reply upon reset, however i get a "timeout occurred" error instead of the fw going thru

    what did i miss? tnx
  16. XCOM7

    XCOM7 Network Guru Member

    The button is called "EZ Setup" is on the box of my WRT54GS and G all you have to do is press it and it suppost to configure wireless security for you.
  17. EternalAT

    EternalAT Guest

    I have WRT54g v.3,i try to flash with Alchemy v.7pre1 and there was error.After that i flash with original firmware.I need some firmware to flash my wrt54g,what firmware to use to make it beather,what will work???
  18. KFACTA

    KFACTA Network Guru Member

    it is an easy setup wireless secirity button, you need to have both the AP and the other wireless device to support this, although I havnt seen any other items with this, I would think that with a driver update, linksys should be able to deleiver this to there range of network cars, but I havnt seen a sign of this yet.
  19. dmulk

    dmulk Network Guru Member

    Yeah, I have to agree with a point in this thread: The WRT54g 2.2 and 3.0 MIPS are pretty unreliable hardware when compared to the v2.0

    I just popped into a frys and found that they had 10 v2.0's so I quickly snatched them up. Have been using them in my consulting business with DD-WRT.

    On another note:

    I think Toxic posted that Hyperwrt and the V3.0.X linksys firmwares were the only "safe" firmwares to load on V.3 HW but I have installed 6 v3.0 WRTs with the latest Prefinal-5 DD-WRT and they all seem to work great.

    The 512 connection setting definitly helped the stability issues. Immediately resetting to defaults after the upgrade also has solved quite a few problems (I do the latter as a rule of thumb now)

    Granted, all 3 firmwares still experience some instability (due to the MIPS procs issues under heavy loads) but they all perform "as well as can be expected". :)


  20. VadWiser

    VadWiser Network Guru Member

    I get the same timeout occurred error :( somebody can help please?
    the boot wait is set to on, I renamed the official fw file from linksys to code.bin and my router is fully pingeable. However i can't telnet with the method showed above. What to do? Mine is version 3.1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice