WRT54G w/ tomato to WAP54G

Discussion in 'Tomato Firmware' started by shadowoverthis, Aug 31, 2007.

  1. shadowoverthis

    shadowoverthis Network Guru Member

    Okay so this is long so i'm splitting it up into two sections, just read the second if you don't have much time.


    About two years ago I needed to seriously expand the range of my wireless network in my house without moving my cable modem. I had a WRT54G v1 (cdf0) which I bought the week it came out and had running in my house ever since. One day it seemed to have bricked itself, so I went out and bought a WRT54GS and a WAP54G to use as a wireless repeater/extender. This functioned decently well, and I had put Thibor 12 on the WRT54GS. The system still was not working perfectly because in the office in the basement (WRT54GS on top floor, WAP on first) really needed a hub. The problem was solved when one day my WRT54G just seemed to unbrick itself. I installed Tofu 13 and after playing around with all 3 units was able to use the WAP as a wireless bridge connecting the wrts in WDS-AP mode with WEP security. This worked FLAWLESSLY for two years, the only time I ever had to reboot anything was after power loss when (rarely) the WAP would lose the connection to the wrts. Until just recently the wrt54gs had an uptime of something like 380 days as it is on battery back-up. Because of how stable it was I never even bothered to update the firmware, so was still running the what seems like ancient thibor 12. Well, sadly, a couple days ago the trusy old wrt54g in the basement bricked itself for no apparent reason, and after hours I determined it would not come back to life, and took the minipci card inside it and installed it into an old thinkpad (works perfectly btw).


    Okay, so given this opportunity to rebuild my network I updated my wrt54gs to tomato 1.07 (done properly, nvram resets hard reboots etc) and "upgraded" my security from WEP to WPA TKIP. I then updated the wap to match the wrt settings, however the two will simply not connect. It seems similar to the WRE issue someone else had (its on the main forum page a bit down). I've changed the security settings around, tried to configure the WAP as a wireless repeater, I acutally turned off security. Interestingly, apparently while I was gone my father, needing to get a connection in HIS office, configured the wap as a repeater when the wrt still had thibor 12 and it worked perfectly. So, does this mean that tomato can't speak to the wap? Maybe because WAPs are designed to only work with linksys products and with tomato the router is no longer recognized as linksys? its a WAP54G v.3 with 3.04 firmware, never had any issues with it. I have a WRT54GL coming in in a few days and I have to decide what firmware to use and how I'm going to configure the network. I also don't want to toss out my WAP, I suspect if I go back to thibor it will speak to my router again. This is the first time in two years I'm messing around with this stuff, have I forgotten something? Any ideas?
  2. shadowoverthis

    shadowoverthis Network Guru Member


    Well, I flashed the wrt to Thibor 15c and after some configuration and playing around and a couple reboots of the wrt I got the wap working as a repeater. I'm using WPA TKIS security, wrt is in AP + WDS mode and mac address of wap is under the remote bridges, and of course the WAP is in wireless repeater mode with the wireless mac address of the wrt. This is a working temporary fix as we can now connect wirelessly from the offices, but I'm still not sure why this didn't work with tomato. Hopefully connectivity with a wap will be in one of the future versions.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice