wrt54g with IBM integrated card

Discussion in 'Cisco/Linksys Wireless Routers' started by marym, Oct 28, 2005.

  1. marym

    marym Network Guru Member

    I am using a linksys wrt54g v 1.1 firmware 4.20.7. I am unable to connect to an IBM Thinkpad with integrated wireless card: IBM b/g wireless mini pci adapter with latest drivers. I have used WEP PSA, and disabled. I have tried to use IBM Access Manager, and without, still unable to connect. IPCONFIG shows "no operation can be performed while media disconnect". I was previously able to connect on an older laptop using a WPC54gs card. In addition, I am unable to change channels on the laptop, and so I have tried various channels. Please advise, and thanks in advance.
  2. danielhaden

    danielhaden Network Guru Member

    For that particular Linksys, use Tofu's HyperWRT or Avenger's HyperWRT 21b1. I would use Avenger's nice simple and reliable creation. In fact, that is exactly what I use. ;)

    Perform a through hardware reset after loading the new firmware.

    Use WPA (personal) plus TKIP.

    Use a channel for the router that is not nearby any other channel in the area. Maybe channel 9.

    Use a unique and uncomplicated SSID such as your home phone number.

    Set the antenna power to manual and type in 84. This will help keep the laptop connected by reducing "distractions".

    You may need to set the router in "G only" mode in order to keep really daft clients from trying to log in via "B" plus incompatible WPA. "G-Only" mode is not so good in a radio dense environment, but it can straighten out some onery client devices.

    --------end of router config------------
    Remove and reinstall the wireless client drivers.
    Remove any pre-existing wireless network configuration information from the PC.

    Configure it with exactly the same information as the router.
  3. marym

    marym Network Guru Member

    still no luck

    Thanks for your reply, and my apologies for my delay in responding.
    I tried all that you suggested, but I still cannot connect. I can see the network, but cannot connect. When attempting an ipconfig release and renew, I receive the error message: no operation can be performed while media disconnected. I also tried using a static ip address:, subnet mask, gatesway Firewall and antivirus off.
    Thanks in advance for any further assistance.
  4. will792

    will792 Network Guru Member

    I did not have any problems connecting T40 with WRT54G v.2.0 (running DD-WRT). I cannot recall if wifi card was IBM with Atheros chip or Intel.

    It sounds silly but check if MAC filtering is not on. At one point I forgot that I use MAC filters on a router and spent close to 1 hour trying to connect my friend's laptop to my wireless network.

  5. marym

    marym Network Guru Member

    got it

    Keeping the settings that member: danielhaden suggested above, I was finally able to get connected when I changed the advanced wireless setting "Authentication type: Auto" instead of shared key. (I am using shared key encryption)
    In the wireless security tab, the settings remain "WPA Preshared Key".

    Thanks for all your help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice