WRT54G: WLan works, LAN doesn't

Discussion in 'Cisco/Linksys Wireless Routers' started by rainer, Feb 13, 2005.

  1. rainer

    rainer Network Guru Member

    Hi all!

    I got a problem with my brand new WRT54G: accessing it via LAN doesn't really work: sometimes I can ping it, a few minutes later I can't ping it, etc... Most times when I brose to i get the screen asking for the password, but after entering it the connection times out. Access over WLan works normally, though - no time-outs etc.
    I tried flashing the new 3.0 official firmware and Alchemy too (after like 5 or 6 tries it worked via LAN, always works via WLan), but to no avail, the problem persists.
    I'm more and more convinced that it's a hardware problem since the router never worked in the first place, ie. before trying to upgrade the firmware etc - I couldn't even install the router as the users manual described it, since I was unable to reach the web interface.
    DHCP is also kinda jumpy over the LAN interface, sometimes I'll get an IP, sometimes not...
    This really looks like some kind of loose contact, but it can't be the cable or the PC, since I tried various cables and three different PCs.
    As for the LEDs, the WLan-LED is blinking even if there's no WLan traffic here (I disabled my antenna and there's no other WLan device here, neither in my house nor at my neighbour's), and the LAN-LED stays on and sometimes blinking even if the router is not answering to pings/browsing to

    Has someone seen this before? Is it really a hardware problem?

  2. RoMe0610

    RoMe0610 Network Guru Member

    Hi, what about your computer an the cable(s)?
    Checked with a different computer and with different cable(s)?

    I, for instance, found a bunch of Cat5 cables, which don't work correct at 100 mbit/s... :(

    And I strongly recommend *NOT* to upgrade a fw on an unstable connection!

  3. rainer

    rainer Network Guru Member

    Thanks for your input, but I'm sure that the cables and the PCs work correctly, I tested them all...
  4. RoMe0610

    RoMe0610 Network Guru Member

    Well, than I assume it's a typical dead on arrival... :cry:

    Grüß mir Salzburg!

  5. Toxic

    Toxic Administrator Staff Member

    and you have reset the router yes? pressed the reset for 30 seconds?

    are you using any form of proxy cache?
  6. rainer

    rainer Network Guru Member

    Yes, I tried resetting the router several times, still the same error... Right now I managed to get the first screen after logging in, but without any images, seems it didn't load these... When browsing to the second page I got a timeout again...

    Looks dead to me too. I guess I'm gonna return it and hope the next one works better...

    Thanks for all your help,

    PS: Schöne Grüße zurück nach Graz :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice