WRT54G won't accept IP from ISP

Discussion in 'Cisco/Linksys Wireless Routers' started by davex, Sep 19, 2005.

  1. davex

    davex Network Guru Member

    I have a new WRT54G that I picked up yesterday. My isp uses DHCP, so I shouldn't have to enter any ISP info for it to work. But for some reason it will not accept the IP, gateway and dns numbers from my ISP. I have a static IP, and when I manually enter all the info it works fine so it's not a huge deal, but wondering why I have to do this?

    It is replacing a linksys wireless B router, and I never had this issue with that router, or the non-wireless linksys router I had before that. In fact, when I unplug the new one and plug in the old one it picks it right up and works fine.

    Any ideas?
  2. nani

    nani Network Guru Member

    if u have a static ip,u have to enter it in the router.then only it will

    work fine.

    ur old routers may have been configured before.so just give those numbers in the router everything will work fine.
  3. CrashX

    CrashX Network Guru Member

    Your ISP (well, really your cable modem) may have your old router's MAC address cached. If this is the case, they probably have an IP assigned to that MAC, and any attempt to get an IP for another MAC address will appear to be a request for a second IP. This can be a problem if your ISP only provides you with one IP address.

    The same thing has happened to me in the past. When I got my first router (YEARS ago) it was unable to pull a DHCP address. I found out this was because my cable modem had learned the MAC of the desktop that was once directly connected to it. The ISP had an IP assigned to this MAC, and when the router tried to get an IP it appeared that I was trying to get an IP for a second system, when only one IP was allowed at that time.

    The solution was to use the MAC Address Clone feature of the router. This allows you to enter another MAC address that will be passed to the ISP, instead of the router's MAC, when requesting an IP address. You typically enter the MAC that was learned by the cable modem (in your case, the MAC from your old router). This gives the appearance that the last system to request an IP is the same system that's requesting one now. I believe you can find the MAC Address Clone setting in the WRT54G under the Setup tab in the router's config.

    Most cable modems have a status page that allows you to view the "learned" MAC address along with other information. I believe that the IP address used to access the modem is pretty standard across manufacturers. The last two modems that I tried this on (including my current SURFboard SB3100) both used the following:

    The following is what the address information looks like on my cable modem's status page (I have two IP addresses):

    #	Known CPE MAC Address (Max 2) Status
    1	00:90:XX:XX:XX:XX                    Learned
    2	00:0D:XX:XX:XX:XX                    Learned
    Another possible solution would be to clear the learned MAC address from your cable modem so that it could learn the new MAC address. This could be as easy as resetting the modem with your new router connected to it, which worked once for me, but different modems may have different procedures.
  4. davex

    davex Network Guru Member

    I thought of this last night, and it could be the mac address. Odd though, I'm on dsl and I've never had to actually register a mac address, though they may have it cached like you say.

    When I set up my dad's router a few weeks ago I had to clone the mac address on his pc to get it to work at all. He's on cable.
  5. Partizan

    Partizan Network Guru Member

    I am having the same problem as davex. I am using cable internet though.

    Regards, Partizan
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice