WRT54G won't allow WIRED ethernet connectivity?

Discussion in 'Networking Issues' started by briantech, Nov 24, 2006.

  1. briantech

    briantech Guest

    I have a WRT54G. The wireless part works fine. However when I plug a normal CAT5 ethernet cable into the back of it, and run it to a desktop computer, it doesn't work.

    The admin config page at shows the computers as showing up in the DHCP client table, and it even shows the computer name. However on the computer itself, it is never given an IP. When I try to renew the IP, it just says it is aquiring an IP address, but never gets one. I can't ping from the wired computer either.

    I have tried all 4 ports on 3 different computers, always the same thing. Any ideas?
  2. snarby

    snarby LI Guru Member

    no connection via Ethernet cable

    Linksys WAG54G Wireless ADSL Router (Faulty)

    Fault: Router works fine wirelessly, but no connection via Ethernet cable on any of the four ports.

    I have the same problem, l called linksys who advised that it was a problem with my pc however wireless works fine with an adaptor.

    I was thinking perhaps a firmware issue but cant find an update anywhere?
  3. bkmo

    bkmo LI Guru Member

    What are you running for a software firewall? DHCP may be blocked by your software firewall. Have seen it many times.
  4. krish184

    krish184 LI Guru Member

    is ur NIC made by BROADCOM... its a known issue with broadcomm driver.

    Which verison of router do u have .. if its a version 5 or version 6.. try updating the firmware to 1.00.9 or 1.01.0..
  5. snarby

    snarby LI Guru Member

    no connection via Ethernet cable

    The only firewall i have is the windows sp2, ive tried disabling it without any joy.

    Also im not using a NIC i have a game adaptor plugged into my rhinefast2 ethernet adaptor which is part of my motherboard.

    Ive noticed that someone on ebay is selling their wag54g for the same reasons, cant get the cale to work.

    If i remember right my stopped working every since i had a powercut?
  6. snarby

    snarby LI Guru Member

    Ive just read a post else where about a chap who had the same problem. he advised to email support@linksys.com and as long as you have proof of purchase within the past 3 years they will exchange.
  7. ezervoud

    ezervoud LI Guru Member

    I've had the same problem up until yesterday. I was on a linksys live chat with a support engineer who advised me to bring my ethernet to 10Mb HD and it worked. He said that the issue was improper load of the firmware but regardless how many times I have "successfully" upgraded my firmware the best I can get out of my WAG54GV2 is 10MbFD
  8. snarby

    snarby LI Guru Member

    Ezervoud how do i do this?
  9. ezervoud

    ezervoud LI Guru Member

    Depending on your OS you have to go to the properties where you set your IP etc. There is a button to configure your NIC, on the advanced tab of the configuration there is an option saying about speed and duplexing. Make sure that you choose no more than 10Mb Full Duplex. If necessary check 10Mb Half Duplex. These properties can also be accessed from your Control Panel/System/Hardware/Device Manager/Network adapters
  10. snarby

    snarby LI Guru Member

    Ezervoud, i followed your instructions and set the nic to value: 10 full mode. and so far its seems to be working. many thanks for your help.
  11. ezervoud

    ezervoud LI Guru Member

    snarby, it really feels good when something that you could do makes a difference:)
    On a different end now, you should ask yourself if you would be willing to compromise with the 10Mb or you should have your router fixed by Linksys. If you ask me 10Mb just don't cut it for my needs
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice