WRT54G/WRT54GS with Centrino Wireless

Discussion in 'Cisco/Linksys Wireless Routers' started by Wintermute_ryc, Feb 21, 2006.

  1. Wintermute_ryc

    Wintermute_ryc Network Guru Member


    So far I am dealing with problems concerning WRT54G V2 and WRT54GS V2, each with latest offiical firmware from Linksys and latest drivers from Toshiba & Acer for each respective laptop.

    Now, here is my problem. Both laptops that have trouble share the same/similar problems. If DHCP is used, then both of the Centrino laptops contantly reconnects and disconnects. If static IP is used, they "seem" to be connected with no real connection to anywhere outside the localhost. Signal strength is displayed as full strength as the laptops were all right next to the routers when diagnosing the problem.

    Notice that one of the Centrino laptop worked previously, and suddenly the problem as described is showing. As for the other one, it happens the moment it is switched from WEP to WPA-AES. Another laptop wth Broadcom-based WLAN works fine with either routers using the exact same settings. A D-Link PCMCIA adaptor also works flawlessly.

    Settings for both WRT54G V2 and WRT54GS V2
    -WPA-PSK / Personal, using AES encryption algorithm
    -SSID on/off (makes no difference to the problem)
    -MAC filter off/on (makes no difference)
    -802.11g only, B mode is disabled.

    What gives? especially that one worked previously.

    Thanks in advance and any input is appreciated.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice