WRT54GC - a puzzle for you. dropping of internet connection.

Discussion in 'Cisco/Linksys Wireless Routers' started by Comisch, Oct 30, 2005.

  1. Comisch

    Comisch Network Guru Member

    Hi Folks,

    I'm having recurring internet connectivity issues with my WRT54GC.

    I've been through several rounds of support with Linksys regarding this issue.

    I have NEVER had an internet connection issue in the 5 years I've been with my ISP, nor with any of my PC's connected to my ISP, until I hooked my new WRT54GC up 9 days ago.

    I'm an IT professional so this has been quite frustrating as Linksys's solutions have had me reconfiguring my home network several times and waiting 24 hours each time to see if their solution has worked... and there are only so many 24 hr periods left, until I can't return the WRT54GC. ;)

    Any help, comments or wild guesses would be GREATLY appreciated.

    I've poured through the linksysinfo.org forums and found that some people have had similar issues with their own router and internet connectivity, but nothing that matched my issue with the WRT54GC. :(

    Network Setup:

    Terayon high speed cable modem:
    ISP - Shaw Canada using DHCP dynamic IP address assignment. DHCP lease time is supposed to be 4 hrs, but I usually have the same IP address for 2 to 3 months at a time. - The Modem is not the issue, it has performed flawlessly for 5+ years.

    2 PC's:
    One Laptop (wireless, WPA TKIP), one Workstation (wired to Ethernet port 1). Both Win XP Pro SP2, both set to automatically detect network settings. Both running Firewalls and Antivirus protection. - My PC's are not the issue, they too have performed flawlessly over the years.

    Nothing out of the ordinary here. I've upgraded the firmware to 1.02.8 as per Linksys Supports suggestion. I've assigned a "static" IP address to my Workstation (, and limited the number of IP addresses that the router's DHCP can hand out to 2 IP's. I've also set the DHCP Lease Time to 3420 hrs, or 3 days, the maximum allowed. The wireless is set to WPA TKIP encryption/security. - There might be something I'm not remembering, but Linksys Support had me unplug the WRT54GC from my home network for 24 hrs to see if it was my ISP that was causing the issue... It isn't my ISP...

    Possible Causes:

    1. The CAT-5 Cable going between the Cable modem and the WRT54GC was too short. It was ~2m (~6ft) which should have been long enough. I had been using that cable for the past 4 years, so that doesn't seem like a probable cause.

    2. My ISP is resetting my IP address every 24 hrs. Which is causing the WRT54GC to "forget" that it has a connection to the internet that it can share. My IP Address hasn't changed in the past 10+ days, so this doesn't seem like a realistic cause.

    3. The fact that I actually shut-down my PC's each night, could some how cause the issue. Shouldn't be the cause as the workstation has been assigned a static IP address by the WRT54GC (, and there is only one other IP address that is allowed to be assigned dynamically, to my wireless laptop.

    4. Evil Nano-Gremlins have infected my WRT54GC Router and I'm in for a rough ride... Not likely, but I did feed my Mogwai after midnight the other night...

    The Only Solution that Works

    The only solution that allows my PC's to regain access to the internet while the WRT54GC is connected to my home network is to access the WRT54GC Admin webpage ( and do an IP Release and an IP Renew. This needs to be repeated as needed usually once every 24 hours (I'm only around my PC's ~8 hours of the day mind you). Once the IP Release/Renew has completed both PC's regain their internet access, until the next internet disconnect...

    Point of interest while the internet connectivity issue is present:

    1. The IP addresses of both PC's never change, even after the IP Release/Renew.

    2. The WRT54GC Admin Webpage is ALWAYS accessible by both PC's while the internet connectivity issue is occuring.

    3. According to the DHCP Client Table the lease time for the IP's assigned to the PC's has still not expired, although the time is decreasing as it should be (lease time is set to 3 days, 3420 hours).

    4. The IP Address assigned to the WRT54GC by my ISP has not changed.

    If anyone has any ideas, what might be going on with my WRT5GC, please post any comments you might have.

    I really feel like Linksys has dropped the ball on this issue and to date all my networking gear for the past 6+ has been Linksys, so I do have some faith in their hardware, just not the WRT54GC that I purchased.
  2. 4Access

    4Access Network Guru Member

    Do you use any P2P software?

    When the connection drops have you tried pinging the WRT's WAN IP address from one of the PC's behind the router? (This should always work)

    What about pinging the WRT's WAN gateway when the connection drops?

    You said that the connection works after manually releasing & renewing the WRT's WAN IP address and you implied that the WRT's WAN IP address stays the same, but what about the default gateway & DNS servers? Have you checked to make sure they are the same after renewing the IP address? (It's very unlikey they'd change but since it sounds like you've tried most other things I'm taking some shots in the dark.)

    Also can you confirm that you took the WRT out of the picure and the problem disapears? (Your post makes it sound like you did but just wanted to confirm.)
  3. Comisch

    Comisch Network Guru Member

    Hi 4Access,

    Thanks for your questions and PING'ing ideas.

    Yes, on occassion, but not since purchasing the router.

    Good idea. I hadn't thought of that, I will try that though. :D

    Yep, the default gateway & DNS servers remain identical pre and post IP release/renew.

    Yes, at the moment the WRT is out of the picture and the problem is gone.

    My PC workstation has been connected to the internet for 24+ hrs of un-interupted internet access.

    I'm anticipating my issue returning once I bring the WRT back into the picture... I can almost guarentee it. :(

    I'll run my Modem and the WRT and all my PC's through the 30+ second power down, un-plug, wait 30's then power each item on, routin, so each piece of equipment will get assigned the right IP's etc.
  4. vais

    vais Network Guru Member

    Just a wild guess:

    did you copy the MAC address of your computer network card into the router so that the cable modem still thinks it is your computer talking to it ?
  5. Comisch

    Comisch Network Guru Member

    Hi vais,

    Yep, last week on Sunday, Linksys Support had me clone the MAC addy of my PC Network card into the router, hoping that would solve the issue. It didn't. I've sinced disable MAC Address Clone in the router's admin website.

    Vais what where you thinking the issue might have been?

    Yesterday I spoke with my ISP's Tech support to see if I needed to clone the MAC address, they said no. I guess their switches just grab the router's MAC address and uses it to dynamically set things up on their end.
  6. vais

    vais Network Guru Member

    I was just thinking that maybe the cable modem knows about your previous MAC address and doesn't want to accept packets from you "new" router's MAC. Some cable modems cache just one MAC and do not talk to others. I know it sounds strange but the problem is quite strange so the solution might be lying virtually anywhere. Or, maybe, the new MAC is accepted when you are doing dhcp renew but then it is forgotten somehow after a day.

    What else can be done ?

    try having your router rebooted every day at 3am, this might help.

    if you have a cable modem, try noticing the IP the CM is giving you and disable dhcp in your router, make it a static IP.[/quote]
  7. Comisch

    Comisch Network Guru Member

    Hi vais,

    Good thinking about the MAC address and the possibility of my Cable Modem possibly caching it. I'll see what I can find out about the modem and if it caches my Workstations MAC address. :)

    One thing that makes me think that this might not the issue, is that my ISP will allow home customers to have two dynamic IP's on each account (using a Switch).

    Word, and bingo! It does seem like the new MAC is accepted and then is forgotten after a day, which is really weird.

    I'll see if there is a setting in the Router Admin webpage that will allow a reboot time to be set. A reboot in the middle of the night might help things out.

    I guess I could do this as well. The only issue is that "occassionally" my IP will change, since my ISP assigns IP's dynamically, so if the IP changes then no more internet until I grab the new IP. :)

    Awesome suggestions and troubleshooting. I very much appreciate all your ideas and help!
  8. Comisch

    Comisch Network Guru Member


    2 new pieces of information

    1. I was speaking with one of my IT buddies this morning about the recurring internet connectivity issues with my WRT54GC.

    He owns a WRK54G and although he is using a different ISP (Telus Canada, DSL) he has also experienced similar internet connectivity issues with his own Linksys wireless router.

    He guesses that it has to do with the ISP resetting their Client IP's every 3 days' or so. His own internet connectivity issue was not a regular occuring (24 hr period) like mine.

    His solution was SUPER low tech... He'd walk over to his router and pull the AC cable out of the back, wait a bit, plug it back in and then he would regain internet access. :D

    I'm just glad to hear I'm not alone with this issue and this solution might work quite well for my wife when our workstation loose it's internet connection. :)

    2. Last night I hooked my WRT54GC back up to my network. But this time I powered everything on the network down, forced a reset on the Router and waited at least 30+ seconds before powering everything back on.

    So far so good.

    I used the Set-up CD that came with the WRT54GC, but it kept saying that the router wasn't present, so I just used the WRT54GC Admin webpage to set everything else up. I've assigned static IP's to my workstation and laptop based on their MAC's, set the Client Lease Time to a day and set the Maximum Number of DHCP Users to 2. MAC address clone is set to disabled.

    I'm really hoping that this will fix the issue, if not, then the router is going back to the store. :(
  9. Comisch

    Comisch Network Guru Member

    Hi 4Access,

    Well the internet connect STILL went down even after a "clean" install of all the networking hardware.

    I was still able to PING my WRT, using both my wired workstation and my wireless laptop. Go figure.

    I think I've just about had it with this little router. It's time for it to be reset and go back to the store. What a pain in the but, it's a good thing we all can't back-charge Linksys Support for all the time put into trying to solve puzzles like this... We would all be rich. ;)
  10. RonWessels

    RonWessels Network Guru Member

    As I understand it, the DHCP lease from your ISP expires every 24 hours. Have you checked that the router is correctly renewing the DHCP lease appropriately? Even if the assigned IP doesn't change, I can imagine ISP security settings that say that packets from any non DHCP-current addresses are summarily dropped.

    Particularly with cable where, at least for me, the connection authorization is given by my router hostname, I can imagine putting the hostname validity check is in the DHCP server and having all non DHCP-current traffic dropped as the valid-user-check mechanism.

    Is there a current time display on the router administration pages? If so, is it correct, and does it keep reasonably accurate time?
  11. Comisch

    Comisch Network Guru Member

    Hi Ron thanks for the reply.

    The DCHP Lease from my ISP actually renews every 4 hours according to their support tech's, now the IP address does not always change, typically it would change every 3 or 4 months. During my week of frustration, the IP address being assigned to the Router never changed.

    I not certain if connection authorization is given by the router hostname.

    Thanks for your guesses.
  12. Comisch

    Comisch Network Guru Member

    Problem solved!

    I took back the WRT54GC and returned it as defective and then bought a D-Link Wireless G Router since the store was all out of the WRT54GC's.

    When speaking with the Customer Service guy, he said he had seen other WRT54GC's be returned quite recently. Maybe it was a bad batch that was sent out to western canada or something?

    So far so good with the D-Link. The D-Link wireless signal is much stronger then the Linksys which is nice.

    Thanks for all your help everyone!

  13. burkhardi

    burkhardi Network Guru Member

    WRT54GS V2 locks up Soundbridge at lease expire

    I am having the same issue sort of. It seems that when the DHCP lease expires (the one to the client from the router) and renews, it hoses my Roku Soundbridge. After I reset the soundbridge, it's fine. There are no issues with my PC, laptop or my Roku photobrige.

    I have three Soundbridges and they all will do it. I increased the lease time and it makes it last longer between lockups sometimes. I have been watching my DHCP client table and it seems that when a day ends, it renews the lease again. Example: I have the time set to 8640 minutes (6days). I can see 5days 22:30:19 for example, well when I log back in and expect to see something like 4days 18:40:10 I see 5days 22:30:19 and the Soundbridge is locked up. it's like the WRT54GS is still only doing a day renew.

    I am keeping a paper log on what I see when I log in now. I will try to see if this is something that is really happening and I am not seeing things. I don't want to get a new rounter, I don't think I had this issue with the original firmware (2.x.x).

    Any ideas? I have reset the rounter and re-ran the setup utility many times.

    Thanks, Matt
  14. virgil

    virgil Network Guru Member

    I also seem to be having the same issue as Comisch. Have tried firmware 1.02.8 (US) and 1.03.0 (UK)

    Set to PPPoE with Keep Alive Redial period 30 Seconds

    Have observed this thrice already - left the unit operating for over 12 hrs. - when I start browsing, the unit won't be able to reconnect to the ISP, despite clicking onto the Connect button at Status -> Router screen.

    The only solution seems to be to power-cycle the WRT54GC. :cry:

    Did not have this problem with my previous WRT54Gv2.2 on the same setup.
  15. virgil

    virgil Network Guru Member

    An update for the WRT54GC is available from ftp://ftp.linksys.com/international/firmware/WRT54GC-EU_FW1045.zip

    Note that as of early Nov., it has only been published in their German website ... and this is a European (ETSI) version.

    Product: WRT54GC (European: Languages EN, DE, ES, FR, IT, SV)
    Classification: Firmware Release History
    Release Date: September 24, 2005
    Version 1.04.5
    - Fixed Internet disconnect issue with Keep Alive

    Version 1.03.0
    - Extend the length of username for PPPoE & PPTP from 32 to 61
    - Fix some funny characters found in time zone selection
    - Fix some messages that were coming up in English under other languages
    Version 1.02.9
    - Initial Release
  16. griffoun

    griffoun LI Guru Member

    Does anyone have any follow-up on this? Anyone tried the German firmware?
  17. demisoda

    demisoda Network Guru Member

    Your problem is on wireless only or even on a cable connected to the 4 ports? I got similar problem using WRT54C ver.2 but its on wireless only. I have troibleshoot it for a long time but cant find out the problem. I thought will be wireless security problem as i use WPA2 but its not.
    Finally i found how to solve the problem. On network mode just force it to use wireless G only the the recurrent connection will be solved. As I said it happened to wireless part only for my router.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice