WRT54GC connection issues

Discussion in 'Cisco/Linksys Wireless Routers' started by jochem, Mar 13, 2006.

  1. jochem

    jochem Network Guru Member

    I recently bought a WRT54GC (my first linksys product), and I've been having some trouble with it. Once every so often (sometimes after a day, sometimes after a week), internet performance starts getting really slow, and eventually, it loses connection altogether. Before this, the machine I work on has trouble with resolving names. This is tested from the outside in, I ssh into a linux box at home from work. After I powercycle, it works perfectly. I have firmware version 1.0.3 (the one on linksys.com is only 1.0.28, they must've not updated the site in a while...). I found a post in this forum with a link to a linksys ftp where I downloaded 1.0.45, which I will try when I get home from work in about 3 hours.

    Another issue that has popped up since I started using this WRT54GC, is that the SSH password promt takes upto 20 seconds to show up, even locally. Before, using a sweex (*cringe*) broadband router, it came up instantly, and apart from a reboot on the linux machine, nothing changed there. I'm also noticing this lag in SMTP and IMAP connections, though that might be a different issue, as I've set those up _after_ getting the router (and after the ssh 'problems' started). HTTP connections seem to work fine, though.

    Has anyone else had these issues? Does anyone have any suggestions to fix either?

  2. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    I ran into the same problem and the 1.045 firmware seemed to solve it.

  3. jochem

    jochem Network Guru Member

    thank you for the quick answer. I've upgraded my firmware, and all seems well so far.

    I'll post my findings in a week or two, when I'm sure it works, in case anyone else has this problem.
  4. vincentfox

    vincentfox Network Guru Member

    Getting to be nearly a year now since any firmware update for this product.

    I dusted mine off and tried to use it again, as just a basic router at my office.

    Guess what, there is no switch to disable the WiFi !

    A strange omission indeed. Anyone want to buy a GC?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice