WRT54GC DMZ/Port Forwarding not working

Discussion in 'General Discussion' started by Anonymous, Dec 24, 2005.

  1. Anonymous

    Anonymous Guest

    I just upgraded my wireless router from a Belkin 802.11b to the WRT54GC. I'm about to throw the thing in the trash. In addition to the widely reported issue of it constantly dropping my connection and the fact that the range sucks even with the Linksys external antenna, I can't get the DMZ or port forwarding to work.

    I have a web server that I ran in my DMZ with the old Belkin router with no problems. I can't seem to configure the WRT54GC to open access to the web server. I've tried configuring it both with port forwarding on port 80 as well as the wide open DMZ all to no avail.

    I updated to the latest firmware (1.02.8 ). Unfortunately, I didn't try configuring it with the original firmware (1.02.5) and have been unable to locate a copy of that firmware.

    I'd appreciate any pointers or suggestions.

    Thanks in advance,
  2. sreevas

    sreevas Network Guru Member


    hey there is an issue with the linksys product regarding this function in some cases if we upgrade the firmware it will work,in ur case it's still not working why don't u try some 3rd party firmware but im not sure about it give a try on ur own risk and hope for the best.
    sreevas. :thumb:
  3. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    1st point: There is no 3rd party firmware for the WRT54GC.

    2nd point: Before posting, you should use the search function. If you had (and I'm not being critical) a search in these forums would have turned up at least two threads with respect to the new 1.04(5) firmware. It seems to cure the port forwarding issues that you described as well as UPnP. I am using it on my WRT54GC and it seems stable. It also cures an intemittent Internet access issue.


  4. Anonymous

    Anonymous Guest

    Thanks for gently pointing out the error of my ways rather than flaming me. FWIW, I did spend quite a bit of time trying different searches on this forum and for whatever reason was unable to locate the thread (those were the same thread) you pointed out. I may have overlooked the thread because the subject indicated a non-US firmware.

    Unlike the posters in this thread, my WRT54GC originally came with 1.02.08. I'm a little afraid of turning it into a brick but I guess I don't have much to lose at this point. I'm curious to know why linksys hasn't released these fixes in the US.

  5. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Mine came with 1.025. I upgraded to 1.028 and am now using 1.045. Didn't brick it myself so I would recommend upgrading. It's EU code and I'm in Canada but no problems.

  6. Anonymous

    Anonymous Guest

    Still not working

    I've got the new firmware 1.04.5 and with my the whole DMZ and port forwarding is still not working.

    This is kind of lame because it spoils an otherwise nice product completely for me.
  7. Anonymous

    Anonymous Guest

    I have the same issue. Always Low ID in eMule... I've tried the EU firmware.
  8. GeoK

    GeoK Guest

    Emule Low ID


    I have the same problems with others...got a new Linksys WRT54GS and my emule ID is low. Any help?

    Did anybody find a solution about this?

  9. Anonymous

    Anonymous Guest

    I just use the port mapping part I set it up so
    comp1 gets ports 9000-9099
    comp2 gets ports 9100-9199

    and so on then I tell emule and utorrent to use ports in that range.

    It works for me, my biggest problem is I have 10 computers on my network but in the static ip thing it shows only 3 even though all 10 are static and it wont let me re-add the other 7! says they are all ready there
  10. Anonymous

    Anonymous Guest

    1.04.05 doesn't fix dmz

    As suggested on this forum, I've upgraded my WRT54GC to the european 1.04.05 firmware and still, neither port forwarding nor DMZ is working. When my server was configured to be in my DMZ with my old 802.11b Belkin router it was visible. I guess I'll either go back to the Belkin or buy a working 802.11g router. :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice