wrt54gc: slow to set up connection on ping or browser

Discussion in 'Cisco/Linksys Wireless Routers' started by t7dp59202, Sep 26, 2006.

  1. t7dp59202

    t7dp59202 LI Guru Member


    [why does this forum not have a proper search option?]

    I've a brand new wrt54gc. Works fine except that new network connections are very, very slow to to initialise. Once set up the connections is (very) fast. How can this be?

    Some details & example:

    When I do a 'ping google' EACH ping action takes 5-10 seconds to complete HOWEVER the actual roundtrip-time is a normal 100ms.

    - when I ping google.com by it's ip-address each ping action is quite fast (normal; around 1 second)
    - when I use my old router again the ping has normal, fast response times.

    This problem is the same for ping, browser, mediaplayer etc.

    Looks like a slow dns but strangely the ping command looks quite fast when resolving the ip from the domain-name?

    Set up:
    - linux mdv2006 box
    - wrt54gc
    - cable internet connection

    Any help is welcome, ROnald
  2. pablito

    pablito Network Guru Member

    Is your workstation getting a DNS entry in /etc/resolv.conf? Are you using DHCP to get setup? It sounds like your machine is going to the root servers for resolution and then not caching the results.

    I would guess that there is a problem with how the DNS is setup or handed out to the clients.

    Instead of ping I use "dig" (nslookup on Win).
    Try something like:
    "dig www.google.com"
    "dig @ www.google.com" (@IP of your WRT)
    "dig @24.x.x.x www.google.com" (@IP of your ISP DNS)
  3. t7dp59202

    t7dp59202 LI Guru Member

    Hi Pablito,

    Sorry, I forgot to mention. My box has a static ip-config. resolve.conf contains the ip-address of my router (182.168....).

    The dig commands you proposed were fast enough. 30ms for a local dns's, 100ms for the IPS-dns. Not too bad.

    What I also did was run a ping command from a WinXp machine connected to the same router. This ping was quick enough.

    So my idea is now that it is indeed a problem of my linux box, and not so much of the router (even though my old router does not have the problem!). Root cause is probably the vmware-install I did (around the same time of my router change) which completely messed up my network. Had to manually config my network again to make it work.

    How about this caching of dns info? How does that work?
    Any other ideas?

    Maybe I should post this on some linux forum?

    Cheers, Ronald
  4. t7dp59202

    t7dp59202 LI Guru Member

    Ok, all solved.

    It had nothing to do with the router but everything with the vmware install I did.

    I solved it by changing my network to dhcp, renew the dhcp lease and turn back to static again. The new dhcp-lease somehow changed some unknown config setting that fixed it all. Appearrently there is some other unknown dns-info send with the dhcp-answer (apart from ip, dns-ip, subnet, etc).

    Cheers, Ronald
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice