WRT54GC web interface problem

Discussion in 'Cisco/Linksys Wireless Routers' started by superakcraig, Dec 10, 2005.

  1. superakcraig

    superakcraig Network Guru Member

    I have been having a problem trying to get ports to foward on my router. I may open a port on the games & applications tab and assign the ip then click save and one time it will save and the next time it won't. The activity throbber just spins on the browser and nothing will happen EVER! I have only really noticed it on this particular tab...none of the other settings pages.

    Has anyone ever had this problem? If so did you fix it?

    Oh and just to verify...I have upgraded to the latest firmware, (twice) reset the router to factory and then unplugged just to make sure there were no settings saved. I have assigned static ip's to my two PCs on my network. Also, the PC I use to change these settings is hard lined to the router. It isn't wireless.

    Thanks for your time.

  2. schriss

    schriss Guest

    having same problem. I was able to save only after I removed few entries (half of them actually).
  3. superakcraig

    superakcraig Network Guru Member

    Okay after returning the last wrt54gc and getting a new one...I have encountered the exact same problem. After being on the phone with Linksys support last night for over 2 hours, I still haven't figured out the problem. They finally told me to go buy a different model...that was their solution. What a load of crap!!

    One thing I can tell you though....it doesn't matter what ports I am trying to open up, if I have more than 8 programs "enabled" it won't save. When I try to enable the 9th, it just sits there trying to save. If I unenable one program and enable another...it will save. Again telling me that perhaps that I can only have 8 programs with ports opened at once when in fact there are 15 lines that I can enter port settings into.

    Does this make sense to anyone??? :sad:
  4. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    There's a new OS for the EU market, version 1.045. I've installed it on mine and it works fine though the changelog makes no mention of the issues you're having. The zip file (link below) contains firmware for 5 or 6 languages. It's self-evident which is the correct one when you look at the file names. Note that the EU firmware provides support for 13 channels...illegal here in North America. If you keep your channel settings to 1->11 you won't make the communications police notice you.


  5. superakcraig

    superakcraig Network Guru Member


    Thanks for the reply. So are you telling me that you bought your router here in the U.S., you live in the U.S. and you used the UK firmware that opens up more channels in the firewall for you than the firmware that came with the router.

    Makes me nervous when using firmware. Already fried one router by using the wrong firmware.

    Thanks for the info.
  6. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Actually I live in Canada. I flashed with the EU firmware no problem.

  7. vincentfox

    vincentfox Network Guru Member

    WRT54GC latest US firmware also has bug with port forwarding. If you try to forward any port higher than 32767 it overflows, can't handle number that big. When you revisit that page it shows a smaller number. I need to forward 49152 for my Azureus BT client.

    Does the EU firmware have same bug?

    I am regretting buying GC thought it would be fun little addition to my stable of GS routers, doesn't seem fun so far just buggy.
  8. superakcraig

    superakcraig Network Guru Member

    Vincent Fox,

    I don't know if the EU firmware has that bug in it or not but regarding Azureus, you are aware that you don't have to use that particular port. You can change that to any port you want in the Azureus options. I think I use 11000, and it works fine.

    One other question for you Vincent, do you have trouble opening more than 8 lines(programs)on the gaming and applications tab at the same time as well? When I say lines, I mean, the name of the program, the port ranges, the protocol, the forwarded IP address and the enabled coolumn would be one line.

    I still haven't installed the EU firmware. I am afraid that I will end up with another dead router.
  9. superakcraig

    superakcraig Network Guru Member

    Hey Eric,

    I think you misunderstood my post earlier. You were talking about the channels...(wireless)...I am talking about number of ports you can open in your firewall at one time counting applications. I can only open 8 at once. I don't think I better install EU firmware.

    Does anyone else have this problem?

  10. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Nope. I didn't misunderstand your question. I was just pointing out that the EU firmware supports more channels. Obviously there's no correlation between channels and port numbers. I only use my WRT54GC when I'm travelling...it makes a great h/w firewall when you're staying at a hotel. Thus, I haven't played too much with port forwarding on it.

    I'll hook it up to my home network and see if I can duplicate your problems.

  11. superakcraig

    superakcraig Network Guru Member

    That would be great if you could do that. I would very much be interested in what you discover.

    Thanks so much for your quick response.

  12. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    I tried it out and created / saved / edited 11+ port fowarding rules and didn't run into any problems. I created a screen shot but for some reason it wouldn't upload. I would recommend trying out the new firmware. It won't hurt.

  13. superakcraig

    superakcraig Network Guru Member

    Thanks for checking on that for me Eric. I will try the different firmware to see if it fixes my problems.

    Thanks again!!
  14. superakcraig

    superakcraig Network Guru Member


    I just wanted you to know that I finally got up the nerve to install the firmware that you mentioned even though I am in the US. Guess what, it worked. Thanks so much for the info. I can now use every line on my applications and games tab.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice