WRT54GL and tomato: terrible, terrible WAN speeds

Discussion in 'Tomato Firmware' started by canadave, Mar 21, 2009.

  1. canadave

    canadave LI Guru Member


    I've got a somewhat weird problem I'm hoping someone can help me figure out.

    I'm running a Mac Pro and a Macbook Pro laptop, both under a WRT54GL router running Tomato 1.23 (quick note--I've tried this with prev versions of Tomato as well). The Mac Pro is in the same room as the router, and is connected via Ethernet. The laptop is connected wirelessly, usually from upstairs. My Internet access is via 15Mbps down cable modem (Eastlink ISP).

    I noticed that when downloading the same file on each computer, I was getting FASTER download speeds using the laptop wirelessly than when using the Mac Pro--in fact, TWICE as fast (yes, I did numerous speed tests, made sure to do the tests right after each other to make sure it's not Internet traffic-related, did several tests at the same time to make sure it wasn't a one-off result, etc).

    This seemed puzzling. So I decided to do a quick test. I downloaded a large file (the Second Life .dmg installer) using the Mac Pro. It downloaded at a consistent 180 KBps or so. I disconnected the Mac Pro's incoming Ethernet cable at the router, and connected it directly to my cable modem's port, then tried again to download the same file. This time, it downloaded at full speed--1.7 MBps (!!!) I put the cable back, tried again....and we're back to the crummy 180 KBps download. I repeated this test several times to make sure I wasn't imagining it.

    Now, I know connecting directly to the modem will speed things up compared to going through ANY router, but this result seems to suggest that something amiss is happening with the WAN download using the WRT54GL--particularly through the Ethernet LAN ports (the wireless downloads, at around 450 KBps for the same file, don't seem too unreasonable, given that I can achieve that speed wirelessly from two floors up). But I'm jiggered if I know what it could be.

    Does anyone have any ideas how I might solve this? Thanks!
  2. humba

    humba Network Guru Member

    Did you factory reset the router?
    Do you use the same ethernet cable when you connect your mac to the cablemodem and when you connect the mac to the router?
  3. szfong

    szfong Network Guru Member

    What protocol are you using to d/l the file. Some requires opening ports and connecting directly to modem is effectively putting it on a "DMZ". Routers will usually block incoming unrequested packets unless somesort of hole punching mechanism or port forwarding is used.
  4. canadave

    canadave LI Guru Member

    Yep--I've factory reset the router and actually even tried using Tomato 1.22 just to see if that would make any difference. Same results.

    And yep--same Ethernet cable. I even tried a different cable from the modem to the router (when testing the modem --> router --> Mac setup). Same results.
  5. canadave

    canadave LI Guru Member

    Just using standard http protocol. I shouldn't need to port forward anything to do a standard file download from a website, should I? :confused:
  6. bripab007

    bripab007 Network Guru Member

    Wow...no clue. I've got a WRT54G-TM, which, I think (?), is basically the same as the WRT54GL, and I can hit download speeds of 8-20Mbps (~750-1500KB/s) to my Mac Mini wired up to the LAN ports.
  7. canadave

    canadave LI Guru Member

    OK, more testing:

    I just re-installed default Linksys firmware, did factory reset, and tested it--still same slow speeds via WAN-Ethernet LAN, but WAN-WLAN was okay. I also switched the cable going from modem to router WAN port; same results.

    So this tells me it's one of two possibilities:

    1) router is broken.
    2) both cables I tried to run from modem to router are somehow faulty.

    I can't think of any other conclusion that fits the troubleshooting. This sucks! :(
  8. The Doctor

    The Doctor LI Guru Member

    Try both cables between modem & computer(direct), that will verify they're both OK. My guess is the router. More specifically, some part of the switch.

  9. canadave

    canadave LI Guru Member

    OK, bizarre. I disconnected all the cables completely, and carefully reseated everything one by one. Tried it again, and guess what? Now everything works perfectly :eek:

    I guess one of the cables must not have been lock-tight, although I'm damned if I know where, since I thought I replaced most of the cables during testing.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice