WRT54GL Game Connection Problems

Discussion in 'Tomato Firmware' started by Kyouhou, Apr 27, 2008.

  1. Kyouhou

    Kyouhou Addicted to LI Member

    I've been having issues connecting to a few MMOs I play, even with ports forwarded it was like trying to take a **** that's been building for four days through a straw. I'd either get connected and play for a few minutes or not be able to connect at all. I'm 100% positive I've got the right ports and forwarded them properly and I've also tried DMZ. I flashed to Tomato today in the hopes it would alleviate this pain I feel, but no dice. It acts like the ports aren't even open. But if I forward a port for uTorrent it seems to work just fine.

    I can connect to them fine when I'm not behind the router, so is there some setting I'm possibly missing? As it stands now I'm pretty much unable to do anything but browse and download as the router is essential in this household.

    I'm running Vista Ultimate 64 if that could pose any problems.
  2. Rob650

    Rob650 Addicted to LI Member

    You can start a game and use this to see if the port forwarding is working. Beyond that, I've never had any problem with WoW. I don't use Vista though.
  3. houman

    houman LI Guru Member

    What is the MMO ?

    I have no problem with WoW and I am using WRT54GL with 1.17 firmware.
  4. LLigetfa

    LLigetfa LI Guru Member

  5. Kyouhou

    Kyouhou Addicted to LI Member

    Cabal Online and Ragnarok Online, I quit WoW.
    Cabals ports are a bit of a mystery, but RO uses 5121, 6121, 6900.
    It seems like even though I forward them they don't open for the game.

    I'm sure no one's on the wireless, and I'm using wired.

    Edit: I've also noticed that when I forward uTorrent's port it goes green on the bottom, but if I click on it and test to see if it's open using the uTorrent site, it says it's not. I find that to be a bit weird.
  6. Rob650

    Rob650 Addicted to LI Member

    It might be easier if you take a screenshot of your port forwarding page.

    Is the WAN IP address in Tomato a private IP? Double NAT can cause problems like this.

    Try disabling your firewall in Vista.

    Did you erase NVRAM in Tomato after flashing?
  7. Kyouhou

    Kyouhou Addicted to LI Member

    I've only moderate knowledge of the happenings of routers, so I'm not sure what you mean by WAN ip being private. I'm 100% sure I know how forwarding is done, as I had no issues on my old BEFSR41.

    Yes, I cleared NVRAM.

    I've decided to name my router Cookie Monster since it's showing no mercy to my jar of the internets. I'm sure it's not windows firewall because like I said it runs fine with it on hard lined to modem. Just to be sure I tried disabling it anyway, no dice.
  8. Rob650

    Rob650 Addicted to LI Member

    I was thinking maybe your modem is acting as a NAT device and when you add the WRT to the mix, your computer is behind two NAT devices. This probably isn't the case if you weren't having problems with your old router, though. But just to check, go to (or whatever your WRT is) and check the WAN IP address. Is it within any of the addresses listed here?
  9. Kyouhou

    Kyouhou Addicted to LI Member

    I was fiddling around with router firewall settings and it seems to be working fine. I'm not sure why they were what they were, but atm, Multicast is enabled and NAT Loopback is disabled, which seems to be working. Thanks for the input guys, much appreciated.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice