WRT54GL issues

Discussion in 'Tomato Firmware' started by schnappi, Apr 16, 2014.

  1. schnappi

    schnappi Networkin' Nut Member

    Using a WRT54GL with PolarCloud's Tomato 1.28. Have experienced the following issues:

    -Two separate machine running Ubuntu server 12 LTS do not show up as devices (do not pull an IP via DHCP) when connected via ethernet ports. Multiple Windows 7 machines pull an IP via DHCP when connected via ethernet and work as desired. I am no computer expert. But basics such as a bad ethernet cable or machine specific issues have been eliminated as possibilities.

    -Samsung tablet connects via Wifi (shows up as a device) but has no internet or LAN connectivity. Even going to (router address) does nothing. Tried setting a static IP from the tablet, did not resolve issue. Have not tried connecting via any other wireless devices.

    Does anyone know what is going on? Specifically does anyone know if these issues are router specific (bad hardware), firmware specific (old firmware), setting specific, or something else?
  2. Porter

    Porter LI Guru Member

    What's the reason for you running this old version in the first place?

    I would suggest you upgrade and then see if those problems persist. Seems the most logic to me.
  3. schnappi

    schnappi Networkin' Nut Member

    Have only remote access and it's a office environment in which tinkering could be dangerous if something breaks.

    If I were to install "tomato-WRT54G_WRT54GL-1.28.7635Toastman-IPT-ND-Std.bin" on the WRT54GL would the current settings be retained (aka would one still be able to access the router remotely the same way) after the flash?
  4. koitsu

    koitsu Network Guru Member

    Any time you change firmwares, including going between major releases (this would include the "official" Tomato 1.28 going to Toastman, or any other firmware or Tomato-subset), if you want to be absolutely 100% certain things work after upgrading, you need to erase NVRAM contents and then manually re-enter all the settings via the GUI. There is absolutely no guarantee that going from version X to version Y, sometimes even minor versions, are guaranteed to work. Effort is taken on the part of the firmware authors to try and be as compatible as possible but no promise are made.

    This is documented here:


    More specifically, these two posts:


    The methodology I advocate is keeping a text file laying around that outlines each and every setting you change from the stock default; any time you change a setting in the GUI, document it in this file. I've attached an example of what I use personally so you can get an idea.

    Attached Files:

  5. schnappi

    schnappi Networkin' Nut Member

    Has anyone changed firmware on a router remotely successfully before (without losing access to the network)?

    Also adding to my original post...another problem was hostnames never worked with the Tomato 1.28 firmware by PolarCloud. VNC...even on the LAN...have to use an IP. Shared printer or Windows network drive...same story. I am hoping all these issues are due to the old firmware and not a bad piece of hardware.

    Additionally connected a Windows 7 machine via WiFi successfully today.
  6. Toastman

    Toastman Super Moderator Staff Member Member

    Schappi - yes. I updated firmware remotely thousands of times. It very rarely fails. The secret is to WAIT. It can take a long time to upload - be patient and wait a long time before you give up an upload as duff. Don't ever do it unless you are fully prepared for a drive out to the site if it fails, though.

    There is however a bigger problem. This was pointed out by Koitsu above. If you remote update to recent software, you still need to reconfigure the router from scratch after erasing nvram. Because of this, the first time, you really do need to be on site. If you erase nvram you lose access at the same time. Basically - you need to visit the site.

    Polarcloud tomato is very very very old now. I haven't seen anyone use it for years. It had issues with some wifi clients connecting, and literally hundreds of things have been fixed, changed and updated. The QOS works better now, and we also have good graphical client monitoring features and better bandwidth charts.
  7. schnappi

    schnappi Networkin' Nut Member

    Is SSH turned on by default in your WRT54GL builds (if so obviously I might be spared a trip)?
  8. Toastman

    Toastman Super Moderator Staff Member Member

    I don't believe it was. Local HTTP is active by default on all tomato builds, I believe. So you don't need ssh - as long as you get access by http - you can set anything you like.
  9. schnappi

    schnappi Networkin' Nut Member

    By HTTP you mean local HTTP access or local & remote HTTP access by default?

    Decided to do a remote upgrade. Was about to upload "tomato-WRT54G_WRT54GL-1.28.7635Toastman-IPT-ND-VPN" when I saw that the file is 3.55 MB. In the admin panel it shows 3,292.00 KB of free memory. Does the upgrade file need to be smaller than or equal or free memory (if so it is not a big deal as VPN is not needed)?

    PS: Love your work but hate the download site you use. Hasn't anyone ever offered you complimentary space on a proper server?
    Last edited: Apr 20, 2014
  10. schnappi

    schnappi Networkin' Nut Member

    Upgraded to "tomato-WRT54G_WRT54GL-1.28.7635Toastman-IPT-ND-VPN.bin" and this fixed all issues.

    *Also Toastman firmware has HTTP and HTTPS remote access disabled by default...which seems obvious but just to clarify since no one actually answered my question earlier.
    Last edited: May 14, 2014
  11. Toastman

    Toastman Super Moderator Staff Member Member

    Glad everything is fine. Have fun... !
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice