WRT54GL periodical lag-spikes wireless

Discussion in 'Cisco/Linksys Wireless Routers' started by tjirp, Sep 30, 2008.

  1. tjirp

    tjirp Addicted to LI Member

    Well, to start: Yes I searched google a 100 times :)

    Every few minutes or so I get a hickup in the line causing me to lag for ~3-4 seconds.

    I know it's a commen problem ;)

    Linksys WRT54GL v1 with Tomato firmware.
    Linksys WMP54G

    Already tried:
    A lot :) here's a list.

    QoS - My PC highest (2-3 people connected to router at all times)
    Upgrade to Tomato 1.17 firmware.
    Disable WZC on my PC (It doesn't even start up @ boot since I let the linksys software control my wireless now)
    Change encryption from TKIP to AES (supposed to reduce overhead)
    Change DTIM from 1 to 3.
    Change channel from 6 tot 7 (7 no other AP's in range use channel 7)
    Change the WMP54G card to a Belkin N1 wireless card (I did swap back to the linksys card since I dislike the utility to much :))
    Change equipment location (My Pc shows signal is 100%, tomato firmware says it's between 20-30 quality (0o but it's not that I have constant lag)
    Changed MTU from 1500 to 1450
    Changed B/G mode to G mode
    Ran both PCI cards together (thus both having their own connection))

    forgot to add all that this morning :)

    Some tests I ran:
    Speedtest. always fun;)
    Download: 20.000KB/s (or somewhere near)
    Upload: 15.000 KB/s (or somewhere near)
    (yes I got fiberglass;))

    I am out of options. It is not as much as it used to be but I still get lagspikes occuring atleast once every 3 minutes for atleast 4-5 seconds.

    ps. No, I am not able to plug in a cord other then for testing purposes.

    I hope any of ya'll got some more options for me to try out, cause the internet stops here :(
  2. jchuit

    jchuit Network Guru Member

    I think you should update to tomoto 1.18., that version uses Jhash for conntrack and not the original function.

    conntrack can easily form long linked lists in the lookup table, this will result in a long lookup time and in creating a lag.

    The list length can be tested, for this I use a program.

    You can run it in a telnet session:

    Load the program:
    cd /tmp
    wget ftp://krumdeel.dyndns.org/Public/wrt54gl/cthash/cttest_mips32
    chmod 777 cttest_mips32

    Now run the program:

    You will get the following output:
    /tmp # ./cttest_mips32
    filename: /proc/net/ip_conntrack
    hash function: original
    total buckets: 2048
    total tuples: 70 (3.42%)
    used buckets: 42 (2.05%)
    maximum list length: 18
    average list length: 1.67
    Count Length CT
    1 18 25.71%
    1 11 41.43%
    1 2 44.29%
    39 1 100.00%
    2006 0 100.00%

    To explore what happens if Jhash2b would be used, run:
    /tmp # ./cttest_mips32 -h jhash2b

    The output will now be:
    filename: /proc/net/ip_conntrack
    hash function: jhash2b
    total buckets: 2048
    total tuples: 66 (3.22%)
    used buckets: 65 (3.17%)
    maximum list length: 2
    average list length: 1.02
    Count Length CT
    1 2 3.03%
    64 1 100.00%
    1983 0 100.00%

    Maybe it will help!
  3. tjirp

    tjirp Addicted to LI Member

    Awesome, certainly did not find that on google. I will try this as soon as I get home (work now for another 4 hours).

    I take it I do not have to upgrade to 1.18 to test this out right? and I do need to be cable connected right (if my memory doesnt fail it would be most wise right ;))

    I'll post my findings (including the telnet output) once I'm done and tested it.
  4. tjirp

    tjirp Addicted to LI Member

    ok, what I did is just upgrade the firmware to 1.21 and then reset to factory defaults (reset nvram troughouly or smth).

    Re-did all the settings.

    It seems to have gotten worse:S
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice