WRT54GL + Tomato 1.13 + WDS + Slingbox = Hell

Discussion in 'Tomato Firmware' started by mjosephc, Jan 10, 2008.

  1. mjosephc

    mjosephc LI Guru Member

    Well, I've about exhausted my patience for this problem I'm having and am now reaching out for help. I've researched this issue up and down, and have found many helpful suggestions, but nothing that can fix it. Here is my problem in as much detail as possible:

    Over this past weekend, I upgraded from a D-Link DI-624 (started dropping connections randomly) to 2 WRT54GL's. The purpose of this was to 1) lose the D-Link, and 2) to add a 2nd router to the living room of my apartment so as to act as a bridge for both wireless and wired (by the TV) clients. As my first foray into non-stock firmware, I went with the latest version of Tomato (1.13) and could not have been happier. Within moments of opening the boxes and installing Tomato, I had both set up, running fine, wireless clients able to switch smoothly between either router. I can't ever remember a networking upgrade in my apartment going smoother...or so I thought. My final piece of the puzzle was to add a Slingbox to the WRT in the living room, and this is where it has gone horribly wrong.

    I have tried probably damn near every conceivable combination of UPnP, port forwarding, static IP's, DHCP, DMZ...and NOTHING has worked. I can see my Slingbox (behind the 2nd WRT) from my main desktop wired to the 1st WRT in the bedroom (the one connected to the DSL modem), but I just cannot get it to be seen from the Internet. Without going on and on about this, let me give you my current settings and see if anyone can offer any suggestions as to what I can do. Here goes:

    PPPoE on DSL Modem

    1st WRT (Bedroom...connected to DSL modem)
    Static IP =
    Subnet Mask =
    Gateway =
    DNS 1 & 2 = from DSL Provider
    MTU = 1492

    Router IP =
    Subnet Mask =
    DHCP =

    Mode = AP + WDS
    Mixed B+G
    WPA Personal (PSK) + AES
    Channel 10
    Linked With = Wireless MAC Addy of 2nd WRT

    Static DHCP
    IP's assigned to ALL computers that will connect
    (Current range =
    Assigned Slingbox IP =

    Port Forwarding = Both (TCP/UDP), port 5001, IP
    DMZ = Enabled (IP of 2nd WRT...per a couple of online theories)
    UPnP = Enabled

    2nd WRT (Living Room...wired to Slingbox)
    WAN Disabled
    Slingbox connected to 1st LAN port

    Router IP =
    Subnet Mask =
    Gateway =
    DNS =
    DHCP Disabled

    Mode = AP + WDS (per instructions at Tomato FAQ)
    Mixed B+G
    WPA Personal (PSK) + AES
    Channel 10
    Linked With = Wireless MAC Addy of 1st WRT
    NO Static IP assignments

    NO Port Forwarding Enabled
    NO DMZ
    UPnP Enabled

    Slingbox (Set internally through SlingPlayer software)
    IP Address =
    Subnet Mask =
    Default Gateway =
    Port = 5001

    So that's that. If anyone has any clue where to go from here, please let me know. If there's anymore info you might need, ask and you shall receive. If there's anything you suggest that I've tried, I'll kindly let you know. At this point, I'm thinking I may have to just turn the living room router to a Wireless Client or Wireless Ethernet Bridge, although I'd rather not have to. This is mostly because the living room router has also greatly boosted the signal to my sister's computer in her bedroom at the opposite corner of the apartment. Maybe one of you guys can reverse my mode of thought. Thanks in advance!
  2. DeCex

    DeCex LI Guru Member

    Static IP =

  3. mjosephc

    mjosephc LI Guru Member

    Sorry. To clarify, I have a SpeedStream 4100, and that's the static IP that it assigns to the router.
  4. Nox997

    Nox997 LI Guru Member

    why do you set the DMZ for the 2nd WRT? The 2nd WRT works as a layer2-device, so it is no gateway or router.

    --> Try to DMZ the slingbox IP and see what you get...
  5. day19

    day19 Guest

    My First Post.. :)

    Here's a few things you might want to look at.

    1. It appears that your DSL Modem is not only doing PPPoE, but it's also acting as a firewall or is doing some kind of NAT'ing. I'm guessing this is the case because your 1st WRT has a static IP Address of IP Range). To test, from any connected PC on your network go to www.whatismyip.com. This should tell you what your public IP Address is actually. This is most likely the case, so you may need to login to your DSL modem and disable that firewall/NAT feature. Then your 1st WRT will act as your main Firewall/Gateway to the internet. Then your port forwarding( should work correctly to your slingbox.

    2. The default gateway on your slingbox should be: Default Gateway =, because your 1st WRT is the Firewall/Gateway.

    3. Disable the DMZ to the , you don't need this.

    4. My personal preference is to never enable UPnP. If there is anything on my network that needs to have port forwarding, I'll manually do it myself, rather leaving it up to the device or application to auto config my router port forwards.

    5. Final thing, I would suggest that you set the channel for your wireless to either 1, 6, or 11. As those 3 channels are far enough apart for any frequency overlapping. Survey your area for other AP's and see what channels they are on. And set your channel to the farthest one of the 3 channels mentioned above.

    Hope that helps...
  6. mjosephc

    mjosephc LI Guru Member

    1. This is something that I have not tried, although I'm not 100% sure, short of turning PPPoE "off the modem," I don't know that this can be changed on the 4100. I didn't have much luck getting connected to the internet any other way when I first set up my DSL (with the D-Link, of course), but I can give the modem a try in "bridged mode" with the router doing the logging-in if necessary. However, for what it's worth, it doesn't seem like there's an issue for other 4100 users that have their modem/router set up like I currently do while using port forwarding in a 1-router situation. Is my 2nd WRT or the WDS introducing an atypical problem? (edit: Here's something I found on another forum pertaining to the 4100:
    When on "PPP is on the modem" mode, the modem is a DHCP server that issues only one IP, The modem then DMZs all the traffic on all ports to only that IP. So if your computer is statically set to some other IP than, then no inbound traffic will be passed to it.

    This was collected at the modem CLI in response to the "show ipfw dmz" command:

    xsh> show ipfw dmz
    Firewall DMZ is enabled, DMZ Host IP =

    Don't know if that helps, but it might shed some light on the subject.)

    2. I've tried both and as gateways on the Slingbox, although I did seem to connect to the Slingbox faster (from the bedroom computer) with the gateway set to, so I can switch that back.

    3. The DMZ setting was just reaching for straws. I'd seen in a few places (notably the DD-WRT forums) that this could possibly help with port forwarding issues with WDS. I have no problem turning off the DMZ.

    4. I have tried every combination of UPnP on/off during my trials, but again, I have no issues with turning UPnP off. I'm not running anything that I can't manually configure anyway. Since Tomato came with UPnP enabled, I just put them back that way as the "default" when I gave up on the problem.

    5. I went with Channel 10 because I had a lot of other AP's around me at the apartment complex on Channels 1, 6, and 11. However, I can switch to one 1, 6, or 11 if that might have an affect on my problem. Should I just go to the "least crowded" of 1, 6, or 11?

    Thanks for the suggestions. I'll try this stuff when I get back home from work this evening.
  7. aqueductape

    aqueductape LI Guru Member

    Try switching you LAN ip address space to a different private IP range (10.x.x.x or 172.16.x.x). The WAN is using the entire 192.168 range so when you use on your LAN side, the router will not know to send the traffic out the WAN port.
  8. mjosephc

    mjosephc LI Guru Member

    I believe I did previously try to DMZ to the Slingbox IP, but that didn't work. Just in case, though, I'll give it another shot.

    Again, this was just something I tried based on DD-WRT's (both official and in the forums) suggestion that a DMZ to the 2nd router's IP, in a WDS system, might help with port forwarding. Obviously, in my case, it has not. (Yes, I realize that I am not running DD-WRT here, but again, I was looking for anything that might work.)
  9. mjosephc

    mjosephc LI Guru Member

    I'll try this out as well. But just out of curiosity, can you explain how the WAN is using the entire 192.168.x.x range?

    I'm going to have to come up with a "priority list" so that I can try each of these suggestions in a certain order. Guess I'll have to figure out which one I want to start with and go from there. :)

    If anybody has comments to either build upon (or refute) other suggestions that have been made, please do. No sense in taking steps that aren't going to work in the first place. Thanks again for the help.
  10. aqueductape

    aqueductape LI Guru Member

    The WAN subnet mask is, this means that any traffic that starts with 192.168 does not get routed outside that local network. Also, since the IP that is being assigned to your router is a private address,your ISP has you behind a NAT and you will have no public IP address. I am not familiar with how the Slingbox works, but it if was working with your previous router, it should still work.
  11. mjosephc

    mjosephc LI Guru Member

    I actually never had the Slingbox working with my previous router because I got it at the same time as the WRTs. But I also never had problems forwarding a port working on the D-Link with the exact same kind of setup (IP addresses in the 192.168.x.x range). Is it possible that the DSL modem does something to subvert the "normal" traffic behavior that you are talking about?

    On the other note, I believe that the Slingbox works on the same kind of technology as something like LogMeIn does...it doesn't need an exact IP address. The box sends out an identifier which the Sling server/software searches for and can find from the internet. You CAN use an IP address, but you don't have to. I think that's a whole other discussion though, so in the interest of not derailing this thread, I'll just keep it at that and say "thanks for the explanation." :)
  12. j.m.

    j.m. Network Guru Member

    The root problem is that you have a double NAT situation (your modem is NAT'ing to your router and your router to your clients). Apparently, your modem seeks to get around this by placing the IP of your router in the DMZ.

    The reason you had no issues before is that D-Link products use a default LAN IP of 192.168.0.x. In your present setup, your WAN and LAN are both set to the same 192.168.1.x subnet. This won't do. As suggested above, you need to change all of your LAN IPs (including the routers) to another private class subnet such as 172.16.x.x. Alternatively, set your modem to bridge mode. In either case, you should either configure the router to forward the appropriate port to the LAN IP of your Slingbox OR (not recommended as it is a security risk) place said IP in the DMZ on your router. Placing the IP of the bridge in the DMZ is incorrect.
  13. mjosephc

    mjosephc LI Guru Member

    Thanks, j.m. This makes a lot of sense to me now. I'll change my set of IPs and do a port forward solely to the Slingbox from the primary router (like I had done WAAAAAY back in the first place). It never fails to amaze me how it always ends up being the simplest of problems (or misunderstandings, in my case, for this particular incident) that causes the most headache. I wasn't able to work on the issue tonight, but I'll make sure I post the results of the changes as soon as I get around to them.
  14. mjosephc

    mjosephc LI Guru Member

    Okay, so I couldn't help myself. I had to know if this would work tonight. And, well...IT DID. :biggrin: :biggrin: :biggrin:

    Here are the steps I took, just so everyone who made suggestions knows what worked:

    1) Changed LAN IPs from the 192.168.x.x to the 172.16.x.x range. (This was my whole problem...I'm glad I understand that now.)
    2) Disabled the DMZ.
    3) Disabled UPnP on both routers.
    4) Set the gateway on the slingbox to (the IP of the primary router).
    5) Port forwarded the appropriate port to the Slingbox from the primary router.

    And voila. The Slingbox setup finally went through to completion. Now, granted, I still haven't tested the box from outside my home network (which I'll do tomorrow at work...and yes, that might introduce it's own set of problems with the corporate firewall, but we'll see). Once I ensure that I've got it working from outside my apartment, I'll update this post and close this issue once and for all.

    Thanks again to everyone who made suggestions. All of the info really helped shed light on the subject for me. Extra thanks go to aqueductape and j.m. for schooling me on subnet masks and NAT. I had a basic understanding of those things before, but now I should (theoretically) never run into problems with basic IP configuration in my home network setups again. I'm going to make sure I post this solution in the Slingbox forums as well, just in case anyone over there might be having the same kind of problem.

    Happy to be done with this...hopefully. :wink:

    Update: It worked from the office today, so all is well. Hope this thread helps out anyone with these issues in the future.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice