WRT54GL+Tomato 1.27 - CIFS loaded, but not save

Discussion in 'Tomato Firmware' started by heget, Mar 6, 2010.

  1. heget

    heget Addicted to LI Member

    I have problem with save logs on mounted CIFS client (WD Book)
    All setup have confirm right and looks good :
    and this:
    But when I try "Save on Shutdown" doesnt some action and mounted folder cisco was empty :-(
    Does anybody sometime this problem as solved? please help me, very thanks.
  2. rhester72

    rhester72 Network Guru Member

    Did you give the cisco user ID permissions to write to that directory? This is _not_ the default.

  3. heget

    heget Addicted to LI Member

    Yes sure, the cisco have Full Access to folder (via WD shared storage manager), but still nothing :-((

    Any anothe idea?
  4. rhester72

    rhester72 Network Guru Member

    Not really.

    When you ssh into the router, if you try to touch/copy a file directly to that mount, does it work?

  5. heget

    heget Addicted to LI Member

    Wow sorry but in this aplications I'm beginner (ssh) it's some script for touch/copy onto tomato table or somethinklikethat ?
    Or in windows basicly open network folder "LOGS" username same as on tomato "cisco" pass: "******" opens than copy some txt file and no problems.
  6. rhester72

    rhester72 Network Guru Member

    From Tomato ssh, try this:

    cp /etc/hosts /cifs1

    If it fails, you definitely have a permissions issue on the Windows side. If not, I can't think of a reason why that operation would succeed but would fail on kernel shutdown.

  7. heget

    heget Addicted to LI Member

    Ok thanks for tip, but why I can pu the cp /etc/hosts /cifs1, where?
    To this: Administration > Scripts > Init > (put here) and Save ? ok ?
  8. rhester72

    rhester72 Network Guru Member

    No - it's just a diagnostic test, you want to do it from an actual ssh shell prompt (i.e. not the GUI).

  9. heget

    heget Addicted to LI Member

    Oh man, thanks for all, but I'm still beginner (lame) :D where I can find the SSL Shell ? In Tomato ? Or cmd in windows ? or where I can put the "cp /etc/hosts /cifs1" ?? Step by step please ... thanks advance.
  10. heget

    heget Addicted to LI Member

    Please, any more?? need taht! Why I can try SSH command?
  11. charincol

    charincol Networkin' Nut Member

    Assuming your running Windows get a program such as PuTTY. It is both an SSH and Telnet client. There is lots of info around on how to use it.

    It should allow Telnet access without any changes, but you must start the Tomato SSH Daemon in 'Administration\Admin Access' so PuTTY can connect that way.
  12. heget

    heget Addicted to LI Member


    SOLVED !!! Perfect thanks! Only one thing ...
    just enable SSH and TELNET and now its savings GOOD, thank very much for all!
  13. tido

    tido Networkin' Nut Member

    i've just followed the troubleshooting steps here and it works. My concern is that in my CIFS network sits on a windows xp machine. In order for tomato to be allowed to copy over the file I had to "Allow network users to change my files". Is there a way in windows XP file sharing to only allow specific users to change the files?
  14. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yes... but you'll have to disable "Simple File Sharing."

    That this brain-dead "feature" is still present in Windows 8 boggles my mind.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice