[WRT54GL - Tomato 1.27] Issue on WAN iface

Discussion in 'Tomato Firmware' started by vmcore, Jan 18, 2010.

  1. vmcore

    vmcore Addicted to LI Member

    Hello all,

    First my apologies if this has already been submitted but I haven't had the courage to go through the hundreds of topics. Please don't slam at me ;) and be tolerant about my bad english.

    Now, the issue.

    Brand new WRT54GL, Tomato 1.27 fresh install, NVRAM reset, default setup.

    It was supposed to be a plug and play one: connect the router to an already installed Linksys WET and get anything to work, at least for home basic needs: NAT, DHCP server, DNS forwarder and AP. The PPPoE and WiFi setup was straightforward but I faced one issue on the WAN side I still have no idea about it...

    PPPoE negociation is always ok. I can remove the cable, plug it again, Tomato will reconnect like a charm. WAN interface parameters are OK (IP, default router, DNS, etc...) are the same that what I get using a direct PPPoE network connection setup with some Vista box. Problem: I am unable to reach any IP outside, unable to get some DNS reply from root servers, etc...

    Using busybox I tried to figure out what was wrong but failed to understand while I was thinking about some MTU issue: even a ping to the default router ended in time out, like if the wan interface was shutdown or iptables silently discarding outcoming packets. So, if my IP knowledge is still accurate, the route cause is not MTU. What's next ? NAT ? routing ? hardware ?

    Unfortunately I am mostly used to play with std *nix tools and I am a little bit lost when logged to the router. Are there tools like ifconfig ? Apparently not provided by busybox.

    A question for you savvy guys, in order to troubleshoot this, what would you start with ?

    Any help will be very much appreciated. :blush:

    ps: I can setup a pppoe server on my bsd box and try to simulate the wan connection. may be useful...
  2. mstombs

    mstombs Network Guru Member

    You should find that "ifconfig" "route" and "iptables" all work as expected on the router, albeit with fewer options than the full Nix versions.

    Have you configured the router to be in nat "gateway" mode?
  3. vmcore

    vmcore Addicted to LI Member

    Hi mstombs !

    Ok for the commands, It turns that upon login, netstat is available but not ifconfig, etc... I'll go deeper in the tree. I had very little time to check things with kids screaming around :)

    I confirm Tomato is in GW mode, not router.

    I am actually building a new kernel supporting netgraphs on my BSD box. With this I will run a ppoe server and check before going back on location which is near to a 3 hours car trip.

    Thanks for your suggestions.
  4. neoufo51

    neoufo51 Network Guru Member

    Had the same problem with the same router, fixed it by using Teddy_Bear's ND version of Tomato found on this forum.
  5. vmcore

    vmcore Addicted to LI Member

    Thanks for your input.

    I just finished testing with my own PPPoE server using Linksys firmware, the router works as expected. Next step, to have a try with tomato. ND or not.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice