WRT54GL, Tomato 1.27 web config, please help (an idiot)

Discussion in 'Tomato Firmware' started by sinbrkatetete, Aug 10, 2012.

  1. sinbrkatetete

    sinbrkatetete Serious Server Member

    Hi beautiful people!

    I've looked across this forum, but I haven't found anyone as stupid as me. Maybe I lack the search skills, maybe my "colleagues" are just to ashamed to share their idiocy, I'd be too, if I had the time for shame :)

    Here's the problem. I've turned off ssh and telnet access to my WRT54GL with Tomato 1.27 (plain) fw and I've opted for a https local and remote access. Unfortunately, I forgot that the ports used (8080 for remote and 443 for local) were both forwarded to my server :(
    The biggest problem is - I've pushed the save button, restarted the router and then it hit me! :)

    Now, I can't access my router. I've tried the 20+ second button-push for a passwordless telnet session (as described in the "before you install" section of the Tomato instalation instructions) and tried to telnet with putty on port 223 but nothing happens (connection is refused). When I press the (only) button on the front of the Linksys WRT54GL, the DMZ light (on the front of the router itself) flashes for as long as I hold the button pressed, but as soon as I let it go, the led stops flashing.

    Is there any way I can telnet into it and change the port forward for 443 / 8080 ports, or change the web access back to http, or, at least, download the configuration to be able to save the routing, portforwarding, static dhcp, adsl pass/settings, access restrictions and QoS setup of my router so I can reset the fw (and upgrade to 1.28), or am I doomed to doing it all over again?

    Thanks in advance! A lot!!
  2. shibby20

    shibby20 Network Guru Member

    20+ sec for enable emergency telnet has to works for you. i haven`t router with tomato 1.27 but on my 1.28 this is working.
    sinbrkatetete likes this.
  3. sinbrkatetete

    sinbrkatetete Serious Server Member

    Unfortunately, it doesn't. Or I'm trying it the wrong way?

    I've tried holding it for 30 sec during the normal router operation, for a minute and for a minute during router boot-up and nothing happens. Can you tell me if any specific lights light up, or start flashing differently when you succeed at starting emergency telnet mode? Also, my router ip is and i try telneting via cmd prompt to & with the response being "could not open connection to the hose, on port 23: Connect failed". When I try with putty, it just beeps (like an error sound) and closes. :(

    What do you specificaly do when you want to start emergency telnet mode?

    Thanks a lot for your time and good will!

    EDIT: Woohooo, I've found the problem. The guy who wrote the help (instructions) for the instalation made a typo! it's not port 223, it's 233!! Now I just have to learn how to forward the port 443 back to the router, or reset the web config back to http. :) If anyone knows how to do that, help would be more then welcome! :)
  4. Porter

    Porter LI Guru Member

    1. Everything you are asking for can be found easily by googling a bit. It's a very common problem.

    2. Since you now can connect to your router you should issue these commands:

    Or you try these instructions here:
    sinbrkatetete likes this.
  5. sinbrkatetete

    sinbrkatetete Serious Server Member

    Well, I do have a lot to learn about the topic to know what to search for exactly. Especially since my first and last "telneting" was done sometime in 1994. As I've stated in the first post, I'm trying to preserve my QoS settings and classes, port forwards, acces restrictions, a few scripts, ppoe config etc; wouldn't "erase nvram..." erase/reset all of it?

    Anyway, in the mean time (just minutes ago, after a few hours of statistics to clear my head), I've learned how to set the http option for web acces back on, through telnet. It's now accessible by "normal" means (web acces on, and has retained all of the config.

    Thanks for all your help! :)
  6. Porter

    Porter LI Guru Member

    Ok, if you really want to preserve all that, don't follow my last post. I'm going to bed now, so a real solution has to wait. The solutin is not complicated but I don't know it right now. What you need to do is essentially tell the firewall to delete the portforwarding rule. Maybe somebody else has helped you till tomorrow.

    Good luck!
  7. Toastman

    Toastman Super Moderator Staff Member Member

  8. Porter

    Porter LI Guru Member

    Taken from this site: http://www.cyberciti.biz/tips/linux-iptables-how-to-flush-all-rules.html

    The commands suggested will hopefully disable the portforwarding rules, too. As a security precaution I would suggest that you disconnect your router from the internet by pulling the appropiate cable (will most likely have something like DSL or WAN on it).

    Then issue these commands:

    You might be able to copy and paste them. If you want to be on the safe side just type them in by hand.

    After this you should be able to reach the web interface again.When you are done disabling the portforwarding, reboot. You disabled your firewall so this is neccessary. Maybe a reconnect would suffice, but I'm not sure.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice