WRT54GL+Tomato not getting full speed

Discussion in 'Tomato Firmware' started by kobik, Jul 10, 2010.

  1. kobik

    kobik Networkin' Nut Member

    Hello guys,
    My setup is:
    WRT54GL running Tomato firmware version 1.28 connected using L2TP

    I've recently upgrade my internet connection 12Mb/1Mb just to realize that I'm having troubles with my router.
    When I use speedtest benchmarks to test my connection speed I get the following:

    I've tried the following experiments:
    1. Connected the PC directly to the modem which gave full speed in my PC for download and for upload.
    2. Restore to default settings with no change.
    3. Returned to the default LINKSYS firmware which gave me max speed with my upload and no change with my download.
    4. Got back to Tomato firmware produced the same results as they were in square one.

    I haven't got any progress of understanding what is the cause for this problem.
    Could it be that the router is too weak to handle this speed?
    Or is it some settings which is causing this?

    I'd appreciate any help here guys, as I'm quite clueless.
  2. kobik

    kobik Networkin' Nut Member

    OK guys,
    I have some progress.
    I've just set back the MTU to 1460 and poof, got the cure for my download speed reached to my 12Mb at the download speed.
    And then, I reverted back to LINKSYS' original firmware I've my 1Mb upload speed.
    Which in total gave me what's expected.

    So MTU messed up my download speed, now how can I compare the NVRAM values between both Tomato and LINKSYS firmwares to understand which one of Tomato firmware settings can mess my upload speed?
  3. Toastman

    Toastman Super Moderator Staff Member Member

    I have a similar problem. One ADSL modem I use (Zyxel) will only give full throughput at setting less than the default 1492. It so happens that I chose 1460 too as that seemed to be the best. I have no idea why, as the figure also varies depending on the server used for the test.

    The ISP's actually issue these Zyxel router/modems but they don't even work well on their own network LOL
  4. kobik

    kobik Networkin' Nut Member

    Hey Toastman, the MTU is the least of my concerns, as right now it's working fine with any site and I get maximum download throughput.
    Do you have any idea why I only can get maximum upload throughput with LINKSYS' original firmware?
    I've reverted to the default settings with Tomato firmware installed and there is no improvement.
    There must be some kind of setting which Tomato configures differently or some service which is running only on Tomato that might cause this problem.

    Giving up on Tomato would be hard for me. It is an excellent firmware which gives me most if not all the power I need from the router.
  5. Dagger

    Dagger Networkin' Nut Member

    What type of WAN connection are you using? DHCP or PPPoE or what?

    When you test the speed are you testing via cable connection or wireless?
  6. myersw

    myersw Network Guru Member

    I had the MTU issue on some versions (don't remember what they were) of Tomato running on wrt54gl. Same modem, same ADSL line just different version of Tomato caused me to have to go to 1440 to get things working correctly. Ran fine like that just unusual as I can normally use the default of 1492 which is what was automatically set. Had to manually override.
    Never saw the issue with VicTek 1.25 on the wrt54gl or teddy_bear mods on a RT-N16.
  7. kobik

    kobik Networkin' Nut Member

    @Dagger, I'm using L2TP and the PC is connected to the LAN port.
    I also tried to set the router to use DHCP instead of the L2TP dialer and dialed from the PC.
    In this setup I get the maximum throughput.

    @myersw, what kind of issues did you had with the MTU?
    And how did you decided what was best value?
  8. Dagger

    Dagger Networkin' Nut Member

    So could the problem be with the L2TP dialer in Tomato?
  9. kobik

    kobik Networkin' Nut Member

    It may be.
    So it may be that there are settings which are only effective when using L2TP dialer @ the router.
  10. myersw

    myersw Network Guru Member

    Kobik, speed was part of the MTU issue as well as email problems. Later builds I have not had a problem. See this link for how to test for your max MTU using ping.


  11. kobik

    kobik Networkin' Nut Member

    Thanks Bill.
    I already got the MTU using this guide and it happens to be the default Tomato setting for L2TP which is 1460.
    Since I reverted to this value I got maximum download throughput.
    But I'm still banging my head what could be the reason for this upload throughput problem.
    I'm wandering if I'll get another Tomato supported router if I'll get the same result.
    Is there a way maybe to contact the dev?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice