WRT54GL Tomato v1.21 problems

Discussion in 'Tomato Firmware' started by Z.B., Oct 28, 2008.

  1. Z.B.

    Z.B. Addicted to LI Member

    My girlfriend has a WRT54GL v1.1. When using bittorent clients the router would become very unstable, losing connections often and making it impossible to browse the net at the same time. Other than that, the default firmware was pretty stable, and had no problems except torrents.

    However, today I decided to resolve that issue and upgrade to Tomato v1.21. The firmware update itself went without problems. I followed the instructions, didn't unplug any of the cables, and after one reset of the router I managed to access the Tomato GUI. The network consists of a Windows XP PC connected by cable and a Notebook running Vista connecting wirelessly, and the connection is through a motorola surfboard 5100 cable modem.

    I then set up the basic network information at first, set up pppoe and username and password, expecting no problems. However, it seems that the router just cant establish a connection to the internet. Whenever I look at the status it says "connecting". I tried rebooting the router, reseting it and trying the whole process again, setting the modems mac address as the wan address of the router, restarting the computer and router several times, however it just cant connect to the internet.

    I tried connecting the modem directly to the computer to see if everything is ok with the modem, and it is, it works flawlessly, and I also tried to connect wirelessly via the laptop to the router and it worked, however only LAN access.

    It seems that the router has problems establishing a connection to the internet, to my ISP and I have no idea why.

    Help please :)
  2. Z.B.

    Z.B. Addicted to LI Member

    Anyone? Please?
  3. icemanv3

    icemanv3 LI Guru Member

    if your on cable, you need to clone the MAC address of whichever pc you registered your service on.

    Some people say you don't but in my experience you have to.

    This could be the reason why
  4. Mastec

    Mastec Network Guru Member

    You mentioned power cycling your router... Did you do the same with the modem? Power off the modem and router. Power on the modem and let it cycle on. Then the router. You should be able to connect.
  5. Mastec

    Mastec Network Guru Member

    Not necessary if you power cycle the modem. I have never had to clone my pc's mac.
  6. bigclaw

    bigclaw Network Guru Member

    Wait. If you are using a cable modem, how come you need PPPoE credentials, which are for DSL?

    Power cycle your cable modem, and select DHCP in your router as connection type.
  7. Mastec

    Mastec Network Guru Member

    Sorry but I figured it would be pretty obvious to power cycle the modem, whether it be cable or DSL. I was just using cable modem as an example.
  8. bigclaw

    bigclaw Network Guru Member

    My message was intended for the OP, who mentioned he was using a Motorola SB5100 cable modem.
  9. Mastec

    Mastec Network Guru Member


    Well then... Nevermind with the apology. :tongue:
  10. Z.B.

    Z.B. Addicted to LI Member

    It is a cable modem but I have to connect via PPPOE with a username and password from my ISP. I did the same with the original linksys firmware before and it worked without any problems.

    Also, I did try power cycling the modem also, I unplugged it and then plugged the power cable back on, and I also tried to clone the modem's mac ID. However, not the PC's that the router is wired to, maybe I should try that. Altho I didnt have to do it with the original firmware.
  11. Z.B.

    Z.B. Addicted to LI Member

    The error message i keep getting when I try to connect is "Can not get IP address from pppoe server". Any ideas what it could be?
  12. Z.B.

    Z.B. Addicted to LI Member

    Now I have another problem. Somehow I managed to get it to connect, first with the original linksys firmware and then with tomato.

    However, in tomato at first I only set up my pppoe username and password and it works. But when I try to change other setting, for example disable wireless or set a password to wireless the router simply wont connect to the internet again.

    Any ideas?
  13. Z.B.

    Z.B. Addicted to LI Member

    It seems I have solved the issue, altho I dont understand why it was a problem.

    It seems that when I entered information in the "service name" field, the router just wouldt connect. If I leave it blank it connects without problems.
  14. makGuitar

    makGuitar Addicted to LI Member

    I had the same problem using openWRT :S
  15. mikester

    mikester Network Guru Member

    I've recently switched ISP's and suddenly started having all sorts of connection issues...I have a static IP and am NOT using PPPoe. The only resolution initially appeared to be re-booting the router.

    I changed the following settings on my Tomato with some success:
    MTU 1400 <default was Auto>
    Respond To ICMP Ping <was unchecked>
    Allow Multicast <was unchecked>
    NAT Loopback - ALL

    I also added a script to ping the gateway every 5 minutes and reboot the router if sequential pings fail.

    The connection losses have improved somewhat. I still have issues with intermittent packet loss - ISP related? This new ISP tech support blows...

    Anybody else see similar issues?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice