WRT54GL, Tomato, XBOX/XP SMB Shares, and RDP

Discussion in 'Tomato Firmware' started by kl34i2, Dec 12, 2007.

  1. kl34i2

    kl34i2 LI Guru Member

    I recently installed DD-WRT on my WRT54GL router, and after having been through a bunch of problems (unable to access admin page, slowed connection while using P2P apps, etc.) I decided to give Tomato a try. Right from the start, this is working as expected, and my connection has greatly improved. I thought all was great, until I decided to try two important scenarios: connecting from my XBOX to an XP SMB share, and trying to RDP into my desktop from my laptop, and vice-versa.

    Here's what works so far:
    - ping xbox and desktop
    - access remote shares on laptop/desktop via UNC
    - XBOX using XBMC can access the internet and download RSS feeds
    - all devices (desktop, laptop, xbox) can see each other
    - P2P applications are working flawlessly

    I'm going to mention this, hoping this isn't the reason, but I have Comcast and they provided me with a WCG200-CC wireless router. I went into its configuration and set up my WRT54GL router in the DMZ area, since I don't want the Comcast router acting as a firewall. This actually resolved the P2P problems I was having, but it's done nothing for my XBOX issues.

    The XBMC configuration was working properly with DD-WRT, but I really don't want to go back to it. The RDP scenario, has not worked at all on either firmwares. I'm using the latest Tomato firmware, 1.13.

    Thanks in advance!
  2. rgh246

    rgh246 Guest

  3. mstombs

    mstombs Network Guru Member

    As per discussion in the v13 release thread - try setting "NAT Loopback" to "forwarded only" if currently set to "enabled".
  4. j.m.

    j.m. Network Guru Member

    Yes, please try this. The setting is at Advanced | Firewall. You may have to restart your PC and Xbox.
  5. kl34i2

    kl34i2 LI Guru Member

    Yep, that did it. I swear though, I searched the forum and came across the same suggestion, tried it, and it didn't work. The difference now is that I had turned off the XBOX and rebooted by computer since I set it up.

    Okay, so with the XBOX problem fixed (can't believe how much your media center can be missed when it's broken), how do I go about fixing this issue with RDP? I mean, my computers can pretty much talk to each other, see their shares, ping, etc., but trying to use RDP fails all the time. I tried port-forwarding but was unsuccessful. I use Sygate on my computers, and have set up the rules properly--though I also disabled the firewalls on both for testing--and these same rules worked on my previous D-Link DI-624 router. I just happen to dislike that router now that I've got the Linksys plus a great firmware!

    Thanks again!!
  6. j.m.

    j.m. Network Guru Member

    I use RDP both LAN-to-LAN and WAN-to-LAN, so I know it works. Are you doing the former, latter, or both? Which, if either, is working?
  7. paped

    paped LI Guru Member

    Please don't take this the wrong way but just to double check the basics first you have got RDP enabled on your PC that you are trying to connect to in the "system" window within control panel?

    Had a friend with the same issue and had it going in 5 mins for him when the box was ticked and a user added, he could'nt believe it he had been at it for a week before that and could not get it to work......
  8. kl34i2

    kl34i2 LI Guru Member

    OMG...okay, so, yeah...that's all I can say now...

    It's working. Where's the red, embarrassed smiley when you need one? Didn't even think about that one!

    Thanks everyone for all your help, still feel like an idiot though :)
  9. paped

    paped LI Guru Member

    Don't worry easily done, its very well hidden in the bowels of the OS....

    Glad its working for you though.....!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice