WRT54GL - Unable to Upgrade FW

Discussion in 'Cisco/Linksys Wireless Routers' started by gnulab, Sep 15, 2008.

  1. gnulab

    gnulab LI Guru Member

    Hi there,

    This is my 4th WRT54GL and I am having trouble upgrading its firmware.

    After clicking "upgrade", few seconds later Firefox 3 came with this error message:

    Connection Interrupted
    The connection to the server was reset while the page was loading.
    The network link was interrupted while negotiating a connection. Please try again.

    Then the power LED will blink for short moment ~10s, and everything (LEDs) went back to normal. However, at this stage, I have to restart the router before I could access the config page again and, of course, it's still with the default firmware.

    I have tried upgrading using dd-wrt v24 mini generic & tomato 1.21 firmware, both generate the same error message.

    Anyone experiences this similar event? Any remedies?

    Thank you in advance.
  2. TVTV

    TVTV LI Guru Member


    1'st of all, the firmware should not be updated via wireless or through a HTTPS connection.
    If you've already tried updating the firmware the right way (over a wired and HTTP connection) but to no avail, you can try updating the firmware via TFTP. There are plenty of instructions available on the web. :)

    Don't forget to do a full nvram erase (via reset button, again - instructions on the web) before (and after) flashing your new firmware.

    G'luck! :)
  3. danix71

    danix71 LI Guru Member

    And even so (I agree with the lines written above) you don't have to ''dd-wrt v24 mini generic'' on a GL!
    All the GL's that I have, I've upgraded via web interface as soon as the comercial package came off...(Tomato :) ). Not the slightest problem...
  4. gnulab

    gnulab LI Guru Member

    Ok, tonight I shall try TFTP using Tomato firmware. Let's see how that goes.

    The past 3 WRT54GL never have such a problem....:frown:
  5. gnulab

    gnulab LI Guru Member

    Word of Caution for upgrading.


    So I've managed to solve it.

    1. Use another PC.
    2. Do a 30/30/30 rule (google it, esp at the www.dd-wrt.com website)
    3. Upload the first firmware upgrade using internet explorer and *NOT* firefox.
    4. Success! Now I'm happy.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice