WRT54GL v1.1, Almost everything tried and still bricked...

Discussion in 'Cisco/Linksys Wireless Routers' started by laattalj, May 9, 2007.

  1. laattalj

    laattalj Guest

    I'm new to this forum and I really would use some help.
    I manage successfully flash OpenWRT to my Linksys WRT54GL router. After that I started to play with the NVRAM values and finally bricked my router... Now, when I turn on the power of the router, it just blinks the power led and all the lan port leds are on. I did extensive search on this forum and find out that it means CFE is not working properly. After reading some more I come to conclusion that JTAG is way to. I both one from here: www.diygadget.com. I got my cable, downloaded EJTAG Debrick Utility v4.8 software and set up connection between my PC and router. First I used the following command to check that my connection worked:

    wrt54g -probeonly /noemw

    router responted and I got this print out:

    F:\JTAG\windows>wrt54g -probeonly /noemw

    WRT54G/GS EJTAG Debrick Utility v4.8

    Probing bus ... Done

    Instruction Length set to 8

    CPU Chip ID: 00000101001101010010000101111111 (0535217F)
    *** Found a Broadcom BCM5352 Rev 1 CPU chip ***

    - EJTAG IMPCODE ....... : 00000000100000000000100100000100 (00800904)
    - EJTAG Version ....... : 1 or 2.0
    - EJTAG DMA Support ... : Yes

    Issuing Processor / Peripheral Reset ... Done
    Enabling Memory Writes ... Skipped
    Halting Processor ... <Processor Entered Debug Mode!> ... Done
    Clearing Watchdog ... Done

    Probing Flash at (Flash Window: 0x1fc00000) ... Done

    Flash Vendor ID: 00000000000000000000000011101100 (000000EC)
    Flash Device ID: 00000000000000000010001010100010 (000022A2)
    *** Found a K8D3216UBC 2Mx16 BotB (4MB) Flash Chip ***

    - Flash Chip Window Start .... : 1fc00000
    - Flash Chip Window Length ... : 00200000
    - Selected Area Start ........ : 00000000
    - Selected Area Length ....... : 00000000


    Then I tried to erase the NVRAM and see if the problem was there

    wrt54g -erase:nvram /noemw

    Nothing, router still in same state.Then I decided to erase whole flash, flash new CFE in and after that use TFTP to install new firmaware. I made the CFE using SkyNet RepairKit 1.3 and used following commands:

    wrt54g -erase:wholeflash /noemw
    wrt54g -flash:cfe /noemw

    Everything went just fine. Didn't get any error messages and wrt54g printed out that CFE.BIN flashed. I rebooted my router and...nothing! The router is just in the same state: power led in blinking and lan leds are on. I figured out that there may have been some problem in the flashing even though I didn't get any error messages, so I made I backup from the CFE that I just flashed:

    wrt54g -backup:cfe /noemw

    then I compared the original and the backup: they are identical! So I know that my flashing is working just fine. After that I did some more reading and came a cross information that Linksys have chanced the flashchip from Intel to Samsung. I started to wonder that could it be that the CFE that I made using Skynet Reparkit ins't compatible with the samsung chip? Or does it matter at all?

    If someone has the same router with same chip (samsung) could backup their CFE and send it to me (jukka.laattala_(at)_gmail.com), so I could compare that there is no difference between that and the one I made with Skynet RepairKit.

    Does anyone have any more ideas that I could try?

    Should I get serial cable? Could I get more information out off it?

    Here's some informatio of the router:
    Linksys WRT54GL v.1.1 (bought from Finland)

    Flash Chip:
    Samsung 628
    Sticker on chip:
    ver:4.30.7 CS:AF81
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice