WRT54GL V1.1 Ser. CL7B DMA Read Error when flashing Kernel or CFE

Discussion in 'Cisco/Linksys Wireless Routers' started by foliastar, Aug 30, 2009.

  1. foliastar

    foliastar Guest

    WRT54GL V1.1 Ser. CL7B DMA Read Error when flashing Kernel


    I tried to ask in german forum but it looks that nobody had this trouble before ;-)

    I hav a WRT54GL V1.1 with DD-WRT V24 firmware.

    I build a SD-MMC inside....its working and formattedt correct.....but the VPN didnt have the SD-MMC switch that why i flashed the Standard version.

    All was ok....but once i tried to send a command over the inside field to work with the sd-card....and it hangs up............

    From this time Power is blinking and the rest is lighting.

    Ok i take my Jtag cable and erased 2 times the nvram.....no result.
    Hard rest didnt change something.

    OK lets make a new CFE and flash it....flash looks ok but nothing change also after clearing nvram, its still not working or possible to ping to use TFTP.

    Also when i flash the kernel i got some DMA READ ERROR'S..........

    i already use the jtag cable last year for flashing and it wokrs coorect....i checked th cable was 40cm and good and correct made.

    I tried also some switches but was not really sure what is useful.

    The time for flashing an CFE or kernel takes hours it looks that it send only 4 strings in time.....u could read all data easiely that slow it is..........

    Someone knows what means the DMA READ ERROR and what is the reason?
    Could someone tell me sshort the functio switches like /noemw /nocwd and soon?

  2. irootsk

    irootsk Addicted to LI Member

    check this link for explaination of those switches. It's on page 2.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice