WRT54GL with Tomato v1.19 loses internet connectivity

Discussion in 'Tomato Firmware' started by ApolloDog, Jul 1, 2008.

  1. ApolloDog

    ApolloDog Addicted to LI Member

    Hi all. I just upgraded the firmware on my WRT54GL router to the forementioned Tomato version. Not sure of the router version, it is not in front of me at the moment, but it is about 5 or 6 months old. I have 2 wired PC's that are on almost continuosly, one XBox 360, a wireless MacBook and a wirelss PC laptop. Over the last few days, I would lose my internet connection... on just the one wired PC, after a 12 to 24 hour period. It happens only that machine, not the other wired machine that is also on days at a time, nor the Xbox or wireless laptops. This only began happening after the update to Tomato. Prior to that, I never lost connectivity. Nothing else has changed. I use Cox Cable for my ISP. Does anyone have any experience with this? Everything is set up for DHCP, nothing static, nothing seems out of the ordinary. Any help would be appreciated.
  2. ooglek

    ooglek LI Guru Member

    More details.

    Just a suggestion, if you want help, you need to post more details about your setup, and also post what you've Googled to try and solve the problem yourself. People will be more likely to help if you've tried to solve this on your own first. And if you have, you need to say what you've done so people don't think you're just lazy and want someone else to provide free tech support.

    First off, you need to post the version of Tomato. If you aren't using the latest version, start with an upgrade to the latest version. Bugs get fixed, and if you are running anything less than 1.19, most will be unlikely to help, as your problem may have already been fixed in a later version.

    You say you would lose your Internet connection, but you don't really, just one of your wired PCs lost connectivity to your router. Your Internet connection is fine. The problem is between your one wired PC and your router.

    1. Move the wired PC connection to a different port on the router.
    2. Still broken? Reboot the PC when it is having trouble connecting.
    3. Still broken? Upgrade the network drivers on the PC.
    4. Still broken? Reboot your router when your PC is having trouble connecting.
    5. Still broken? Larger issues are at hand.

    If moving ports works, the issue is an ethernet port going bad. It happens.
    If rebooting the PC works, the problem is the PC. Consider updating drivers, running windows update (assuming it's running Windows), get a new network card.
    If upgrading drivers works, great.
    If rebooting your router works, maybe Tomato doesn't like your router. It's rare, but it happens. It could be a hardware issue too, just one that doesn't occur with other firmware, and in that case, jump ship back to DDWRT or Linksys firmware.
    If none of that helps, well, then it's beyond me. Move the wired PC that DOES work to the port connected to the PC that fails. See if that other PC loses connectivity to your router.
  3. ApolloDog

    ApolloDog Addicted to LI Member

    Thanks for the response

    FYI, I did state in the title that it was Tomato v. 1.19...and although the title does say lost internet connection without specifying it was one only PC, it is mentioned in the post that it is just one wired PC. I did not mention that the PC was losing connectivity to my router; it still has access to it. I can ping the router and access the firmware GUI, no problems. Problem is that this one particular PC can not access the internet unless it is rebooted (no SMTP, HTTP, etc.). Rebooting the router does not fix the problem. Network drivers are up to date. Port is not a problem. Windows XP Pro SP2 is up to date. When I go back to the latest version of the Linksys firmware, problem is gone. I can run indefinitely without having to reboot the PC because of Internet connectivity issues. I tried an older version of Tomato (v 1.17), problem happens again. Runs a day at most before I lose internet access (this PC only). Reset the router 30/30/30, still lose connectivity after a time (again, this one PC only), on any version of Tomato from 1.17 up to 1.19. Nobody else seems to mention this particular problem with the WRT54GL v1.1 router, so I wouldn't imagine it is the router. The only difference I see when the connection from this one PC to the internet via the router is not lost is the firmware, original Linksys works, Tomato loses the connection. I was going to try DD-WRT, but I really wanted to get this working if possible. As for searching on google, I have been doing it for days now. Hard to find anything for this specific issue. I did find this forum by googling though. As for free tech support...isn't that what this forum and others are for?:smile:
  4. nitehawk337

    nitehawk337 Guest

    Thought I'd chime in here. I ma having the same problem, but with different enough hardware that I'm willing to bet it's a bug in the firmware in 1.19.

    I am running 1.19 on a WRT54G v 2 or 3.
    Ever since the upgrade (from tomato 1.17) a few days ago, my one wired server is losing connection to the router. The box is a linux kernel
    I've rebooted the server, the router, swapped out the cable, and swapped ports, and still get random disconnects.
    The port gets pretty regular traffic, as (among other things) I run a calendar that is pulled across the web every 15min or so.

    On the upside, I don't need to reboot the box, just have refresh the network connection to have it connect again.
  5. i1135t

    i1135t Network Guru Member

    Have you guys checked the logs on the router to see if there are any clues there? Before the change over to Tomato, did you RESET your router to default settings (ie clear NVRAM), then manually enter in all data?

    Side note, one thing I did notice on hardc0re's speedmod & original Tomato firmware, was that one of my hardwire connection was trying to grab a new IP, when I set it to have a static IP.

    I think the only way I was able to fix this was to set my DHCP lease to infinite, in the advanced settings, under firewall, I believe. Not 100% sure, can't remember off the top of my head. It's in the drop down box. But by doing this, the lease is infinite, so it should never try to grab a new IP after it has one. (FYI, after setting the changes, you will need to renew the IP or reboot the router.)

    My thoughts is that it could be a bug in the firmware. Right now, I'm using Victek's mod and seems to be stable and working good. This should also fix the issue for all Tomato mods...


    OK, the setting is under 'Advance' , 'DHCP', 'lease time'... have fun!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice