WRT54GS and DMZ/Port Forwarding

Discussion in 'Networking Issues' started by badassz34, Sep 26, 2009.

  1. badassz34

    badassz34 LI Guru Member

    Ok, so the wife is going to Iraq soon, and I wanted to set up so she can access certain things on our home network while she's away. I Hem-Hawed about it for several days, and finally decided I'd use Apache 2.2.13 on my machine, use port forwarding or DMZ to open it to the network, and provide her a webpage to log in and access what she may need on the home network. It should only be so simple, right?

    Well, I decided to go with dyndns, since my isp only offers fixed ip address with business-class service (read: expensive-class). I set up dyndns, and it works fine when I port forward to, or DMZ, my NAS. All well and good, I think, so lets switch to forward to (or dmz) the ip of my recently built apache server. No dice.

    Well, maybe apache isn't running right, I thought. It's listening to port 80 for http traffic, and responding correctly, as it serves up my temporary 'index' page from any machine on my local network. Ok, so I check out windows firewall and macafee, apache trusted and wide open on both programs, full access inbound an out. What gives, I think.

    Now I think, maybe the wrt54gs has taken a dump on me, so I change it back to forward to the NAS's IP address. Go to my dyndns address, and bang. It works. Change it back to point the port forwarding to my apache server, still not working. Strange thing is, I KNOW my ISP isn't blocking 80 because that's the port I'm accessing the NAS on. Add to that the fact that the router is letting me get to one device, but not another, the only difference between the two set-ups the forward-to IP address, and that I can still acess the web server from elsewhere on my network, and I am jsut plum puzzled. Anyone got a bright idea for me, or maybe can re-kindle my apparently waning lightbulb?

    I'm using a WRT54GS with fw v7.2.07, the apache http server 2.2.13., and the NAS is a usb drive behind a stock SLUG runnign fw 2.3R63.

    Edit: I fixed it (for the most part). I'd overlooked something in windows firewall. It was allowing incoming requests from trusted network, but not from outside. I have yet to have time to work on the web interface to allow her in beyond the index page. I don't know if I will find time.

    For now I've got the NAS allowing incoming connections from known users via web interface to their folders only, as well as guest access to a 'public' folder. It works, but it's all by web interface. I havent tried setting up the FTP interface yet, but pan to sometime. It seems it would be easier to navigate and use with FTP, but security woes concern me.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice