WRT54GS Connection Problems

Discussion in 'Cisco/Linksys Wireless Routers' started by morsmordre, Mar 5, 2006.

  1. morsmordre

    morsmordre Guest

    Hello everyone,

    Laptop: Dell Inspiron 9300
    Wireless Adapter: Intel Pro 2915ABG
    Router: Linksys WRT54GS V4 running official firmware 1.05

    I've had this wireless router for a little over a month and have had no trouble until recently. My laptop can see the router but once connected it takes an abnormally long time to assign an IP address. After it assigns an IP address I can't access the internet or the network. I tried repairing the connection and still nothing. I've also tried resetting the router and installing/setting it up from scratch only to come up with the same problem. If I manually assign the addresses I can connect to the network.

    My network is using 64 bit, 10 hex, WEP. I found that the problem only occurs when I'm running secured. If I disable the WEP I can connect to the network just fine.

    My brother has the same router that I do but his is a version 1 running official firmware 3.37.2. He also uses the same security settings as I do. I've used my laptop here before and managed to connect to his network. But now I can't connect. I figured I would manually assign the addresses as it's worked at my house but it doesn't work here. If we disable his security settings on the router I can connect with no problems.

    To tell you the truth I'm not even sure if this is the router's fault as it could be a faulty adapter. But when I connect my Nintendo DS (Mario Kart DS) now I have to manually assign the addresses versus it doing it automatically, like before.

    I've posted on other forums and this site was very highly recommended. I pray that you guys can help me out.

    Thanks in advance.
  2. limesoft

    limesoft Network Guru Member

    try the officecial one v1.05.2

    Linksys, A division of Cisco Systems, Inc.

    Product: WRT54GS v.4

    Classification: Firmware Release History

    Firmware Date: 9/15/2005

    Release Date: 10/5/2005

    Last Firmware Version: 1.05.2
    Firmware 1.05.2
    - Fix WDS under WPA mode issue
    - Fixed issue where user can choose "Shared Key" under WPA-Personal and WPA-Enterprise.
    - Fixed issue where long SES push generates new SSID and key instead of reset to defaults
    - Fix iDEFENSE issue
    - Add SES disable function in "Wireless Advanced" page
    - Fixed SES LED delay
    - Fixed issue where SES SSID/security is applied even when there is no SES clients
    - Fix L2TP disconnect issue
    - Fix DMZ and Port forwarding issue

    Firmware 1.05
    - Initial release for version 4.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice