WRT54GS, D-link DSL-320T, PPPoA, is this correct?

Discussion in 'Cisco/Linksys Wireless Routers' started by Jaidee, Jun 10, 2007.

  1. Jaidee

    Jaidee LI Guru Member

    Hello all, I'm new and thanks in advance for any help I might recieve here.

    To make something quite clear, my connection is WORKING, I'm just making sure I have a sensible setup, and that heavy p2p connections wont crash my system.

    My current setup is as follows:

    D-Link DSL-320T ---> WRT54GS (DD-WRT Micro) ---> Rest of network --- ---- 192.168.0.*

    I am in the UK and have a PPPoA only ADSL conenction to Nildram (GetADSL). I have the D-Link modem setup to connect to PPPoA, with all the settings entered correctly. I have a static WAN IP of, which registers correctly on the D-Link. I also have DCHP on the D-link enabled, and the WRT54GS internet mode is set to DHCP (Automatic). It correctly recives the WAN IP of, and provides DHCP to the rest of the network perfectly. Everything is working fine.

    As I have a static IP on WAN, I've set the DHCP timeout from the modem to be 60 mins.

    The thing that worries me is I have read the following http://www.csc.liv.ac.uk/~greg/projects/dlink.html and the thread at http://www.linksysinfo.org/forums/showthread.php?t=53258 and I'm worried that I have a "double NAT" situation that might cause ARP problems with heavy p2p connections. Will the fact that the modem and router are on different subnets help? I tried putting the modem in bridge mode and it worked for one evening (how it did this I have no idea - how did it now my connection username and password? Bridge mode did not ask for them!) but then it failed and now I'm back in PPPoA mode with DHCP.

    Thanks for reading this, sorry if it comes across a little disjointed, I just wat to cover all aspects.
  2. mstombs

    mstombs Network Guru Member

    If Nildram routes via BT you may be able to use PPPOE full bridge mode, even though not officially supported. But if/when they LLU your exchange you may get kicked back to PPPOA.

    D-Link zipb causes a number of problems, a potential arp table (device list) issue in the router, an unnecessary NAT table issue in the modem, and the version I looked took ages to get a DSL connection (DSL drivers?) and didn't even bother to transmit both ISP DNS servers to the router by dhcp.

    But only you know if it is a problem for you! I found rebooting the modem every couple of days helped!

    Good news is you will be able to fix any of the problems because both your devices can run 3rd party firmware which give you access to Linux.

    If your IP really is static then you also don't have the half bridge complications others have with communicating the change in WANIP.
  3. Jaidee

    Jaidee LI Guru Member

    Thanks for the advice!

    I am having problems with my setup now. The probelsm are intermittent, so I don't mind much, but the whole point of me buying this new kit was for stability so I really want to get it sorted.

    Could you point me in the direction of 3rd party firmware that works on the DSL-320T? All I can find is some telnet commands to modify the various timeouts.

    Many thanks.
  4. mstombs

    mstombs Network Guru Member

    Well as you are already using dd-wrt you will understand the risks of 3rd party firmware, warranty etc, and my caution in recommending anything. The solution supplied by Greg in the link above does not change the firmware, it Telnets in and configures at console script level, and does indeed solve the modem NAT and router ARP problem. As you have a static IP you do not need the complication of passing the IP address from modem to router when it changes, and resetting the routes/gateways.

    I use Routertech firmware on my ADSL2MUE, which is so similar to the DSL320T that it can also run D-Link firmware - but the 2MUE has more flash/ram so no guarantees etc etc. I don't think I have seen anyone post success with a 320T with latest 2.3 version, so you may want to ask in the forums first. They also supply a Router Update Checker - a telnet script (RUC) which will help check compatibility. I recall the LED configuration was wrong in a previous version, may be fixable in the latest (with led_conf environment variable correctly set). But RT 2.3 doesn't include zipb (D-Link do not publish source for this bit) - it includes my own home-grown 'experimental' script for managing half-bridge mode with non-static IP - this may need an additional patch to dd-wrt to work properly (firewall script for Hyperwrt which also works with Tomato supplied).

    Note that RouterTech.org firmware is based on a Russian Acorp GPL software release which in turn is close to the Ti AR7 NSP reference design, and therefore compatible with a huge range of commercial products based on the same chipset - thanks to the Linux GPL core! I guess a DSL320T is similar to Acorp LAN120. There are binary modules included for which there is no published source, and the Routertech team have added a number of their own.
  5. Jaidee

    Jaidee LI Guru Member

    Right, I'll have a look at the Routertech firmware and see how compatible it's gonna be. Cheers for the help!

    ps: stable now for one day with D-Link firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice