WRT54GS disconnects every hour (Wired and wireless)

Discussion in 'Cisco/Linksys Wireless Routers' started by RobW, Jul 27, 2005.

  1. RobW

    RobW Network Guru Member

    This is a different problem from the long thread on wireless disconnects and rebooting with copying large files...

    I have a small network at home - desktop PC and 2 laptops (One Dell Precision M50 and one HP Pavilion zd8000) all running XP Pro. Using the European WRT54GS (v1.1 by serial number). All the computers can talk to each other on the network. The HP laptop can use either wired or wireless. The Router has the latest (european) firmware ie 3.37.2. There are no problems copying files between the computers and I've even tried the Micorosoft Office file that one thread mentions as causing problems and this can move about on my little network with no problems. The only thing is, when we try to play Warcraft 3 on a local LAN game, it disconnects all the computers nearly every hour. It doesn't matter if there are two or three computers in the game, and it doesn't matter if one of the laptops is wired or wireless. I've tried port forwarding in case that would help, and I've also tried reducing the fragmentation and RTS thresholds to 2304 (though not sure how this would help with wired connections). Yet we still have to remember to save the game at around 50 mins as we get thrown off shortly after that. I suspect that I'm doing something really daft here, but would welcome any help. And looking at the problems that some people are having, I suppose that I should be grateful. But I would just like it to work properly...

    Thanks again.

  2. jjmack

    jjmack Network Guru Member

    DHCP leasetime

    How about hte lease time on the IP address for the routers. Do you have the leases for the clients expiring too soon?

    They should renew, but since you describe the problem with a predictable expiration of 50 minutes, then my hunch is that there is something that is timed to do this every 50 minutes.
  3. jagboy

    jagboy Network Guru Member

    did you try to reset the router.
  4. snowgoose

    snowgoose Network Guru Member

    PPPoE disconnects

    This problem sounds very similiar to the one that is described here:

    I have been chatting with the linksys support about it for a long time, finally they suggested me to replace it (after asking me to reset it, reflash it, reset it, and all over again-no use) its seems that its some kind of a confirmed HW bug in the WRT54XX.

    Funny thing is that this problem got worse after the upgrade to the 4.00.7 version, maybe I should flash one of the non official firmwares.
  5. RobW

    RobW Network Guru Member

    Thanks for your replies, guys. The client lease time is set to "0" which should mean it lasts a day, I think...

    I've tried resetting it, and reflashing both with the "official" 3.37.2 and with hyperWRT 2.0.

    I think it's going back in the box and back to PCWorld...

    Thanks again for your help.
  6. jagboy

    jagboy Network Guru Member

    maybe it is a bad unit.
  7. freaky_00

    freaky_00 Network Guru Member

    I'm pretty sure it is not a bad unit! I have the exact same version and the exact same problem!!! I'm from the euro region too!

    I'm getting sick that this problem is being ignored even by users of this board! I think I started 3 threads no one replied.

    szurlo stated the problem pretty good in this thread.

    Not everything is exactly like szurlo's problem. Mine only disconnects and reconnects after 10-180 seconds.

    The only resolution I have is update to the newest us firmware. It still disconnects sometimes. But not as much as it did in its worst days (every 10 to 45mins!!!).
  8. rb1kenobi

    rb1kenobi Network Guru Member

    Disconnect Every 4 minutes like clockwork!

    Ok, "me too". I have the same problem.
    My WRT54G f/w 4.00.7 will disconnect my wireless laptop at EXACTLY 4 minute intervals.
    If I setup a ping from the laptop to the router (ie: constant traffic), it will "pause pinging" at 4 minutes...and in my event log, it logs one of these every 4 minutes:

    The system detected that network adapter \DEVICE\TCPIP_{89B4437A-33B8-4058-A9F3-6B4B6984B8B5} was connected to the network, and has initiated normal operation over the network adapter.

    - My laptop is configured for DHCP
    - no "disconnect" errors in the event log (WinXP sp2), just the "connect" above
    - I have NO SECURITY enabled, although I did turn on MAC filtering cause I felt like my pants were down without my WPA.
    - all power save settings for the nic are disabled
    - I don't have any 2.4 GHZ phones/baby monitors etc.
    - I am getting EXCELLENT Signal Strength

    Ok, now get this, as I'm writing this, I have an idea.
    So I start watching the "Speed" parameter in the wireless status screen in Win XP.
    I'm normally @ 54MB/s
    At the 4 minute interval described above, my speed drops to 1MB!!!!!
    At that point, I lose connection, and then it ramps up to 2, 5.5, 12, 18, 24, 36,48,and finally 54MB with EXACTLY 8 seconds between each step.
    Now, I'm guessing that this ramp up is NORMAL behavior, ie: once a wireless client connects to the router...it tries to bump its speed up to the max it can handle.
    So maybe I'm off on a goose chase with the speed thing, may be a result of the disconnect, not the cause.

    I'm out of information, will post more if I get smarter.
  9. TMAC

    TMAC Network Guru Member

    are you using dsl or cable connection? try changeing the mtu of the router DSL=1492 Cable=1400... if still the same problem... try isolating the problem connect modem to computer checl if your having the same problem...
  10. rb1kenobi

    rb1kenobi Network Guru Member

    TMAC: you misunderstood my problem
    I am NOT losing connectivity to the ISP....I'm losing connectivity from the WRT56G to the wireless client So MTU on the WAN side is a moot point.

    For a hoot though, I changed my MTU from Auto to 1492 (DSL), not a sniff of a difference (of course).

    (Thanks for trying though, effort is appreciated , even if not succesfull)
  11. TMAC

    TMAC Network Guru Member

    try relocating the router... and changing channel and ssid... try resetting the router... and if still the same... firmware upgrade the router then reset it... if still the same... replace the router... that is the last oprtion...
  12. snowgoose

    snowgoose Network Guru Member

  13. rb1kenobi

    rb1kenobi Network Guru Member

    Problem solved

    Ok, first I'd like to thank the people who tried to solve this problem for me, even those who somehow got the idea that it was a WAN/ISP problem (it wasn't!).
    To summarize
    Problem: My wireless laptop client (HP nc6120) kept getting disconnected from the router every 4 minutes, exactly.

    Solution: upgraded the driver/firmware for my laptop client (Intel Pro Wireless 2200BG) to

    Hope this helps someone else.
  14. bigdog

    bigdog Network Guru Member

    I have a very similar problem as well as my wireless laptop gets disconnected every so often too (not sure if every 4 mins) but sounds like the same problem, especially with the speed changes you mentioned. I've tried both Alchemy and DDWRT and similar results so don't think it is on the router side.

    Where did you find the updated drivers for Intel Pro 2200BG? I have that built into my laptop as well and would like to see if that helps. Mine says
  15. rb1kenobi

    rb1kenobi Network Guru Member

    Updating Intel 2200BG drivers

    You can find the "generic" drivers direct from intel here:


    Intel does recommend that you try and get the driver from your laptop manufacturer directly, as there is sometimes some minor differences. In my case, I dloaded the driver directly from HP's website (as I have an HP Laptop)

    Hope this helps!
  16. bigdog

    bigdog Network Guru Member

    Thanks I will give that Intel link a try. I have a Gateway 8510GZ and they don't have any drivers listed for it yet... Have you seen any problems with the new driver? Is the disconnect problem totally fixed now? I tried 2 different versions of firmware (Alchemy and DD-WRT) bumped the power up to 56mw, bumped the cpu speed up to 216 and still had the disconnects ONLY on the wireless laptop, even from like 20ft away.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice