WRT54GS firmware upgrade fails

Discussion in 'Cisco/Linksys Wireless Routers' started by robt, Oct 31, 2004.

  1. robt

    robt Network Guru Member

    Everytime I try to upgrade to 3.17.4 my router says finished successfully but it doesn't come back. Power light keeps flashing even after reseting it for 30 seconds. Did a tftp -i put 2.07 code, and it came back up. I then forced the 3.17.4 firmware in with the tftp command, after that the router works then reboots after 30 seconds or so. I am back on the 2.07 codenow and all is good. Any ideas????

    I get the same results with the HyperWRT code. I noticed some people have flashed to the new code without problems so I guess the file is fine. Maybe I have a bad flash chip.
  2. Toxic

    Toxic Administrator Staff Member

    use the web interface upgrade

    tftp has a known issue with firmwares over 3Mb

    also make sure you download the file again incase of a corrupt file
  3. robt

    robt Network Guru Member

    Thanks fo the reply. I tried the web interface 10 times and it failed every one. After that I used the tftp just to see if it would work but I ended up with the reboot problem so I went back to 2.07

  4. Toxic

    Toxic Administrator Staff Member

    3.17.4 should be 3,560,448 bytes in my eyes.

    reset router before upgrading. jst fo see if this helps. make sure your web broser is not using ANY proxy cache either and delete ALL temp ineternet files just incase something is making the upgrade crash.

    make sure you dont upgrade over the wireless signal always upgrade from a WIRED pc.
  5. robt

    robt Network Guru Member

    Thanks again.
    I cleared the cache, reset router, verified file byte size is the same as yours. Web upgraded using IE, it said it succeded but it didn't return after it rebooted. Power light flashing and the dmz light comes on for 3 seconds off for 5 seconds, on for 3 off for 5. Reset router for 30 seconds still didn't work. Went back to 2.07.1 using tftp, tried upgrade with Firefox, same results. Tried a second wired computer/IE same results.

    Back on 2.07.1 now, router is fine. Tried to web update to 2.07.1 while the router was running 2.07.1 and that failed also. Is the web update screwed up or what?
    Thanks for helping.
  6. robt

    robt Network Guru Member


    I will try using the setup wizard/tftp program from the befw11s4 download page. Maybe that will help this POS router.
  7. Toxic

    Toxic Administrator Staff Member

    it is definately a GS router and not a G? seems wired that it will only update to 2.07.1 only
  8. robt

    robt Network Guru Member

    That failed too.

    Yes it is a 45 day old WRT54GS Speedbooster 1.0 ser#CGNXXXXXXXXX, I bought it to replace my BEFW11S4 which I never had a problem upgrading.

    It will take a manual dos command "tftp -i put 2.07.1.bin", but it will not take 2.07.1 throught the web update. It doesn't take anything through the web update and only 2.07.1 from dos, which is the version the router came with.
  9. frogger3d

    frogger3d Network Guru Member

    You should remove all other network cables.
  10. robt

    robt Network Guru Member

    Thanks for the suggestion. I tried, and that failed also.

    I tried to dos tftp 2.06.1 and that worked. I then tried to web update straight to 3.17.4 and it failed again.

  11. fatoil

    fatoil Network Guru Member

    It is likely that the problem is caused by the flash chip as u said.
  12. robt

    robt Network Guru Member

    thanks fo reply..

    RMA time.

  13. robt

    robt Network Guru Member


    My new WRT54GS arrived today. Flashed to 3.17.4, no problems. Linksys must have got some bad flash chips or something. I have seen 2 other people complain about the same problem.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice