WRT54GS grinds to a halt with file sharing / P2P running

Discussion in 'Cisco/Linksys Wireless Routers' started by Demon, Sep 5, 2005.

  1. Demon

    Demon Network Guru Member

    Hi all,

    I'm having a real problem with my WRT-54GS when using file sharing programmes (specifically emule and azureus).

    The problem Ihave is that as soon as I loaded one of these two up (on a PC connecting wirelessly - haven't tried wired), my internet connection slows right down. I mean grinds to ah halt - to the point where suring is impossible... webpages kept timing out etc.

    I THINK this problem came when upgrading my firmware from the one that came with the router originally (version 1?) to the most rcent version. Trying Alchemy and HyperWRT haven't made a differnece.

    I found this thread and added the echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts line to the statup script - but it didn't make a difference.

    Another "fix" I've tried is changing the MTU setting to Manual, with a value of 1492 on the Basic Setup page. My wireless router is wired to an ADSL router which also has MTU set at 1492.

    I thought this second fix had cracked it - but I'm not so sure.

    I'm wondering if anybody else has any suggestions?

    Thanks a lot,

  2. jgutz20

    jgutz20 Network Guru Member

    is your Azureus or emule upload rates capped? That could be causing the problem, also with azureus you can limit the number of incoming connections: (# on connections globally, # of connections per torrent). you can prevent multiple connections from the same IP. i had a problem very similar to yours and only thing that would fix it was playing with those settings
  3. Demon

    Demon Network Guru Member

    I haven't yet resorted to altering these settings (which are on default) because i KNOW the router can handle them. I was running both emule and azureus without a problem for ages before updating the firmware.

    Talking of firmware, does anybody know where I can get hold of old versions of linksys firmware? I will happily go back to the original version if it solves this problem....

  4. NoviceTeen22

    NoviceTeen22 Network Guru Member

    Hi Dan! You can check for old firmware versions from ftp:ftp.linksys.com/pub/network

    Watch out though! It's a truck-load of files there. Be careful when selecting firmwares. :rockon:
  5. matthiaz

    matthiaz Network Guru Member

    Or just use Quality of Service (QOS). DD-WRT provides this, for example...
  6. Demon

    Demon Network Guru Member

    NovieTeen22: Thanks for the link - but can't find anything earlier than version 2.x :eek:(

    Matthiaz: Just tried that - setting port 80 to highest priority. Doesn't seem to make any difference. Is this just for wired connections (cos I'm connecting wireless)...

    Does anybody use the linksys wrt54g(s) with emule / azureus and get good (normal) throughput??? I read somewhere that this could be software issue on the PC - but no more information than that.


  7. beagleboy

    beagleboy Network Guru Member

    I managed to finally fix this problem.

    First I set up my Router with a static IP e.g.

    Then I logged on to the setup for my ADSL Modem and set the NAT flavour of BIMAP to forward to this IP address.

    Since doing this i have had no more problems with P2P or browsing.

    Hope this helps others.

  8. Demon

    Demon Network Guru Member

    Thanks for the info beagleboy, but I'm not sure I understand you entirely. Could you explain more please?

  9. mooP

    mooP Network Guru Member

    i dont really understand either :(

    i have a similar problem, a user on the network uses bitcomet which doesnt have an option for setting a global connection limit, which in turn grinds everything to a halt after about 10mins af slowing down steadily, then the pppoe drops/reconnects
  10. beagleboy

    beagleboy Network Guru Member

    Sorry Guys this didn't fix the problem, things ground to a halt over night.

    I did find another fix though:

    The modem I was using is a DSL-302G.

    I set this to "half-bridge", then the router to Automatic Configuration. The modem is now passing the management of the ADSL directly to the Router - External IP address is now passed to router rather than the modem handling it.

    I then forward ports 6881-6889 on the Router and hey presto the fastest download speeds I have ever got on torrents (green smileys) and web browsing works fine.

  11. Demon

    Demon Network Guru Member

    Thanks beagleboy - need to look in to my modem then... (a zoom x5)

    Not sure what half-bridge is though.

    Are you connecting to modem to the router via the wan port or one of the lan ports?

    Are you connecting you pc to the router with a lan port or wirelessly?

    I just don't understand where this problem has come from - it only started for me after upgrading the firmware (and I now can't find a version 1.x firmware to go back to). So many people seem to have the problem and there is no clear concensus on a fix. Very strange.
  12. elconejito

    elconejito Network Guru Member

    upgrading to the latest firmware fixed this for me.

    Another thing that helps (with a netgear router i had), is limiting the number of connections. I read "somewhere" that each connection takes up a certain amount of memory in the router. if there are too many, then the router locks up and dies....
  13. beagleboy

    beagleboy Network Guru Member

    My Understanding:

    I thought that my "modem" was really a modem and apparantly it is not a true modem, it is an ethernet router. Which was also having problems with managing P2P itself. If you have a true modem then the router does all the traffic management. I had the option of setting the modem to full bridging so the router takes over management of the traffic, but the protocol that my adsl provider uses is PPPoA and the WRT54G does not support this, so I found out that some "faux modems" can be half bridged so they can handle the login/password and then lets the router manage the traffic.

    Modem to Wan port

    Both, I have two on lan ports and one wireless
  14. beagleboy

    beagleboy Network Guru Member

    I had tried nearly everything from MTU setting, connection settings etc. until I half bridged the modem.

    With the modem set at "half-bridge" I have MTUs set at Auto 1500 no problems, maximum number of global connections for torrents set at 400 and no problems.

  15. Demon

    Demon Network Guru Member

    OK - Playing with this - set the modem to half bridge and it doesn't seem to be passing on the IP address to the router. So a few more Q's if that's ok??

    Do you have the DHCP server on the modem switched on or off?

    Do you have the Modem and router on the same LAN IP range (or am I right in thinking it shouldn't matter)?

    Do you have the Router (in advanced settings) set to Router or Gateway? WHat other settings do you have on this page?

    Ermm... I think that's all for now!

    I appreciate your help on this though.
  16. beagleboy

    beagleboy Network Guru Member

    On (and on the the Router)

    Different: Modem Router

    Set ot Gateway, I reset the router to factory settings, the only setting changes I have made on the Router is setting up the Port Forwarding.

    Hope this helps
  17. Demon

    Demon Network Guru Member

    Great - got it working... Thanks for your help! I think the problem was that the modem reset the Internet connection to PPPoE rather than PPPoA as soon as you enable half bridging.

    Things seem OK for now. The problem I have is that even though I have 512kb down, I only have 128kb up - so if I let eMule and/or Azureus chew up my upload speed, surfing the web is slow even with download bandwidth to spare. I just need to throttle the P2P upload speed - hey ho - the problems of being in a 3rd world country.

    Well - I'll keep an eye on it and report back - but for now things are looking good..

    Thanks again,

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice