WRT54GS -> High Throughput causes disconnect

Discussion in 'Cisco/Linksys Wireless Routers' started by zephyr325, Feb 7, 2005.

  1. zephyr325

    zephyr325 Network Guru Member

    Hi, all. I've got a WRT54GS, version 2.0. The basic probem is when I try to push a high-speed connection (i.e., copying folders of files, a big ISO, etc.) from LAN <--> Wireless. When I do that, the copy option will start, it will run for about 10-20 seconds, the data throughput will stop, thing will pause for 30-60 seconds, then I get a Windows error saying "network name not found".

    I've tried all the things below on both Linksys as well as Sveasoft firmware:

    - This is not the case when I go Wireless <--> Internet, but I think that is because my max speed there is 3.0 mb.
    - Lower speed connections from Wireless <--> LAN work fine. I can run a remote terminal all day long and it won't get disconnected.
    - This happens from both a Cisco 340 wireless card working at 11 mb and an Intel card working at 54 mb.
    - It happens on any channel I set the router to work.
    - It happens when I'm running 128 bit WEP as well as in the clear.
    - It occurs when the wireless clients are bridged onto the LAN as well as when they're routed (I hook up the WAN port on the router onto the LAN switch).
    - It will happen even if I connect the linksys's WAN connection directly off my 2003 server so I eliminate any problems I've got on the LAN side:
    . (2003 Server) <--> Linksys <--> Wireless <--> (Cisco or Intel card)
    - It happens when I set the router to be in b-only, g-only and mixed modes.
    - I still happens after I've replaced the linksys hardware with a new WRT54GS.
    - I"ve got a copy of Airopeek, and a trace of the connection shows Wireless Transmission retries, lots of data rate changes, TCP invalid checksums and several CRC errors.
    - It occurs when I have multiple wireless clients as well as only one wireless client running.
    - It still occurs (even the frame errors) when I unplug the 2.4 ghz phones and take out the batteries.
    - Wireless <--> Wireless connections seem to be able to work fine, even if I am copying from a "b'" client to a "g" client.
    - It still happens when I drop the MTU down to 1400.
    - The problem doesn't happen when I turn off the linksys and bring my old Cisco access point, so it doesn't seem to be interference (at least on the "B" frequencies).

    Any thoughts here? Is anyone else running into this kind of problem? I'm going nuts! The Linksys tech, and his supervisor, sounded like the were only trained to read out of the FAQ database and couldn't understand half the things I've done to try to troubleshoot this.
  2. zephyr325

    zephyr325 Network Guru Member

    Here's a very interesting piece of data...in watching the connections fail, just about the same amount of data will pass each time before it fails (12.1 - 12.2 mb). This happens if I've got the data rate set at 1, 2, 11 and 54 mb/sec...the time to fail is shorter at higher speeds (to be expected), but the fact that only a specific amount of data at a sustained rate goes through has to be indicative of a failure somewhere...

    Also - this is NOT a wireless problem. The problem exists if I connect to a LAN port on the Linksys or if I go through a wireless point.
  3. rbeauch

    rbeauch Network Guru Member

    I have exactly the same problem. It also occurs when trying to print to a network printer. I've tried several firmwares with no effect.

    wrt54gs v 1.1
  4. Seven_PRX

    Seven_PRX Network Guru Member

    Same problem here, when I max out the bandwith it happens a lot, I might loose connection to the AP for some seconds.

    This also happens when I open A LOT of simaltanous connections (for example when I use Bittorrent and some other P2P client).

    It's very annoying...

  5. AWC01

    AWC01 Network Guru Member

    Looks like almost the same as my problem....

    I've connected a Network Storage (EFG120) connected via an wireless accespoint to my WRT54G.

    Data troughput over my LAN is no problem, transferring large files don'tseems to have any problem.

    Data troughput (FTP) over the Internet causes my EFG120 to hang.
    And.... almost at the same time at about 130KB of transferred data.

    This occurs when I transfer data to the office (broadband connection). When I transfer data to someone else who has a lower speed Internet connection, it seems there are no problems at all.

    On advice of the Linksys helpdesk, I reduced the MTU to 1300.
    Same problem.
  6. zephyr325

    zephyr325 Network Guru Member

    OK, the problem is fixed, but to do it I had to go trade out my WRT54GS to a WRT54G. The main difference between those two models is that the GS has "speed booster" technology. I plugged in the "G" and everything works fine, even when I turn on all the accelleration features. All I can think of is that there's something wierd with their interaction with the Cisco and Intel 802.11g cards.
  7. Okay.. I have the same problem.. after many communications with Linksys tech and many hours of searching on the internet.. this is the first i have seen of it.. I can browse the internet forever.. but as soon as I tried to do some stuff on my networked harddrive (a heavy traffic issue).. I drop to 24 mpbs.. then a few moments later (maybe up to a minute).. My connection goes to "no signal" then the icon turns into the one with the X in it (disconnected).. it reconnects soon after.. but I loose whatever i was doing on the networked drive...

    If I don't find a solution I am afraid I might have to go another brand or at least a replacement router.

  8. BlueJay

    BlueJay Guest

    Same problem with dropped connection during file transfers

    I spent over an hour and a half on the phone with Linksys tech support today trying to solve this problem, without success. He blamed it on an unknown bug in Windows operating system. But no problem occurs when I use my old Linksys BEFW11S4. In all fairness, I must say the exact same problem does occur using the Netgear WRT624 and matching WG511T adapter. It's amazing that neither Linksys nor Netgear have anything about this issue on their web sites. If anyone finds the solution to this, they will be doing many people a great service.
  9. zephyr325

    zephyr325 Network Guru Member

    Not a solution, but maybe a glimmer of hope...the Sveasoft forum admin just posted "Not sure if it is the driver or hardware. Linksys seems to be aware that there is an issue." on the similar topic on their board.
  10. fowlrock

    fowlrock Network Guru Member

    just wanted to post and say I am having a similar problem. When I try to transfer a large file (lets say 400MB or something)...It'll go for about 2 minutes...then lock up...I'll lose my wireless connection....AND THEN THE WHOLE ROUTER WILL TAKE A CRAP!!! I keep my main rig wired in all day...and I lose connection to IRC ( which is on 24-7). Gotta wait a few seconds before I can connect to the router's web interface...and then I can get a connection again.

    If I just leave the laptop connected all day...no transfer...it stays connected. However, if I transfer ANYTHING over the network wirelessly....even if I stream a movie or music....the whole router craps out. I just got this router to replace a perfectly good linksys 802.11b router...thinking the added bandwidth of .11g would be worth it...but I feel screwed. I may have to look into another brand for a router if I can't get some sort of resolution.

    And just in case anyone is curious....I tried the default firmware that came w/ the router, the latest of Linksys' site...and also HyperWRT's latest...same thing with all of them.

    would also like to add, I'm using a Broadcom 802.11g wireless nic that was built in to my new HP Pavillion zv5000z
  11. perisch

    perisch Network Guru Member

    guys, i'm glad that i'm not the only one having this big issue!

    zephyr325, i tried the same steps as you did and i mean every one of them and NO it does not fix the problem. i have exactly those same connection drops.

    i'm using a wrt54g v2.2, i connect with a netgear wgr614v2 and my dlink cards.

    zephyr325: you wrote that after you got a wrt54g it solved the problem ??
    this seems strange, as other wrt54g users have this issue...

    hopefully something will be done. can't believe that so few people have noticed these problems...

  12. jlp1

    jlp1 Network Guru Member

    Hi all,

    it seems to my I experience the same problem with a WRT45G v2.2 - EU.

    During all the testing I've done I've experienced that how more "heavy" the encryption is how shorter the interval is between my "drop outs".

    After the wireless connections drops out (even the WLAN led of my router is out) it comes back on after a couple of seconds (something between 2 seconds up to 30 seconds) and the connection is restored automaticaly. On some occasions I have to power down my router to get WLAN back on.

    For more details about my problems I refer you to testing results I've posted WRT45G v2.2 'crashes' using WPA.
  13. perisch

    perisch Network Guru Member

    seems that more and more people are reporting this behaviour...

    i'm really wondering if this is a GENERAL issue with the wrt54g/gs or some hardware issue with a bad production series ? i really hope it's a firmware bug, cause i might like my wrt54g if it wouldn't drive me crazy with those drop outs. :?

    in other words, does ANYONE :D have a stable high-bandwidth wireless connection on this unit over a longer time period ?
    if so, i'd try to replace mine...
  14. perisch

    perisch Network Guru Member

    ok people, looks like it's a heat problem. according to other forums, the cpu is overheating causing the reboots.

    i tried cooling mine with a fan and the reboots are gone!
    try that and report back.

    i'm wondering how many units i will have to replace before i get a stable one, damn.
  15. gzorn

    gzorn Network Guru Member

    fan ?!?

    Pericsh, what kind of fan setup did you add? Was it a heatsink+fan, or a little fan attached to the back of the unit. And how did you power the fan?

    Inquiring minds want to know :)

  16. fowlrock

    fowlrock Network Guru Member

    if heat is the issue, then this will be the last linksys product I will own. It just backs up my feelings that Cisco isn't putting much time and effort in the design of their residential products.

    I'm trying a modified fan setup as we speak...and will post here with my findings.
  17. perisch

    perisch Network Guru Member

    Re: fan ?!?

    greg, don't laugh, i used my hair dryer which has a "cool air" button to blow the air into the case. simple, huh ? :D
    i want to replace my unit, so i did nothing fancy.

    but i saw a thread on another forum, where people have really mounted fans on their wrt's. if i can find it, i'll post the url.

    anyway, this is no acceptable solution for me, because my router will be placed in the living room, so cisco will have to do their job and get me a unit that is operable without my hair dryer...
  18. walay

    walay Network Guru Member

    Well I have the same problem, I have already returned and exchanged for 2 routers, and also have narrowed it down to the router problem.

    This problems still occurs even when locking the speed at 11mbps, using B only mode at 11mbps, and disable speedbooster, and enoroumous other setting changes.

    I'm also having problems playing World of Warcraft with this router!
    see link to this thread: http://forums.worldofwarcraft.com/thread.aspx?FN=wow-tech-support&T=117416&P=1

    All problem was gone after hooking up my old Dlink 624 router and uses it as a access point.

    This problems sux as what is the point of having a 54G router that Can't do file transfers, when my old 11mb B router(Dlink) is good enough for all the internet access you ever need.......and transfers large amout of data to my file server with no problem at all...althoguh a slower rate....but atleast it finishes its job!

    Clearly this is Linksys's fault and I really need a fix for it, because I really want to stay with Linksys because of all the 3rd party firmwares. Dun like Netgear due to their almost non existant support.

    Any solutions yet?
  19. Toxic

    Toxic Administrator Staff Member

    there is but none are what you want.:

    1. dont use linksys.

    2. write your own firmware.

    3. hope someone fixes you problems, as linksys wont.

    4. dont overload your router.

    sorry this may not be what you want to hear but it is fact.
  20. TheJust

    TheJust Network Guru Member

    I have exactly the same problem with my new WRT54G 2.2 EU. Tried official firmwares, newest Alchemy and HyperWRT but it doesn't work at all.
  21. walay

    walay Network Guru Member

    Did you solve the problem with a fan, is it overheating?
  22. vfoong

    vfoong Network Guru Member

    Hi, on the flipside, I have a WRT54GS v1.0 with stock 3.37.6 firmware paired with a WPC54GS and a D-Link DWL-G650 and I've never experienced the aforementioned problems. I transferred 9GB between the WPC54GS and the G650 with no problems... Also transferring huge files (>4GB) between a NIC physically hooked up to the router to the WPC54GS worked fine. In fact I installed Chariot endpoints and tested them with transfers involving more than 5GB at a time and the performance seems pretty consistent (~35Mbps).

    And if heat could hamper my router, it should have stalled a long time ago seeing that I stay right in the middle of the Equator in tropical weather constantly at 28-35C all year round. The router sits in a typical room and most of the time the air-conditioner is off...

    Since no one here reported problems with their WRT54GS v1.0, perhaps it could be a bug with newer revisions?
  23. ceevee

    ceevee Guest

    I have a WRT54GS v1.0 with Tinypeap's Satori firmware. I've tried stock and Alchemy firmware, however the router still craps when doing large transfers. Large and sustained emule, torrents, and LAN transfers all cause the router to take a crap. Wired or wireless connections to the router will not work. Every client slows terribly and eventually drops.

    Doing a top command around the time of the drop states that there is around 99% CPU use for ksoftirqd_CPU0.

    This has been a problem for WRT54G and GS for awhile. I've tried the WRT54G and same symptoms.

    I think it's a problems with the whole WRT series. I love the customized software, but coming home to a frozen router, incomplete transfers and having to forcefully reboot the router is very very annoying.

    edit: I'm not sure if its the wireless security that causes the frozen routers. I'm using WPA AES with PEAP authentication. I've tried WPA-PSK and WEP, too and it still freezes. But I don't remember if I tried the transfers w/o any encryption. Maybe the router can't handle the secure connections? I dont know...
  24. xkeithx

    xkeithx Network Guru Member

    im having a similar problem wiith my wrt54g v2.2 with the latest alchemy rc6a firmware. its used as a wireless bridge to my neiighbors router, and im just running straight ethernet cable to my laptop. it works great but eventually dies after a few hours, and i have to unplug the router and plug it back in to get the internet back up. im not using any security key, but im running emule and bittorrent. maybe thats causing my router to hang? but the funny thing is that its crashing only my router, not the neighbors which is directly connected to a cable modem. so i dont think iit has to do with security issues...
  25. vfoong

    vfoong Network Guru Member

    I've actually tried HyperWRT 2.0b4 on my WRT54GS and it seems to stress out the CPU a little more... After a couple of hours of torrenting, the web based utility becomes really slow and the load keeps increasing... I've put it back to stock 3.37.6 and it hasn't given me any problems... I've run more than 20 hours of BT via wireless continuously without any dropouts...
  26. fowlrock

    fowlrock Network Guru Member

    No...it did not solve the problem. I tried just a desk fan blowing on it at first...then i tried a 120mm 7200RPM fan on the top side blowing out...then added a second 120mm fan on the bottom blowing in and still had complete lock ups and reboots from the router within 2 min. of transfers. I've purchased a new Netgear router and will try it out as soon as I get back home tomorrow. If the netgear works, then that's it...I'm done with linksys.

    I've also noticed that even if I have the wireless disabled on the linksys, it'll reboot about 6 times a day with just my main rig being on and connected to IRC...no transfers. This didn't start happening until I first started trying to transfer anything over the wireless network. I believe the whole router has crapped out and I'm returning it on monday.
  27. Dowunda

    Dowunda Network Guru Member

    It is a bit weird that some people have this issue and others not!!

    I have transferred about 4Gb of data between wired Desktop and wireless laptop without any reboot neither connection drop out....

    By the way, I have a WRT54GS Australian Version...

  28. TavoX

    TavoX Network Guru Member

    I've got the same problem here, and blowing the WRT54G router with a fan didn't work... I've tried flashing the firmware but it's the same as nothing... I've sent a mail to Linksys, I hope there is some way to fix this...
    My config is:
    PC connected via Ethernet to the router and a second PC with an Encore PCI card 54mb...
  29. vfoong

    vfoong Network Guru Member

    Actually, I purchased my WRT54GS v1.0 in Australia too and so far it hasn't given me much problems even in hot countries like Malaysia. :)
  30. jhugues

    jhugues Network Guru Member

    I am experiencing the same problem as described by various users of a wrt54gs
    When transfering large files from an XP Pro wired station to a wireless Iomega NAS I get a "Semaphore timeout" error after awhile.
    Going back to my previous BEFW11S4 fixes the issue.

    It seems from this thread that the issue could be linked to the speedbooster feature? How can we disable this feature? also can one load the firmware of a non speedbooster wrt54G in the wrt54gs and does that fixes the problem?

    Any help would be greatly appreciated.

    I am puzzled by the fact that Linksys has not reacted yet, not even acknowledged the issue.
  31. Toxic

    Toxic Administrator Staff Member

    unless there is massive emailing about the problem linksys do nothing.

    i had addressed a issue before on the WAG54G , you might all want to start emailing linksys for and answer.. check the thread out here

  32. TavoX

    TavoX Network Guru Member

    I' ve got this problem with the WRT54G, so the problem isn't the SpeedBooster option...

    Yesterday I spent more than an hour chatting with one at Linksys and said that they are not aware of this problem, so C'mon everyone, let's email Linksys
  33. TavoX

    TavoX Network Guru Member

    I recieved this response:

    Dear Valued Linksys Customer,
    “Thank you for contacting Linksys Customer Support.â€

    Good day. Regarding this concern, currently we are still consolidating this concern on the Lab so that they can have a look at this specific problem, rest assure that when this problem is verified, they would post a fix or a firmware that would specifically address this concern. Just frequenly visit the Linksys website for update.

    “If you have further questions, please contact us at (800) 326-7114 or send us an email at support@linksys.com so that we may further assist you." Please use this phone number given as reference for future support calls.â€


    Kristoffer Chavez
    Linksys – A Division of Cisco Systems, Inc.
    Product Support Specialist


    I'd really like to believe...
  34. fowlrock

    fowlrock Network Guru Member

    Just wanted to post my findings and results from further testing.

    I returned my "crapped out" WRT54G V2.2 yesterday, and decided to give linksys one more shot. The new one did the EXACT same thing as the other one was doing. Update firmware to the latest on linksys' website...same thing. Used the latest HyperWRT...same thing.

    Took it back...got a refund. Plugged in the NETGEAR WGT624 I purchased last friday....NO ISSUES AT ALL WHAT-SO-EVER! I'm done with linksys. Good luck to all of you getting your routers working like they should out of the box.
  35. TavoX

    TavoX Network Guru Member

    Well I've returned my WRT54G because it was still in warranty, and got a new WRT54G V2.2 and it's working great, i've transfered up to 4 GBs and works great, at full speed, with stock settings. So I would say you should do the same. Now that it works, this router is great... BTW, it's firmware is 3.03.1, i won't be updating it for a long time.

    EDIT: I'm now using 128 bits WEP and it's still a rock solid connection :)
  36. walay

    walay Network Guru Member

    just some more info.

    Since I bought my router at Staples' I have returned and exchanged 3 times, and all Linksys with speed booster performed the same, no matter which firmware I tried(tried almost all the available firmwares) also tried opend 1 up and blowing air at it and try to stick a heatsink on top of some chips, but nothign helps.

    So I switched to a Netgear dual 108 but was unable to get a fixed speed at 108mb

    So I got my self a Dlink 624, and it is now working perfectly without any problems at all.

    Maybe will get a Linksys wrt54gs when the problem is finally solved since I really liked the option of using 3rd party firmwares.
  37. jhugues

    jhugues Network Guru Member

    The only answer I got from Linksys is that the high troughput problem is an operating system issue and I should contact Microsoft.

    I am going to try a Dlink router and will keep you posted.


  38. soulcoughy

    soulcoughy Network Guru Member

    also having this problem. very frustrated. router gets killed within a minute of opening a VNC session from a wireless windows client to a wired linux machine. works fine otherwise. using sveasoft.
  39. walay

    walay Network Guru Member

  40. dougxd

    dougxd Network Guru Member

    Fix.......sort of?

    At some point, someone mentioned they put a fan on their router and it worked without problems since then.......indicating that it was a heat related issue.

    I flashed my WRT54GS with the latest 2.1b1 HyperWRT firmware and then I lowered the power to its minimum 25% setting in the settings and haven't experienced any drops since.

    Can someone else try this out too? Maybe we can prove once and for all that it is indeed a heat related problem.
  41. walay

    walay Network Guru Member

    I do not think it is a heat issues as I have exchanged for 3 linksys routers and have opend up all of them and attach heat sink and fan toward 3 biggest chips i see on board....and still not working.....so I returned all of them.

    Although I didnt' try to lower the power down to 25%

    so maybe someone can try that and see....if works, then I will go buy another one.
  42. Guyfromhe

    Guyfromhe Network Guru Member

    I have had the v1 and a couple v2s and none of them have acted this way... I have transfered several gigs over it without issue... dunno.. i'll try again and see if I have any trouble and post a follow up
  43. soulcoughy

    soulcoughy Network Guru Member

    IMHO, the issue is directly related to the amount of bandwidth being used. A simple test I've been able to do is this:

    start a VNC session on my linux server

    connect with a windows client, settings for medium compression, no allowances for slow network. inevitably, the router reboots. I don't think it's just the single wireless client being dropped. I know for certain that the other wireless clients on the router are dropped as well, and i'm fairly certain the wired clients recieve interruption.

    if the VNC settings are set to use 8 bit colors and high compression it is much more solid. I haven't seen it happen once using these settings.

    From what I've seen, I don't see how heat could be the issue, or at least the issue I'm seeing.

    BTW - i'm using a v2.2 with alchemy
  44. dougxd

    dougxd Network Guru Member

    Well, I still think that it might have something, at least in part, to do with overheating and resetting.

    The reason I think this is because I'll take the same file.......a 7.3GB DVD ISO image of a movie ripped using DVD Decryptor......and transfer it from my notebook to my desktop with the router at default 50% power and the transfer craps out pretty much within the first few seconds (say around 15-20MB). I'll then set the power down to 25% and begin the transfer over again and it'll go right through.....well, it takes awhile to txfr that much but it completes at apparently full bandwidth without any hiccups.

    Unless maybe 50% power increases noise so much that the link just craps out since it can't figure out what's going on anymore....and by lowering the power it helps to "clean up" the signal just enough to stop the drops and resets.

    Anyway, I don't mean to beat a dead horse here......just my own observation from my limited experimenting.

    Thanks for listening :)
  45. dougxd

    dougxd Network Guru Member

    Ok......so maybe my "observation" was a little funky....like, wrong. Made a change to my notebook by disabling WZC and using the Dell Trumobile utility to control the 1450 card instead of letting Windows control it.

    Since I've made that change, it doesn't seem to matter what the power settings are.......so, it appears I stand corrected at this point.

    Oh well.....at least I got to tinker a bit :)
  46. Guyfromhe

    Guyfromhe Network Guru Member

    I just ran DVD decryptor for over 10 mins got over 500 mb of data send over wlan as fast as it could read at the same time I was xferring back a file from the laptop to my wired box and it hasn't lost a single ping packet...
  47. TheJust

    TheJust Network Guru Member

    I exchanged my first WRT54G which had these problems and the new one I just got (v2.2 too) seems not to have such problems at all. I transferred ~1gig in both directions without any disconnects..
  48. NtegrA

    NtegrA Network Guru Member

    Finally some company!!!

    I am testing out the WRT54G for my company as a possible solution for broadband connected "field" users.

    I am experiencing EVERYTHING that the original poster posted but with the WRT54G as opposed to the WRT54GS.

    After reading all the replies in this thread, I can say that I don't believe it is an overheating issue, as I have now tried 2 different routers straight out of the box. Meaning 1 1/2 minutes after pulling the plastic from the box I can crash the router. (My testing) If I try to transfer a large file, either to wireless or from wireless, to or from wired connection, whether the wired connection is directly connected to the WRT54G, or through another router (dlink di-614+) or through another router & switch (dlink di-614+ & dss-8+).... the wireless connection may drop up to 3 times, aby the 4th drop the router completely crashes. Then all I can do is unplug it and plug it back in.

    I am using an IBM T42 with built in IBM (Atheros) 11a/b/g wireless nic. As I'm doing the transfer I have IBM's "wireless connection status" window open, and I see my transmit rate drop from 54 to 36 to 18 up to 24 back down to 18 (where it stays for most of the transfer), then down to 12,6 then 1, where all communication stops.

    I HAVE been successful transferring a large file with this router wirelessly ONLY by setting on the card itself (802.11b only), giving me only an 11Mbps connection on my internal network (which I already had with the dlink di-614+). If I leave the card "open" (54Mbps) I can run it all day if all I am doing is internet related transfers (up to 360KB/s), but as soon as I do something internal "WHAM!!!!!!!!!"


    I don't know what version router I am testing, but with both that I have when I save the config file it gives the following filename "WRT54GV2_v3.03.1.cfg".

    I read on "DSLREPORTS" (I think) a thread that seemed to be the same problem, and the solution for the person was to disable some 802.11 authentication check box, but that was for Win XP. no such thing for my 2000 based laptops. And to make it so bad the thread was about a year old.

    ANYONE HAVE ANY REAL ANSWERS TO THIS????? Buy a different vender product???
  49. shimman

    shimman Guest

    about a year ago, i tried serval routers because most of them were not stable enough for p2p; a better one was befw11s; not only it could sustain more connections than others routers from ms, dlink, netgear, and belkin; but also it was far more stable.

    after getting wrt54gs v1.1, i used it with satori v4 as a repeater. it seemed working great, but there are unexpected connections drops & i have to reboot about once a week for better speed. it never died, but the router could pump up about 10kbyte/sec....sure it was after 24/7 p2p

    befw11s isn't completely stable either for p2p...reboot about once a few weeks

    after trying to resolve the issue, i tried buffalo WHR3G54 because my friend told me he had never experience such problems with his buffalo router. WHR3G54 replaced befw11s & it has not crashed or slowed down since last nov. that's about 3 months; wireless performance is bit weaker than wrt54g & befw11s, but acceptable. no fancy qos & restriction functionalities, but it is super stable & wired performance is great.

    now the computer doing p2p is connected to WHR3G54 wired & wrt54gs is doing wired bridge in differenct channel. no problem so far.

    if you don't need fancy features but want stable performance, try WHR3G54....my only wish is that WHR3G54 can do a client mode + qos so i can replace wrt54gs
  50. Guyfromhe

    Guyfromhe Network Guru Member

    i've used both my non S routers with my dlink DWL-G650 and my linksys card I stole from my v1.0 I broke with some bad settings... no issues with it rebooting/drops... I watched the speed during my xfer the monitor never showed any drops it sorta fluctuated between 54 and 48 mbps but never changed and never crashed in fact one of my routers has been up over 50 days without incident... maybe I just got lucky :)?
  51. pauls

    pauls Network Guru Member

    Re: Finally some company!!!

    "I am experiencing EVERYTHING that the original poster posted but with the WRT54G as opposed to the WRT54GS."

    I've made exactly the same observations. Using a Thinkpad T42P with the IBM A/B/G wireless card and with my older Thinkpad using a Linksys WPC54G.

    The laptops will mostly stay connected for web browsing. If I try to transfer a file larger than a couple of meg and the connect rate will drop (54, 48, etc.) then the connection will fail. 9 times out of 10 a few if I wait a few seconds the connection will be restored. 1 time out of 10 I will have to reboot the router.

    I have had a Linksys B router for a couple of years. I never noted any failures when connected with either laptop.

    The older Thinkpad is XP SP1; the T42P is XP with SP2. Disabling Wireless Zero Configuration does not help.

    I've unplugged the new WRT54G router and gone back to using the Linksys B router. I've checked with Linksys, no joy there.

    This is the second WRT54G I've had. Took the first one back for the same reason. Hate to take another one back...

    Has anyone seen an official position statement from Linksys? I have searched their knowledge base but have found only the usual references about WiFi interference, etc. I can rule interference out for 2 reasons: first don't have it with the B router. Second, I can do an AdHoc file transfer without any failures!
  52. Scroatdog

    Scroatdog Network Guru Member

    I've got the WRT-54G v2.2 and I am experiencing the SAME EXACT problems. I'm going to e-mail Linksys. This is ridiculous. I bought this router to have a wireless NETWORK in my home, not a wireless internet drop for a second computer.

    Tried moving a 1.5 Gig MPEG2 file from Computer A (desktop hardwired to router) to Computer B (shuttle with WMP-54G wireless card) and it would crap out after about 3 minutes, saying "network no longer exists" or something to that effect.

    Tried accessing the file on computer A through browsing from computer B, and just running it like that. No dice. Lose connection. I am using the offical Linksys firmware, I haven't tried anything else...... but if someone can confirm that by using HyperWRT and lowering the power that it FIXES the issue, I'd be more than willing to try that.

    I am unfamiliar with that firmware, but I'm sure reading the forums here will bring me up to speed.

    Can anyone confirm the power lowering in HyperWRT will fix?
  53. Pacif13r

    Pacif13r Network Guru Member

    Linksys and Intel etc etc ...

    Well well. I have been having problems transferring files on my network with my new laptop and WRT54GS and have finally isolated the router as the culprit and do a search and find this....

    For me I can txfr a 150MB rar file without a problem and 12MB AVI without a problem but given a 4.5MB M$ Money data file (.*.mny) and boom 200K is transferred than the packet sniffer detects lots of re-trans requests and many packets suddenly having bad checksums. and poof the common across this thread problem of the server name disapearing temporarily. for around 10 seconds or so. This is 100% reproducible in that the Money file will never transfer through the Linksys and the other files will do everytime. Its like 1 in 5 files over 500K don't work.

    This happens wired or wireless through the linksys. If I plug my laptop into my Billion 7100 it works perfectly as expected. The finger of blame seems squarely with the WRT54GS. I notice the original poster got some luck out of switching to a G. I hope there is a better solution.

    Anyone heard of a problem between Cisco bargain brand (They are using a Broadcom network chip ?) and Intel network chips ?
  54. real_firefly

    real_firefly Guest

    I'm having the same problems with mij WRT54G v2.2. Returning it next tuesday, this is useless. Can't transfer big files over wlan, and I'm also hanving problems with wired connection. The router seems to crash and hang for a few seconds when i download something from FTP and playing an online game (like Counter Strike).

    It's definately not an OS bug, i'm having the same problems with Linux (Debian, kernel 2.6.10).
  55. CrazyCanuck

    CrazyCanuck Network Guru Member

    Hi all, I just bought the same router 2 days ago and had the same problem. I'm new to the networking thing but not to computers so I found this website to help with the issue.
    I have to admit that it was looking pretty discouraging after reading this forum.

    I was having problems transferring some larger files from my desktop to my wife's new laptop. It was dropping out like described in previous posts. Tonight I was about to upgrade the firmware but then I remembered that I did not disable the XP built-in firewalls on my computers. Desktop = amd athlon2400 running XP pro sp1; laptop=toshiba a70 w/ p4 3.06 atheros wireless running xp home sp2.

    I tried transferring a 177meg file after disabling the firewalls and everything works fine.

    Correct me if I'm wrong but I beleive the firewall in the router will still "protect my little home network?
  56. Skully

    Skully Network Guru Member

    same problem here with my new WRT54G 2.2 EU with hyperwrt.
    I use a Asus notebook with ipw2100 @11mbit.
    When i transfer a big file, the router hangs up and it lost the internet-connection.
  57. Guyfromhe

    Guyfromhe Network Guru Member

    what speed are your files transferring at? I just fiinished sending 3 gigs from the lan to wlan without any trouble...
  58. c_olsson

    c_olsson Guest

    I've similiar problems only with my Windows XP-machine, but not the Linux-machine.

    I've also tested to use a dedicated Linux-based computer as router and had no problems ever.
  59. djhpr

    djhpr Network Guru Member

    I'm having the exact same problem with my WRT54G (v2.2). When I'm transferring a file between a computer on the LAN to a Wireless client, the transfer will hang after 10 seconds of full throughput transferring. The wireless client loses its connection with the AP and after a few seconds it comes back up again and the connection is restored. I noticed that the WLAN light turns off during the disconnect duration, and then comes back on. I'm assuming it's a problem with the router itself. I tried changing the channels (note the wireless client is right next to the router), turning off encryption, and a buttload of firmwares.
  60. dmxsoulja3

    dmxsoulja3 Network Guru Member

    I'm going to try this to see if it eleviates some problems with dropped wireless connections no matter what your sending.
  61. Pacif13r

    Pacif13r Network Guru Member

    Further to my earlier entry

    I contacted Linksys support with no luck so had a replacement sent to me. This produced exactly the same results (WRT54GS). I noted that if it was a batch problem then the new one was only 11 away by serial number.

    So after getting fed up I suddenly thought maybe it's the internet port. And sure enough for my problems as outlined in my previous post it was indeed. I used a Billion ADSL 4 port switch for internet and also my file server and PC's were plugged in there. Then I had the WRT54GS Internet port plugged into the Billion. It appears that in my case the Internet port is simply unable to sustain behond very short bursts a high transfer rate. So I reconfigured so that only my 2MB ADSL connection went through the Internet Port and everything seems to be working fine now.

    In hindsight I guess it stands to reason that a port labelled Internet is unable to cope with a 10+ Mbps throughput. However it does specifically mention the sort of configuration I had... router to router in the manual and advises to connect it like I had it.

    Anyway I'm working and maybe this will help anyone else with a similar problem...

    Good Luck....
  62. djhpr

    djhpr Network Guru Member

    This is getting rediculous. You can say that I'm not a newbie when it comes to computing and networking. I've tried everything suggested in this thread, and many things of my own to no avail. I've purchased many Linksys products in the past and they've proven themselves reliable. I'm putting off returning/exchanging the unit until I'm for certain that there was a v2.2 manufacturing defect in the batch (or until I go bald by pulling out all of my hair!). BTW, I attend college down the street from Linksys , so if you want me to throw the AP at their doorstep, feel free to ship it to me! (jk :D)
  63. JohnSK

    JohnSK Network Guru Member

    Hi ppl..
    I've been researching for the whole day about this problem. I have 2 WRT54G's v.2.2, one is used as AP, the other as client. Both run Alchemy pre7a. Basically as we all know when coping a large file the connection goes out, sometimes for a few secs, sometimes for good. So I got fed up and decided to test the AP's with my OvisLink 11mbit AP..

    Basically I've tried EVERY possible mode or combination there is and came up with the following:

    It MUST be a hardware error! Why you ask? Well one of my WRT54G's was from another batch and that one works flawlessly. The other one, well, disconnects all the time - and just to make things even more realistic, my friend has a WRT54G from the SAME batch and he also gets timeouts!

    However, I must admit that the AP that is working now wasn't working properly from the begining. The procedure I used to get it working was as follows:

    1. d/l latest fw from LinkSys site
    2. hard reset the AP
    3. flash the fw from the site, I did it 3 times in a row
    4. flash Alchemy pre7a
    5. hard reset the AP
    6. change a few settings (I was desperate so I tried EVERYTHING :)..
    not sure if any of these have an effect or not but now one of my AP's
    workx correctly.Here's the changes:

    disable DHCP
    beacon 50 000
    DTIM 3
    TX/RX Right/Right
    Disable firewall and ping block
    Disable CRON
    Disable DHCP
    Disable DNSMasq
    Disable Local DNS
    Disable Loopback
    Disable 802.1x
    Disable NTP client
    Disable Routing
    Enable Syslogd
    Disable Telnet
    Disable UPnP

    7. Save all settings, power down AP for a few mins and try copying something..

    Well, as illogical as my step-by-step guide may seem, it helped me to get ONE of my WRT54G's working flawlessly = I can upload/download files using FTP and ping the device with zero packet loss.. (tried this for about 6 hrs straight, transferred about 15 gigs of data)

    As for the other WRT54G - well, using the same proces and even loading settings from the other working WRT54G DOESEN'T help to get rid of the disconnects. Indicating perhaps a HARDWARE error..

    Btw, as I am typing this post, I am d/l 5 torrents and pinging the AP, no lost packets so far! And the distance between my AP at home and at work (that's where I get net access from) is roughly 2km, I am using a external 15dB antenna. I mentionned the torrents because yesterday,just before I began playing around with the AP's, I couldn't even download ONE torrent without hanging the WRT54G.

    One last thing - it's not a heat issue IMO, I've opened one of the WRT54's and left a big fan blowing atop the whole PCB without any improvements.

    Hope this helps, take caution not to brick your AP with the flashing.

  64. Mars2005

    Mars2005 Network Guru Member

    Now, when I bought my Linksys, I don't think it was my idea to downgrade my WRT54G (2.2) to an AP to get it to work.

    I am still not convinced of the heat issue: I tested this week with two wireless clients. One being a desktop with PCI interface running WinXP and the WZC, the other being a laptop running Win98 with the Linksys utility.

    In both cases I managed to transfer one 300+ MB file completely once from my wired PC to one of the wireless clients. Any other attempt after that failed.

    So my very simple conclusion is that the router gets to hot and stops working to prevent some sort of overheating.

    Will continue some more this weekend, probably with case open and my wife's hairdryer blowing into it.... Otherwise I may put the damn thing outside, where it will be way below zero (Celsius).

  65. Zingam

    Zingam Network Guru Member

    Here I join the unhappy customers! I have started another thread yesterday but after I have found this one and tried what many of you have been writing about I can report the same problem:

    brand new WRT54G wireless router HW v.2.0 Firmware 2.02.7

    When just browsing the internet or copying small files over WLAN: no drops no lost connections, etc.

    Each time when I try to copy large files (or multiple large ones) or when I stream a movie over the WLAN. It doesn't matter if it is LAN-WLAN, or WLAN-WLAN connection. The connection to the router is lost and the only way to get it back is to restart the router.

    No problems with LAN even copying 4Gb of files over it.

    Wrote to linksys, tried different settings: the problem is still here.

    From the 5 routers I have tried in the last 4 months I can say that I had no problems with 3Com OfficeConnect. All of the rest weren't reliable enough.

    Althogh the 3Com stops transfering data over the WLAN at about 1 1/2 hours for a few minutes and then it is resumed automatically.
  66. Zingam

    Zingam Network Guru Member

    I have had it!!!

    Since my last post I set beacon to 50 ms and I had some progress. When the large files transfer is interrupted I do not loose the connection of my clients to the server immediately. I can even initiate a new transfer then the WLAN crashes and I have to reset the router to get the WLAN working again. (with beacon 100 I loose the WLAN after 10 minutes or so).

    I give up! I've installed my 3Com OfficeConnect again and although it has much slower WLAN and shorter range I have no problems with it so far!!!

    If nobody discovers a solution until Monday I'm going to return the Linksys router and won't check that brand again.
  67. Zingam

    Zingam Network Guru Member

    Some success here!

    This is my third update in a row :) I decided to give the router one more try and flashed it to the latest firmware for EU: 3.03.1... and I have just transfered 3.31Gb of data (5x .avi-s) and it has taken about 1h 15min. WLAN-WLAN transfer.

    Though I'm not too satisfied with the resault:
    1. Before the signal was always: "Excelent" now it is mostly "Very Good" on all 3 adapters.
    2. Before the speed was almoust always: 54Mbps now it varies constantly and 48Mbps is more frequent.
    3. Before while transfering the speed was constant even if the connection failed now it varies alot even reaching 1-2Mbps

    I have 3 wireless clients and one connected with a cable. During the transfer the the 3 wireless clients were used for Web browsing.

    Any ideas if this is OK or not? Is it possible to get more stable speed?
  68. JohnSK

    JohnSK Network Guru Member

    Re: Some success here!

    That's an average of 750 kb/s which is OK but it depends how far the 2 devices are between each other. If they are in the same room the speeds should be considerably higher. Myself I reached around 400 - 500 kb/s over a 2km distance, the AP at the other point was a 11mbps device..
  69. Zingam

    Zingam Network Guru Member

    Re: Some success here!

    It doesn't really matter. The devices are 3 a notebook, a router and another notebook. None of them are in the same room but the distance is about 30 feet or less between a notebook and the router. I have one more notebook in the same room as the notebook who I am copying the files from.

    It seems that my network consnisting of 3 wireless devices, one wired device and the linksys router is peforming well in the last 12 hours after the firmware update but I'm still not convinced if I want to keep this router. Especially after reading so many bad things about it in these forums.

    Today I'll try to copy GIGs of date to all of the computer in the network simultatiously.

    BTW why is copying of files so slow even wired-router-wired device? It takes a few minitues (6-7) to copy a 700Mb file and about twice as slow if the connection is wireless. Could it be a WindowsXP issue?
  70. RoundSparrow

    RoundSparrow Network Guru Member

    Ok, everyone, let's get your attention...

    Ok, slow down here...

    First off, I just read this whole thread top to bottom. And some things are very obvious to anyone who read close. First off, I think there are about 4 different problems being discussed here :)

    0. Rule number zero is that you don't all have the SAME problem! So if you eliminate one that doesn't mean that others don't have the problem nor does it mean that the problem is widespread.
    1. Overheating. There are people who have posted here that say they had failures that were RESOLVED/FIXED by adding cooling.
    2. Resource/memory leak. Someone said that after 12.x MB of transfer every time their router hangs. There are known versions of the firmware that have issues.
    3. Overloading the WAN/Internt port. The newer versions of the router have a higher-speed Ethernet part... maybe there is a overload problem on the older units?
    4. Other causes? Issues with specific versions of the hardware?

    With the dozens and dozens of variations of firmware, none of which are perfect, this kind of problem can be hard to track down. THERE ARE problems in firmware that can cause these symptoms, plus having bad settings (not clearing the nvram).

    There are too many people here saying 'I have the same problem (as posted in the thread)' when it is NOT so clear. And believe it or not, there are many people with multiple routers who don't have this problem (I have personally copied 200GB disk without a reboot of my router using Windows XP to Windows XP at 54Mbps on a WRT54G v2). There is HOPE you can find your specific cause and FIX IT instead of just thinking the router sucks and is 'unrelable' (and other general terms without actually finding out the exact problem an possible solutions).

    Please, post all information:

    1. What version of router? 2. Firmware you are using. 3. Have you reset the configuration after firmware upgrade? 4. What settings have you change / features you upgraded? This includes power boosting, adding remote logging, using WDS, etc. 5. Have you tried a second WRT54G, get a friend over if you have to (find one on forum). That eliminates the hardware side pretty well.

    We need to get this down to a reproducable problem with specifics. This is why Linksys doesn't believe people there are real problems, everyone is mixing all kinds of things into one topic :)
  71. pauls

    pauls Network Guru Member

    OK, just spent 30 minutes on the phone with Linksys level 2 tech support. They referred me to a senior level tech support specialist -- all are busy now, try on Monday.

    We checked beacon time, thresholds, etc all to to avail. I have also tried different channels, lower MTU, etc. Closest neighbor is 100 meters, turned off the cordless phone, microwave, etc. Interference is not a factor.

    What is really interesting was when I finally got the tech to understand that I have a problem transferring large files with the WRTG54 router but not with the old B Linksys router. Linksys did ask specific questions like "does this only happen with large files?" Connections are OK for web access? Hmmm...

    For the record:
    WRT54G V2.2 hardware
    Linksys V3.03.06 firmware
    No extra logging, utils, power boosts, etc (just want it to work)!
    No problem between wired clients
    No problem with idle surfing or transfer of small files.
    1st Thinkpad laptop with Linksys WPC 54G PCMCIA, XP SP2
    2nd Thinkpad A31 laptop with Linksys WPC 54G PCMCIA, XP SP1
    3rd Thinkpad T41P with IBM A/B/G wireless.

    All exhibit the same problem.
    Can do AdHoc file transfers, with large files (400 MB) no problem!

    SN CDF70DCD5477

    Went back to my trusty old Linksys B router, works perfect just slower.
    Q is what to do with WRT54G? This is the 2nd one from BestBuy. Linksys seems to know there is some kind of problem -- if they have isolated it they are keeping quiet about it.

    Maybe if enough people contact tech support directly progress can be made.
  72. lnorange

    lnorange Network Guru Member

    Same Issues with WAG54G

    I have the same issues as all with the WAG54g. Dropout with large data files. All versions of firmware tried including latested beta from Linksys.

    Again Linksys tech support are hopeless not help what so ever.. probably because they don't have an answer!!

    I have solved it in the interim by purchasing a Linksys WAP54g, diabling the wireless on the problem WAG54g and plugging the WAP54g into the WAG54g. Guess what, it works, large files in excess of 4Gb, no worries.

    Not the best solution as the original kit should work.
  73. djhpr

    djhpr Network Guru Member

    Quoted for this is exactly what I am experiencing, with the exact same revision router and same firmware.

    Cliffs: v2.2 WRT54G with newest official Linksys firmware (S/N: CDF70DC19032) will disconnect after a few seconds if transferring a large stream of data at full throughput through WLAN. Regular internet browsing works fine UNTIL I download a large file.

    I'd like to add that when the wireless connection conks out, the WLAN light on the router itself BLANKS OUT for a few seconds, and then comes back up. I'm assuming the radio is crashing due to a firmware level driver problem or some unknown manufacturing defect. (I have read through dozens of FAQs and none have worked.)
  74. lnorange

    lnorange Network Guru Member



    Been trying to access UK technical support via email, had a response regarding disconnection, no help but I will not give up!!

    Linksys response below:

    FW: WAG54G Problem

    Response (Ryan N.) 03/07/2005 02:57 PM
    Dear Mr. Orange,

    Thank you for contacting Linksys Technical Support.

    We’re sorry for whatever inconvenience this issue has brought upon you. We might be experiencing some technical difficulties on the UK server so it took time for client's email to arrive at our personal inbox. I have double checked your previous email and you are experiencing on the WAG54G.

    I believe there's a problem with the firmware on the device itself, since on your case, you have used a AP and it works fine., no problem with the download and internet connecton via wireless. Try to change the working channel of the gateway and also if its possible to load updated firmware from the UK site.

    I’ll be glad if this helps. Thank you.


    Ryan M. Noble
    Linksys - A Division of Cisco Systems, Inc.
    Product Support Specialist
    From: Linksys Support [mailto:linksys@mailca.custhelp.com]
    Sent: 07 March 2005 22:57
    Subject: FW: WAG54G Problem [Incident: 050307-000103]

    Linksys Support

    Firstly thank you for your reply, however, your answer is simply not satisfactory what so ever.

    I have downloaded all the various firmware versions and now have seven stored on my laptop. The versions include:

    V1.00.19 (UK Website Firmware)

    ALL versions, I repeat, ALL versions have the same problem of disconnect / wireless lockup when larger files are copied over the wireless. I have also meticulously tried every channel in a desperate attempt to get the WAG54g to work as sold.

    I have followed Linksys advice when flashing the firmware, that was to reset the box to defaults, hard reset, flash upgrade, reset, re-setup login etc… no change, same problem.

    In recent testing over the last week my setup has been stable with the wireless element of the WAG54g disabled and using the loaned WAP54g for the wireless element, this arrangement is flawless. However the WAP54g is on loan and I don’t consider this to be a solution, it just enables me to utilise the equipment that I have purchased which should actually work as described without having to purchase additional equipment.

    I look forward to your next suggestion with interest!!

    Les Orange
  75. Saber

    Saber Network Guru Member

    WRT54GS disconnect issues

    I have been experiencing issues with my WRT54GS v1.1 with 3.37.6 firmware and transferring large files. My Linksys B router has been working flawlessly but I wanted to get better wireless bandwidth so I decided to upgrade. That decision has so far been a mistake as I have not been able to move large files around my network at all. I have a server-client configuration and most of my applications pull files from my file server. The WRT54GS has worked great for web browsing and small (<10MB) files but as soon as I begins to move multiple files or very large files my signal degrades and then disconnects. I talked to Linksys support via email and this was there response.

    Dear Valued Linksys Customer,

    Thank you for contacting Linksys Customer Support.

    If you still encounter the same problem with the WRT54G router, then you may try to follow the subsequent procedure to further check the settings on the router.

    1. Check the advanced wireless settings on the router and set Beacon Interval = 50; Fragmentation Threshold = 2304; and RTS Threshold = 2304. Then save the settings.
    2. Then perform power cycle in the network. To power cycle: Turn Off or Shut down the Computer, Linksys Router and the Cable Modem. Wait for 30 seconds.
    After that Power up the Cable Modem first, wait for the modem to stabilize. If the Cable modem is already stable, turn the Linksys Router ON, then the computer ON. Check internet connection.
    3. In case the same problem persist, then try to reflash the router’s firmware (version 3.37.6), and reset the router then just reconfigure the settings of it.

    Hope this helps.

    If you have further questions, please contact us at (800) 326-7114 or send us an email at support@linksys.com, so that we may further assist you.


    Catherine S. San Juan
    Linksys - A Division of Cisco Systems, Inc.
    Product Support Specialist

    I will try this solution tonight and report back my findings. If someone else could try this as well it would give me additional information to provide Linksys support to push for a firmware correction.
  76. djhpr

    djhpr Network Guru Member

    Re: WRT54GS disconnect issues

    Still have problems after changing settings.
  77. pauls

    pauls Network Guru Member

    Decided to check with Linksys one more time. Got through to the senior tech who had me move the router to within 8 feet of the laptop and change the transmit rate to 54Mbs instead of auto. Connection lasts a few seconds longer now before it fails. Here's to my "B" router -- and "G" wiz what a nice door stop I have now.
  78. pauls

    pauls Network Guru Member

    Re: WRT54GS disconnect issues

    Tried it as well -- no improvement.
  79. Saber

    Saber Network Guru Member


    I tried the suggestions that I posted above from Linksys support and have had no luck. Actually I made a brick of my router since it failed the upgrade of the firmware, thankfully there were enough other posts in here on the subject for me to bring it back to life. I responded to Linksys with my findings.... stay tuned for the next chaper in AHHHHHHHH!!!!!!! Linksys, !##@$!@$
  80. jienn

    jienn Network Guru Member

    Hi everyone.

    I just got my Linksys WRT54G today. It only took 15 min to setup and browsing the web was working, but then i tried to start downloading a file with Azureus, and i noticed the router timed out once every minute or so, and finally dies so i have to hard reboot. It only happens when Azureus is running. The computer im running Azureus on is connected with linksys with a cable. I do have wireless running for my laptop.

    I searched my problem on google and instantly found this thread, and i have the same problem as many of you, the router dies when there are too many processes/threads/connections whatever.

    I've tried with/without uPnP/Portmapping and different combos with no luck.
    I have v2.2 of the router and the latest official firmware. Do we need to spam linksys about this?
  81. NtegrA

    NtegrA Network Guru Member

    Re: Ok, everyone, let's get your attention...

    OK, not speaking for anyone else and their specific problem(s) with this router....

    If you look up a few posts (above yours), you will see a detailed one by me. At this point, I have now experienced the same exact situation I described on a total of (COUNT THEM) 1,2,3,4,5.....11 different routers within 5 minutes out of the box. The company that I work for is in the process of giving field users broadband access and I am the one that configures the routers that get sent out.

    The good thing for them (bad for me) is that I am the only one that has a 54g adapter built in, everyone else has 11b adapter only.

    It would be nice to get an answer.
  82. kenshell

    kenshell Network Guru Member

    I'm new here and got my WRT54GS yesterday.
    I have the problem of transfering large files from a wired xp computer to my wireless xP laptop. After a few seconds it just stops or locks up.

    I might just go back to Circuit City and get the new GX today.
  83. jlw

    jlw Network Guru Member

    Have only experient this issue a few times with my wrt54gs with hyperwrt.
  84. rogkm

    rogkm Network Guru Member

    I was having a similar problem with any large files downloads.

    -WRT54G V2.2
    -HyperWRT 2.0 Firmware
    -WEP enabled
    -Static IP on my clients
    -eMule Ports opened
    -No other wireless networks in my area
    -No 2.4GHz phones in my house
    -No microwaves working while it happens.
    -If the connection is idle or I'm just surfing, the connection stays on forever!

    I was having the WRT54G disconnect me from the Wireless network whenever I was downloading something large. It used to happen with HTTP downloads (fileplanet) and eMule downloads (I could connect perfectly with HighID). I disabled the WEP and now my HTTP downloads are working fine, but whenever I open eMule my connection lasts only 5-10minutes then I loosed my wireless connection to my WRT54G router, and to get it back I need to "right-click" on the connection and "repair" it.
    Anyone with a similar problem?

    Today I'm changing my broadband provider from DSL to cable, and I'll do further tests to see if it's a wireless problem or a problem with "cable-conection" too.
  85. kenshell

    kenshell Network Guru Member

    Well easy come easy go. Picked up the GX today and SRX is awsome!
    No dead spots where the GS had it. I transfered files from one machine to the laptop with no issues.
    Only problem is I have a dedicated ftp box.
    I set it up in router like the old one (port forwarding) but I cant connect to it.

  86. sadness

    sadness Guest

    High throughput disconnect seems fixed now ¡

    Hey everybody, introducing me to linksysinfo.org forum ; )

    I had the same problem as all of you, transferring huge files over wireless or cable connection caused disconnect from acces point.

    I´m running a WRT54G V2.2 EU, with alchemy pre7a installed. Have my PCS logged with static IP, no DHCP. Somebody told me to set MTU to manual instead of AUTO, wich is the default setting. Just put it in MTU 1500, and voila, problem seems to dissapear. Transferred files succesfully that i cannot transfer before.

    Also told me, that Realtek network cards seem not to handle correctly MTU with some devices, so it was better to set it Manual, and force it to 1500. Hope this helps you.

    Bye ; )
  87. PhilSmith

    PhilSmith Network Guru Member

    I just got this router with a new laptop yesterday from tigerdirect. Guess what? Same problem you guys are generally having. When copying large files between my laptop and deskop computer using the router I lose the connection before it finishes. If I try this several times in a row I eventually have to unplug the router and plug it back in, in order to to get the wireless connection working again.

    OS Windows XP
    Router WRT54G
    firmware 3.03.1( same firmware it came with out of box)

    It doesn't look like anyone has a solution to this problem. Can anyone suggest another brand of router which doesn't have this problem and support 802.11g

    Dlink?, NetGear? US Robotics?

  88. gabo21

    gabo21 Network Guru Member

    Here's the solution:

    Encryption causes high CPU load / temperature. Turn off all encryption, and everything's fine
  89. Saber

    Saber Network Guru Member

    Not quite. I never used encryption and it still exhibits the same problem.
  90. Shalford

    Shalford Guest

    WRT54GS file transfer problem!

    Using WRT54GS XP Pro desktop - XP Pro laptop

    Hi All

    I've read all the posts with interest, let me just say first of all that i'm no network expert, but after tearing my hair out trying to find a solution to the transfer of files problems, I feel I have to add more confusion to the situation.
    My problem has been "The specified network name is no longer available"
    Is this the same problem you guys are having?

    When transferring a lot of files from desktop to laptop, it would generally fail on certain types of file extension. (Didn't seem to like *.Doc's) amongst others.
    Anyhow I started using "Beyond Compare 2" a duplicate file finding program, I noticed it had a file copy option.
    Out of curiosity I used it to copy files to my laptop, I still got the message "The specified network name is no longer available" on the same files as before, but it didn't stop copying and indeed copied all files including the files that threw up the error.
    As I said before I'm no expert, but could all the problems be Windows related.

    I'd be interested to know if any of you clever guys can throw any light on this!
  91. Zingam

    Zingam Network Guru Member


    Upgrading to 3.03.1 solved my problem with transfering large files. Haven't tried yet to transfer MS Money and Doc files.

    Write emails to Linksys! Lots of them! They generously answer: for now :) I have written about 7-8 of them and they answered me each time: not giving me any useful information.

    BTW. Try this:

    And write if you have any success!!!
  92. jienn

    jienn Network Guru Member

    All of you who has wireless disconnects during large file transfers, have you tried if the same thing is happening when a computer is directly connected with the router?

    I only have a PC to the WRT54G connected with cable, and it disconnects on me in the middle of a large file transfer from the internet. I've tried different settings, wireless is OFF. different MTU, DHCP on/off, firewall on/off, 3 different firmwares. Nothing helps.

    It MUST be a hardware error in v2.2. Please prove me wrong.
  93. Zingam

    Zingam Network Guru Member

    No such problem here! When I had it it was Wireless related problem only .
  94. NtegrA

    NtegrA Network Guru Member

    That suggestion defeats the purpose of this router. Why would I buy a 54g router only to be able to use 11b? BTW, I mentioned in my first post that this scenario works (not to jump down your throat or anything).

    The required "WORKING" solution is to have 54g working as intended, encrypted or not. Why buy a broke product?
  95. pauls

    pauls Network Guru Member

    I received the same advice from Linksys. Tried it just to see what would happend - did not help anyway.

    Of note: I tried to copy a large number of small files. Takes longer before the router crashes.

    I also moved the router right next to the laptop so I could see the LEDs.

    Just before Windows notes the loss of connection the WirelessG light on the router goes out. Then the power light flashes like the router is rebooting. I have mailed this info to Linksys, so far no response.
  96. Maddogg0003

    Maddogg0003 Network Guru Member

    I am having the same issues. I am about to consider buying another product. I want to stay with linksys because of Cisco, but this is becoming a major issue. I am supporting a small business and need to have this issue resolved.

    I thought it was encryption at first, but after disabling that, I still experience issues.
  97. Rainey

    Rainey Network Guru Member

    I have tested this problem up and down and have come to the end, it just don't work. there is some flaw in this router at its current hardware release and firmware.

    It is a shame, you buy a wireless router that is spec'ed at high speed but it don't work at high speeds. I can not even set it for low speeds and get a large file xfer from a wired PC to a wireless pc to work. Every thing else works fine. Rarely do i have a disconnect form the internet over wireless for any thing i am doing.

    I do not have the required equipment to test this, LINKSYS should be doing that for us. You need to have an emulator and ntework monitors on both the wired and wireless sides check the packets and break it down to the debugging info at each PC end for what was sent and recived.

    I have not heard anyone say they have it working at full G speed without problems. Now do i just try and return this router and then what do i get in place of it. Or do i wait for a few more firmware releases to fix it hopefully. Hummm....

    You would think this would be top priority for Linksys to get it fixed before it spreads a folw taste through out the networking community.

    WRT54G V2.2 with stock firmware also tesed with HyperWRT2.0, Wireless laptop Dell D600 with Turemobil 1400 dual ban WLAN mini PCI
  98. moi666

    moi666 Network Guru Member

    I had the same problem on a new WRT54G v2.2, on 3.06.1 firmware, the "network not found" msg only occuring during wireless large file transfers from my desktop to notebook.

    This prob is apparently fixed if we enable SSID broadcast but I have not had a chance to test it yet.

    Can anyone confirm if this fixes the problem?
  99. Saber

    Saber Network Guru Member

    Yeah, I can absolutely confirm that this doesn't fix the problem. I have spoken with several linksys tech's about this problem and from what they told me they are setting up a test scenario to validate our complaint and find out what is happening. My guess is it will take several weeks for this problem to be resolved by a firmware upgrade, but time will tell.
  100. Maddogg0003

    Maddogg0003 Network Guru Member

    No, this does not fix the problem. I have tried enabling, disabling every option and still nothing. I just think this is a bad run for linksys. They are a great company and like all great compaines, they have their mistakes. Just appears we have that mistake. Hopefully I am wrong, but I am going to return one of these routers tonight. I have one in production and can not take it down until this weekend.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice