WRT54GS -> High Throughput causes disconnect

Discussion in 'Cisco/Linksys Wireless Routers' started by zephyr325, Feb 7, 2005.

  1. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Re: More Linksys stuff

    [quote="jsimmons]But the only time I really have a problem is when I set my encryption to AES. Using AES, my transfers start a t 54, then continuously drop until it levels off at 1 Mbps. Eventually, I lose connection. As long as I use TKIP or WEP, I don't have this problem.[/quote]As TheKing allready said this is a hardware limitation, the routers processor can't keep up. It is all related to the wl driver being useds as it runs the different encryptiong schemes for the wireless connection. Don't forget encryption ads on something lik 30% overhead as it ecrypts the packets to secure it. Performance will be lower when enabled but it sounds like the router eventually gives up or the wl process dies.
  2. V. 3

    Can anyone confirm that v.3 also suffers from this problem? I've got 2 new v.3 boxes sitting at home that I want to take back if they do suffer from this problem.
  3. SometimesLinkyFan

    SometimesLinkyFan Network Guru Member

    Re: V. 3

    I had a WRT54G hardware v. 3 (for one day) and it, too, had the same disconnection problem.
  4. kkapoor

    kkapoor Network Guru Member

    I initially thought it was a problem with my WUSB54G network adapter. After I called Linksys (yesterday) and spoke to them for a good 20 minutes they told me that it was a known problem with the WRT54G router and that they were attempting to fix it through a firmware update. Additionally it seems that all versions of the router have this problem to some extent.

    The temprary solution was to drop the transmit rate of the Router to 11MBPS from the 'advanced' wireless settings page. So far I have not had a dropped connection but am pissed that it is not operating at the advertised speed.

    I hope in hell that this will be fixed with a firmware update and that we are not left out to dry.

    P.S. I have Ver. 2 of the Router so it seems that all versions of the router have this issue. Do I hear 'Recall'!!
  5. Partizan

    Partizan Network Guru Member

    I have my second WRT54G v2.2 EU (the first one was RMAed). And It has the same symptoms. Always when I am downloading something I get disconnected. Sometimes the router connects to the internet by itself, sometimes I have to unplug it.

    My current routers uptime is 1 day and 22 hours (which is a record), but I am not downloading anything, just surfing the net and running ICQ. If I try to download a linux image, or start my Torrent client, the router will lose connection in one hour max.

    Should I wait for some firmware solution or return my 2nd router?

    I am very dissapointed. I bought the router, tried to find a solution for a month, then returned it, and waiter another month for a replacement. And the whole drill is starting again.

    Regards, Partizan
  6. Manip

    Manip Network Guru Member

    I have a different problem... Nothing to do with downloading large files.

    - WTR54G - 2.2 (WPA-PSK, Mac Filter, Channel 7)
    - Mac iMac Airport Card
    - Dell Laptop - Intel Pro chip

    The wireless with die, just die, when it is not in use.. And I have to reboot the AP to get it back.. And I mean a hard reboot. It happens every few hours after no-use.

    It is causing the dam AP to become unusable and it was in light use anyway.

    It never dies when it *is* in use.... And this has nothing to do with large files.

    I am considering jumping ship to D-Link ... This is the second WRT54G (had a sucky 2.0) now and I am pissed off at these issues from someone a month ago I trusted.
  7. g412b

    g412b Network Guru Member

    as stated before, i think this is indeed a hardware failure
    i did a series of tests and I think (not 100% sure tho) that is is temperature related. The new broadcom chip in wrt54g v2.2 routers seems to be getting very hot when high loads are caused.
    Some reasons for high loads are
    - Large wireless file transfers
    - Opening multiple simultanious connections

    I base my findings on this
    - Checking the cpu load using hyperwrt and the uptime command -> when loads are high it will crash
    - "Wet Finger" test, measuring the temperature of the bcm chip and it gets way to hot imo
    - Adding extra cooling improves the stability but still it isnt 100% errorfree

    I think think this is the cause of the problem
    but thats only my theory ofcourse

    My 2€cents
  8. mnol

    mnol Network Guru Member

    So what about LAN->LAN and LAN->WAN transfers? Don't they cause a high load and temp? Or different chip?

    More theories / inside info / test results anybody??

    I've simply disabled the wireless part on one of my WRT54G v2.2 routers, flashed to the original 3.03.1 firmware and factory settings (opened some ports) and it has been running for two days, flawless. Testing a 100MB+ file at 750kbyte/s (8mbps ADSL) without problems, looped for more than 15 minutes. Amazing.

    If they'd just fix the wireless issues, this could be a nice product.
  9. RedFive

    RedFive Network Guru Member

    I, unfortunately, have the same problem. I had two v2.2 WRT54G routers, running the latest Sveasoft Alchemy firmware. I tried running them in WDS mode as well as in AP / Client mode. Either way, I ran into this same issue with large file transfers or streaming.

    Tonight I exchanged them for two newer v3 WRT54G routers. Installed Alchemy on both of them, set them up in AP / Client mode. Same problem is exhibited, sadly.

    Is there any chance of a work around for this? If not, who at Linksys do we need to harass in order to get this problem solved?
  10. ezrock

    ezrock Network Guru Member

    I just notice,it may not relate to the file size.

    I have WRT54GS,v1.1.I have same disconnect problem.

    But I notice it only hapeen when i try to copy multi files.Yesterday I copy 2 files which each one is 700M,it working good,no disconnect.but when I try to copy more than 20 files,it disconnect all the time.

    does any one notice it?
  11. bbloemen

    bbloemen Network Guru Member

    I'm another unlucky owner of the WRT54G v2.2 router, having the crash problem.
    The only difference is that I cannot relate the crashes to the load on the router. Sometimes it disconnects while simply surfing the net, or using messenger... and sometimes i'm able to transfer large files (>1Gig) from a wireless client to a wired server...

    Crashes seem to occur at random time intervals to me.

    I called linksys support, they tell me to return the router for a new one but I doubt if this will resolve my problem...

    Are there any recent developments on this?

  12. dpearcePNG

    dpearcePNG Network Guru Member

    More information

    I'm running ethereal (a sniffer) now in tests and seeing lots of TCP re-transmissions and some wireless disconnects on mine.

    On my WRT54GS v1.1, most of the time, SMB connections hang, but not web or FTP actions that may be going on, even to the same two boxes!

    I open two DOS boxes. In one box I copy a series of "good" files to another computer. In the other box, I copy a series of "bad" files to the same computer. When the "bad" box hangs, the "good" box hangs also.

    Also, if I have a web broswer open to the web server on the second computer and I start copying the "bad" files to this computer, the copy will hang, but the web session comtinues to work fine! Same with FTP.

    I can FTP the "bad" files with no problems.

    All of this tells me it is a protocol/communications problem, specifically SMB (aka Windows networking) in the router. Which gives me hope a firmware fix may handle this issue.
  13. dpearcePNG

    dpearcePNG Network Guru Member

    Does Alchemy affect this issue at all?

    Does any one know if Alchemy (or any other firmware) affects or fixes this issue?

    Just wondering...
  14. tc27

    tc27 Network Guru Member

    Tried both HyperWRT and Alchemy, neither fixed the problem. I replaced the 2.2 with a 3.0 and still same problems. I wonder if this affects ALL of the 2.2 and 3.0s? I mean what is the probability of picking up two with the same problem in a row?

    Anyways I'm picking up a version 2.0 tomorrow.
  15. mnol

    mnol Network Guru Member

    If it's not all v2.2/v3.0s but 'just' a bad batch, say all made on production line XYZ or all since date YYYY-MM-DD, that chance is quite high. All stock in your store or maybe in your whole area / country is likely to be from the same transport, thus batch.

    Reading many threads on this subject, it seems everybody who returned their v2.2 got another bad one back. And i don't think i've seen anybody reporting a v2.2 that does not have this problem. And, far as i know, no one has been able to fix it (with different firmwares or settings, or..).


    Who owns a fully tested & working WRT54G v2.2 ?!
    The serial number on the box (S/N) should start with CDF7. Copy a large file, preferably a 700MB avi, between wireless and wired LAN at full speed (+-2200kbyte/s) to test. If this always (say 5+ times) succeeds without the router rebooting (blinking POWER led) and there are no other wireless high bandwith issues, it's cool! Please post some details such as serial number, firmware, test setup..

    If it does fail, it's interesting to know how soon. All info gathered could be send to Linksys for that extra bit of pressure ;-). My test results:

    Transfering 700MB avi file from wired (10/100 ethernet) computer to PowerBook (Airport Extreme 54/G). Default firmware 3.03.1. Factory settings with wireless security disabled. Command line FTP on PowerBook. Same results when FTP'ing from wired computer to wireless Windows XP SP2 computer.
    1) reboot after 2 seconds of transfering file
    2) reboot after 2 seconds
    3) reboot after 6 seconds
    4) reboot after 1 second
    5) wireless crash after 2 seconds (lan/wan & router web interface worked normal, but no wireless link possible. had to power cycle router.)
  16. Manip

    Manip Network Guru Member

    The problem is you're not going to come here and read this thread *unless* you have a problem..

    I returned a v2.0 which had a fault in which the broadband would have a max of 5Kb/s (no joke!) over the router. They replaced that with a v2.2 which didn't have that issue but the wireless just drops out (in general, not JUST with large files) ~ every 30min's or "randomly".

    The original v2.0 *could* have had the wireless drop out issue, I didn't test it long enough to find out (I didn't test the wireless at all).

    Now Amazon is refusing to replace the v2.2 and just wants me to return it (they say it is a known issue) but are still selling the WRT54G on the shop... ! So I'm not sure if Amazon are sick of me returning routers (2 returned now) or they are just happy to keep selling a known failty product.

    You would assume that if Linksys re-stocked their warehouse with good quality routers that Amazon wouldn't mind replacing mine.
  17. bbloemen

    bbloemen Network Guru Member

    I would like to stress that I do not believe that the crash is caused by heavy traffic/load and/or high temperatures of (some) components.

    I'm perfectly able (as a test) to copy the ISO's (few times 630 meg or so) of linux for 10 times right after each other (causing >20 gig heavy traffic) without a single drop out.
    However, a very simple logon request/profile loading operation (traffic less than 60meg's) of my winXP client laptop makes the router reboot....

    I have overheated the thing by blowing hot air over it without a crash (under heavy load), and cooled it down outside my window (to 5°C) crashing while loading a stupid small profile of a few meg's.

    I've read a few cases of people who have a file of only 1 kb or so, causing the router to fail consistently. Other files of many more megs seem to work fine.

    It looks to me that an ip packet with specific data or so might cause the crash.

    i'm using it only as an access point... anyone else here? would be very strange this could cause problems, but I've seen many strange things through the IT years :)

    also, i started to notice the problem after i did a few tests with peap authentication (wpa/radius). Likely the problem was there before already, but you never know we all did this :)
  18. garymok

    garymok Guest

    I brought the problematic routers back to the dealer in Hong Kong. The dealer said it's a problem related to the firmware.

    The dealer mentioned they have tested quite a lot of V2.2 routers and some of them seem more "stable" than the others. So the best thing they can do now is to replace mine ones with some more "stable" ones.

    They're asking Linksys to release the updated firmware. The new firmware may include buffer to handle requests at high load.
  19. tc27

    tc27 Network Guru Member

    I also agree that it has nothing to do in how much you copy or how fast you copy. I've been able to copy a 4GB directory of MP3s at fully speed without a crash, but staying online in MSN for an hour while voice chatting is nearly impossible. Like the previous poster says, it seems like every few minutes (randomly) it starts dropping packets for a minute or two.

    Previously i've transfered files from my local network to my laptop at 2.5MB/s and in the middle of the transfer it would drop to 100-200KB/s out of nowhere. The connection would reduce to 1Mbps, even though the signal strength is excellent. Also try playing a shoutcast stream in winamp with the default buffer settings, every little while it will start dropping packets like crazy.

    Another frustrating day with a v2.2.


    P.S. I'm also using the WRT54G as an AP only, nothing connected to the WAN port and DHCP disabled. I have a Windows Server 2003 on my LAN that handles DHCP, DNS, and NAT.
  20. ianwood

    ianwood Network Guru Member

    I would like to throw my two cents in here having just added a WRT54G to the backside of my WAG54G to have both a private and public network.

    I have been having the same problems described here with respect to the WRT54G giving up when transferring a large volume of files using either WEP 64, WEP 128, or WPA TKIP. I noticed it consistently dropped the wireless connection more or less at the same point every time. Mine is a 2.2 with firmware 3.03.1.

    As an experiment, I decided to make the unit into a convertable temporarily while a large fan blew air over it. I then repeated my transfer attempt and voila! It worked. And I tried it again... and it worked. I closed the box up, turned the fan off and tried again. Guess what? The problem returned. I am not a scientist but I think this is proof enough for me that my unit is overheating.

    Given this, I suppose I could mod the box and put a 60mm fan in the top. And I suppose I could put some heatsinks on the larger chips. But, I was wondering if anyone had any clever ideas about keeping these el cheapo boxes cool without going through too much effort.

    Let me know what you think.

  21. tc27

    tc27 Network Guru Member

    Seems like disabling G mode, and running in B only, reduces or gets rid of the problems. I'm testing right now in B only, or having only B devices connected seems to keep the connection stable. Can anyone confirm?

    Just as I posted it started to messup again. DOH!!!!!!!!!!
  22. celkukec

    celkukec Network Guru Member

    I also had problems with wireless disconnects when transferring large files (disconnections in less than 8 minutes when transferring large files from lan to wlan). All my problems went away when I disabled logging on the router and switch to another wireless channel (from 11 as default). The channels which work best for me are 9 and 13 (I live in EU). Now I'm very satisfied using wrt54g v2.2 on dsl. (64 bit wep, mac filtering, downloading with edonkey 2000 on lan constantly, latest original EU firmware).

    Maybe there is a problem with interferences? My cordless phone nearby router is also using 2.4 GHz band. It can also simply be internal interference. Just a guess. Can some try and report?
  23. ianwood

    ianwood Network Guru Member

    I too have a DECT (2.4GHz) phone and have tried with and without plus have tried all of the available channels not in use. I've scanned my neighbourhood a number of times with NetStumbler and identified the used channels. RESULTS: I noticed no difference with or without a cordless phone nearby and also no difference with the channel selection. The unit consistently drops the wireless connection under load.

    I DID notice that providing additional cooling DID make a profound difference as mentioned in my previous post. With a large fan blowing on it, I was able to run the router all of last night making repeated large file transfers (100Mb or more) without any disconnects.
  24. celkukec

    celkukec Network Guru Member

    I guess I'm simply lucky. I knew sometime will happen to me too.
  25. thirteenva

    thirteenva Network Guru Member

    Any resolution on this issue yet? I have a v2.2 router and I also suffer this issue. Is there any known solution? I regularly max out my bandwidth when working from home (between remote login/vpn and file transfers) so I'm desperately searching for a solution.
  26. dpearcePNG

    dpearcePNG Network Guru Member

    Is the latest Talisman a fix?

    I would really like to hear from anyone who has tried the latest Talisman firmware on whether it fixes this problem.

  27. Pibe38

    Pibe38 Network Guru Member

    Well I have read lots of posts on this thread, didn't have time to read all of them, and I am sad to report I'm suffering the same issues. Not only that, but I have experienced the worst customer service Linksys has to offer.

    I had a Microsoft Wireless Base Station MN-700 and my laptop running an MN-720 MS Wireless Adapter. Everything used to work fine until I started having range issues, so I decided to buy the WRE54G Range extender from Linksys, which was not compatible since it could not associate to the AP in repeater mode. I decided to upgrade my router to WRT54G v2.2 because MS stopped manufacturing networking hardware (a shame, I did not have a single issue with their hardware and although cust. support was also outsourced, my issues were always solved).

    The router was a breeze to set-up since I have some experience, then I tried the range extender which was my first pain. After finally using the Linksys Tech Support Chat about 4 times I got the range extender working. Although one of the recommendations was to have the router with one SSID and have the extender use a different SSID so that I would know which one was my laptop connected to... that was just plain stupid, why would I want to do that and then have my laptop disconnect and then reconnect to the new SSID every time I went into the range extender's area?

    After thinking my issues were solved, I had a problem playing the MMORPG City of Heroes, I would get disconnected from their mapserver often and I noticed my connection was being reset because when I was thrown back to the desktop the bubble would pop up telling me that the LAN was connected (BTW, my desktop is wired to the WRT54G and my laptop is wireless). I was able to 'fix' this by opening the necessary ports, which never crossed the tech support agent's mind until the last minute. However, I still experience some random issues with the game.

    So I finally thought I was back on the game... wrong! Tried to move 500MB of data, not 1 file but a group of folders from the laptop to the desktop. Same issues as here, transfer failed, sometimes I just got the error, sometimes I had to power cycle the router, sometimes I just needed to use the repair option from WinXP to re-connect to the router. After trying this on many occasions, I also noticed that WLAN light would go off at the time of the error, the decline of the speed even though signal strenght was excellent and ending in a disconnect. My laptop was only a couple of inches away from the router, and even when I was doing absolutely nothing the speed would be at either 48 or 36 Mbps.

    So I called Linksys, first time the agent put me on hold for 20 minutes while he was going to input my info on the system and then hung up on me. The second tech tried to help me by changing some setting like limitting transfer speed, lowering my wired desktop's adapter's speed to 10Mbps Half Duplex instead of 100Mbps Auto ??? ~ etc. He finally decided, when he asked me if my laptops NIC was Linksys, that I did not have the latest drivers for it, and that I should update it and try again. Yeah, good move Linksys, blame it on someone else's hardware that has always worked...

    Also, while using the chat feature one of their "tech" support agents, without even asking me to go to the management tool or change a setting at all... told me to return the router because it was defective. How could he have known that if he didn't even ask me to check a log, or change a setting, or try this or that... unbelivable.

    So finally I decided to send a nasty but polite e-mail. Telling them about my situation, how I know I'm not the only one, and offering to provide any more info they need in order for this problem to be solved, or I would be returning every single Linksys product I have ever bought; I would also be informing all my friends (PC and console gamers, business and home owners) about this situation and if no measures were taken, we would be forced ti judge Linksys' products on this experience. I received my automated e-mail telling me that I should expect an answer in 24 hours... it's been 36 hours; they give you an option to reply or update tou case thread, so I let them know that it had been more than 24 hours and no response had been received. If I don't get acknowledgement in 48 hours, Linksys is going to be losing my business forever. I can't believe that Microsoft, which is company not dedicated to this and that tries to get into every single market they can, was able to make a better product than Linksys (Cisco) which is a company that is DEDICATED to this. If this what we can all expect from them, one of these days Linksys' employess are going to starve because they won't be succesful in business.

    Just some notes, I was also having issues with MSN Messenger... trying to share my webcam and to see someone else's webcam. I would disconnected from MSN Messenger altogether. I have just updated to the HyperWRT firmware to be able to determine how long has the router been up for.

    Well I have informed you that I am a disgruntled customer and also vented a little... I'll update when I get more info on this or when I return the items.

    Sorry for the long post... :oops:
  28. Pibe38

    Pibe38 Network Guru Member

    Sorry for the double post, I just received an e-mail from Linksys which is more than the usual one-click answer they have...

    However, this answer had not been e-mail to me... it shows before the message I sent to them today. Here's the second response on the thread...

    Is it much? Not really, but I thought I'd let everyone know about it.
  29. Partizan

    Partizan Network Guru Member

    Well my v2.2 started working flawlessly. You ask how? It's a simple answer:
    I am only surfing. No downloads, no file transfers between my 2 computers.
    And I didn't have a single disconnect in 3 days.

    Greetz, Partizan

    P.S. Ok, a little black humor, but I am frustrated.
  30. bigbaraboy

    bigbaraboy Network Guru Member

    DD-wrtg prefinal 3.3. >>> installl this firmware and try communication between LAN and Wireless ( disconecting when transfering large files has disapired on my device after installation of this firmware)
  31. ianwood

    ianwood Network Guru Member

    I am sticking with my heat dissipation issue as it makes the most sense and so far I see nothing that would contradict this theory. My guess is that there is an ongoing manufacturing issue with one or more of the main components in the router. This would explain why not all of us have the problem. I am not normally one to suggest such activity, but they have admitted the fault and with so many problems unresolved, Linksys is overdue for a class aciton suit.

    BTW, I think I read somewhere that the 2.2 is a Broadcom based chipset. If so this would be my 2nd bad experience with their chips. My motherboard (an Asus P4G8X) has a Broadcom Ethernet controller on the mainboard. And guess what behaviour it exhibits? The Ethernet controller would often fail under heavy load requiring a full reset to get it going again. From now on, no more Broadcom for me.
  32. mnol

    mnol Network Guru Member

    Cool (sort of :-|)... If this is the cause for all v2.2/v3.0 units, it might not be possible to fix this in the firmware at all!

    The WAG54G v1 (wireless router + ADSL modem) has had similar problems since at least june 2004. Linksys didn't fix it yet! I've read some posts only this week that if you contact Linksys now, they will swap your v1 for a new v2 that 's supposed to work well.

  33. thirteenva

    thirteenva Network Guru Member

    I also contacted linksys support. Here is the answer i received.
    I can't speak for everyone but this is not what my issue is. My MTU is set according to my what my ISP recommends.
  34. mnol

    mnol Network Guru Member

    Funny. They just send back random answers, regardless of the question.

    What's your ISP's MTU got to do with this? Even if you disconnect your ISP (WAN), the router will reboot on heavy wireless activity.

    Is it a helpdesk, or is it a mail script? :-D
  35. netmaster

    netmaster Guest

    i have installed approx. 150 v.2.2 WRT54G units. Some of them seems to have that "high traffic" issue. We rent these to customers and use as wireless clients in our network with OpenWrt . Some units started come back to me over, and over again with complaings about disconnects. So i started labeling them. After second return, i stop using that router and after week, i have found 8 such units. I have all empty boxes with serial numbers (packed by 20 to bigger boxes, just like they come from store), and i'am not sure yet, but probably all these faulty units has come with one (or two) delivery at late january or in february. I belive, that WRT54G's produced by LinkSys in some period, have hardware gliches and now they trying to find software workaround for this problem, what may not be possible at all...
  36. Pibe38

    Pibe38 Network Guru Member

    Well after installing HyperWRT I have been able to notice that my router's uptime resets itself every now and then when using the connection, meaning my router resets itself.

    The maximum uptime I have been able to achieve is 10 hours, and when these resets happen I don't seem to be able to notice them, even when they happen while I'm on the computer.
  37. Partizan

    Partizan Network Guru Member

    Well I tried to copy some of my userdate from my secondary computer to primary via wireles. It was approximately 600 Mb, and I got 4 disconnects.
    I am going to return my second router.

    Damn you Linksys.

    Regards, Partizan
  38. dannyhawaii

    dannyhawaii Guest

    Like many out there, I have been following this thread, searching for the Holy Grail of Linksys fixes.

    Don't worry, I haven't found it. But I have improved my situation, so I'll share it with all of you.

    I have a version 2.2 WRT54G, and the most success I've had is with the latest HyperWRT firmware. My average uptime is about a week.

    I was previously using GetRight to download files from easynews.com, with ten simultaneous connections and speeds of around 800Kb/sec. After a few seconds to a couple of minutes of this, the router would crash and reboot. Transfers and regular surfing all work fine. I have one PC on ethernet, one on wireless, and a Powerbook on wireless as well. My problems all occur on the PC connected through wireless.

    After plenty of frustation and extensive fiddling with settings, I tried out a different download manager - Free Download Manager.

    Now I'm getting the same download speeds without the rebooting!

    The damn thing still seems to reboot once a week, but I can live with that for now.

    I'm still considering swapping the router for a newer hardware version, but I might just stick it out for a while and see if the firmware situation improves. Bit it really does bug me that Windows ICS worked more reliably than a hardware router!

    Danny Hawaii OUT
  39. MarkFour

    MarkFour Network Guru Member

  40. Pacif13r

    Pacif13r Network Guru Member

    Re: Anyone tried this?

    Hmmm sounds intruiging. Seems like a slightly different problem but by the looks of it all sorts of people are having some sort of success with it. Gotta be worth a try... thanks.
  41. thirteenva

    thirteenva Network Guru Member

    Not sure if thats the same issue we're having, but if it is related this seems like a pretty easy thing for linksys to fix, yet they're dragging their asses?
  42. eitan

    eitan Network Guru Member

    Now that it's apparent that these routers are junk, what's everyone doing about it?

    I'm giving up on this crap, and want to buy something proven that doesn't have a flurry of issues posted up.

    Can anyone recommend a Wireless G router to replace a POS WRT54G V3?
  43. thirteenva

    thirteenva Network Guru Member

    I'd really just like to find the cause of the issue. Also, I urge those of you who have not contacted linksys to do so.
  44. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    i just seen this topic/forum and i'm happy to hear that i'm not the only one, in fact i have a complex Network built on IPCOP/LINKSYS with servers/laptops and i was trying to change both Linksys/IPCOP settings for 3days without any success !!!!
    anyway i tried almost every slution in this topic except the FAN because i don't have one, and i'm still having this problem.... i hope someone will be able to have some solutions!!!
  45. Pacif13r

    Pacif13r Network Guru Member

    HyperWRT - startup script

    For what it's worth I have a WRT54GS 1.1 which resets completely after passing certain byte streams over wireless and therefore stops certain files from crossing and causes random disconnects. Yesterday I tried the idea of inserting that startup script into HyperWRT to reduce the length of time connections were cached. (Mentioned several posts ago).

    It does nothing for this specific problem in case anyone else is thinking it's worth a try.
  46. dpearcePNG

    dpearcePNG Network Guru Member

    Alchemy impact

    I tried Alchemy 1.0 on my WRT54GS v1.1 with no change in my hangs (it still does).

    I'm quite curious about the various premutations in the symptoms. Mine doesn't reboot (ever), it's just that particular stream hangs when copying a file. HTTP continues to work.
  47. mstombs

    mstombs Network Guru Member

    Re: HyperWRT - startup script

    I have this exact problem - so thanks for saving me the effort of trying.

    Got an email from Linksys today saying the case is closed as I hadn't contacted them for n days - but their last message was that the problem was being escalated and they would get back to me (which they haven't).

    I guess you can imagine what I put on the quality feedback questionaire which they also sent me as my problem is resolved..

    Can anyone point me to email addresses of Cisco/Linksys senior management?
  48. dpearcePNG

    dpearcePNG Network Guru Member

    My 2¢ about trusting Linksys

    Being a computer geek with direct contact to over 500 users (I live in an overseas multi-national compound), I get asked for recommendations A LOT. People trust me so when I'm asked about what to buy, I think long and hard about who I recommend.

    I applaud Linksys for bringing the WRT54G to market. Basing it on a Linux kernel is a great idea. They came so close...

    I can accept mistakes. They happen. What I cannot tolerate is making a mistake, then blaming others or not admiting publically they made a mistake. Even less tolerated is not offering a remedy for the damage done.

    Linksys, I truely hope you can get this problem solved. It would mean a lot to your customer base. In the mean time, I'm going back to recommending Netgear or maybe D-Link. Not as slick or geeky, but it works. I've already in the past week stopped two people from buying Linksys gear.

    Once my next router shows up, the WRT54GS goes into it's box and on the shelf. I can't even sell it, because I value my friends' trust too much.

    It's a shame Linksys doesn't value our trust as much.
  49. bjodom

    bjodom Network Guru Member

    I also finally gave up on this piece of shit. I then decided to go with a netgear and that one worked for a couple days with a shitty wireless range then one day just stopped working. Flashed the firmware and was working again then dropped the connection and got pissed and returned it right there. Bought a D-Link 524 (had a wired d-link that dropped like once a month that needed to be restarted). Seems to be working good so far.
  50. gaogi

    gaogi Network Guru Member

    There is a beta firmware (version 4.00.5) available that resolves this issue. The problem is with the memory mapping that is used on the router. After the memory is remapped, the issue has gone away.
  51. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    a link please? where can i find it?
  52. gaogi

    gaogi Network Guru Member

    It's not published since it's a beta. Just sent you a PM.
  53. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    hmmmmm... it didn't solve the problem.. also the cisco logo is lighted orange :eek: do you know why??? do it needs factory settings?
  54. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

  55. raeandy

    raeandy Network Guru Member


    Thankyou for hosting this.

    It HAS solved numerous issues for me such as
    a) Slow transfers from the server (fixed)
    b) Slow internet traffic (fixed)
    c) Unable to transfer small files (fixed)

    WRT54GS Ver 1.1 located in Australia.

  56. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    no problem, thank gaogi instead he's the provider...

    GUYS we need more testers please...
  57. ericchang591

    ericchang591 Network Guru Member

    I just went wireless a few days ago, and I wish I had read this thread before I got my Linksys WRT54-G v3. I have the problem where attempting to transfer a file between one computer and another over the wireless causes a disconnect, as well as the router occasionally needing to be unplugged. This also occurs when getting some files over the internet as well.
    I first had the problem with the stock firmware, then upgraded them to the official ones from Linksys (whatever the latest is). I also tried the HyperWRT firmware as well as the various changes in the some of the settings. They all failed.
    I then attempted those beta drivers that Gandalf hosted, and it didn't work at all...in that my router stopped working period. The Cisco logo on the router turned orange (don't know what that means), and my router essentially stopped doing anything even though all the correct lights were on. I couldn't even reach the router's web setup. However, after resetting the modem totally, and starting from the very beginning with the CD that came with the router...it works again, but still have the same problems as before. I think I'll just wait and see what Linksys will come up with in the end, as I can surf the internet over the wireless just fine. If something doesn't come up in a month or so, I'll probably have to go with a different brand in the future.
  58. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    exactly i had the same results except for the part that stop responding, as for the Orange logo it's a new feature that will Change SSID and WAP key and update those conencted to it as well
  59. raeandy

    raeandy Network Guru Member


    In my hast to reply I forgot to mention your role in this. My deapest appologies. Thankyou gaogi.

    I performed a factory reset after loading the firmware and have had no isses thus far. My cisco icon is the same colour as normal. No probs there.

    This firmware came in the nic of time as I was having troubles setting this up in a funtion room and linking to the server. All good now.

    Thanks again.
  60. JohnSK

    JohnSK Network Guru Member

    Can someone else test this firmware and confirm it fixes the problems discussed?
  61. Golverken

    Golverken Network Guru Member

    Hello Everybody,

    Some good news !! I have tested it !! and my router WRT54GS V1.1 works finaly normal, all files can be copied!!!
    All downloads can be performed also this one:


    PS: You have to reset the router after the firmware update.
  62. JohnSK

    JohnSK Network Guru Member

    ...and now how can this be integrated into current FW's like DD-WRT? :)
  63. Couledouce

    Couledouce Network Guru Member

    DD-WRT can integrate it when the source code is released by Linksys, should not be too long, but I suppose they have to release the firmware version officially first lol
  64. Juscelino

    Juscelino Guest

    LAN <--> WLAN causes disconnect - Temporary Resolution


    After trying EVERYTHING (and I am not exagerating) here is what finally solved my issue. Keep in mind that it is a "temporary resolution" because my wireless speed decreased significantly and I still want to resolve the issue 100%.

    However, the following settings worked for me and I can now transfer files between my LAN and WLAN...

    Wireless Advanced Settings

    Authentication Type: Auto
    Basic Rate: All
    Transmission Rate: Auto
    CTS Protection Mode: Auto
    Frame Burst: Enable
    Beacon Interval: 50
    DTIM Interval: 1
    Fragmentation Threshold: 2346
    RTS Threshold: 2347
    AP Isolation: Off
    TX Antenna: Auto
    RX Antenna: Auto
    Xmit Power: 251 mw
    Afterburner: Auto

    Hope this helps. Let me know...
  65. JohnSK

    JohnSK Network Guru Member

    Re: LAN <--> WLAN causes disconnect - Temporary Resolu

    I could live with any of those settings except... Xmit Power :) I have a 26dB antenna and putting 253mW into it would be a overkill (for reference, I've set this only to 1mW)
  66. mistergee

    mistergee Guest

    More on the (beta) firmware update ...

    Hi everyone, I too am well pleased to have found this forum. As per a previous post I am also shocked at Linksys for not actually withdrawing the product or at least letting us know it has a problem.

    I have tried the firmware upgrade 4.00.5 that was posted - and still no luck. I have a WRT54G v2.2 and I am trying to copy all of my photographs off of my notebook (wireless - SMC2835W) to back up on to DVD on my desktop (wired - VIA 10/100 LAN card(?)). It copies anything from 10 to about 200 pics and then loses the connection - and gives me the "path too long" message !

    I did do the factory reset after the upgrade but the problem is still just as bad if not worse - it is so frustrating - I need to get these pictures off to make space before Monday and now it looks like I'm going to have to go out and buy another ethernet cable and have to sit in my office and do all the copying - ridiculous .... AAAARGH !!
  67. Partizan

    Partizan Network Guru Member

    Can someone confirm that the WRT54GV3.1_4.00.5_US_code.bin works with a wrt54g v2.2 as mine is still under warranty and I don't want to brick it.

    Regards, Partizan
  68. ericchang591

    ericchang591 Network Guru Member

    I'll admit, I did not perform a factory reset after the firmware upgrade (I assume that means that I should push that reset button for a certain amount of time?). Now the question is, should I have done that with every firmware upgrade? If so, then oops! Maybe I'll give that another shot then when I have the time.
  69. bbloemen

    bbloemen Network Guru Member

    I installed the WRT54GV3.1_4.00.5_US_code.bin file on a wrt54g v2.2 EU router. Firmware seems to do its job. Is't only up and running for 5 minutes now, so i'll let you all know if the crash problem is still there as soon as I get a crash here.

    (I don't see that orange cisco logo that some people mention... where should I look for it?)

    ok never mind. as i'm typing this message the bloody thing is going down again. I was too late to watch the actual reboot (blinking power light), but anyway, it still disconnects.

    so WRT54GV3.1_4.00.5_US_code.bin DOES NOT fix the problem for me.
  70. Jon12

    Jon12 Network Guru Member

    Hi, I have a WRT54GS V1.1 and the Beta firmware linked in a previous post has done the job for me :). Just uploaded the firmware to the router and its working great.

    I don't know about other versions of the this router but it definetly worked on mine.
  71. Partizan

    Partizan Network Guru Member

    well I am going for it. I have a WRT54G v2.2 EU too (bought in Germany). Will post the results in an hour or so.

    Regards, Partizan
  72. m00n

    m00n Network Guru Member

    Hye guys,

    I had a BEFW11S4 before i bought the WRT54G v2.2, two weeks ago. I experience some trouble with this router. After a will my connection drops and i can't connect, so i have to disable/enable my ethernetcard. (mostly it happends when i'm downloading (1.2 mb/s).

    Maybe it's the same trouble you guys have or is it something else? I tried every firmware.

    I'll try this beta firmware after some good results form you guys....
  73. hajnal

    hajnal Network Guru Member

  74. bbloemen

    bbloemen Network Guru Member

    As I said in my previous post, I installed WRT54GV3.1_4.00.5_US_code.bin.

    It's even bigger crap than the previous firmwares. Now it works for a few minutes, the router hangs and DOES NOT even reboot anymore.

    Also, it hangs while updating the firmware back to its original version.

    In other words, I called my store, and my wrt54g is flying back to where it came from. And I'm never ever gonna buy something else of linksys.
    They fooled me with a wireless pcmcia too. pretending to support AES (in the manual), it simply does not support it.
  75. ericchang591

    ericchang591 Network Guru Member

    Well, I tried the new beta firmware again, and made sure I did a factory default reset...same results with the WRT54G v3...everythign runs well for about a minute, and then the internet light goes out on my router and a power cycle doesn't do anything. But luckily, I'm able to run the firmware installer that Linksys packages with their last official firmware (3.03.6) to undo my changes and then if I run the setup CD again, I'm able to get back to where I was.
    I also tried setting my wireless transfer rate to 11 mbps with no luck either. Oh well! Here's hoping something official from Linksys arrives soon...otherwise I might just go D-Link or something.

    Oh and if anyone else has a v3 and has managed to get this to work, I'd appreciate them posting the exact steps the went through to flash the firmware because maybe I missed something (I don't think so though!).
  76. Golverken

    Golverken Network Guru Member

    Hello, News from the front.

    All saterday I have done some test. And with the new firmware allmost 99% was copied.
    There was one directory that received the message: network name is no longer available.

    I have changed the following settings under advanced wireless settings:
    Basic rate: all
    CTS protection: auto
    beacon interval: 50

    And from now on, everything is fine.
  77. m00n

    m00n Network Guru Member

    And WRT54G V??? :)
  78. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    ok it seems that this beta FWs are fixing V1.1 problems but not V2&V3
    i'm informing gaogi!!!
  79. Partizan

    Partizan Network Guru Member

    I totally agree. It was running fine for 2 hours on my WRT54G v2.2 and when I tried to copy 300 Mb of jpegs via wireless to my second computer, I got constant disconnects and even had to unplug the router.

    Should I wait or RMA it?

    Regards, Partizan
  80. osgood

    osgood Network Guru Member

    My WRT54g

    Ya know folks... I have a WRT54g v2 and I am having no problems at all... I do however keep it, and the rest of my network equipment in a cool room in the basement... I am using the latest DD-WRT firmware and all seems good... Even transfering VOB files and remote connections, not a drop one...
  81. Partizan

    Partizan Network Guru Member

    Re: My WRT54g

    V2.0 is not the problematic revision. V2.2 and V3.0 are the buggy ones.

    Regards, Partizan
  82. bbloemen

    bbloemen Network Guru Member

    I agree
    A friend of mine owns a v2.0, and does not have this problem at all.
  83. Pacif13r

    Pacif13r Network Guru Member

    Linksys Victim Support Group

    Just a thought...

    It's getting quite confusing (at least for me :oops:). This thread started as WRT54GS high throughput causes disconnect. Now a lot of people are having different problems with different models. Perhaps we should think of this thread as some sort of "Linksys Victim Support" thread. To that end, It may be useful if people perhaps used a signature stating their model/version/firmware and typical problem ?

    Then we would kind of know if a post had some relevance to us as a glance and it may help us identify the key problems.

    Opinions/Comments ?
  84. kkapoor

    kkapoor Network Guru Member

    I have v2.0 router and it with the latest current firmware it does have this problem. I talked to Linksys and they say that all products from v2 up have this problem. It has something to do with the update of the wireless driver in the last firmware.

    I was thinking about trying the beta firmware released on this forum but I think I will wait it out.

    I'm going to give Linksys a call on Monday to see if they have a status update.
  85. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    Re: My WRT54g

    well not *ALL* routers having this problem :(
  86. Partizan

    Partizan Network Guru Member

    v2.0 doesent have the dreaded broadcom chip :)

    I am thinking of switching my v2.2 for a v2.0

    Regards, Partizan
  87. mnol

    mnol Network Guru Member

    I found a WRT54GS v1.1 owner suggesting that heat might be causing the reboots. It's a nice read, including some heat transfer calculation results, so check it out.


    Maybe Linksys could release a WRT54G(S) hardware update: Click-on feet, positioning the unit face down 'for optimal performance'. I'm all for it. :-D

    Will try this tomorrow. Let me know if this works for you..
  88. Kyoshiro

    Kyoshiro Network Guru Member

    right now im only regretting buying a Linksys after all the good stuff i heard about it lol.
    Hong Kong tis the land of no refunds.
  89. thirteenva

    thirteenva Network Guru Member

    Just thought i'd pop in to say that i also tried the beta firmware posted above and i'm still experiencing issues with my v2.2 router.
  90. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    nope that didn't work for me neither, WRT45G V3
  91. RyFeR

    RyFeR Network Guru Member

    Beta firmware solved my prob on WRT54GSv1.1

    Hello all,

    Have had some nice conversations with Linksys Technical Support (Netherlands) last week, they confirmed the problem on a test WRT54GS in their lab with my (mailed) config. They didn't had the solution however (didn't expected that either) and they would escalate to the US.
    Only solution offered was to RMA my WRT54GSv1.1 and hope that the replacement one worked ok. Having read many posts that replacing with the same / newer model resolved nothing i didn't know what to do...

    Until today! A beta firmware was posted (thanks for putting that up, Gandalf_SX1!), resolving my issue (copying certain files would cause a SMB reset, ping and HTTP traffic was unaffected) completely!
    I flashed that firmware and did a 30-second reset of the router afterwards.

    Let's hope that this fix will be finalised soon and will be made available to all those custom firmware makers...

  92. sxwlinksys

    sxwlinksys Network Guru Member

    Well, I tried it, and doesn't work. I also tried putting a vacuum cleaner on top of the router, so the air is constantly refreshed inside, and that also didn't help. I think after the vacuum cleaner test it's safe to assume that the problem is not heat related, I had a LOT of air going trough the router this way...

    I've also tried dd-wrt, that also doesn't help, and I've tried the Beta of the Linksys firmware that was posted here, that also didn't help. I own a WRT54-G hardware rev 2.2, and after a few seconds of pulling more than 1 megabyte per second over the wireless, it crashes, shuts down and reboots. I didn't have this problem with my old Wlan-B card, maximum speed 450 kb/s.
  93. m00n

    m00n Network Guru Member


    I tried the firmware posted above, now my WRT54G is bricked... the power les is flashing all the time and wont stop.

    If i force the ip settings from my ethernet card i can ping it, but cant go to the webbased interface...

  94. ericchang591

    ericchang591 Network Guru Member

    Moon, I had similar problems when using the beta firmware. All I did you fix it was to reset my router using the reset button (hold it down for a few seconds while the power is on). Then I updated the firmware using the official one from Linksys (the one with the executable to update it without needing to access the web-based setup). Then I ran it through the setup CD again from scratch, and I got back to where I was before the beta firmware. Hope that helps.

    And this is getting frustrating, because the router also disconnects quite a bit with just regular internet file downloads, and I shouldn't have to download from spyware infested download accelerator like GetRight just to download files when using the wireless connection, let alone the wired connection. Even if Linksys does fix this, I truly doubt I'll ever buy another Linksys product again.
  95. m00n

    m00n Network Guru Member

    Omg dude, it worked.... It seemed that it didn't but after a few moments the powerled stopt flashing! Thx a million!
  96. ericchang591

    ericchang591 Network Guru Member

    Well, I gave up! I ended up bricking my router (I like how owning this Linksys router has made me start using "brick" as a verb) after trying to update the firmware again and having it fail in the middle of it...now no matter what I try (resetting, etc), I cannot get it to work and that includes trying to update the firmware again with Linksys official firmware. So screw it, hopefully I can return it and get a refund.
    And naturally, I went out to Staples, told them I wanted anything other than a Linksys router, and ended up getting a Netgear WGT624, and so far, no transfer problems, and it works just fine with my existing Linksys WET11 WAP/Bridge. Thanks Linksys, for totally losing someone as a customer with your shoddy product. I mean seriously, how can you release something that doesn't provide something as simple as being able to transfer files between a wireless connection, not to mention it disconnects every once in a while.
    Man...hopefully the rest of you who still are holding onto your routers can get your problems fixed with the new firmware that will come out. I just plain lost my patience.
  97. eitan

    eitan Network Guru Member

    After having updated to the 4.00 firmware, I have this to report:

    My problems aren't fixed, though I think they've changed a little. The router crashes with pretty much any wireless activity, regardless of the speed. It'll work for about 200kB and then crash, but it manages to come back up by itself a little quicker before, enough so that IRC and AIM don't notice.


    I hope by the final release they've actually fixed the problem we're all having.

    Also, I noticed it has this new "SES" feature regarding wireless security (and support for WPA2). Anyone know what SES is?
  98. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    yes SES is a feature that (with a compatible wireless cards) set a new SSID/WEP key by simply click on the SES icon or the Cisco logo in the front panel that is lighted orange now, and hold it for 3 seconds
  99. Partizan

    Partizan Network Guru Member

    Argh, I don't need a SAS, I need a stable, working router.

    Regards, Partizan
  100. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice