WRT54GS -> High Throughput causes disconnect

Discussion in 'Cisco/Linksys Wireless Routers' started by zephyr325, Feb 7, 2005.

  1. Partizan

    Partizan Network Guru Member

    Gandalf, you are a powerful magician, use your magic on our bugged routers. :)

    Seriously: Should I RMA my router for another v2.2. Should I swap it for a v2.0 (if they will have it), or should I lookd for another brand?

    Regards, Partizan
  2. enx23

    enx23 Network Guru Member

    It works for !!! (put it up-side down, heat problem)

    I own a WRT54G v2.2 (with WEP 128). I experienced also wireless high-throughput disconnects. I tried to position the router upside-down (the side with leds is downwards, http://www.angelfire.com/ga/govandy/junk/vertical_linky.jpg ; the picture is by http://www.dslreports.com/profile/565882 ) as specified in this forum and now the router works perfectly and no more drop-outs.
  3. Morpheus

    Morpheus Network Guru Member

    I have a WRT54G v2.2 and I can transfer 10.9Gig ISO With out a single drop on the Wireless. I am using the DD-WRT Talismen its rock solid.
  4. wa11y

    wa11y Guest

    This also works for me, prevented wireless disconnection! :) But speed should be decreased a bit. I have a v2.2 box w/ 3.03.1 .
  5. Red97

    Red97 Network Guru Member

    Setting Mode B only makes it stable but slow...

    One workaround that appears to work for me so far is to switch my Router to mode B only. It defeats the point of getting a mode G capable router but until Linksys can fix this issue at least I seem to have a stable router.

    Previously my router was locking up after transferring large files and needed a complete power cycle to get it functional again. But this seems to have prevented this problem so far...
  6. Kyoshiro

    Kyoshiro Network Guru Member

    good bye linksys wassup netgear :D
  7. eitan

    eitan Network Guru Member

    Heh, I bought the WRT54G to replace my WGR614 v1 (Netgear), which was also problematic.
  8. Kyoshiro

    Kyoshiro Network Guru Member

    it first started with the Sercomm 54G router which was simply outdated. I then got a Linksys WRT54G v2.2, headaches, i just gave up. Today i went and exchanged for Netgear WGR614v5. Its doing great right now. Stress tested, and was doing fine. It was 2nd choice of this networking friend of mine. He said 3com was the best but apparently the store didnt hold any. 2nd was D-Link and Netgear.

    edit: Just when i said it was great, it did what v2.2 did. DISCONNECT ME LMFAO
  9. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    Re: LAN <--> WLAN causes disconnect - Temporary Resolu

    hmmmmmmmm.... :roll: that made my router hold twice more, i mean before it holds 10/12 MB now it holds 24MB also it restart faster, before it hangs don't restart (Beta FW, WRT45G V3)
  10. thirteenva

    thirteenva Network Guru Member

    After many back and forth emails with linksys they have also asked if i wish to send the router back. I'm hesitant because the v3 routers also seem to be affected.

    What should i do?
  11. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    I just bought a wrt54gs and wmp54gs and am having the same exact problem. What firmwares are acceptable to use with the gs and should I just save myself the hassle and return this pile? I have v2 or 2.2 it seems as though the labels don't match.
  12. Arantar

    Arantar Network Guru Member

    I will send back the WRT54g and WAP54g I have bought last week by tomorrow.
    I feel somewhat ripped of by Linksys, as the problem is known since months and they are still selling their defective hardware.
    Dunno what to buy then. Could be either a D-Link or Netgear. Anyway, this time I will check the forums before I spennd a penny on a new solution.
  13. mnol

    mnol Network Guru Member

    Tried this (router in vertical position for better heat transfer) on the 'best' one of my two WRT54G v2.2s. No success. Transferring WLAN-LAN made the router reboot after about 50 seconds / 100MB, like before. 'Spontanious' reboots (when just surfing and reading mail) seem to occur less, but that's just a guess.. and could be caused by any other factor.

    I also tried the other recent suggestion in this thread, changing beacon interval (to 50) and two other settings. No change. Reboot after 93MB of WLAN-LAN transfer (with the router still face down ;-)).
  14. Kyoshiro

    Kyoshiro Network Guru Member

    For those who are exchanging their V2.2 n V3 and no luck with getting V2s. Get D-Link. This netgear WGR614 v5 has issues of 4 hrs disconnets lol
  15. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    for all who wants a decent router, get an old junk PC, stick on it IPCOP get a wireless Access Point (not a router) don't know which is the best maybe D-Link (even if it's a router you will need only an access point and you can setup it to do this) and be happy for ever this way :D
  16. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Not exactly what I was wanting to hear. After dropping the dough down it is upsetting to have these issues. What firmware is besy for the wrt54gs? I do realize it doesn't fix anything, but which is the best.
  17. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    hyperWRT i beleive, for WRT45G it's the best (in my point of vue) but i guess it is BTW look at the poll on the frontpage, it is rated 1
  18. gaogi

    gaogi Network Guru Member

    For those who are experiencing still experiencing disconnects on the WRT54GS (SpeedBooster model only) with the beta firmware, please let me know which file you tried to download/transfer that caused the disconnect. It would be great if I can get that file. PM me and I'll give you a place to upload the file. Thanks.
  19. Nimdae

    Nimdae Network Guru Member

    Years ago, I used 10 mbit linksys nics. Got one of those starter kits with 2 nics and a 5 port hub. Most horrible experience I had with any kind of hardware. During extremely mild use, it was ok at best. If we had to transfer files, we had to reboot the computers, transfer files, then reboot again. Gaming was the same. What happened if we didn't reboot? Starting a file transfer MIGHT be possible, and if it did, it was guaranteed to fail. Rebooting actually only raised the chances of completing a transfer. This was the same for gaming. Exchanged the nics for a pair of netgear starter kit with 2 fa311 nics and 10/100 switch. Vowed never to use linksys hardware ever again.

    A couple years later, I heard rumor that linksys was improving their hardware and that their broadband routers were the best on the market for consume broadband routers. My anger prevented me from buying one. I used a linux machine as my router. After a while, news that Cisco bought Linksys hit me, and my first thought was maybe they'll actually get better.

    I've recently bent and bought a linksys 5 port switch out of necesity of a replacement. Not long after, I wanted wireless connectivity, so I got a WAP54G, which for the most part works great. And now, after discovering my wired uplink from one room (where the internet comes in and a computer resides) to this room (where 2 more computers reside) is going bad, I decided to go wireless between the rooms. I got the WRT54G from radio shack today, set my WAP54G to client mode and connected it to the WRT. It worked great...or so I thought.

    My linux machine is a machine I ssh to from work, and keeps 2 screen sessions open for irc. I've had to kill them because every few minutes they would disconnect, and it started flooding the quieter channels. I tried some gaming, and it's possible, but laggy, and the possibility of harder lag makes me not want to take any risks in the games. I've yet to complete an update on my linux box today as the package downloads keep failing.

    Now, after all this, I'm going to give linksys a chance. I'm going to email them with lengthy details along with facts of this being a pre-existing problem, that is well known, and documented in several places. If the response I receive to the email is NOT a firmware update that fixes it, a workaround that actually works, or an offer for a product that actually works, I will return this device and return to the stance that I will not buy or use linksys products.

    I would like to point out that this was replacing not only my failing uplink, but a MICROSOFT router that was working fine. While not wireless, it was a lot more reliable.

    Sorry for the lengthy post, but I've not had very good experience with Linksys/Cisco.
  20. pedratan

    pedratan Guest

    I decided to join the forum so as to try to help.
    Experienced the same problems you describe here with a WRT54G v3, FW 3.03.6, so went to exchange my router and got one with almost the same serial (one was xxxx80, and this one is xxxx77), so I thought would have the same problems. For my surprise I have not yet experienced the problem. Transfered a couple of isos and even did the ping flood (linux's ping -f, which killed the old router in less than a minute) without any problema at all.

    The difference is that with the first one I used a wireless-B linksys card, and with the new one I tried with intel pro G one. Not sure yet if it will work with the old one.
    Can it be the B compatibility layer?
  21. sxwlinksys

    sxwlinksys Network Guru Member

    Nope, with me it's exactly the other way around.... If I use a B card the router works fine. Then I bought a G card, and then the problems started. The bad thing is that I always thought the router was good, because I was using it with the B card. I am not really pleased that now suddenly the router is showing it's flaws....
  22. enigmaxp

    enigmaxp Network Guru Member

    Bumped my recently purchased WRT54G v3 firmware to the beta one.

    Was able to transfer about 1GB of data before my connection died. Curious though that instead of the router resetting, its was my wireless adapter that wasn't able to see the router anymore. I had to disconnect and reconnect my adapter for it to see the router. With the original firmware, the modem would reset after about 50megs of data was transferred.

    In any case looks like linksys is getting some progress with the problem, just not all the way there yet...
  23. droopy

    droopy Network Guru Member

    Ok, my replacement router has arrived. To my surprise it's a v2.2 also (they told me it will be a v3, frankly i don't care). Got it out of the box, plugged it in. No more problems. This box works flawlessly (or so i thought). I then flashed Sveasoft's Alchemy 1.0 final. It worked fine for about 12 hours then ping times went crazy (200-900ms with great loss - WMP54g NIC), changed my wireless NIC to a DLINK - same latency problem), i then turned on WPA AES encryption and my beloved WRT (now The Second) refused to boot (power led wouldn't stop blinking). Did a hard reset and everything went back to normal. I then flashed WRT54GV3.1_4.00.5_US_code.bin to the box and AES started working as a charm. Uptime is 72hours now with no disconnects or hiccups. Could it be that the latest Alchemy has some stability/encryption issues?

    Bottom line is: Is it just me or the disconnect problem resides in faulty hardware? But then again the first v2.2 i bought worked perfectly for 1 week before started to mess up. Only time will tell.. and my patience as well.
  24. RyFeR

    RyFeR Network Guru Member

    Hello all,

    Reported earlier that my "the specified network name is no longer available" error while copying files was solved with the new beta firmware flashed into my WRT54GSv1.1... Well, it;s not :-(

    With the new beta firmware, all my previous test files copy perfectly, but other files (don't know if they failed with the normal firmware as well) now give the same errror.
    I first saw that with a 3.6GB PS2 ISO file, but i now have the same issue with a 700KB file.

    Let's hope LinkSys will finally solve this issue once and for all...
  25. dpearcePNG

    dpearcePNG Network Guru Member

    My experience with the "beta" firmware

    Using a WRT54GS v1.1

    Did a hard reset, flashed to stock Linksys firmware, did a hard reset, flashed to unoffical beta FW, produced a brick. Did the 45 second reset and it came back.

    In my previous tests, on really large files, the best throughput I could get using ROBOCOPY was about 18 Mb/sec (megabit per second) to a Linux box. ("54 bps connection"). In looking at the network traffic, large files (10 MB+) work best to max out the link.

    With the new firmware the best speed I could get on known 'good' files (files that did not produce a hang) gave me the same speed as before.

    However, with the new firmware, instead of hanging on SMB transfers (like file copies), I now am getting a 3.6 Mb/sec transfer. Much slower, but no hangs.

    Well, it did hang once (nretwork name not found).

    So, better, but not fixed. Not enough to make me regret ordering a Netgear router.
  26. thirteenva

    thirteenva Network Guru Member

    I'm not really sure what to do here, the beta firmware did not solve my issue. I've had issues with newer netgear products so i don't want to buy another one.

    I'd really just like my issue fixed but linksys keeps telling me it's my MTU setting.
  27. oopsibrokeit

    oopsibrokeit Network Guru Member

    i think it's to do with the way that windows networking deals with file transfer.

    I can ftp, or http transfer a 300+ meg file across my long distance dlink wireless bridge, but my windows networking pc-pc transfers error after after between 10 and 150mb.

    my sister and my lodger on the other hand have absolutely no problems with transfer between their linux boxes and are swapping gigs of video files between each other (but then you can modify the transfer timeouts on both these OS')

    i can easilly believe that over a 500m link it is possible that the connection between the ends of bridge drops and re-negotiates every-so-often during the process of a sustained transfer and that if conditions aren't optimal (rains, mist, humid weather, trees swaying) the link is not re-negotiated before the windows box decides it doesn't want to wait any more and so it says that the place it was talking to isn't their anymore.

    it may not be exactly the same setup as we were originally looking at, but it might be food for thought for someone...
  28. thirteenva

    thirteenva Network Guru Member


    I have had two macs, one pc and a linux box cause the reboot. THE PROBLEM IS WITHIN THE ROUTER.
  29. oopsibrokeit

    oopsibrokeit Network Guru Member

    ok, then...

    i have a different problem with the same symptoms then...

    it was just a thought.
  30. m00n

    m00n Network Guru Member

    I hate this, i keep getting a bricked connection after a X minutes of downloading, and then i have to disable/enable my ethernetcard.

    Verry frustating. Maybe we have to send this forum thread link to the linksys support desk. Not 1 just everybody make the same mail just change your name. Maybe then they will respond/do something.
  31. jhugues

    jhugues Network Guru Member

    I own a WRT54GS V1.1 and I just tried the Beta software. It worked!.

    I have no more high thruput disconnect when using Microsoft Backup from a wired LAN to a Wireless NAS.

    It is very clear to me that Linksys is on its way to finding a solution to our problem.

    Thanks for who ever posted that Beta release.
  32. jcastill

    jcastill Network Guru Member

    Tried the new firmware on my WRT64G V3 and it half-worked I get less disconnects but still get some from time to time.

    I noticed that with this firmware the logo from Cisco lights up, and actually with that found that it is a button, anybody knows what does it makes?

    Also noticed that sometimes the navigation is slow with this firmware, sometimes the configuration page takes LONG time to load.

    Finally, my 1024/512 aDSL speed is great, but copying (G-only network but configured as mixed) from pc to pc goes in a crawling 30KBps (around 400kbps) which is really slow compared to the old firmware.
    So in other words I can leech faster from the internet (110KBps) than my own network (WiFi-WiFi 30KBps) which is definately not good, as both cards get 4 out of 5 stars.
  33. CyMi

    CyMi Network Guru Member

    I'm an electronics engineer and have worked years with network electronics and nowadays with cellular phones. I bought my WRT54G v2.2 few weeks ago and it has this same annoying problem. Today I had some time to make few tests with my unit at our electronics lab. Because I don't want to lose the warranty I didn't open the box and measure any signalling (I really wanted to). Anyway the results:

    1) continuous wireless transfer reboots the router
    2) high speed transfer through the internet port causes the router to be jammed for a while
    3) packet losses happen without any bigger activity on any port (gets worse when activity grows)

    The router didn't work well at any temperature, 32F/0C to 104F/40C. The router worked better cold, which explains why some units work well with additional cooling (different tolerances in faulty components).

    I think all users do not discover the internet port failure because of relatively slow internet connections. With my 10Mbps WAN at home it is impossible to use this router. I tested this port with 100Mbps WAN and the router jammed almost immediately and never reached over 20Mbps throughput. 100Mbps transfers between the switch ports works good, but causes packet losses on other ports (--> disconnections), which drives my wife insane.

    I tested with official 3.03.6 and with the new beta firmware. Didn't notice any difference (as well as when disabling the firewall or wireless).

    No much new info for you. I will return this piece of ****...

    added: Only who can analyse this and find the root cause is Linksys who has the low level HW/SW info. It seems to be some sort of design error or just bad quality of components.
  34. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Got the new beta and no dice. I tried to move a home movie and it crapped out in a couple of seconds. I even had to disable my pci card and re-enable it to get good signals. Time to switch from linksys. Too bad to I have been a devoted fan for a couple days now. Great first impression and great first impression of wireless in general. Are there other router/ pci combos that actually work together? I am being serious because I do not know.
  35. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    GUYS i have a very good news for you!!!!!!!
    gaogi just mailed me the latest Beta FW of WRT45G, i tried it and guess what :D not even one disconnection on serval files via wired/wireless on local server HTTP and netBios and i didn't have any problem
    i asked him to mail me the WRT45GS FW
    i hosted the Firmware on http://www.siemens-mobiles.org/linksys/
    filename : WRT54GV3.1_4.00.7_US_high.code.bin
    description : WRT45G 4.00.7 BETA Firmware

    Please WRT45G owners try this and tell me about the results
    thank you
  36. jcastill

    jcastill Network Guru Member

    Thanks Gandalf_SX1

    Downloading right now, will test as soon as I get home, hope this helps since I'm thinking in getting my BEF router back on until this gets fixed.
  37. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well i think problems from now on are gone,
    i don't have any problem since i upgraded to this one, i tried almost everything and so far so good
  38. jcastill

    jcastill Network Guru Member

    As soon as it gets more stable it's good, else I don't want continuous disconnect or sometimes disconnect with very slow speed between my network.
  39. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well for me it's stable, and fast, i was able to downlaod at 7Mb/s from my local server on wired connection and up to 2mb on the wireless connection, so it's fast/stable and not even one disconnection for me, i hope you get the same results guys
  40. tedbiv

    tedbiv Guest

    yahoo... just tried the new beta firmware :)

    just uploaded the new 4.00.7 firmware to my ver 3.0 hardware wrt54g and my large file upload troubles are gone. so far. My version 2.0 has never given me a problem, but the previous 2.2 had upload from wireless to wired issues. I just uploaded a 700MB movies twice with no dropped wireless connections. Hope it continues. Thanks to this forum for it's help. I hope to be able to contribute instead of being a parasite :)

  41. bbloemen

    bbloemen Network Guru Member

    Hmm I planned to go to the store tomorrow to exchange my wrt54g for a d-link... I'm gonna wait a few moments now to hear some results of you guys. My router died of the previous betaversion (4.00.5) but now it's a (4.00.7)?
    where are these beta's comming from actually?
    Is there a linksys insider here somewhere?
    anyone knows in what this version differs from the previous one?

  42. jcastill

    jcastill Network Guru Member

    Re: yahoo... just tried the new beta firmware :)

    Hope to be able to say the same history tonight... and Congrats!!!
  43. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well gaogi (the guy who mail me with FWs) is a developper in linksys company , i'm a volontire to test those FWs and also to host them so people here can also test them as well :D
    if it will be postitive to everyone here, it will be soon release as a final/official release so we expect also to see unofficial Firmwares based on it
  44. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Gandalf have you gotten the new wrt54gs one yet? I recieved a beta from linksys yesterday WRT54GSv2 Beta Firmware 4.50.5 and it didn't work. They emailed it to me, let me know what he gives you, god I hope they email you one that fixes it!
  45. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well he actually replied that they concetrayed on doing the WRT45G since not everyone has this problem on GS, but they will do it soon (they are testing right now)
  46. gaogi

    gaogi Network Guru Member

    Jaqz, is there a file that will consistently cause a crash? If there is, please send it to me. PM me for a email address. Thanks.
  47. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Is there somewhere that I can see what settings I should have in the firm ware options? I have the same version as the one you have for the gs, so I figure that one is old? It's great to hear that they fixed the other one though (fingers crossed), now maybe I can get some help!
  48. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Just a home movie from my dig camcorder, thats the only thing I have tried. It failed almost at startup, by fail i mean to say it went down to 1Mbps and then I stopped it after around 2 minutes with minimal transfer being completed. Should I try other stuff? I tried the movie 2 times. It was around 2Gb in size.
  49. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    no no need to try another thing, if it fails on 1 file then it will on others, i hope he get also the GS version working ASAP
  50. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Ok it's "trying" to go through now. I restarted it and it'll drop from 54 to 1 and stay at 1 for a couple seconds (15-30) and then back up to 54, but as of right now the sent vs received packets is pretty bad 361,000 sent 210,000 received, but it's still going as of right now.
  51. kkapoor

    kkapoor Network Guru Member

    Oh, thank the lord!!

    I updated my WRT54G V2 to the latest firmware, setup WPA-PSK (AES) and transferred 2 files.

    1. 264MB
    2. 465MB

    Both transferred without a hitch. This firmware is a hell of a lot better but not bug free as yet. The main problem is the inconsistent transfer speed. It's up and down constantly but it does not drop the connection. I can also browse the files on my wireless machine through my wired deskop (through 'My Network Places) without it crashing.

    So far, so good. I'll keep you guys updated.

  52. Hernexto

    Hernexto Network Guru Member

    Seems to work !


    i uploaded the latest firmware beta, it has copied about 2 GB all ok.
    i will do some scripts to have it all night (i'm spanish) copying files.

    WRT54G EUropean hw v2.2 sw v4.00.7 US (old=EUropean 3.1.3)

    transfers at 2.30 Mbyte (pci conceptronics C54RI with the software of Ralink) connection at 54 mbit

    no reboots, no hangs... no nothing bad :)

    Also i must test if fast transfers/big number of connections by internet hangs the router...

    upload firmware and hard reset.

    6 hours and you will have more info...

  53. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    glad to hear that, thx for testing...
  54. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    Ok, the test I just did was transfering 4.3 G of home videos, it went good. Sent vs received was 3280000 sent 1700000 received. Does that matter? The file went through though! Speeds did tend to jump up and down, but overall it was stable enough and NO DROPS! Great job guys, I can live with the speed up and down all day long! Now does the sent vs rcvd mean anything though? I will now try and burn my home videos again to see if it reproduces them. GREAT JOB GUYS! Oh and this is with the beta fw for the gs!
  55. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    hmmmmmM.. i don't know why you have a difference between send and receive speed maybe it depends on the network you use, anyway glad to hear that too
  56. Nimdae

    Nimdae Network Guru Member

    Tried beta firmware. Still having problems. Linux update is still freezing when attempting to download information. I also had a ssh session die. The new firmware does NOT fix the problem.

    Note: The first time I attempted to post this failed thanks to this problem.

    Attempt #5 (this is to prove a point)
  57. gaogi

    gaogi Network Guru Member


    Did you use firmware 4.00.5 or 4.00.7?
  58. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    2nd transfer of 4 Gb is going strong. First one took about 30 minutes, I am going to time the next one. Gandalf, could the almost exactly 1/2 "loss" have to do with the speed booster tech? Isn't that what it does to "boost the speed". Just a thought, but the reproduction of the file was exact.
  59. JohnSK

    JohnSK Network Guru Member

    gaogi, what exactly is causing the dropouts? How is it possible that some WRT54G 2.2's have problems and others don't? Could you please give us more insight into this problem?
  60. thirteenva

    thirteenva Network Guru Member

    I just uploaded the new 4.00.7 firmware and did a 30 second reset.

    I'm now downloading all 4 redhat cd iso's. So far so good. Each of the 4 files is about 100mb into the download with each file moving at 279kb/s pretty much maxing out my 10mbs cable modem.

    No issues yet and I'm still able to post while downloading. If this works I'll turn encryption back on and try it again. (currently using factory default settings for testing, didn't even change the ssid).
  61. gaogi

    gaogi Network Guru Member

    The issue is basically a memory mapping issue. It doesn't really have to do with specific router, but specific files you're transferring. Files with certain bit patterns can trigger the issue, which is why some people can transfer gigs of file with no problem, while others can't transfer a 500k file.
  62. pauls

    pauls Network Guru Member

    I rec'd the 4.00.5 firmware from Linksys in an email. Worked better with the WPC54G in one thinkpad. 2nd thinkpad has built in Atheros wireless - failed almost instantly when copying a large file.

    Downloaded 4.00.7 from link posted here. Works much better -- able to xfer 455 MB mpg file without interruption. An observation on throughput is to be noted. Single is 85 - 90%, 54Mbps with no activity or just surfing. When copying a file speed drops to 18-24Mbps just after the copy begins. As soon as the copy is complete speed returns to 54Mbps. Looks as if throughput is being throttled down by lowering the baud rate (?).

    Will try to force speeds to 54 Mbps for a test (tomorrow).
  63. thirteenva

    thirteenva Network Guru Member

    I haven't tried it with the 4.00.7 firmware but i was able to reproduce the issue after a few minutes whenever i used limewire P2P to download music and movies.
  64. JohnSK

    JohnSK Network Guru Member

    Thanx for clearing that up :) The only thing missing is the source code and a new build of DD-WRT. Thank you very much Gaogi for helping us all! :D
  65. Nimdae

    Nimdae Network Guru Member

    Firmware Version : v4.00.7

    That's a copy and paste from web admin. I've noticed an extremely large amount of packetloss, higher than 20%. Yes, 20% is a small number, but try playing games on 20% packetloss. Try performing network file tasks on 20% packetloss. Try browsing the web at 20% packetloss.

    Edit: Adding bit about reproducing my problem

    My linux machine is the most reliable way of reproducing this problem right now. I get packetloss on my windows machien (this one), and obviously had trouble posting one of my updates since the 4.00.7 FW update.

    Cable -> Modem -> WRT -> WAP -> Switch -> Linux machine

    Attempting a gentoo emerge --sync, I have yet to complete a file list update. Just received this error:

    receiving file list ...
    io timeout after 180 seconds - exiting
    rsync error: timeout in data send/receive (code 30) at io.c(109)

    Packetloss is reproducable with any ping test. My network is having a hard time with domain resolution. I'm seeing significantly reduce network performance on my windows machine, though I've yet to see outright failures yet. Games are unplayable. I'm having to cancel online events until I get this resolved.
  66. rockshox

    rockshox Network Guru Member

    I downloaded WRT54GV3[1].1_4.00.7_US_high.code.bin to test on my WRT54G v2.2. I had been lurking around the forums for weeks and talking to Linksys about these problems and tried every work around someone suggested. I put the new beta firmware on powered up my Apple Powerbook 15inch with the built in Airport Extreme 802.11g card. I started up a 10.13gb transfer (a collection of about 15 files making up the 10gigs and all files I had been using to test earlier test runs). I sucessfully transferred all 10.13gb from my Windows XP SP2 wired machine to my Apple Powerbook. I did notice one thing, once I got to 6gigs my wireless signal dropped to around 35-50% which is not normal for where my Powerbook sits, it usually is at around 85% signal. I noticed the drop in signal and took my Powerbook into the next room so it could be near the WRT54G. The signal then increased to about 60% but would fluctuate between 50-60%. As soon as the 10.13gb transfer finished, the signal immediately increased to almost 100% signal. I could not find any reason for the drop in signal, however I never lost connection and the 10.13gb transfer finished sucessfully. Thanks for the hard work Gaogi and the beta firmware...
  67. Nimdae

    Nimdae Network Guru Member

    Since I seem to be the only one having trouble with the latest beta firmware, I'm doing some additional testing and analyzing. I've come to find port forwarding isn't working, but this is probably something I'm doing wrong. I can't get the router to accept incoming connections from the internet at all so I'm looking for misconfigurations somewhere.


    I've discovered some odd behavior within my network which I will investigate further tomorrow. Basically, there appears to be a problem with the router communicating directly with my linux machine. I've not seen any of these problems with my previous router. So far, this appears to only affect port forwarding as I still experience poor network performance on my windows machine (packetloss, etc).

    I'm gonna compare notes with a friend tomorrow.
  68. Pacif13r

    Pacif13r Network Guru Member

    And I have a 600 byte file which I created based on the initial work of drpearcePNG which resets me everytime...

    I asked Linksys for an update on my case and brought this file to their attention 5 days ago. lol have not heard back... I guess that fits in with their behaviour on this issue to date.
  69. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    for what i've seen here till now, i guess the Beta FWs are almost working for everyone,
    i will try to see if my wireless signal will drop down,
    @Nimdae i think you are the only experiecing this, i have a linux laptop too, running ubuntu hoary (best distro) anyway i ran ping for 6 hours, and i didn't even had one packet loss, i received 100% so i guess you have a problem with your network settings, as a begining try to reset your router to the factory settings, link WRT directly with 2 PCs transfer from one to another, if everything goes right, then you might take a look to your configs pal...
  70. CyMi

    CyMi Network Guru Member

    The new FW seems to work with my v2.2 as well. Only 0,5% packet loss so far. I can manage with slight drop in wireless speeds and won't return this unit yet. Let's see if there are any connection drops in longer period.
    Good job Linksys making some progress. My trust is still gone because I have lost hours and hours valuable time fighting with this problem.
  71. Partizan

    Partizan Network Guru Member

    Hmm, will try the firmware later today, but I don't have any hopes, because didn't do much for my v2.2 wrt54g. I don't have thetime right now, have to go to my girlfriends. :)

    Will post the results later.

    Greetz, Partizan
  72. enigmaxp

    enigmaxp Network Guru Member

    Tried dumping onto my WRT54v3 the 4.00.7 firmware. All I have to say is that it works great. The 2GB of data that I transferred would always crash the router, but its no longer doing it. No more disconnects and no more "network no longer available" messages. Hopefully, my router will hold out.

    With respect to the lower speeds some users are getting, I noticed that during my transfer, my speed would drop down to 48Mbps and then switch back and forth between the two but go no lower.

    I'm using the WPA2-PSK Mixed Mode if anyone cares to know, althought I don't think it makes a difference in my speed.
  73. bbloemen

    bbloemen Network Guru Member

    could you post that 600byte file somehow?
    I don't know if that file is a crasher for every router... maybe each router needs a different bit pattern to crash, but i would like to try it.. if possible.

  74. Hernexto

    Hernexto Network Guru Member

    50 GB transferred ok !

    50 GB at 2.3 Mbyte/sec with file sharing
    no one drop ! (with sw v 3 i have drops every 20 secs while high throughput)

    transferring some files at the same time in the same direction works good too

    transferring at the same time in two direction works also very good

    in 15 minutes, only small slowdowns, its very stable.

    no drops in the internet interface, but i must wait 2-3 days to be sure.

    wow now it rocks, i will not RMA today as i'm thinking before
  75. m00n

    m00n Network Guru Member

    Cymi, is it possible for you to test the router with this firmware. Wireless i didn't test, but i also got a 10mbit internet connection and i'm always downloading, but it keeps disconnecting me where i have to disable/enable my nic to get my internet working again.
    Anyone having this problem?

    I will try the firmware later tonight, but the 4.005 one bricked my router... so i'll be gentle this time.
  76. bbloemen

    bbloemen Network Guru Member

    Hi All,
    I just got my router back up and running thnx to ericchang591 many posts ago.
    I've just uploaded the 4.00.7 firmware. Hell I'm curious how it will turn out.
    I'll get back here in a few hours, after work to report.
  77. Protozoon

    Protozoon Network Guru Member

    ...finally?! veery close.

    I'm getting happier and happier every GB...

    After a month of reading forums and agonizing waiting and wondering whether to send wrg54g-eu v2.2 back, this morning has started very, very promising.

    Flashed to 4.00.7 from Alchemy and results:

    Able to transfer wireless-wired vice versa at a transfer rate around 2.7MB/s. No hickups or drops. Tested also two 1GB file simultaneously going both directions.

    Link speed stays stable at 54Mbs and the utilization very firmly at 42-47% (2,7-3.1MB/s) which is the normal percentage without boosts, I think.

    No special advanced settings on router.
    DHCP disabled
    Encryption WEP 128bit
    Channel 6 works best for me at this location.

    (Zyxel prestige 600 series adsl-modem->)WRT54G-EU-> Desktop winxpsp2, Linux mandrake 10.1 (both wired) and wireless laptop.

    Next off to test with heavy traffic from/to wan simultaneously with wired and wireless lan. And waiting for this code to be icluded in the Alchemy or HyperWRT
  78. Pacif13r

    Pacif13r Network Guru Member

    I've put it on https://maiken.homelinux.org/~adminjb/
    (there is only one zip file there).In it : Files 1,2,3 are from dpearcePNG who did most of the hard work. I just shaved off data till I got File0 which has reset my router 8/8 times. In fact I had to zip it with Best compression just to be able to move the damn thing to my server downstairs without a reset... :evil:

    For him (dpearcePNG) it went really slow, whereas mine reboots completely. I have tested if both via SMB and FTP.
  79. bbloemen

    bbloemen Network Guru Member

    OK tried the 4.00.7 for a few moment, and i already have some remarks:

    1. leds are not moving anymore, although router seems to do its job
    they remain 'on' all the time...

    2. sighnal strenght went down. I'm only 1 meter away from the access point. Placing my hand over the wireless pcmcia will drop my wireless connection....

    I've got fluctuating ping times from 2ms to 90ms. Only 1 meter away from AP. This used to be <1ms, full signal strenght.

    This isn't a solution for me :s

    (thnx Pacif13r, 'll try it in a minute)

  80. bbloemen

    bbloemen Network Guru Member

    ok, you ain't gonna believe this, but I got connected to my neighbours (unprotected) WLAN by accident. Of course a very weak signal, and of course my router's leds arn't giving any sign of life.

    sorry guys :)
    what a mistake to make
  81. m00n

    m00n Network Guru Member

    Whahahah nice :). Shit happens, hopefully you got some good results with it.
  82. sxwlinksys

    sxwlinksys Network Guru Member

    I didn't try the 4.00.7 yet. I returned my router to the store (Funprice, The Netherlands), saying that it was crashing on high speeds. They gave me another one instantly, good service. They say they haven't had any people returning their routers yet, although they sell 100's.

    So far the unimportant stuff. The important stuff: This v2.2 works out of the box. I've transfered... let's see.... 3.5 GB of data over FTP on 2,5 MB/s now.... No drops.... Me happy for now.

    I wish all of you a lot of success with your routers.
  83. m00n

    m00n Network Guru Member

    I too live in the Netherlands. Bought the router 3 weeks ago by 4Launch.

    Mailed them if they knew something of the problems with the LinkSys WRT54G routers. One of them told me he had the same router @ home and @ work and the sameproblems. They replaced the routers @ work with d-link i think...

    I don't know if i should return the router, or wait and see the progress of LinkSys beta firmwares.
  84. jshadez

    jshadez Network Guru Member

    Well this new beta firmware is a lot more promising than all the others I've tried. I've definitely been able to copy a lot more BUT I have already encountered my first disconnection after several minutes. Transferred around 1.5Gb before it disconnected though.

    I will keep trying and keep you guys updated.

    Linksys WRT54G v2.2 AU (Firmware Version : v4.00.7)
    Wirelss router reboots when transferring large files from Wired PC to Wireless PC
  85. sxwlinksys

    sxwlinksys Network Guru Member

    Up to 7 GB now. I declare this router for problem-free.

    I hope (-:
  86. Protozoon

    Protozoon Network Guru Member

    Hehe. I'd like get connected to my neighbours daughter, preferably in a protected manner:) ok enough jokes.

    Did more tests and simultaneously transferred appx 10GB of different kind of data between wired, wireless v.v. and internet. Worked very fine at full speed. But I'll still keep fingers crossed for a while...
  87. m00n

    m00n Network Guru Member

    Gna gna humor :). I'll test it when i'm home.!

    Someone who can test it with it's internet connection 10mbit or faster? That was my problem.
  88. jshadez

    jshadez Network Guru Member

    So far so good, been copying 7.5Gb for the past hour now. Average speed is 2.5MB/s - 3MB/s. Also tried copying 2GB file on another wireless PC to another wired PC at the same time and no problems whatsoever. I am very happy so far. No errors and no disconnections yet.

    Linksys WRT54G v2.2 AU (Testing with Firmware Version : v4.00.7)
    Original Problem: Wireless router reboots when transferring large files from Wired PC to Wireless PC
  89. Ainars

    Ainars Guest

    Upgraded my WRT54g v2.2to FW 4.00.7, seems stable now, but i cant see router uptime from there. so tried to upgrade to latest alchemy version, but nothing. tried 4 times and evry time "upgrade failed".
    Someone have tried to put latest sveasoft alchemy on wrt54g from FW4.00.7?
  90. CyMi

    CyMi Network Guru Member

    m00n, with the new FW my router works perfectly in full 10mbit internet load (so far). Just try this new one, it worked for me :)
  91. m00n

    m00n Network Guru Member

    Oke thx man, i will try it when i'm back from work :) Can't wait!
  92. devil-strike

    devil-strike Network Guru Member

    i have also the WRT54G v2.2,
    new out of the box without 1 single problem no drops nothing

    also the netherlands (buy @ computerland)
  93. kickerspot

    kickerspot Network Guru Member

    I own a WRT54G V2.2, and i'm happy! :) No disconnects with the 4.00.7 (tried 1 GB file transfer, watching video, using VNC).
    While transferring 1GB i got some ping timeouts, but that is ok for me since the connection did not drop.
  94. zhuwei1231

    zhuwei1231 Guest

    Has anyone noticed the WEP problem with the beta version?

    Once enabled, cannot access internet anymore.
    Will test again tonight.
  95. Nimdae

    Nimdae Network Guru Member

    I'm big enough to apologize for previous harsh responses, so, uh, yeah, sorry about that. While I did have the previous problem, I appear to have a NEW problem with this new firmware that didn't exist before. If I can't figure it out, I'm going to create a new thread since this problem seems to be resolved for the most part.

    I'm not gonna post about the problem in detail (yet) so if you want the details, go ahead and ask. I'm not sure if it's even a problem with my router, but I suspect the problem is causing the symptoms I'm having accross my network.
  96. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    i have a 20Mb connection i tried it and download 1gb on 1.6Mb (maximum of my connection) no prblem
    also i tried from my local server so at 100Mb and i donwloaded at 7500MB/s without a problem <<---- i was wired to linksys of course at this speed
  97. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    can you give details please, becaus eif the problem would be related to the FW, it would be solved also before the final release
  98. Nimdae

    Nimdae Network Guru Member

    Well, here's a crude map of my network:

    {Internet} -- Modem -- WRT54G -- Windows computer
    Windows Computer -- 5 PORT SWITCH -- Linux Computer
    Everything wired to the 5 port switch work in perfect harmony with each other. The WAP54G is in client mode connected to the WRT54G. The linux computer can ping out, but anything that has to go through the WRT54G cannot reach the linux computer. The windows computer on the 5 port switch has in and out connectivity and port forwarding works fine on it (I can remote desktop to it from work). I've been watching traffic on the linux machine and the packets just don't reach it, so that rules out the possibility of a firewall despite knowing it's turned off anyway.

    I suspect there is some kind of conflict causing this. I'm not sure what kind until I can dive in further, but it does feel like things on the 5 port switch are competing when it comes to communication with the WRT54G. I can't do much right now in testing since I'm at work, but when I get home I have some tests I want to try.

    Previously, before the above map, the network was a lot more stable (until the failing uplink cable). Just change the WRT54G to a microsoft router (yeah, ew) with a direct link to the uplink port on the 5 port switch.
  99. bbloemen

    bbloemen Network Guru Member

    Router seems to work just fine now for me, running 4.00.7.
    havn't copied large files yet, but the crash-files posted earlier are copied without any problems.
    I'm sure I would already have had a crash by now if I were running the old firmware.

    I'm not aware (yet) of any other problems.
    I hope this won't change :)

  100. tzare

    tzare Network Guru Member

    hello, i'm new here and just purchased a WRT54GS v1.1 and had some wireless disconnections, i use now HyperWRT's firmware and seems to work fine...but haven't tested much the router yet. In case i need to, can i use the FW4.00.7 with my unit or only with WRT54G?
    Thanks for the help
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice