WRT54GS -> High Throughput causes disconnect

Discussion in 'Cisco/Linksys Wireless Routers' started by zephyr325, Feb 7, 2005.

  1. sxwlinksys

    sxwlinksys Network Guru Member

    Well... I just had the weirdest thing....

    I had tested today all day at the office... No disconnection problems whatsoever, also not after 15 GB of full load over the wlan.

    Then I came home, hooked the thing up, booted my laptop, connection came up.... I started transferring at high speed to test some. And the router crashed! After which it came up again, and I have been transferring 4 GB without any problems since.... It's still working fine.

    I don't really get it.... Does it have anything to do with ether activity? At the office there are all sorts of wireless networks in the air. At home the ether is crystal clear...

    I didn't load up the Beta firmware yet by the way. I figured I'd put that off until the FW would go gold... I'll see what happens... I'll check into this thread from time to time....
  2. pharma

    pharma Network Guru Member

    Yes, you can use it. I also have a WRT54G v 1.1 and have loaded the latest WRT54G beta firmware version WRT54GV3.1_4.00.7_US_high.code.bin. Extremely stable & fast -- works fine.

    CORRECTION: You have a GS so would be best to wait for your specific firmware. WRT54G & WRT54GS are not compatible with regard to firmware.
  3. Pacif13r

    Pacif13r Network Guru Member

    As some of us have suspected and gaogi has confirmed it's byte or bit sequences that are the trigger. He has also informed us that memory mapping is the problem. I assume that this would be highly dependent on load and what was in buffer at the time.
  4. Partizan

    Partizan Network Guru Member

    Well just installed the on my v2.2 two and a half hour ago. Torrents loading via lan without problem. Will test wireless in the morning.

    Keeping the fingers crossed.

    Regards, Partizan
  5. Hernexto

    Hernexto Network Guru Member

    120 GB transferred OK


    I previously transferred 50 GB... well i have stoped it the test in 120 GB, i think no drop.

    Emule is running at full speed, huge number of connections and all is ok (this is another problem of the router without using WLAN, only by inet inteface)

    in the weekend i will test more, with more devices ...

    PD: I used only Win2k on these tests.
  6. Partizan

    Partizan Network Guru Member

    And I already got my RMA number, I think I am gonna cancel the RMA process :)

    Regards, Partizan
  7. Toxic

    Toxic Administrator Staff Member

    he has a GS model not a G, so no it is not compatable.
  8. Nimdae

    Nimdae Network Guru Member

    I hate to stray from the original topic, but since it's shifted to the latest beta firmware anyway...here's some news on my progress.

    I did something very minimalistic, I changed the switch port the WAP was plugged into and for about a minute, the router was able to reach my linux machine. After a moment, I lost it again.

    My linux machine is headless (it acts as a network server for various services, soon to expand) so my access to it is almost strictly over the network. Is it possible that my wireless uplink is only allowing one machine to connect through it at a time behind the switch? Since I'm primarily on my windows machine doing web browsing, gaming, etc, is it possible it's take precedence over my linux machine when attempting tests on it from my windows machine?
  9. gaogi

    gaogi Network Guru Member

    The the firmware 4.00.7-high version will not be the official release. The reason being that this is a highly overclocked version of the old firmware (overclocking the CPU increases the memory clock rate as well, which solves the issue with high load transfers). There is another version of the firmware that I have also sent Gandalf, which is also overclocked, but not as much. There shouldn't be any problems running the -high beta, but it might be safer to run the less overclocked version in the long run.
  10. gaogi

    gaogi Network Guru Member

    Pacif13er and Ryfer:

    I tested the files you guys sent, and was able to transfer them back and forth between the LAN and wireless. I also downloaded the file from your Internet locations while connected to the WRT54GS v.2. This was done running the 4.50.5 firmware....
  11. Partizan

    Partizan Network Guru Member

    Hopefully this overclocked firmware wont void my warranty. And I hope the official release will be stable too.

    Regards, Partizan

    P.S. Gaogi thank You for supporting us :)
  12. Protozoon

    Protozoon Network Guru Member

    overclocked. hmm..
  13. Nimdae

    Nimdae Network Guru Member

    Well, I have to say I've learned more than I ever wanted to know about wireless networking the past few days. It turns out my problem was with my WAP and not the WRT. Really, the WAP wasn't at fault, it was me. If you saw my crude network map, you'll notice that the wireles portion acts as my uplink between the rooms.

    The problem was the fact I set the WAP in client mode. Since it was connecting to the router as a client, that was the mac address and IP it was receiving for that connection. Going into basic switching and routing, you'll know that an IP is mapped to a mac address. The router was finding that the IP of my linux box belonged to the mac of the linux box, but since the mac wasn't directly connected to the router, it didn't know where to find it. Since my windows machine was the primary source of traffic, it was mapping that mac address to the wireless client.

    I changed the WAP to bridged mode. I basically copied the MAC of the router from the client field, selected bridged mode, dropped the mac into one of the available fields, and saved it. If you know anything about bridging connections, you'll then notice that the switch is then what is considered to be directly connected to the router instead of the WAP. With the switch being directly connected, anything behind it then becomes accessible as the router will then refer to the switch, which finds which port the mac address in question goes to.

    I didn't see any documentation immediately available on the different AP modes so that part was mostly done through guessing. Now I know how all of that works.

    SO FAR everything appears to be working happily. I'm tired of messing with it so I'm gonna hold off on updating the firmware (since I just reset my entire network, I don't feel like reconfiguring my router yet again).

    Edit: Quick note, I did experience the problems originally mentioned in this thread prior to the beta firmware update (router disconnect/reboot, etc), so my posting wasn't all in vain.
  14. jshadez

    jshadez Network Guru Member

    Gaogi... does this mean we are shortening the life of our router by running it at the overclocked speed over the long run? Will the official release solve the problem without overclocking the CPU?
  15. m00n

    m00n Network Guru Member

    This new firmware didn;t solve my problem, my connection tot the router bricked again.....

    Fucking hell.... what can it be that my connection bricks and have to disable/enable my ethernet card to get it workiong again...

    And next to that i can;t download @ full speed. Normally i could reach 1240 kb/s, now it can't go faster then 1150.... (That was the reason i switched to the WRT54G from BEFW11S4)
  16. tzare

    tzare Network Guru Member

    Thanks for the help :)

    So which firmware would you recomend to use with WRT54gs to avoid trouble ? Is HyperWRT ok? I'm a bit lost with so many FW and Hardware versions
    Thanks again for your help :)
  17. sxwlinksys

    sxwlinksys Network Guru Member

    ok, I'm willing to believe that, but there is still a problem with this theory: My last router dropped every connection after 10 secondes of high load. The one I have now only did it once in total until now, after now a total of 20 GB or something transfer. Including the same files I tested the last router with....
  18. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    no it won't be that easy, it overclock the CPU to solve the problem, gaogi in his mail has explain to me that it's by overclocking the CPU will also solve the memory mapping problem so i just uploaded back the low one (low one is 216 MHZ, high one is 240 MHZ, normal was 200MHZ as he mentioned also in the mail)
    so, now on my site you will find also

    location : http://www.siemens-mobiles.org/linksys/
    file name :WRT54GV3.1_4.00.7_US_code.bin
    description: WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]

    which is the low rate of overclocking, i'm going with it i already test it, works fine with high transfer over lan, Wlan i hope you try it too because this one will be the official one not the high one
  19. xb0xb0y

    xb0xb0y Network Guru Member

    welp, the new 7-highcode beta firmware seems to do the trick, both for a v3.0, which i'm keeping, and a v2.2, which is going back tomorrow after i run some more tests tonight. i'll try the new "less clocked" beta. don't want to FUBAR the WRT54G now that it's working! :p

    didn't have any problems with LAN connections, only WAN. transfers would reboot the router big time. but it never corrupted my LAN, only the machines connected by WAN. lost complete access to them until i reset the WAN connection on the affected machines.

    anyone know what the lit orange cisco button does on the v3.0? when i press it, it flashes white and completely messes up the router. no network connection works when it's flashing, and i don't know how to stop it, aside from pulling the plug on the router. guess i'll avoid playing with it for now till i know what's up with it! :)

    thank goodness for this forum. especially this thread. been a life saver. really thought i wasted my money on a WRT54G, which i was starting to think was a POS!!!
  20. dpearcePNG

    dpearcePNG Network Guru Member

    Any rev of WRT54GS FW coming?

    Any word on whether we'll be seeing another rev of the WRT54GS firmware? The 4.50.5 FW mostly works for me. Throughput really is aweful on "bad" files though.

  21. RyFeR

    RyFeR Network Guru Member

    Re: Any rev of WRT54GS FW coming?

    I second that ;-)

    Would love to test with a new beta 4.50.7 in my WRT54GSv1.1 to see if this solves my probs as the 4.00.7 did for the WRT54G users...
  22. m00n

    m00n Network Guru Member

    Re: Any rev of WRT54GS FW coming?

    Not all users, i still have some problems, if it's the router or the cable i don't know yet, going to test it @ home.
  23. kantjer

    kantjer Network Guru Member

    Cosmetic Problem

    I just installed the 4.50.5 beta firmware on my WRT54GS v1.1 and copied all the bad files I could find between my WL Laptop and a Shared Network Drive and all is going well. I noticed performance decrease on known bad files (my WRT is partially sensitive for copying MS Word documents) but it is a huge improvement.

    I only notched a cosmetic problem on the interface using Opera all the dropdown label are crippled e.g.

    On the Basic Setup Page:

    In Opera it says: “Capture(setupcontent.dhcp)”
    In IE 6 it says: “Automatic Configuration – DHCP”

    This is just an example in opera a unreadable CaptureXXX message is shown in all drop down labels, making setting up the router in Opera a bit more problematic.

    Anybody else seeing this?
  24. m00n

    m00n Network Guru Member

    If it doesn't work maybe i'm going for the following setup

    Cable modem -> Linksys Cable Router -> Linksys Accespoint -> wireless

    And from the Linksys cable router a wired connection to my pc....

    (it's possible then to go from the wired pc to the cable router throu the accespoint to the wireless pc's and back?)

    Or the easy way and go for the Linksys SRX version...
  25. hfam95

    hfam95 Network Guru Member

    Good job guys with the wrt54g beta FW. I do have a question. For those of us that used alchemy as a wireless bridge how do we get that function back if we go to linksys's FW

    my situation:

    3 WRT54G (a,b,c) acting as bridges with alchemy v1.0 final

    A is hooked to a wired router (which is hooked to my cable modem). it is also set up in wds mode to B and C
    b is set up in wds mode to router A. B has an Xbox connected to it.
    c is set up in wds mode to router A. C has a network printer connected to it.

    I have 3 wireless PC's throughout the house that connect to any AP for internet access.

    with the linksys FW I cant do wireless bridge (unless someone can tell me how)

    If I go with the linksys FW then I lose bridge. If i go with alchemy then I have disconnects.

    Can you guys help us in this situation?
  26. g412b

    g412b Network Guru Member

    Installed WRT54GV3.1_4.00.7_US_code.bin half an hour ago and have been trying to make it reboot, but it doesnt :)

    Cant wait for alternative firmwares based on this version
    maybe it would be possible to give the changed file(s) that fixes this problem (the driver ? dunno) so the developers of the alternative firmwares can quickly compile a new version as i can understand you are not wanting to release the full source code just yet
  27. m00n

    m00n Network Guru Member

    I'm back from work and guess.... the connection bricked again.... other ethernet port @ router, same problem.

    Did a hard reset and changed MTU (didn't matter 1472 was best size, +28 = 1500 = standaard).

    I'm going to change the cable now, and i will see.... I'll let you guys posted!
  28. Xenomorph

    Xenomorph Network Guru Member

    i just got my WRT54GS v2.0 router from Best Buy.

    i have the 4.05.05 firmware loaded (although the firmware says its 4.50.05).

    so its "fixing" the router by OVERCLOCKING it?

    is it possible the "official" 4.x firmware could fix issues without overclocking the router?
  29. RyFeR

    RyFeR Network Guru Member

    Sorry to hear that.. please let us know if it's something external (as in: not the router) that is the culprit, otherwise there still might be probs with the latest beta firmware... In that case gaogi wants to know i guess.

    Good luck!
  30. focuser

    focuser Guest

    Firmware Worked

    I know absolutely nothing about routers, but have been following this thread due to experiencing the same problems, not being able to transfer large files from my desktop to my laptop. I have the WRT54G 2.2, and was going to just return it for a refund, after talking to a CSR last night, whom I could barely understand, and didn't have a clue.
    As a last ditch attempt, I loaded the WRT54GV3.1_4.00.7_US_code.bin firmware, and it worked like a charm. I just transferred a 2.7 gig file, without a hitch, all else seems to be working fine.
  31. m00n

    m00n Network Guru Member

    Did a hard reset, changed cable, changed mtu size. Router bricked again....

    Linksys told me the following:

    Dear Marc Delemarre,

    Thank you for contacting Linksys Technical Support.

    Accept our apologies for the inconvenience this has caused you. There should be no such problem with the router unless there is a problem with the router itself. You've already done all the possible solutions for this kind of problem which should have solved it already. It could really be the device already that is having a problem.

    Hope this helps.

    So...... what now?

    Anyone using Newsleecher to download stuff? any experience with connection hanging after a couple of gig?
  32. RyFeR

    RyFeR Network Guru Member

    I'm using NewsLeecher (1.0 final) and never have a bricked connection... Use to have some drops with the normal firmwares, but the latest beta for thr WRT54GS (4.50.5) does it's job ok while downloading (only the file-copy prob left)...
  33. m00n

    m00n Network Guru Member

    Youre connected wireless or wired to the router? In my case it's wired, i tried everuthing, other ethernet card/cable, lanport on router, firmwarews, mtu size...
  34. enx23

    enx23 Network Guru Member

    WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]

    I tested "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]" with my WRT54G v2.2 and it works fine for LAN and WLAN transfers!!! I had no problems or disconnects with it yet.
  35. m00n

    m00n Network Guru Member

    THe WRT54G v2.0 doesn't have this wireless problem ect?
  36. jshadez

    jshadez Network Guru Member

    Been testing with the LOW CLOCK speed beta for the entire day and no drop outs or disconnects.
  37. MarkFour

    MarkFour Network Guru Member

    I have a WRT54G V2.2 that had all the usual problems, but now works perfectly with the "WRT54GV3.1_4.00.7_US_code.bin" firmware. Thanks to all involved.
  38. m00n

    m00n Network Guru Member

    Am i really the only one with the connection hangs/bricks form a wired pc to the router?
  39. Outback2k1

    Outback2k1 Network Guru Member

    Nope! My desktop is wired and I get the same thing.
    Router could run for days on end if I didn't use bittorrent but as soon as I do, it's all downhill from there.

    Your problem sounds abit different, though. Mine would reboot and resume operation, it doesn't just freeze up and sit there.
  40. m00n

    m00n Network Guru Member

    Could someone tell me what's the result with a WRT54G 2.0. Does that router have any problems or not? I found a store who sells them so... If i'm sure that the 2.0 doesn't have any problems i'm going to buy that one.

    So pls someone?
  41. DocSavage

    DocSavage Guest

    Unfortunatly I have a need to use WDS and cant use the stock linksys rom

    I have an environment that I can succesfully compile the new alchemy release in. Can anybody point me to the area of the code where I can tweak the clock settings to see if this will fix the problem in alchemy. I will be tickled to post my results.

    Right now I am just ratting around in the code - not the most effcient way to find the offending part.
  42. kkapoor

    kkapoor Network Guru Member

    Yes I have the V2.0 of the WRT54G and I had the wireless disconnect issue. However, the issue only occured on the latest official Linksys Firmware 3.03.6.

    When I updated to the beta release all is well and the router is a lot quicker than before.
  43. emtbrad

    emtbrad Network Guru Member

    I figured out the problem, the CPU cannot keep up with the throughput, what I did was disable all crypto and enable the mac address filter, I get n dropped connections, also if your using TKIP it drops the connection for 1 sec to rekey the network client and causes a drop on all filesharing networks which can be annoying.

    Just disable WEP, AES, and/or TKIP and enable the MAC filter Only.

    You Can VPN in to another box on the network, thats wired to the router if you are affraid of sniffing attacks.
  44. m00n

    m00n Network Guru Member

    I've got some new developments in my case.

    I was so pissed that i removed the router and connect directly to the modem, and started to download.... and guess what, after a couple off minutes the connections hangs/jaimes.... Again i had to disable/enable my ethernetcard.

    What can it be... the modem not cause when the connection jaimes connected to the router, the wireless people could continue to internet.

    Cable i changed, so as the ethernetcard.

    This could mean 2 things.... --> hardware problem @ pc or.... problem with the program i use when i'm downloading.... "Newsleecher 2.3 Beta 2."

    I just installed the Finale 2.1 version and i'm downloading 15 gig, i'll let you guys know tomorrow how it went!
  45. m00n

    m00n Network Guru Member

    Oke didn't help.... jaimed again.....

    What can it be.... never had problems with the BEFW11S4... (is broken, plugded the wrong powersupply in it and now the wan port keeps a red diagnostic led burning..)

    Modem.... can't be as i said before when i'm connected to the router and the connection drops, the wireless people could still connect.

    Changed Newsleecher version 2.3 beta 2 to 2.1 final.... didn't help.
  46. Toxic

    Toxic Administrator Staff Member

    have yout tried a differnt ethernet porton the router? different cat cable?

    any new or older drivers for the PC ethernet port? disabled all firewalls on PC?
  47. m00n

    m00n Network Guru Member

    Tryed ther ethernetport on router
    Tryed Different Cat Cable
    Tryed other ethernetcard
    Didn't try disable firewall... going to do that right now!
  48. pharma

    pharma Network Guru Member

    You might need to increase the number of allowed tcp connections (limited to 10 under XP SP2).

    Look into the event viewer (either using one ot the following 2 methods: Control panel --> Administration Tools --> Event Viewer --> System, or start->run 'Eventvwr.msc'->system). When you see entries with the event ID 4226, the system is telling you that the connection limit has been reached.

    If this is the case, you can download a freeware tool to make the change for you. The link below will allow you to increase the tcp connections as well as providing some other specialized XP functionality. If you use the XP-Antispy tool, what you seek is under the Special menu item -- Connection limit.

  49. bigclaw

    bigclaw Network Guru Member

    Posted in the firmware thread already... but after installing the high-clock-speed firmware, my v3 router's Cisco logo now lights up. It's an amber light. I definitely didn't notice this before. Is this normal?
  50. mzuidwijk

    mzuidwijk Network Guru Member

    I've got exactly the same problem with my WRT54GV22 :(
    I've connected my laptop to the 2nd ethernetport, and that works great!!! No problem at al ... It seems to be just the first ethernet port.

    I've got a Proxim Orinoco Wireless goldcard, and with or without encryption that works great!!!

    "Normal" downloading seems to be no problem at the 1st ethernetport. But when i start accelerated downloading with for example DAP, the whole internet connection freezes. Only disable/enable the ethernet works, just like m00n told earlier post.

    I've just tried out the 3rd and 4th ethernet port with my laptop, both working fine! No problem at all. It really seems to be just the 1st ethernet port.

    I've just hooked up my computer on the 3rd ethernet port. But still the same problem. :( My laptop doesn't have any problem at al on each of the 4 ports, but the connection on my computer freezes on every ethernet port, when running an accelerator :(

    My laptop has got an 10/100mbit ethernet controller, and my computer an 10/100/1000mbit controler. Perhaps that's the isue???

    I've disabled firewall, unchecked Block Anonymous Internet Requests, Filter Multicast, Filter Internet NAT Redirection, Filter IDENT(Port 113)...

    But that didn't worked for me.

    Anyone got more clues?
  51. wolvenar

    wolvenar Guest

    The overheat problem was easily overcome (if you dont mind voiding your warrenty) by adding a heatsink to (at least) the cpu.

    I tested this using 2 Linksys WRT54G one is version 2.02 the other 3. something
    the ver 3... is in a weather resistive case 85' up a tower now.. makes it a bit tough to verify and I dont remember

    I also replicated this problem, It has nothing to do with operating systems that
    I can tell since I prefer Linux and it did happen to me also

    I added a heatsink to the CPUs and Broadcom chip of both machines, testing to see if there was an improvement I transfered a 650 mb ISO WITHOUT ANY DROPS!!!

    I wanted to do a sort of torture test to verify the results, so I wrote a script to transfer back and forth that same file when it succeeded one direction it sent the file back again. with a second file name, in case of a drop the original file always was in tact the same size, recording the failure if the original file and new file were different sizes

    I left this run for about 6 hours, with no ill effects.
    It seems this indeed seems to be a heat related issue, the new CPU heatsink does get quite warm after some time of load

    This is only one of what seems to be multiple problems occurring with these machines..
    I am using DD-WRT #22 (prefinal3.2) as the firmware load.
    This has an auto reboot option at a timing you choose ( hours days weeks)
    if you need for long term speed lossess ( if they happen)

  52. Toxic

    Toxic Administrator Staff Member

    proving the PC has the problem and not the laptop could piont the finger at the pc's ethernet port.

    can you configure the port for 100/tx full or half duplex? tried new drivers for the ethernet pc port?

    if not get youself a another network card, they are cheap, just to test it.
  53. m00n

    m00n Network Guru Member

    Yo Zuidwijk,

    What i did to (solve it, havent had a disconnect to now from yesterday 11:00, and i downloaded like 30 gig), first hooked up my pc on a 10/100 not the onboard 10/100/1000. Then entered the modems webutilitie, and did a reset there, my first ethernet port on the router is oke, that shouldn't be a problem.

    More questions, what kind of isp do you have? What kind of modem do you have, what kind of program do you use to download?

    I changed from Newsleecher 2.3 Beta 2 to 2.1 Final

    (P.s. hook youre pc directly on you modem, and start downloading, does it freezes then? It did with me.....)
  54. mzuidwijk

    mzuidwijk Network Guru Member

    Hey mr. Moon,

    The problem still isn't solved, the connection still freezes when i use Download Accelerator Plus. When I connect my computer directly on my modem/router (A netdsl 1000), then it works perfect!! No freezing at al. But with the WRT54G between, the connection only freezes when using Download accelerator Plus.

    I can use DAP on my laptop using wirelss, or connected to any off the 4 ethernetports.

    But my computer, a 6 months old Shuttle with onboard GBlan, freezes when using DAP.

    I've just added the latest HyperWRT (Version: v3.03.6 - HyperWRT 2.1b1), But the only improving is the stronger wireless connection.
  55. Partizan

    Partizan Network Guru Member

    Firmware Version: v4.00.7 works for my v2.2

    Well, the 4.00.7 firmware works for me. Look at the uptime:

    Flash Type=Intel 28F320C3 2Mx16 BotB;
    CPU Clock=216;
    Write Mac Address=xx:xx:xx:xx:xx:xx;

    get wl_gmode=2;

    totalram=14819328, freeram=2310144, bufferram=1728512;



    Regards, Partizan
  56. mzuidwijk

    mzuidwijk Network Guru Member

    What is it proving? If I connect my computer directly on the modem/router, it work's fine! And with the WRT54G between the connection freezes. I have found out that i don't have to disable/enable the connection. If I close the application, the connection to the internet is back.

    I have the latest driver for the network, I'll try to force/select the 100/tx full or half duplex.

    I have tried every possible config but none off them helped.
    * 100 full duplex
    * 100 half duplex
    * 10 full duplex
    * 10 half duplex
    None off the above modes worked.

    This one is on his way back to the store. It's ridiculous that a router of this price gives that much problems!
  57. capn_q

    capn_q Network Guru Member

    Re: Firmware Version: v4.00.7 works for my v2.2

    Partizan, how did you get this information?
  58. Partizan

    Partizan Network Guru Member

  59. RyFeR

    RyFeR Network Guru Member

    Hi guys,

    Any news on the new beta firmwares? Is the "Network name not available" error solved now? How about a new (beta) firmware for the WRT54GS so i can test further?

    Will there be a final version for the WRT54G and WRT54GS models soon? Sure hope so...
  60. mzuidwijk

    mzuidwijk Network Guru Member

    I've made a little (maybe big) discovery :oops:

    I've connected my computer directly on my modem again, and the problem was still there.
    So perhaps it isn't the WRT54G at all :oops: :oops: :oops:

    The stranged part of it is that the problems occured after i've start to used the WRT54G...
    Therefore I'dd never trouble with this download manager...

    But like I said in my earlier post, no problems with using my laptop wired or wireless.
    Very odd :cry:

    I've rolled back all the drivers off my network card, and used the original drivers which never gave trouble... But the problem keeps on existing :?

    Well, i'm going to another forum for my shuttle

    I am very a shamed :oops:
    I've tried everything, except reïnstalling the download manager :lol: :oops: :lol:

    Everything works perfect now!!!
  61. Dokken

    Dokken Network Guru Member

    Hello! I am from Romania and I have a WTR54G router with the same problem as all of you. I`ve tried the new beta firmware and it seems to do the work. I`ve tested the router and I was able to send about 7GB from LAN to WLAN.

    But I noticed something strange: the ping response from router to WLAN is 1-2 ms when I copy something from LAN (eg. a movie); on an idle connection, the ping response is 18ms. Is this normal?
  62. enx23

    enx23 Network Guru Member

    Re: WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]

    After more testing I had the first disconnects (network not found) also with "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]". I transferred around 5 GB both ways (wireless<->wired computer) and after this I let my laptop to be connected via wireless more than 24 hours. After 24 hours the first disconnects appeared. The router used is WRT54G v2.2 and WEP 128 bits.

    It seems that the beta 7 firmware with low clock rate doesn't solve the problem completly!!! I really hope that the next firmware will solve it.
  63. RolfW

    RolfW Guest

    I had several disconnects during large transfers in Windows XP SP2.
    After applying a patch for event 4226 ( http://www.mrtech.com/news/messages/4119.html ) I no longer have any disconnects.
    WRT54GS 1.1 / Intel Pro/Wireless 2200BG
  64. mnol

    mnol Network Guru Member

    Some test results..

    I've updated my two WRT54G v2.2s with the 4.00.7 HIGH (WRT54GV3.1_4.00.7_US_high.code.bin) firmware and not a single reboot yet! I've stress tested both units by transferring large files and they seem very solid.

    One is now up for over 5 days and the other 2 days.

    My wireless desktop PC & WRT54G work well together: 0% packet loss (about 1 out of 1000 is lost).

    However... the packet loss in combination with my Powerbook G4 (with 54mbps wireless) is enormous: 4%. :-( Even when idle. With WPA or without any security. Tested on two WRT54G v2.2s on different locations and with two new Powerbooks. When tested with a different 54mbps and a 11mbps basestation: no packet loss at all. The default 3.03.1 firmware didn't give any packet loss either. It seems to be a problem with this specific firmware only..

    In all cases ping times are around 1ms, so that's fine.

    The 4.00.7 'low' (WRT54GV3.1_4.00.7_US_code.bin) firmware didn't do it for me. Wireless transfers lasted longer (say 30 seconds in stead of 4), but reboots occur anyway. Only tested on one unit.
  65. b_u_z

    b_u_z Network Guru Member


    Does anyone know if the WRT45GS 4.50.5 BETA Firmware is safe to use on WRT54GS version 1.0 hardware?

    (Sorry if this was already addressed, I couldn't find it)
  66. Xenomorph

    Xenomorph Network Guru Member

    i would NOT put it on a 1.0 - for a couple of reasons.

    one, it says its for 1.1 and higher ONLY. and two, its supposed to fix issues the 1.1 and 2.0 routers have. something the 1.0 doesnt suffer from.
  67. no-talent-ass-clown

    no-talent-ass-clown Network Guru Member

    I posted a while back that I had a v2.2 router with this problem and took it back for a v3.0 router. I just checked my uptime and am just over 28 days on this one. I transferred about 10 GB of divx files, random install files, and mp3's the other day without an issue. This is with the latest bios on the linksys site. Not sure what the problem was with the first router, but everything works fine now. Best of luck to you all, hope you get lucky and get a good router. Once they work, they are great.

  68. Red97

    Red97 Network Guru Member

    I am using BETA v4.00.7 High Clockrate firmware and my connection has been stable since upgrading to it a week ago.

    Apart from Gaoggi's hint about the issue being Memory Mapping, the only other clue we've had is someone noticing that the router CPU maxes out on high throughput transfers.

    My own testing confirms this, and it appears that the issue is Hardware design. The router isn't fast enough to run large transfers at 54Mbps. By overclocking the router in the firmware, more CPU cycles are available to get through the work. Unfortunately, this probably will shorten the life of the router and most likely will void the warranty unless it becomes an official release.

    The only other solution, apart from overclocking, is somehow to make the code more efficient so that it takes less cpu cycles when transferring data. I don't like the chances of this happening...

    Just my $0.02 worth...
  69. TheRoDent

    TheRoDent Network Guru Member

    For anyone using Sveasoft's Talisman, enable telnet/ssh and issue the following commands at the prompt.

    nvram set clkfreq=216
    nvram commit

    And reboot the router. This has the same effect as the new beta firmware, it overclocks the CPU slightly.
  70. JohnSK

    JohnSK Network Guru Member

    TheRoDent, thanx.. this should also work with alchemy-based FW's (i.e. DD-WRT if I am correct)
  71. JohnSK

    JohnSK Network Guru Member

    I think this is worth mentioning...

    the overclock fixes the problem with dropouts on DD-WRT too -- I've set mine to 240, no dropouts that I got all the time with one specific 700 MB AVI file - already did 4 transfers without problems @1,5MB/s.

    I will try lowering the cpu clock to see which value is optimal.. although 20% overclock doesent seems so high ;)
  72. Toxic

    Toxic Administrator Staff Member

    it is also worth mentioning that overclocking should not really be done without decent ventilation.

    linksysthemselves have said the official firmware will NOT be anywhere near 240Mhz. overclocking this cpu will result in damaging your router.

    is it really worth it?
  73. JohnSK

    JohnSK Network Guru Member

    Yes, true.. I've glued (with thermal conducting glue) a passive Zalman cooler on top of the CPU itself and took out the PCB from the plastic box, hope this will be enough until the source code is released for the low-clock official FW :)


    230MHz seems to work fine,will try lower thought...
  74. Pibe38

    Pibe38 Network Guru Member

    When I tried to install any of these files I immediately received an error and could not test any of these firmwares. I got tired of waiting and before the first 30 days ran out I returned ALL my new Linksys products for a full refund.

    Now I have a D-Link router that was a breeze to install and as we speak is transfering a 600MB file wirelessly. I have also posted my story on all the gaming websites I am a member of and I will never recommend a Linksys product, nor buy one again.

    I want to thank everyone that provided help and insights with this issue, and wish luck to the ones that are still waiting for Linksys to release a new firmware version.

    Thanks again!
  75. thirteenva

    thirteenva Network Guru Member

    What are you using to detect packet loss on your powerbooks? I'll try it with my powerbook and see what i get.
  76. bigsteve101

    bigsteve101 Guest

    I have a Linksys WRT54G V2.2 tried all the firmware's had same problems wireless crapping out under load - last about 2-5 seconds before crashing etc. My solution to this problem was to change the power supply I am at moment using my scanner power adaptor running at 18V around 1.5Amps never had a problem since. Maybe this problem is just an under rated psu?.
  77. capn_q

    capn_q Network Guru Member

    Using Alchemy v1.0, I tried TheRoDent's advice of bumping up the clock speed to 216 MHz.

    Works like a charm.

    I'm starting to suspect that this is a vicious buffer overflow bug whereby the wireless LAN <-> wired LAN buffer can't keep up with the other side's production. Or even better, Linksys has a setup/hold problem with their design--this would explain why some boxes experience the issue and others don't. It seems to me that the memory-mapping excuse is a hoax; otherwise making a single change of the clock frequency on the Alchemy firmware wouldn't have fixed the router stability.

    Now I just have to hope that their design is robust enough to handle a hotter, less stable processor.

    I'm happy for the moment :)
  78. mnol

    mnol Network Guru Member

    Thanks :). Just opened a terminal and typed 'ping' (my router's address). When i wait for some thousand packets, it will show 4%. When i stop it after only 100 packets it will show 2%-6%. So packets seem to be lost all the time.

    It is also very noticable when controling my powerbook with my PC's mouse and keyboard over the network (using synergy).
  79. honkidonki

    honkidonki Guest

    maybe a solution

    hi people,

    maybe i got a solution for some of you, maybe not. this will take quite long, but it's worth reading.

    I'm from germany and I started my "WLAN experience" about 2 or 3 years ago with a Linksys BEFW11S4 and a no-name-WLAN adapter. When i put up my first WLAN at home I still was using Windows 2000. And I was really amazed how easy everything worked for me. Over about 1 1/2 years I was using the router and the no name WLAN without any problems, which means nice pings during online gaming, no break ups, no drop outs, no strange disconnects, all downloads running fine, all file transfers between wired and wireless network were working fine.

    Well, then some time ago I changed to Windows XP. and everything started to be crappy. My system was still the same, my WLAN components still the same, just the operating system had changed. Then, there was no service pack 1 as well as of course no service pack 2 for XP out yet, which already got me lose lots o nerves on setting up my WLAN under XP, because Microsoft had implented his nice "Wireless Zero Configuration Tool", which I think is for some people the root of all evil. That meant that you were forced to use the Microsoft tool instead of using firm specific tools, which were a must under WIN2K and older OS, because otherwise you weren't able to connect to the router. Things got much easier when Microsoft threw out service pack 1 & 2, which brought much improvments to wireless lan. Well, but my problems started with the installation of Windows XP and stayed also with SP 1&2 until, yeah, yesterday :D

    I had all the same problem much of you listed here already, drop outs, connectivity loose, break ups, download problems with file-sharing tools, problems with multimedia over internet like webcams, problems during online gaming, etc.. and all with the same configuration I had already when using WIN2K, where i didn't have those problems. So, frustrated, i decided to buy me a new router. So I bought me a Linksys WRT54GS, because i still was convinced of Linksys' easy use and handle and quality. I bought also a WUSB54G, just to be sure that everything would work fine. This was about 8 months ago or so. Well, unfortunately, I got to know, that nothing changed, the router worked great, but the problems were still there, just a little bit shorter. I looked everywhere over the first months, in every forum, help sites, tried new firmwares, tried open firmwares, but nothing helped. Thinking that I was the only one on earth with this problem, i just decided to leave everything as it is, because except of the online playing, the other things didn't bother me very much, for the router although losing all the time the connection, put it up on the next moment, and everything was working alone on and on.

    Well, wouldn't i have started to play a specific game a little bit more "professional", i probably would never have landed here. Because of this crappy drop outs during the online gaming, i got frustrated more and more during the last weeks, so that i decided to try to solve the problem once again. and started once again searching. first of all tried other firmwares, original linksys, satori, hyper wrt, but nothing worked. some time later i landed here in this forum, reading the first time, that there are masses of people out there with the same problems as me, and my hope to solve the problem began to rise, because there were already 24 sites related to this problem. i even tried the newest beta, which was posted by gandalf (4.50.5 beta). but unfortunately it didn't work out. frustrated, about the fact, that this probably was a hardware problem as many of you think, I already was willing to RMA my router.

    I also found this microsoft site with your help:
    Wireless Network Adapter Intermittently Loses Its Connection to the Server
    tried it out, but it didn't work, because after deactivating the Wireless Zero Configuration tool, and installing the (new or latetest) drivers windows XP is not able to find a WLAN any longer. Got a bit confused, why microsoft tells to deactivate it, when WLAN is not working after that any longer. Well, i got more and more frustrated. Bored, i visited another german router forum, to look up, whether they speak also about the "hardware" problems of the WRT54G/GS models there. By fluke, i found a thread where one guy was complaining about connectivity losses and problems during online gaming. Another one gave him the hint to try a tool called "wireless zero shutdown" which you can get here:
    Wireless Zero Shutdown
    don't be irritated by the ad, just wait 15 seconds or click on the link at the top of the page. the page also loads a little bit slow, just wait a moment, it will appear.

    Now, if you think, that you heard already Wireless Zero in my text, then i say you, you're right, and when you think why to return to that Wireless Zero thing when it didn't work, then i say you, that i thought the same, but anyway i gave it a try, because I actually got no other options. Well, and I'm freakin happy that I gave it a try and I think some of you will be too. You can download and copy the tool as often as you want, it's freeware. the site itself is in german, but the tool is in english. The only thing is to start it after downloading, you even need not to install anything. After starting click on -->file and the -->settings. then check the box next to "automatically?" and write the ip of your router in the field where it belongs. after that click on "apply". done!!

    after that you'll find an entry in your system start, which you can look up by msconfig. well, but what does this tool actually do?? i'm actually no programmer or technican or anything similiar, but i understand it that way, that Wireless Zero Configuration is still loaded with every Windows XP startup, but then in the next moment deactivated by WZS (wireless zero shutdown). that way, your connection to the router stays up, although the wirless zero configuration is shut down. you can try it manually, when doing the steps written above on the microsoft page i posted. the problem with microsoft's way is the thing that Wireless Zero Configuration is shut down completely for every Windows XP startup. But Wireless Zero Configuration IS NEEDED TO FIND ANY WLAN, so what?? they say to install the latest drivers of your WLAN Adapter, but that didn't work for me. So what is the crappy problem?? the problem are not the drivers. the problem is that after deactivating the Wireless Zero Configuration you need a tool, which simply finds your router, so something like the Wireless Zero Configuration. Well, but where do get something like that from?? the answer is simply: When deactivating Wireless Zero Configuration you have the same situation like when using windows 2000 and older systems, which didn't have the Wireless Zero configuration tool, you see?? they needed extra tools from the specific firms, so that the WLAN adapters could find the wireless router!!!!

    I was always angry about the fact, that i couldn't use the specific tools of the firms, because they were always much more exactly and precisly then the standard windows xp tools with it's 5 bars saying that the signal strength is poor or very good.

    well, you probably ask yourself, what is the damn problem with this whole Wireless Zero Configuration. The problem is, that this WZC is searching all the time for Access Points, and you can't do a damn thing against that, except of shutting it down. but this searching provokes that your Wireless connection simply "stands still" (drop out, hang out, whatever you want it to call) for about 1,5 seconds, yeah 1,5 secondS!!!!!!! MY FUNNY DROP OUTS DURING ONLINE GAMING LAST ALWAYS about 1,5 SECONDS!!!
    And now everything comes together to one picture. The WRT54G/GS models seem to react so sensitively to this searching, that they just lose the connection, have drop outs, hang over and all the problems people are listing up. Linksys seems not to be aware of this problem, if ever this is the real problem. AND I AM NOT BLAMING LINKSYS FOR ANYTHING, I LIKE THEM AND I STILL WILL USE THEM FURTHER ON, BECAUSE EVERYTHING WORKS FINE NOW FOR ME.

    well, and now put it all together:

    ---->poeple owning WRT54G/GS and have not a damn problem with this
    ---> ever thought about the fact that still many people DO NOT use winxp,
    and instead of that use the specific connection tools, which are
    optimised for the routers, and work probably better for the routers,
    then microsoft's "nice" Wirless Zero Configuration"

    --->newest/latest firmwares didn't work???
    ---> how should they work when the WZC was always messing up

    ---> some guy told here in this thread that a microsoft router worked fine
    for him and he was shocked, that a firm that is specified for making
    "good" (yeah, good...... :S) software is able to do a better hardware
    router than a firm who is specifed to network solutions
    ---->Wireless Zero Configuration is a component of MICROSOFT
    Windows XP, well then these MICROSOFT routers were
    OBVIOUSLY optimised for the WZC

    --->some people tell that there are routers from other firms, that work fine,
    but others don't
    --->seems that linksys is not the only firm, whose productcs have
    problems with the WZC, and on the other hand there are firms, which
    just run fine with the WZC

    you see the connection??? now the whole confusion and chaos makes sense, somehow, or not??
    i remember once building up a network with linksys products for a friend of mine. He got 1 WinXP PC and 1 Win2K PC over wireless access, and one over wired. While the Win2K PC ran fine with linksys' WUSB54G and linksys'connection wizard, I unfortunately messed up with the WinXP PC, on which i didn't just install the drivers for the WUSB54G as every manual tells it when installing WLAN adapters, but by accident installed also the Linksys Connection Wizard. well, at the first moment everything ran fine, but not even one day later the friend called me, that the WINXP machine was doing strange things. his childs where not able to use games or other programs, because they were always thrown back to the desktop. something was working in the background. first i thought of a virus or something like that, but then i realized that obviously WZC and the Linksys Connection tool were collidating and that WZC was running "furious" and all the time searching for new networks, which provoked that the memory was overloaded in some way and that was why no programs could be used and being quit.

    The only thing that i don't understand and that does not fit in this whole picture is why linux users have those problems. i'm unfortunately not used to linux and can't say anything to that.

    And it might be that all the things that i wrote are totally crap, and don't work, then i excuse myself for that right at this moment. But i know that they have worked for my WRT54GS V2.0. and you can't imagine how happy i am that everything is running fine, no hang ups, no connectivity losses, no drop outs during online gaming, my webcams keeps connected and so on. everything works as it should work.

    Maybe there are really models with hardware faults, but give it a try, maybe just the firmware needs to be optimized to the WZC and linksys is searching for the fault at the wrong places, i don't know, maybe they already know the problem, maybe i told you just crap, but

  80. thirteenva

    thirteenva Network Guru Member

    Re: maybe a solution

    This may very well help some people but there are quite a few of us running Macs and Linux boxes that are experiencing these issues also. So while it may be part of the problem I don't think its the solution we're looking for from linksys.
  81. hajnal

    hajnal Network Guru Member


    Dear capn_q,

    first, I absolutely agree with the reasoning of capn_q
    (don't know the truth, yet), but I think this is the point here.
    To answer the question who made the setup/hold problem
    read below, maybe not Lynksys...

    Dear honkidonki,

    from your long description (I have to say that I was very
    suspicious after reading tens of promising and false hints,
    but I read it till the end anyway) it seemed that I can simply
    test your solution by killing manually the

    zcfgsrv.exe (or something like this, I shut down so I can't see it now)

    process from taskmanager. I started a copy that had failure before.
    And it WORKED! (I still don't believe it...)

    @2.4 MB/s copied 300MB files (non of them worked before I killed
    the process).


    (My config: WRT54G (EU) v2.2, Firmware Version: v3.03.1 ,
    Win XP, SP1)

    Thanks again honkidonki!

  82. TheRoDent

    TheRoDent Network Guru Member

    Guys, please don't confuse one kind of problem with another...

    Yes, Wireless Zero Config is a bitch. But some of the people in this thread are having a different problem. Their access points manually reboot, due to a bug in the Version 2.2 hardware of the WRT54G.

    I've seen this, with a serial port attached to the router, under high load conditions, it simply reboots.

    Some of the other problems mentioned in this thread could be WZCFG related, but not all of them.

    Please don't confuse the problems here. There is a bug in the LinksysWR54G v2.2

    Wireless disconnections, in general, can be caused by a number of things, but this thread is not about those problems. This thread is about randomly rebooting linksys routers.

    The apparent fix, according to a Linksys engineer (page 22 or so) is to slightly overclock the CPU to increase the memory access rate. That is the fix, and may be implemented in an official linksys update. The other wireless disconnection problems are not at issue here.

    If your router starts blinking the power LED during large file transfers, then it has rebooted. That is the sure fire way of detecting whether the router died or not, since they all blink their power LED's during a boot cycle.

    If it does not, it's reasonably safe to assume that your problem is caused by something else, like the Wireless Zero Config service doing an network scan.
  83. sxwlinksys

    sxwlinksys Network Guru Member

    I tried it... I shut down the Wireless Zero Configuration, but only half a minute after that the router went down again. That is quite a coincidence, because my router hardly goes down anymore since I had it replaced...

    It sometimes still does though... Today I think I caused about 15 GB high-speed traffic over the wireless, and had in total 2 crashes... I hope it doesn't slowly get worse over time....

    Mine is a v2.2 WRT54G with the standard (3.03.1) firmware....
  84. hajnal

    hajnal Network Guru Member

    Well, then there are other problems left to solve...
    and I'm not happy hearing that news.
    Actually I didn't transfer gigs of data, I wanted to
    simply copy 100MB, which failed, and I was
    worrying about that.
    I thought the same problem causes the crash
    at "high throughput"
    (actually I didn't watch the router's leds, does it
    reboot or not).
  85. rockshox

    rockshox Network Guru Member

    The Wireless Zero Configuration might be a good thing to try if you have random drop outs without a high load on the router. However, I have an Apple Powerbook running Mac Os X 10.3.9 (and now 10.4) and the problems with the WRT54g were not resolved until the beta firmware was released.
  86. BMan2

    BMan2 Guest

    THis firmware works better - but I still get hangs in some large file transfers. I mostly use it transferring files wirelessly to an bxox - but also there is a wireless laptop user in the house that has troubles. This firmware resolves the problem PARTLY - but not fully.

    And yes - I did a factory reset - at least I can get SOME throughput now - before it was hopeless - now at least it does some - and a quick reconnect in FlashFXP works for me to the Xbox - it's a bit more annoying for the laptop user though.
  87. enx23

    enx23 Network Guru Member

    Re: WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]

    I got 2 more disconnects with "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]" until now.
  88. CyMi

    CyMi Network Guru Member

    CPU Clock=240;

    Has been worked great since the beta v4.00.7 FW update. I don't care anymore if it dies overclocked this high. Keeping thumbs up.
  89. sxwlinksys

    sxwlinksys Network Guru Member

    I flashed to 4.00.7 (low clock) and haven't had any dropouts since.

    I found quite a useful network throughput tester, with which I've tested the new firmware now for 25 GB at high speed. It can be found at http://www.stanford.edu/~preese/netspeed/ I've been running the linux compile on my server, and the windows compile on my wireless laptop....

    Useful switches: -i 5 -n 20000M -c -w 128K -f M

    -n = data amount to be sent
  90. Partizan

    Partizan Network Guru Member

    strange problem since 4.00.7

    Since I installed the 4.00.7 (low overclock), my v2.2 loses internet connection. It happens if I use P2P or no P2P. My http, ICQ and p2p programs stop receiving and sending data. I can't ping. If I wait for 30 minutes or an hour it starts working again. Or if I just unplug the router an plug it back it works.

    Wireless and LAN are still working and pingable.

    Any idea?

    REgards, Partizan
  91. Pacif13r

    Pacif13r Network Guru Member

    Warning playing with NVRAM

    I overclocked my GS v1.1 to 240 to fix the byte sequence reset problem. This worked fine and solved the issue so I tried 235 which also worked fine.
    When I tried to go 230 a small accident happened. I was using PuTTy from my laptop and telnet'd to HyperWRT on my GS1.1, so to find the clkfreq and see what it was I copied the contents of the terminal window to NotePad and did a search.
    My mistake was accidently right clicking = paste in linux gui terminal / PuTTY. This pasted all the contents of ' nvram show ' back into the session and restarted telnetd. I thought well that's probably only copied / reaffirmed all my nvram settings and should be fine (I was in a rush) so I telneted back in and did nvram commit. And there went my GSv1.1 absolutely dead except for blinking power light for the last 5 days.

    I tried everything under the sun to fix it : pin shorting, tftp timing, reset combo's. Eventually I built a EJTAG interface as detailed by hairydairymaid. and tried to delete everything and restore the CFE etc etc.

    After having no luck with my CFE I got hold of one from wolf's website for the GS1.1 and tried that with no luck. I was just about to order another WRT54GS to get my laptop wireless again when I had a look at hairydairymaid's code and it dawned on me that those addresses were not likely to work for a 4MB G AND a 8MB GS. So I joined Sveasoft just to see if he had an update and sure enough he had and it could now cope with 8MB chips.

    Finally after deleting the real KERNEL, the real NVRAM and comparing my CFE to the one from wolf it appeared that my NVRAM settings had screwed up my CFE (boot loader) so I then wrote wolfs CFE to the intel flash and rebooted and voila at long last I saw the long flash from the dmz light and used tftp to squeeze HyperWRT back on and now all working perfectly.

    So just thought I would share 4 things.
    1) be very careful with right click and any nvram settings - I have also hear that setting too many nvram settings between commits can also lock you out of your unit without EJTAG.
    2) When *all* else fails try hairydairymaid's EJTAG and it works :cool: or maybe try it first because short circuiting means that you will be pulling down (or up) against something which is never a good idea...
    ( I highlight all because the only stone I left unturned was building a serial port interface)
    3) you will be wasting your time using v2 of his EJTAG solution on a GS with 8MB firmware :p so make sure you use ver 3 or above.
    4) overclocking solves my wireless reset problem but I just need to find the lowest working speed which does'nt lock the cpu :roll: and need the nvram erased.

    I hope this helps someone.

    UPDATE I have found that (on mine at least) the lowest stable speed is 230 Mhz which I have been working on for 2 hours and everything that failed all the time with regard to wireless resets is now working perfectly for the first time.
    Caveat : be aware that what seems to work (clock speed) with just a reboot often fails and requires NVRAM to be erased after a power cycle.
    I just hope that my broadcom chip doesn't burn out at this speed..... 8O

    UPDATE2: Now working perfectly for 6 hours of solid use and a night of rest :lol: looks like I have a convoy...
  92. RedFive

    RedFive Network Guru Member

    WRT54Gv3 working properly!

    I've got two WRT54Gv3 routers (one as my main router connected to a cable modem and my main workstation PC and another as a living room client mode box). Both have been having this "high throughput" reboot issue. I've been very frustrated with not being able to fix it for quite some time.

    ...but today the issue has been resolved, thanks to people in this thread!

    Using Sveasoft Alchemy v1.0 on both routers and upping the clock speed of the CPU to 235, all of my throughput reboot woes are gone! It couldn't have been easier.

    1. Make sure SSH (or telnet) is enabled on router.
    2. Login to router via SSH (or telnet).
    3. Enter "nvram show | grep clkfreq" to see the current clock speed of the CPU on your router.
    4. Enter "nvram clkfreq=235" (or whatever clock speed you want to set it to).
    5. Enter "nvram commit".
    6. Enter "reboot" (or just pull the power plug and plug it back in).
    7. Once the router is back up, login to it via SSH (or telnet) and enter "nvram show | grep clkfreq" again to make sure the clock is set to the speed you entered.

    Does anyone know what the lowest working clock speed that the CPU can be set to and still be rid of the throughput reboot issue? I've set both of my routers to 235 for the time being and it's been working rock solid all day. Also, is there a difference in the clock speeds that can be used on different versions of the WRT54G?

    Thanks to everyone in this thread for helping me get this problem solved!
  93. Toxic

    Toxic Administrator Staff Member

    Re: WRT54Gv3 working properly!

    a notr to everyone please.

    this CAN damage your router. minor increases may help however they will give more heat. with more heat comes more problems.

    with that out of the way :)

    Who is gonna be the first to clock their cpu to 400mhz with liquid nitrogen? :D
  94. mstombs

    mstombs Network Guru Member

    Quite a few references to this specific problem in this thread.

    I can now confirm that the latest US WRT54GS beta firmware:


    does indeed fix this problem - and must therefore be the problem that is referred to in the version history file in

    WRT54G WRT54GS Beta_Firmware_for_Wireless_Transfer_Issues

    Linksys, A division of Cisco Systems, Inc.
    Product:                WRT54GS
    Classification:         Firmware Release History
    Firmware  Date:		4/20/2005
    Release Date:           4/21/2005
    Last Firmware Version: 3.37.6 
    Firmware 4.50.5 BETA
    - Resolves wireless file transfer issues
    Thanks to everyone in this thread who has helped to put pressure on Linksys to do something!
  95. Partizan

    Partizan Network Guru Member

    Re: strange problem since 4.00.7

    It is enough if I go to the routers main settings page ( and just press SAVE SETTINGS it starts working again. Isn't it interesting?

    Regards, Partizan
  96. Whatever

    Whatever Network Guru Member

    Is there anyway to schedule a WRT54g router reboot, say, at midnight so I don;t need to manually reconenct?
  97. nicweb

    nicweb Network Guru Member

    OK, if this problem is solved by overclocking the CPU I can go back to Alchemy 1... but Update fails evertime I try updating with the web interface. Doing resets didnt solved this problem. Actual firmware is 4.00.7...
  98. nicweb

    nicweb Network Guru Member

    OK, had to go the way over hyperwrt flashing between that... so after Alchemy v1 was installed, I've tested FTP Transfer from WLAN to LAN... rebooted as everytime before... then I set clkfreq to 235... worked fine so I set clkfreq to 205 (normal is 200) and this worked too for me!!! I've transfered 1,8 GB at 54 MBit/sec without any problems. So far...
  99. Pacif13r

    Pacif13r Network Guru Member

    Just a reminder that as I mentioned in my post earlier on this page that I found quite different results between overclocking and rebooting which seemed to work almost all the time at any clock speed. And when the tires meet the road during a power cycle. I assume that different parts of the CFE are run only during a cold boot and *most* clkfreq's which worked during a warm boot required me to erase NVRAM after a powercycle to get the router to boot again. That was with a GS v1.1 though. Also inmho I would guess that 205 is too low to make a difference (why else would Linksys push too 240/250) and that is just chance that it is working atm... inmho :p
  100. nicweb

    nicweb Network Guru Member

    After 205 I set clkfreq to 195, commited and rebooted like everytime... didnt worked out. Back to 205 and the AP is still stable
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice