WRT54GS -> High Throughput causes disconnect

Discussion in 'Cisco/Linksys Wireless Routers' started by zephyr325, Feb 7, 2005.

  1. bigclaw

    bigclaw Network Guru Member

    Would a firmware flash reset the frequency to 200?
  2. RedFive

    RedFive Network Guru Member

    I had to use the official "WRT54GV3.0_3.03.6_US_code.exe" from Linksys to flash my routers back to 3.03.6 before flashing to Alchemy v1.0. For whatever reason, the update would always fail when I was using the 4.00.* firmwares. Just my two cents.

    Also, my routers are still going strong at 235. It sounds like some people are having success at 205 or 216, though... I'll give those speeds a shot this weekend and post my findings here. Thanks!
  3. Acoustique

    Acoustique Network Guru Member

    It works!

    Hmmm.. Just got my router from the retailer.. And the same problem occoured to me as well..

    I tried the latest offical firmware.. Both the up-clocking 4xx and the low clocking firmware..

    Nothing worked! (Tried factoryresults and all other little trick but yadda yadda.. no effect.. )

    So I installed the latest official firmware again (the first one I tried) and guess what... It works! :D Really strange actually.. I got a 2.2 router.
  4. MarkFour

    MarkFour Network Guru Member

    Did you do the hard reset? I have good luck doing a hard reset both before and after a firmware flash. (My 2.2 was cured with the low-clock beta).
  5. henke

    henke Guest


    I have had the same problem ever since I got my WRT54G router.
    I´ve been searching numerous forums, been in contact with Linksys Chat 5 times. No workable solution. They had me change MTU and came up with different numbers each time. Then they stop answering in the chat...maybe because they ran out of option.
    The last suggestion I got was.

    Linksys: Try another version of the Firmware?
    Me: I have the latest, which one shall I try?
    Linksys: All, you can download them on our FTP...

    Yes, that is a good way of buying time.... :evil:
    Especially if you need to enter all your configs by hand each firmware switch.

    At last I found this thread where people have the same problem.
    MY solution is to reboot by disconnecting the power cable every 15-30 minutes while downloading and trying not to over use the router,. That really feels nice and really annoys me.

    I was hoping for the other firmwares here, and I’ll give it a try now. Not much hope after reading this though.
  6. Acoustique

    Acoustique Network Guru Member

    No, I used the factory default option in the web-interface..

    Henke: Swe i pressume? :)
  7. trbrol

    trbrol Network Guru Member


    Same here, it has been only trouble since I bought my WRT54G v.2.2 a week ago :x
    Have tried different firmware ,and ended up with V3[1].1_4.00.7_US_high.code who partly solved the problem. Still many daily disconnects from internet (LAN works).Have to take out power cable or go to and "save settings" Can it be accepted to buy "non function" products as all posts in this forum clearly states ??? If it had been some other product on the market with such failure it would have been withdrawn promt....
  8. crishnu

    crishnu Network Guru Member

    My Router Crashs when I'm using Bittorrent.
    I have testet all Firmwares, but nothing worked for me.
    Any Solution?

  9. Ballista

    Ballista Network Guru Member

    My Turn

    My set up is just for a simple home network.

    I have a basic cable Internet service with one IP issued to my account.

    Adelphia Power Link cable Internet connected to a Linksys cable modem connected to a Linksys WRT54G v.3 Wireless router.

    From the router I have a desktop connected (Just a few feet away) via Ethernet cable to slot#4 and via wireless to a PC in another room.

    Both computers are running Windows XP w/SP2 and the router does issue individual IP's to both the computers.

    My Problem is not unlike most of the problems posted in this thread.

    When I attempt to DL large files (994MB is a large file for me) from for instance FileSchack.com, FileFront.com or File PLanet.com the router after a period of time (that is never the same) resets and I get the message that internet explorer cannot complete the DL of (Insert file name here) from (insert file location here) The connection to the server has been reset.

    This is the main problem for me but I also experience an intermittent loss of Internet connection.

    At first I was sure this was a problem with Adelphia but have determined that in fact my connection is as solid as I could want it to be. It was a Tier II technician with Adelphia that started me on the path to correct my Linksys router issue.

    I have contacted Linksys 3 times now and so far the solutions while good for my connection have not solved my problem.

    Solution #1

    From the Knowledge Base DL and install the latest Firmware, NO help!

    Solution # 2

    From JD in the Philippines (MTU Setting) this configuration was preset to auto on my router. Before speaking with JD I had done some Ping testing to determine the proper MTU setting for my network and my 1st packet loss was at 1744 so I added 28 to 1472 and came up with 1500 which Adelphia supports and per the Linksys Knowledge Base I should be somewhere between 1300 and 1500. JD suggested I set to 1400 so I did I was able to DL one 591MB file then back to the same issue.

    (At this point I called Linksys again and spoke with a young lady in New Deli who wanted me to go back and do everything I had already done when I told her I had already done these things she prompted me to set the MTU to 1110? I advised the nice but confused young lady that the Linksys knowledge base says not to set the MTU below 1300!)​

    Solution #3

    I spoke with a different young lady in New Deli who had me go to my control panel and open the network connections window then open the properties of my network connection and click on configure for the network hardware device then click Advanced. Then I went to the Speed & Duplex Option it was preset to auto, she had me set it to 10 mbps Half Duplex. I was able to DL one 641MB File and she was nice enough to wait until the file was finished then she advised me to at my leisure tweak the settings until I noticed the problem again at that point I would then know the best setting. Unfortunately after I hung up the phone with her I again began having the same problem and have not been able to complete a DL?

    Frustrating to say the least.

    I have though of exchanging the router but after reading this thread, I don’t believe I need to do that. I have tried to sort through the replies in this thread to find help for my problem. Although some of the problems posted here are not necessarily the same as mine I have found a couple more theories I will put to the test maybe the answer for me is in here somewhere?

    I am no Network guru I am simply trying to access the Internet for file downloading and uploading to my web host (ftp and all that stuff), online game playing and general Internet surfing nothing to serious. But not being able to is really racking my brain.

    I also will post my FINAL SOLUTION! To this problem as soon as I figure out what I am going to do. Any one who reads this and know a solid fix please post it.

    [marq=right]UPDATED 051205 Solution #4.

    I installed the 4.Lowclocked version of the firmware I found here on this thread and a light came on (the company symbol on the left of the routers face) I did not know that was a light? any how I had high hopes with the noticeable change but then I started a 964MB dl this was a milestone though I did get 64% of the file DL before the connection to the server has been reset message appeared. (I should point out that the speed of the DL was also a marked improvement for both the hard wired desk top and the wireless lap top)

    I am going to try the over clocked version of the firmware tonight and push the cpu up to 235 and work my way down from there.

    I located the firmware via this thread where I located this link:


    I really dont like overclocking anything as is shortens the life span of our little electronic buddies. BUT! if this router dont shape up soon it's life span will be short lived anyway :execute:

    (UPDATED 05/13/2005)

    THE FINAL SOLUTION! :givemebeer:

    But seriously last night I DL the High Clocked version of the firmware from the link above and after shut down the PC's and reset the router. Aftet I rebooted and began the 964MB Dl and was FINALLY :rockout3: able to complete the whole thing at an average transfer rate of 550KBs I wouldhave liked it to have been faster of course but the point is the 4. High clocked firmware version worked! SO! I hope this adventure was a hlep.

    Me ---> :punch: <--- Linksys

    And with all the posts about very similar problems in ths thread by more qualified folks than me you would think Linksys would Own this one :protest:
  10. rockshox

    rockshox Network Guru Member

    Ballista - Does this problem happen on both the wired and wireless computers?
  11. Lord_Diablo3

    Lord_Diablo3 Guest

    I’ve been reading a lot on this problem, and i have it on my WRT54G (v1.0) as well. The thing is that I haven’t had this problem when i 1st bought my router 3 years ago. I bought my WRT54G when 802.11G was still in so-called "draft mode". Anyway I was wondering when people loose their connection, do all wireless clients connected to the router loose the connection, or just individual PC's? I have a roommate and am sharing a 4mbit Internet connection with him. We both are using a Linksys WMP54G wireless card in our systems. I am also using a Linksys WPC54G - Wireless-G Notebook Adapter in my laptop, on occasion. But I’ve had some issues where the internet would stop working for everyone on the network, and other times when only one person would get disconnected from the network.

    One thing I’ve noticed that seems to help slow connection problems is to pay attention to how you have your antenna facing behind your pc. Don't have it parallel with your case... I’ve found that the connection is a lot more stable when you angle the antenna 45 degrees away from the back of your case.

    If I get mine working correctly again, I’ll let u guys know.
  12. Justroln

    Justroln Network Guru Member

    I had the same problem of freezing, every x minutes from high download througput. Changed clock speed to 235 and now it only freezes every 1.5 days. Couldnt we solve this by writing a script that can issue a reboot command through telnet when the router freezes?
  13. Scroatdog

    Scroatdog Network Guru Member


    Don't hold your breath waiting for an "official" firmware to finally fix the problem, even though the beta was at least a step in the right direction.

    Note the e-mail from Linksys below:

    Recently you requested personal assistance from our on-line support center. Below is a summary of your request and our response.

    Thank you for allowing us to be of service to you.

    To update this question by email, please reply to this message. Because your reply will be automatically processed, you MUST enter your reply in the space below. Text entered into any other part of this message will be discarded.

    [===> Please enter your reply below this line <===]

    [===> Please enter your reply above this line <===]

    WHEN is Linksys going to FIX WRT-45G problem??

    Discussion Thread
    Response (Maricelle R(17740)) 05/11/2005 11:16 PM
    Dear Valued Linksys Customer,

    Thank you for contacting Linksys Customer Support.

    First, I would like to apologize for any inconvenience this has caused you. The beta firmware we have has fixed the problem for transferring large files using the WRT54G routers. We don't have any dates as to when the next firmware upgrade will be released.

    If you have further questions, please contact us at (800) 326-7114 or send us an E-mail at support@linksys.com so that we may further assist you. Please use this phone number given as reference for future support calls.


    Maricelle Raqueño
    Linksys – A Division of Cisco Systems, Inc.
    Product Support Specialist
  14. Ballista

    Ballista Network Guru Member

    in reply to Rockshox

    Unfortunatly yes it does. I did load the low clocked version of the 4. firmwhare I found posted in this thread here is the link.


    last night and a light came on that was not on before :huh: I started a 964MB DL and was 64% of the way complete when it happend again? I didnot want to try the over clocked version but I guess I can allways roll it back if I need to.
  15. The_Wave

    The_Wave Guest

    Glad to have company

    I also have had this problem and agree its a heating issue. I read some obscure thread where a guy stood his wrt54g on its face and performance improved. It actaully worked, but the problem was still intermitant. I was really frustrated with the linksys support, because it was very apperant that this was a "known issue" but i got little help. It is also obvious that their online support is contracted out to the planet pluto where communication skills are optional. I was finally promised a "beta driver" that fixed the problem, but it has not shown up. I think linksys unloaded a bunch of faulty equipment knowing that only high load users will ever see the problem.

    But on a happer note, my new $80 paper weight is really growing on me. I am thinking maybe if i put some seeds in it, it will make a nice chia pet.

  16. Pibe38

    Pibe38 Network Guru Member

    You can get the beta firmware here: http://www.siemens-mobiles.org/linksys/ ~ read previous posts about the difference between the two version, one of them (the over clocked one) seems to be fixing the issue.

    I feel your pain, I was lucky because I was still during the 30 days within the return period, I got so frustrated with Linksys support that I returned all the products I had from the brand. I got a D-Link DGL-4300 (gaming router) and works like a charm.

    It's funny, yesterday I got an automated response from Linksys e-mail support saying that because there had been no activity on my part in 366 hours the case was closed. I sent a nice reply telling why there was no response from my part... because I don't have the products anymore, and will never buy Linksys again.

    Anyway, once again, good luck to everyone still waiting. Also The_Wave check the announcement on top of this forum for more info on the beta firmwares. I had a WRT54G v2.2 and none of them work, they upload utility would not recognize them.
  17. mstombs

    mstombs Network Guru Member

    My WRT54GS v1.1 seems fine with the beta firmware v4.50.5 (only one version don't know/ don't care if it is high or low clock)

    Is it now only the WRT54G that has problems with beta firmware v4.00.5 or v4.00.7 (2 versions)?

    Note subtle differences in version nos between G and GS.
  18. dimaki

    dimaki Network Guru Member

    New firmware works great !

    the new beta firmware works great on my WRT54GS.
    But I also had to reduce the MTU to 1492.
    Because 1500 seems to be too large for my network. I had fragmentation errors.
    ('ping -f -l 1472 microsoft.com' shows me fragmentation errors. ping size is 28, so 1472 + 28 = 1500.)

    Now I can transfer GBs of data without any error.
  19. PedroAlves

    PedroAlves Guest

    WAP54G, WRT54 - Hangs - > Tosca solution

    I use a WAP54G as a wireless bridge for internet access.... And.... It hangs.... So after use a firmware frea and have a telnet enable i realize that only wireless communication was lost. I create a reboot script and wait for a better solution.... The wap54g reboot is during 10 seconds and the boot interval is 6 minutes.... it is work around but is better than nothing....

    The reboot script:

    use IO::Socket;
    unless (@ARGV > 0) { print "usage: $0 host ...\n";exit; }
    local $SIG{ALRM} = sub { print "Error: Connection timed out ($timeout sec)\n";exit }; # NB: \n required
    alarm $timeout;
    $host = shift(@ARGV);
    $port = 23;
    $cmd = "reboot";
    $remote = IO::Socket::INET->new( Proto => "tcp",PeerAddr => $host,PeerPort => $port,);
    unless ($remote) { print "Error: Cannot connect ($host) to agent daemon";exit; }
    print $remote "$cmd $parm $parm2 \n";
    print $remote "\n\nexit\n\r";
    while ( <$remote> ) {
    print $_;
    close $remote;
  20. Jagzzzzzz

    Jagzzzzzz Network Guru Member

    One thing I noticed with the new firmware for my GS, I can now only seem to tranfer data on channel 6 or any other channel that is not a speedbooster channel. Anyone else see this. When I go to a "speedbooster" channel where it says it is 54 MPS and speedbooster enabled, it starts off fine, then drops to 1 for the MPS. But when I do it on a channel that says I am at 54 MPS and 54 MPS (instead of speedbooster) it goes through fine and stays at a high throughput. Anyone know why? How can I trnasfer files at 54 MPS and speedbooster enabled? Thanks in advance.
  21. Scottie

    Scottie Network Guru Member

    Losing Internet Connection Now

    The new firmware has solved my problems with transferring large files but I am now dropping my internet connection with alarming regularity.....does any body have the same problem and any idea how to fix?.....Thanks
  22. enx23

    enx23 Network Guru Member

    WRT45G 4.00.7 BETA Firmware [HIGH CLOCK RATE] works!!!

    I've tested "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]" with my WRT54G v2.2 and I had several wireless high-throughput disconnects.

    I've tested "WRT45G 4.00.7 BETA Firmware [HIGH CLOCK RATE]" and I had no more disconnects. Finally my router works fine.

    The beta firmwares are here from here:
  23. trbrol

    trbrol Network Guru Member

    The WRT45G 4.00.7 BETA Firmware DID fix the wireless transfers for me ,but as Scottie I have regular internet disconnects, and when downloading large files it locks up. I have the hw ver. 2.2 WRT54G and bought 14days ago ,and should I wait for a new firmware to fix or change it to another brand? I`m not impressed with this product..
  24. G-man

    G-man Network Guru Member

    WRT54GS - large file transfer disconnects

    I was getting the same issue with transferring large files through a WRT54GS. Network name not found, path too deep, yadda yadda. I loaded the beta firmware WRT54GSV2.1_4.50.5_US_code.bin. Seems to work a little better I was able to transfer a 40MB file. But I still get disconnects but with a different message - Access denied or file in use. Mind you I'm copying a folder that contains mulitple files. The folder gets created and a bunch of files get copied but when it comes to a large file the transfer fails. I have WPA Radius running with AES so I thought I might back off the security settings and see what happens. Might end up with a different wireless router if this keeps up.
  25. MilesTEG

    MilesTEG Network Guru Member

    I was having trouble too with wifi...
    I contacted linksys french support by mail ( :? :| :roll: we have only mail or phone...) and they reply me including this firmware : v4.50.5 (WRT54GSV2.1_4.50.5_US_code.bin)
    and they told me to set "Beacon Interval" to 50 (default is 100)...

    And for the 1.5Go transfert I test, and the printing whitch crashed wifi yesterday, they worked without crashing wifi...

    So I hope It will continue...
    And I hope 3rd party firmware will move soon to this source code of the firmware...

  26. freaky_00

    freaky_00 Network Guru Member

    Well I have Firmware 3.37.2 ETSI (EU Version) for the WRT54GS v1.1!!! Since 2 weeks I have those kind of disconnects. I am not sure what it is, but I regularly download with Azureus. Right now it disconnected like hourly. I keep the internetgateway Symbol open to check how much time flies by until the next disconnect comes. Sometimes I got the feeling it helps if you are connected over half an hour with NO SIGNIFICANT TRAFFIC at all. Had the computer shut down for the whole night and the next morning internetgateway said I was connected for 9 hours. This day the router had not a single disconnect!!!
  27. leipo007

    leipo007 Guest


    i've received this firmware from linksys nlsupport. I havent tried it yet, but does anyone know what changelog is? Is it still only a higher clockrate? I want to use a 3th party firmware, so i want to set the changes manualy if possible.

    I have a Linksys WRT53G v2.2
  28. G-man

    G-man Network Guru Member

    WRT54GS v2.0? Any problems?

    Freaky_00: File transfers seem to work okay if the files are small. I transferred almost the whole Windows I386 directory without a problem. It wasn't until I tried to transfer a 40MB file that the thing choked...

    I see that Linksys has come out with a hardware revision for the WRT54GS, v2.0. Mine is unfortunately a v1.1. Has any one tested large file transfers with the 2.0 hardware version? I'm wondering if it's worth exchanging this one with the later version.
  29. mstombs

    mstombs Network Guru Member

    Re: WRT54GV3.1_4.00.7_US_beta.code.bin

    from the linksys ftp site (down tree sg) doesn't really tell you much!

    Linksys, A division of Cisco Systems, Inc.
    Product:                WRT54G
    Classification:         Firmware Release History
    Firmware  Date:		4/20/2005
    Release Date:           4/21/2005
    Last Firmware Version: 4.00.5 BETA __________________________________________________________________________
    Firmware 4.00.5 BETA
    - Resolves issues with wireless file transfers
    Firmware 4.00.4
    - Updates LED definitions for SES
    Firmware 4.00.1-classB (BETA)
    - Adds class B subnet support for LAN IP address (For internal testing only)
    Firmware 4.00.0-qos (BETA)
    - Updates QoS functions
    - Adds SES support
    Firmware 3.03.6-access
    - Resolves issue with access restrictions
    Firmware 3.03.6-Mulitcast (BETA)
    - Fixes issue where multicast breaks when MAC filter status changes
    Firmware 3.03.6
    - Supports hardware version 3
    - Updated help file
    Firmware 3.03.1
    - Wi-Fi certified
    Firmware 3.01.3
    - Updated wireless driver
    - Supports hardware version 2.2 (cannot downgrade to previous versions)
    - Resolves issue with VoIP adapters
    - Resolves issue with long domain names
    Firmware 2.04.4
    - Updated wireless driver
    - Updated certificate generation for https access
    Firmware 2.04.3
    - Resolves issue with disabling firewall
    - Added QoS function
    - Added Port Triggering function
    - Added L2TP option for WAN connection type
    - Added ability to back up and restore configuration files
    - Added Wireless isolation function
    - Added ability to filter internal NAT redirection
    - Added ability to restrict access to web GUI from wireless clients
    - Added ability to filter IDENT port 113
    - Resolves issue with HeartBeat WAN connection
    - Added support for 40/56bit cipher to support old browsers to use https
    - Resolves issue with PPTP passthrough
    - Changed WPA Group Key renewal time range to 600~7200 seconds
    - Added IGMP proxy support
    - Added ability to allow web GUI access only through https or http
    Firmware 2.02.2
    - Updated wireless driver to support all versions of WRT54G hardware
    - Adds support to allow WAP54G connect as a repeater
    - CTS protection mode set to disable by default to improve wireless performance in normal environments
    - Resolved issue where the WLAN LED stays on even when wireless is disabled
    - Resolved security vulnerability causing the web server in the router to crash
    Firmware 2.00.8 (WRT54G v.2 only)
    - Updated wireless driver
    Firmware Version 1.42.2
    - Updated wireless driver to 3.31.15
    - Added URL and contents filters
    - Added L2TP passthrough
    - Added HeartBeat Signal support
    - Resolved issue with Connect on Demand
    Firmware Version 1.41.2
    - Updated GUI format and layout
    Firmware Version 1.30.7
    - Adds UI control to enable/disable frame bursting
    - Resolves issue with firmware upgrade error in Internet Explorer 6.0.2800.1106.xpsp2.030422-1633, on Windows XP pro.
    - Send to disable DynDNS
    - Resolves issue with using the 4th tx key for WEP
    - Resolves issue with disconnecting PPPoE causing WPA to be disabled
    Firmware Version 1.30.1
    - Adjust PPTP max MTU value from 1400 to 1460 
    - The router is now certifiable for the UPnP logo
    - Complies with final 802.11g standard
    - Improved performance asymmetry between the transmit and receive paths
    - Receive Broadcast packets from renew state. Some DHCP server (Dlink 300G+) send broadcast ACK after it receives a REQUEST
    - Fix: The firmware upgrade will fail, if DDNS updates while upgrading
    - Fix: If first DNS address fails, the second or third DNS address will be used to resolve domain names
    - Added the following items under Setup Page:	
        - Router Name
        - Manual Time Server
        - MAC Clone
        - wireless domain
        - Security Settings 
    - Added the following items under System Page
        - UPnP enable/disable
        - Ping Test and Traceroute
    - Added the following items under Wireless Page
        - CTS Protection Mode
        - Basic Rate
    - Added the following items under Status Page
        - Router Name
        - Start IP Address
        - End IP Address
    - Added Wi-Fi Protected Access(TM) support including AES and TKIP encryption
    - Resolves issue with Port Forwarding name showing up as garbage characters
    - Added "B-Only" option to wireless modes
    - Added "Default" option to Basic Rate settings
    Firmware Version 1.02.1
    - Incorporates updates found in the Draft IEEE 802.11g version 6.1 specification
    - Resolves interoperability issues with legacy 802.11b devices under Mixed Mode 
    - Resolves a performance bug where the performance in a mixed b, g network did not go up once the last b client disassociated
    - Resolves issue where WEP degrades performance
    - Resolves issue with TZO DDNS Service 
    - "Domain Name" replaces "name"
    - TFTP server will only verify image file name "xxxx.bin"
    - MAC Address Filter under the Advanced tab works on both wired and wireless clients
    - Fixed a bug that prevented wireless clients from connecting to the Internet if there was no active wired PC (PPoE customers in Europe and China only)
    - Support for UPnP enabled applications such as MSN Messenger
    - Fixed a bug that caused computers connected to the LAN ports to be dropped at some interval only to be immediately re-connected
    - Fixed Dynamic Routing issue between 2 Routers
    - Allows User to name Static Route Configurations
    - Modified PC List Web Page to avoid confusion
    - Stabilized Wireless-G to LAN and WAN Throughput
    - Stabilized Wireless-B to LAN and WAN Throughput
    - Improved LAN-WAN Throughput
    Firmware Ver.:	1.01
    - Initial release
  30. Scroatdog

    Scroatdog Network Guru Member

    4.07 HIGH clock rate works 4 me !!


    The other night I left WinMx on all night. Low and behold I get up the next day and both computers are no longer connected to the Internet. I had been running the 3.06 firmware. So I said to hell with it, reset the router, logged in to the admin page, upgraded the firmware to the 4.07 HIGH CLOCK RATE version, reset the router again, then went in and got everything set up. Did a transfer test by transferrring a 2 gig tv show recorded the other day, from my wired computer to wireless. Took 15 minutes, but NO DISCONNECT!!! I'm a happy camper.

    WHat's all that new stuff on there???? I noticed there's WPA2 and somehing called AES with a green logo on the Wireless security page. Anyone know what these features are all about???
  31. firestarter

    firestarter Guest

    ooooops, well guys..had the same problems as most of u: disconnects, and the need to reboot the router in order to make it work again.
    Tryed all the things mentioned here and on the linksys website, but with no succes...
    So i went back to the store and got a replacement.
    The replacement was better, but still i got disconnected, no need to rebooddddd.....soooo i updated the firmware to the highclock version, modified my wrt54g by adding a 12cm cooler on it, got rid of the powersuply, and replaced it with a 2 Amp, 12 Volt version, and since then i am up and running!!!!
    No more drop outs...no more disconnections...and no problem transfering HUGE files from wired to wireless and vice verca
    In other words: i am a happy Linksys user. :D :D :D
    But.....in order to get better coverage in my garden, i bought myself a WRE54G, wy??????? well: it works without cabling, and makes roaming availible
    At this point i have the WRE54G working, but when the signal of the WRT54G is to weak, ill have to connect to the WRE54G manually, no roaming whatsoever:(
    Been chatting to a linksyssupport technician for serverall hours, but that didnt work, soooo ill do some testing tomorrow and let u guys know if its working. 8O
  32. lebaige

    lebaige Guest

    I have the same problem as everyone else. It seems my router can't even handle a few megs at a time, it chokes on attempts to move mp3 albums around (10-12 normal sized mp3's). This is going from wireless to wired. I tried the beta firmware, it seemed to help but I still got occasional "network blah blah not available". Couple that with the beta firmware's lack of Static DCHP capability and rather limited QoS and I went back to the Sveasoft stuff.

    Oddly enough though, I found a rather unorthodox workaround. I have two Microsoft Media Center Extenders, a PAP2 Vonage adapter, and my main Media Center PC attached to my WRT54G running Sveasoft Talisman. I also have two PC's connecting to it wirelessly. If I transfer files over the network with no other traffic going on, I get the usual disconnects. However, if I happen to have one of my media extenders turned on and watching TV, I get none, yet for some reason it causes the Media Center Extender to hiccup.

    To to make a long story short, moving files from wireless to wired works when I have a different wired to wired transfer going on at the same time. Which just makes NO sense to me at all, but is quite consistant. I'm also a bit confused why moving files over the wireless is causing the wired portion to hiccup.
  33. jamaica

    jamaica Network Guru Member


    Here is the fix as I found it: Install HyperWRT 2.1 and put the signal strength at 100%. No more disconnects.
  34. Dobos

    Dobos Guest

    Here is my experience. I first bought a WRT54G at Office Depot a few weeks ago. It was v 3.0. I experienced terrible trouble using wireless file transfers, VNC, and bittorent. If I was lucky it would just drop the connection, if not I'd have to physically power cycle the router it would get so conked out. Ordinary web surfing worked fine.

    I was not aware of this forum so I called linksys, and after an hour the tech basically just told me to get another one. He didn't even mention any overclocked firmware. I brought it back to Office Depot and found out they have some kind of special contract with Linksys so they were able to just swap me with a brand new one without any fuss. All I did was show them the receipt, but no paperwork was needed. I just handed them the old one and they gave me a brand new box.

    They new one worked almost perfectly. The wireless stuff was perfect but then as I used it more I found that once or twice overnight the Internet (WAN) link stopped working, so that I had to reset the router to get it to work again. So then I put on the Sveasoft firmware and using the telnet commands overclocked it to 216, and now it's been up for about a week with no problems.
  35. RyFeR

    RyFeR Network Guru Member

    WRT54GS + Alchemy final + clock to 216 solved the prob

    Hi all,

    I've been waiting a while now for a slightly overclocked version of the 4.50.5 firmware for my WRT54GSv1.1 (asked goagi several times, he said he was posting one but haven't seen any). After reading the previous post i decided to do the same, loaded the Alchemy 1.0 final firmware and set the clock speed to 216.

    And behold... I had 6 small files in the beginning (with the stock firmware)with major probs, after flashing the 4.50.5, 2 files still gave the "network name bla bla bla" error... Now all files transfer succesfully!

    I still hope that a new beta / final firmware fron linksys will come out and solve all our issues, so that the source code can be made available and all 3rd party firmware makers can use it...

    Happy now!
  36. Scottie

    Scottie Network Guru Member


    New Beta version of the software has cured the high throuput issue but then I still had the Constant Internet Disconnections.

    One of the Linksys Supervisors advised setting thye MTU to 1350 then in advanced wireless settings set
    Basic Rtae to 1-2Mbps,
    Transmission Rate to 11Mbps
    Beacon to 50
    both Fragmentation and RTS to 2304

    after a few days it seems to be ok i will try for as couple of weeks.
    This is for Internet Disconnections Only
  37. leethax

    leethax Guest

    Is there a firmware available with manual overclocking ability for the WRT54GS v2? I know Alchemy can handle OCing, but AFAIK, it's not compatible with the GS v2. I've been using HyperWRT, but if that supports OCing, I haven't been able to get it to work. :(
  38. RyFeR

    RyFeR Network Guru Member

    I believe DD-WRT is compatible with the GSv2 and supports overclocking... Check out this forum topic:


    Here's a list with compatible firmwares for each WRT54xx router...
  39. Scottie

    Scottie Network Guru Member

    Inrternet Disconnects

    The new Beta version of the software has solved my problem of transferring large files but NOW I am getting disconnected frequesntly from the internet???

    One of the Linksys Supervisors advised setting the MTU to 1350 then in advanced wireless settings set
    Basic Rtae to 1-2Mbps,
    Transmission Rate to 11Mbps
    Beacon to 50
    both Fragmentation and RTS to 2304

    It is still connectingfrom the internet and I have totally given up with Linsys Tech Support which is bar far the worst I have encountered....Now that I have that off my chest can anyone help solve why I am disconnecting from the internet so frequently?
  40. mstombs

    mstombs Network Guru Member

    Re: Inrternet Disconnects

    I was told the above config as well - they just cripple the throughput and don't seem to do anything about the disconnects. What wireless card and drivers/ encryption are you using?
  41. moi666

    moi666 Network Guru Member

    Ok, I just got my v2.2 G back from RMA (due to the large file xfer issue) and have yet to test it out yet, but obviously I am not optimistic.

    As many have mentioned the latest beta firmware 4.00.7 solves this issue but introduces a internet disconnection issue???

    Doesnt this just SUCK. I think I'm about give up on Linksys and go with 3com. Bugger.
  42. xpanmanx

    xpanmanx Network Guru Member

    v2.0 WRT54G running v4.00.7 high-speed firmware. Router configured as a AP only. OE 12v 1a PSU on a small Belkin UPS. Sitting about 8' from the antennas.

    Disconnect problem remains. Powering cycling seems to help for a few minutes, but problem always returns and aggravates.
  43. Eugenios

    Eugenios Network Guru Member

    haha! nice! I was reading the posts when I can to your "true" answer on what to do when you have a Linksys problem. I agree, big companies like Linksys (Cisco) etc, etc, really don't (can't?-) fix their software incompatibility problems. You woould think that wireless has come to age and everyone uses the same protocols... it isn't so.

    Ofcourse if you get everything Linksys, router, accesspoints, pccards, lancard, then you won't have any problems. That ofcourse is what Linksys wants all of us to do!! Use only their products. What they don't realize is that they are also losing customers.
  44. jnord24

    jnord24 Network Guru Member

    This is exactly why

    I do setup of in home networks. I see customers purchase the wireless routers all the time, and I tell them.. take it back, return it for a wired router & purchase a wireless access point for the network.

    Linksys wireless routers have a tendancy to lock up which causes everyoen connected to the network - not just the wireless to lose their internet & sometimes internal network connections. I used to have to reboot mine SEVERAL TIMES A WEEK. I don't recommend anyone depend upon a wireless router for their internet connection.

    Since moving to a new setup over two years ago (with the WAP instead) I hardly ever have to reboot, and only when Earthlink reports having problems locally. I use bittorrent, winmx, warezp2p, have wireless survellience video live on the internet, do ghost multicasting, have an hp all in one networked product which constantly broadcasts for the rest of the functionality and I don't have problems. I run 2 win2k servers, 1 slackware box, 1 mac, 2 laptops with xp, 4 windows workstations. I do remote support and I even activate ftp internally occasionally.
  45. Eugenios

    Eugenios Network Guru Member

    Re: This is exactly why

    I agree with you completely. First of all, when you have an all-in-one machine, you can not use the method of deduction when there is a problem. When you have three devices instead of one, then it is much easier to pin point the problem.

    I have everything seperate. Adsl modem, Switch, and Wireless accesspoint. This way I can easily see what is working and what is not. Especially when the problem is the Adsl modem (which is the most common problem). I simply reboot the Adsl modem and everything is back to normal.

    At the time I have a not-so-good Adsl modem made by a Greek company called Intracom. They make a very bad modem which easily gets over heated and locks up at least once a week. I have to unplug it from the electric outlet in order for it to reset, and even then, all settings return to default (which is very annoying).

    So keeping things simple makes it easier to fix things. Also when one piece of equipment goes bad you don't have to completely stop working!
  46. opodeldok

    opodeldok Guest


    Got a hint from the linksys hotline:
    The ethernet and wireless part of the WRT both have their own MAC address.
    Using the ethernet MAC causes disconnects.
    Since I use the correct MAC address (Status-->Wireless), I have no disconnects and all runs fine!
  47. el_magnifico

    el_magnifico Network Guru Member

  48. Hernexto

    Hernexto Network Guru Member

    Re: Disconnects

    mmm, you "use the correct MAC" ??

    where do you set, or use the MAC ?

    setting specificaly to the wireless clients to connect to the AP with these MAC ?

    i can't understand where do you use the MAC...

    (sorry my english xD)
  49. GekkePrutser

    GekkePrutser Guest

    I've also been ripped off with this :(

    Hi Everyone,

    I just bought a GS (EU model), because of the future expandability with third-party firmware. It turned out to be the wretched 1.1 hardware, and of course I have the same problem! I can't even transfer a 50 meg file before it hangs! Unfortunately I didn't know of this problem before I installed it or I would have returned it after seeing the serial number.

    Linksys is of course saying the problem is all new and are sending me bogus links to firmware versions that don't work either. And I can't try the overclocked firmware because there doesn't seem to be one available for the GS yet, only for the G..

    So I'm stuck with a dead paperweight I paid 100 euro for and the reseller won't take it back because I've opened it :( Great service Linksys!

    It's time they own up to the problem and fix it, or just recall these units and replace them with a decent hardware revision! It's insane they're still selling them right now after all these problems.

    Anyway to get back to the topic, has anyone had any success with any other firmware? I don't really want to use OpenWRT at this stage..


  50. malfeasance

    malfeasance Network Guru Member

    Reflash with Official Firmware

    Why can't you reflash it with some Linksys Official Firmware and take it back, making sure to pay careful attention to the serial number when you exchange?
  51. koo9

    koo9 Guest


    I have a WRT54G and have problem transfer big file and when there is heavy load on the traffic.

    I guess after all linksys does not make good products. few years ago, I bought a brand new linksys hub and it didn't work because of the power or something not working, then i decided not to buy any linksys product, now this time, I went with this WRT54G and again, it doesn't really work.

    at this point, I will say NO MORE LINKSYS PRODUCTS!
  52. thescreensavers

    thescreensavers Network Guru Member

    remove you windows firewall and or allow it
  53. hajnal

    hajnal Network Guru Member


    now I see a new firmware on the OFFICIAL SITE (that I was waiting for
    a long time...) for WRT54G - Wireless-G Broadband Router v2:


    Firmware Date : 6/27/2005
    Firmware File Size : Varies
    Firmware Version : 4.00.7

    Anyone tried it? Is this the high clockrate version?

  54. A-ONE

    A-ONE Network Guru Member

    Its wierd cuz i have never had this wireless disconnect problem before. Its probably becuz im using a different setup then the majorty of you.

    Ive got one WRT54G v.2.2 with hyperWRT 2.1b1 and A WRT54GS v.1.1 with Alchemy 1.0 with a WDS link inbetween. WEP 128 encryption in G only mode.

    I do large file transfers all the time and i get no disconnects or hiccups.
  55. sooby77

    sooby77 Guest

    The new firmware for my WRT54G v3 has completely solved my disconnect problems with my Intel 2200BG adapter on my Dell. It still fluctuates between 48 and 54mbps on occasions but I can live with it. Good job linksys. Hope it will get integrated into the other third party firmware as well. The ability to use wpa2 completely stable is awesome with this new firmware!
  56. dadaniel

    dadaniel Network Guru Member

    in my eyes overclocking is not a solution... shame on Linksys :(
  57. littlerm

    littlerm Guest

    Does the WRT54GC suffer the same throughput problem as the G and GS (before latest fix)? I have searched but cannot find the answer. Thanks!
  58. rbeauch

    rbeauch Network Guru Member

    I have been using the new firmware v4.50.6 with my WRT54gs for three days now and it has completely cured the transfer problem. I also haven't had any disconnects.

    Thanks Linksys but since the date on the firmware is 4/24/2005, I would love to know why we had to wait so long?
  59. moi666

    moi666 Network Guru Member

    Is this for real? The 4.00.7 firmware fixes things??? Any more feedback guys? What about the intermittent Internet connection dropouts?
  60. dpearcePNG

    dpearcePNG Network Guru Member

    v4.50.6 works!

    I tested v4.50.6 on my WRT54GS v1.1 router and firmware v4.50.6 now passes all of the files that previsouly hung the router or slowed it way down.

    I'm still not sure if I'm ready to recommend Linksys yet. Why did it take so long?
  61. ybbmadysu

    ybbmadysu Network Guru Member

    When I leave my GS in wireless mixed mode it disconnects while doing file xfer of 250MB or more wlan to lan.
    In b-mode only, works without disconnecting, just very slow.

    WRT54GS v 3.37.6 with HyperWRT v2.1b1

    The last router that I had was the G series, when i upgraded to v4 firmware it permanantly bricked it.
  62. ybbmadysu

    ybbmadysu Network Guru Member

    Well i just upgraded the firmware to linksys ver 4.50.6(or something like that). then installed hyperwrt 2.1b1.

    WOW it works now, file x-fer wlan to lan is best for me when the lan comp is on 100Mbps/half duplex.
  63. meimei

    meimei Network Guru Member

    Just wanted to let you all know I have never experienced any of these problems. I have a WRT54G 2.2. Firmwares I have used are Rupan's firmware and currently I'm using HyperWRT 2.1b1. Have always been using startup scripts (never without, so I can't tell if they have any effect on this).

    echo "300 600 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts
    echo "4096" > /proc/sys/net/ipv4/ip_conntrack_max
    Give it a try. No luck? Probably hardware related.
  64. CrashOne

    CrashOne Guest

    Re: v4.50.6 works!

    Just upgraded my WRT54GS to firmware version 4.70.6, but i still got this problem when downloading local from lan to wireless.
    But the connection to the internet remains, before 4.70.6 the connection between laptop and router got reset totally...
  65. mstombs

    mstombs Network Guru Member

    Surely the Linksys firmware used to install Hyperwrt is irrelevant - you replace it with 3rd party firmware based on previous Linksys Firmware
  66. drkilmer

    drkilmer Guest

    Dropped Connections

    I had the same problem with my WRT54G ... as soon as I hooked it up, I would lose my DSL connection. I tried calling tech support, but since I'm a Mac user, I was pretty much ignored. I took the advice of another person here and returned the Linksys and goy a D-Link DI-624 ... now I have a rock solid connection. I could not download a firmware upgrade for my Linksys since I use Macs ...
  67. mattoneill

    mattoneill Guest

    WRT54G Connection Breaks When Transferring Large Files

    What a relief to see that I wasn't the only suffering this absurd problem. I'm using the 2.4Ghz Wireless G (USB) connection point to connect to my WRT54G (third one I've purchased/returned). I have the exact same issue as folks here.
    - I have to download files < 100Mb or the connection drops
    - Luckilly, as I have USB, I don't have to shutdown/restart and can just unplug the USB and plug it back in (still, highly annoying)
    - If files can't be split up easilly, I have to burn it on DVD and use my still foolproof sneaker-net to take the files to the main computer upstairs.
    - Internet connections never drop
    - It's only when transferring large files

    Also, I've NEVER been able to get more than 10-12Mbps connection between the two. They are touted as being able to transfer 54 - 100Mbps between them but I've NEVER seen this.

    Firmware: 2.04.4

    Please someone help me!
  68. elconejito

    elconejito Network Guru Member

    WOW. My first post on these forums, i've been browsing off and on for a few days now looking for info just like this. 29 pages of posts! Eeek!

    I have a WRT54GS v2. One XP machine connected via LAN, a XP machine connected wireless with a WMP54GS, and a XP laptop connected wirelessly with an intel 2200. I have WPA security, and all have SP2 installed.

    I have the same/similar issues here (i read page 1&2, then skipped to 28&29 cus i'm at work. I will likely read the remaining pages later). My wireless gets disconnected frequently, the speed ramps down from 54 to 1, then back up again. sometimes even tho i have "excellent" or "very good" signal strength it will say that i have "limited connectivity" (or whatever that phrase is). BitTorrent clients are a sure way to bring the connection down, altho really it can just be sitting there and disconnect. Sometimes i lose the whole internet (for the wired too), but usually its just the wireless.

    Does the latest firmware help? i tried to download that a few days ago, but it gave me a .bin file and the router upgrade page asked for a .rmt file and wouldnt upload the firmware. Is this right?

    Would it be better to use a 3rd party firmeare? i dont mind paying a few extra bucks at this point. I bought the GS mainly for the additional speed(booster) so i'd like to stay with the GS if at all possible.

    Thanks for your help!
  69. mstombs

    mstombs Network Guru Member


    The helpfile is wrong - the .bin file is what you need. Try the latest US Linksys Firmware for the GS v4.70.6 first - the 3rd party ones add extra features and increased power but are currently based on slightly old Linksys code so may not have whatever fix Linksys have applied to patch their latest hardware.

    I also recommend you download and install netstumbler on the PC with worst connection - play around with channel numbers and aerial orientation to get the best signal. I've just made my laptop connection rock solid @54Mbps* by poking the aerials out horizontally!

    * which peaks at 32Mbps actual data transfer rate.
  70. elconejito

    elconejito Network Guru Member

    Thanks for the response. I'll try again when i get home this weekend (I'm dogsitting at my gf's this week while shes out of town). Looking forward to a *stable* connection :cheering:
  71. elconejito

    elconejito Network Guru Member

    Just an update. The new firmware seemed to fix it for the most part, but I still have some disconnects, and speed still ramps up and down altho not nearly so much. i have tried channel 1 and 3 so far (i think 6 was the default) and 1 was terrible, 2 is better than one not as good as 6. I havent had alot of time to play with more channels and the antennas yet.

    Am i going in the right direction or do i need to do something else?
  72. RastaFaI

    RastaFaI Network Guru Member

    Multicast issue ?

    Hi there,

    I've a WRT54GS hardware 1.1 and soft 4.70.6.

    I think that I have a problem similar to those described in this topic.

    Using multicast stream:
    - wired thru 54GS works fine
    - wireless starts working, then the connection drops after a random time.

    If I enable firewall (uncheking filter multicast obviously) it won't work.
    Disabling security for wireless will make the video play longer, but a the end the router crash.

    My problem seems similar because the symptoms of dropping are the same (I can see the speed of connection decreasing....54,48,36.....,2,1 the drops !)

    Anyone could help ?
  73. waddi

    waddi Network Guru Member

  74. adywarna

    adywarna Guest

    Finally.. if you love your current firmware so much like me, and would not go for others, try the instructions below. I am using Alchemy-V1.0 v3.37.6.8sv on WRT54G v2.2, and love the SNMP feature. This effectively remove all drops when transfering large files...

    1. Go to Administration, Diagnostics, Run and paste the follow then click "Cmd"
    nvram set clkfreq=216
    nvram commit
    **Warning: Do not change any clock speed other than 216. It could brick your router.

    To check you current clock speed paste the following and click "Cmd".
    nvram get clkfreq
  75. Woolbox

    Woolbox Guest

    I got hooked up when transfering certain files over the WLAN after less than 10MBs on my WRT54G v.2.2 (only used as access point).

    Just upgraded to version 4.20.7 which seems to have solved the issue (partly anyway), check this out from their rel. notes: "Resolves large file transfer issues".

    Anyway, now it's all stable but my throughput seems to peak at about 33% of 54 mbit on my Dell Truemobile 1350b/g integrated card in Latitude D600 (according to the networking tab of Win XP's task manager). I have experienced range problems with this NIC, but I'm at a "very good" level, so shouldn't I have close to 54 mbit throughput?

    Maybe the new firmware just takes the top of the speed?
  76. scawa

    scawa Network Guru Member

    This is disconcerting...

    I'm an online trader. The amount of data flow through my WRT52G is huge because I get streaming quotes for multiple markets and multiple stocks.... For this reason, I am using a direct port hookup to my Linksys Modem.

    Under high data loads, the connection keeps dropping out. I've been calling Comcast with nasty messages.... but it appears that it's the Linksys modem....

    I also can't run my stock program AND a wireless laptop withough dropping the wireless connection.....

    I upgraded firmware to 4.00v5.... I guess I have to upgrade to 4.20.7...

    If this doesn't work, can some one suggest a decent modem that can WORK OUT OF THE BOX.... Very agravating.... :wallbang:
  77. oraclejones

    oraclejones Network Guru Member

    i also have a WRT54GS v 1.1 . yesterday i have installed the last HyperWRT by thibor from 08/10/2005 based on the originally linksys firmware 4.70.6. this problem should normally have been removed in this firmware. unfortunately, there still are the interruptions.

    does anybody know another solution?

  78. smrh2002

    smrh2002 Network Guru Member

    Hi oraclejones,

    i have the same problem as you. WRT54GS and HyperWrt Thibor 08/10/2005 based on 4.70.6.

    When i want transfert 4GB from PC2 to PC1 wireless i get the message error .....

    Please does any body know what to do now to resolve this problem ?

    Many thanks.
  79. oraclejones

    oraclejones Network Guru Member

    @ smrh2002

    i hope to be a step further again. my provider operates wireless internet on the channels 7 and 13, it was recommended to operate the internal wlan on channel 1. someplace i have read that changing the channels brings something. if i am at home again, i will test the whole thing. i will try channel 2, then 3, ...

    perhaps you can tell me on which channel you operate your WLAN?

  80. smrh2002

    smrh2002 Network Guru Member

    I tried all channels from 1 to 11 ... I have still the problem ...
  81. nani

    nani Network Guru Member

    hey most of them seem to be wrt54g v2.2 's.it could be a product known issue.is there anyone having same problem and a different hardware version?please post if u do.
  82. Toxic

    Toxic Administrator Staff Member

    the vast majority of the throughpout issues we solved with Linksys overclocking the router to 216Mhz. no all issues were fixed with this but most were.
  83. ranpha

    ranpha Network Guru Member

    My router: WRT54G v2.2
    Firmware: 4.20.7 official.
    My adapter: D-Link DWL-G22 - USB2.0 port is used.
    OS: Windows XP SP2 patched fully.

    After a few hours of heavy Bittorrent session (multiple torrents downloaded at once), my computer will suddenly lost the wireless conenction to the router. My computer doesn't lock-up unlike some post in this thread, but I have to restart Windows to get my connection back.

    The router doesn't seem to crash, because if it does, my WAN IP would have changed (my ISP assign dynamic IP, it will change everytime a PPPoE session is started, and I can hold any IP as long as the PPPoE session is not disconnected). Of course I will not know if the WRT54G can reboot without losing the PPPoE connection.

    I use both WZC and the Odyssey client, and the same thing persists. No amount of scanning will make the router WiFi signal detectable again. Removing the adapter from the USB port and reinserting it again also doesn't work. I have to restart the computer to make it work again.

    BTW, if I only use the connection for casual surfing or lighter BT sessions (only one or two torrents running at the same time), there will be no problems.

    I want to know whether WRT54G can reboot without losing PPPoE DSL connections, and also any opinions whether the router is the fault or my computer.

  84. Toxic

    Toxic Administrator Staff Member

    more likely it is the WRT54G not being able to handle heavy loads for a long periad of time. can you limit the max upload speed in your BT client software?

    what firmware are you running at the moment?
  85. ranpha

    ranpha Network Guru Member

    I did limit the upload speed to around 80% of my max upload.

    Firmware is 4.20.7 official from Linksys.
  86. exist2ski

    exist2ski Guest

    linksys problems

    I hate to say, but I have ben doing lots of research lately about several different linksys routers and every single model has the same problems, including my befw11s4 v4 which I spent 3 hrs on the phone (2 of which were with level 2 tec) to find out what I allready knew. :eek: I have a server 2003 (hardwired), XP pro (hardwired), and 2 xp pro laptop (wireless). my server is running 2 websites and a MU game server which started having problems after comcast upped my connection to 6 megs. try to stream video with a fast sonnection and the latest firware (on a befw11s4 v4) and the router locks up until you reboot it. I spent some time on some gaming forums (if you are looking for something that doesn't work just disconnect a 15 yearold gamer and you will hear more than you can handle) every game forum has a entire forum dedicated to one or more linksys routers and the problems that are associated with it.

    Now, I have tried the US robotics router and it works for most things but for me the DMZ does not function properly (as needed my the game I host.) for most unless you are hosting websites or other such things you should never notice a issue. I will now be returning this router and searching for another. I would stll be using the befw11s4 v4 if the speeds had not increased... it was great for the 2-3 years I had it... oh well feel free to contact me if you have specific questions exist2ski@comcast.net
  87. oraclejones

    oraclejones Network Guru Member

    I always had problems when copying bigger files. I have established my network instead of with the client function with WDS now. And see there > the transfer of bigger files works now. I use the last dd-wrt firmware.

  88. the_gift

    the_gift Guest

    sorry, i have no energy to read throughly all 30 pages, i had read about 5 from beginning and from the end, but someone tried to set manually transmit rate to 11, even to 5 mbps and change preamble to short? in most cases it's solves the problems with wi-fi transfers.
  89. mstombs

    mstombs Network Guru Member

    But it would be quicker to unplug the PC and plug in locally with a network cable for large transfers!
  90. handyaswan

    handyaswan Network Guru Member

    for: exist2ski

    what firm version u used in befw11s4 v4? official firmware?
    what version number?

    couse i still use since 1 year until now befw11s4 model (s/n:c2760d2c8759 e1) with v.15.2 official firmware, and i had some trouble, like disconectly every minute....(every 30 minute or 1 hours...)
    this is bad situations...... [can this trouble come from overheat?]

    anybody can help my trouble? specialy for mr exist2ski..

    thx u..all
  91. Bazzek

    Bazzek Network Guru Member

    WRT54G v5

    I have a WRT54G v5 with firmware version 1.00.2 (latest)

    My issue is almost the same as some of the ones i read here (have read the first page and the last 4).

    I have 1 machine hooked up to the wired LAN connection number 1. On this system i run a private FTP server.
    The WRT54G is connected to a Speedtouch Home DSL modem using a PPTP connection (no choice atm).

    If i connect to the FTP server from work (set up the ports etc), i can start the download just fine, but after a while the complete router seems to reset. I can't reach the web admin pages or use VNC on my PC (or conect to the FTP server). I am not using the wireless setup in this situation, so i think it has nothing to do with this. I also have no issues when i am downloading to my PC or copying between my laptop and PC through wireless.

    I read something about overclocking the router as a fix, is this available for the v5 routers too ?
  92. Bazzek

    Bazzek Network Guru Member

  93. Gekko2

    Gekko2 Guest

    I have a Thinkpad T42 with an Intel Pro 2100 wireless card and Windows XP SP2. Comcast Cable ISP. I was using a Linksys WRT54GS version 1. I had intermittent disconnect problems especially when trying to stream audio or video (ex. youtube) or when trying to download large files. The wifi connection would just drop and then reconnect a few seconds later - usually screwing up the stream or download. I installed both latest drivers/firmware and still had the problem. I tried all of the other various fixes/settings found on the internet and nothing worked to help fix this setup. After reading all of these issues with this Linksys router, I concluded that I should try another router brand. Last night I went to Best Buy and picked up the NETGEAR RangeMax Next Wireless-N Router - Model: WNR834B for $99.99 and all of my wifi problems were solved. Good luck all.
  94. Toxic

    Toxic Administrator Staff Member

    nice of you to open a 2 year old thread:)
  95. Gekko2

    Gekko2 Guest

    yet still relevant today.
  96. vincentfox

    vincentfox Network Guru Member

    Intel 2100 if I recall were notoriously finicky about drivers. I had one of those once and getting the right driver on it solved all kinds of problems for me, that I thought were the fault of the Access Point.
  97. Travelller

    Travelller LI Guru Member


    same/similar problem, I guess as the OP.

    Via an 802.11g connection I can surf all day long, even download large files, but when transferring files over my own LAN I get drop-outs which sometimes restart, other times I get a connection-lost error.

    No such problems via an ethernet connection to the router. Problem occured to two different Notebooks, both with different OSes (VISTA & W2KSP4).

    I have an "older" WRT54GS version (1.1) but I could not find any official firmaware for EU and only the U.S. one (4.71.1 4/25/2006) and of course, access to several "GPL" versions but the last EU-specifc listed is 3.37.2 which is what I've got right now.

    Furthermore, I have zero experience with GPL code and I do not know how to install such ".tgz" or ".tar.qz" files :p

    Lastly, the 4.71.1 includes, among other fixes:
    "Firmware 4.50.6 - Resolves large file transfer issues"
    which may or may not help to solve my problem.

    What would you suggest I do, go with the U.S. version and lose ch. 11&13 or would you suggest a specific GPL version that you think may resolve my problem better?

    Any input would be greatly appreciated :)
  98. Travelller

    Travelller LI Guru Member

    Well all good forum members use the SEARCH function prior* to making a new post :D

    *'Cause if we don't we usually get flamed by moderators & Admins, ahem... :tongue:
  99. Toxic

    Toxic Administrator Staff Member

    I would use either Thibor's 15c firmware if you want the same feel of webgui or if your wanting more functionality then go for tomato firmware
  100. mstombs

    mstombs Network Guru Member

    Gosh - blast from the past - my UK WRT54GS v1.1 had a very reproducible fault on specific files transfer via Wireless, not just large ones and I had to use the US 4.50+ versions to make the box usable, then progressed through Hyperwrt Thibor for a couple of years - now moved onto Tomato!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice