WRT54GS Loss Of connection when using Azerus

Discussion in 'Cisco/Linksys Wireless Routers' started by Evil_Genius, Nov 21, 2005.

  1. Evil_Genius

    Evil_Genius Network Guru Member

    I have just recently bought a linksys router WRT54GS v1.1 and everything works fine except for when i run Azerus or emule. I am able to surf the web when i start up azerus or emule for a couple of hours. However after a while i am unable to surf the web, but azerus or emule seems to still be connected. The only way to get back my internet connection is to hit the reset button on the back of the router. I have already upgraded the firmware and locked down the router. I use azerus and emule almost continuously and if the router is unable to handle them then its pretty much a paper weight to me.

    Anyone got any suggestions on how i can solve this problem, any help would be greatly appreciated

  2. moidoi

    moidoi Guest

    I have the same problem. Just got the wrt54g and continuously run azureus. The internet will work fine for a couple hours then internet connection to all computers die but azureus is still doing it's thing. Once I close azureus, the internet works fine again. I've tried another torrent client, utorrent, same thing... When this happens I can't even ping the router...

    there must be a fix for this...
  3. dalimdalim

    dalimdalim Guest

    exact same problem.. as described.. :thumbdown:
  4. Evil_Genius

    Evil_Genius Network Guru Member

    Now i have new problem...After running the router for a couple of hours without Azerus or emule running it spontaneouly disconnects all my wireless clients. I have to reboot the router to gains access again. Once i had to unplug the router...modem and reboot the pc to bring up back my internet connection for my wireless connections.

    This router is proving to be a big pain in the but....And im starting to question the quality of linksys products in general.

    If I cant get get this thing to work in the next week or so...Back to the store it goes, and back to my d-link 624 router.

    If you got any Idea on whats going on, and of how i can rectify it it would be greatly appreciated.
  5. danielhaden

    danielhaden Network Guru Member

    The latest HyperWRT contains "frequent TCP cleanup" to support p2p and bittorrent style downloading. You may also activate "frequent TCP cleanup" by a startup script.
  6. Evil_Genius

    Evil_Genius Network Guru Member

    Thanks for the help...much appreciated...

    Apparently this does solve most of my issues. However i still do loose connection to the internet and im not able to surf the net. I no longer have to hit the reset button on the back of the router i just gotta wait a couple of minutes for it to kick in.

    Also i notice that when I start surfing the net the connection is great however after about 30 mins its starts to degrade and becomes horrible slow.

    Thanks for the help much appreciated...hopefully i can work out all the bugs in this router.
  7. THILE

    THILE Network Guru Member

    well doesn’t every router do this?

    My current router is a very cheap northQ, and does the exactly same thing as yours.
    Its stop the internet in some way, but still it works at the same time.

    It’s like the router can’t make new connections, but can use the old ones.
    If I recently had opened up Google (before the crash), I can still use it, but not a new page I haven’t visited before the router "got weird". And edonkey can still download from the peers it already has connected to.

    Then after 5-10 minutes, it is all back to normal. This thing can happen 10 times a day, and I really hate my router. (and there hasn’t been any firmware updates for 2 years)
    I hoped that if I bought a more expensive router this would be gone.
    I have actually ordered a WRT54GS, and after you story I doubt that this was a good choice.
    (even if I use 3. party firmware)

    (Just needed to get something out. Becouse my stupid router had just been going down again)
  8. Evil_Genius

    Evil_Genius Network Guru Member

    I agree with you about most routers being crappy at handling P2P applications. I have previously purchased a D-link and SMC routers which i throughly hate, and thus the reason i bought the Linksys WRT54GS.

    At first I expected to just plug the router in, upgrade the firmware and i should be good to go. I was obviously wrong!

    However because of the info I found on this site I have since resolved all my issues with this router, and am happy to say that so far this router has met and exceeded my expectations. By far this router is my best purchase so far.

    To give you an idea of how well this router is working for me right now i am running Azerus (bittorrent) 20KB/s Down, 10 KB/s Up and emule 20KB/s down, 10 KB/s Up and i am still able to surf the web realatively well provided i am killing my Bandwidth. This setup has been running for 24hours and I havent had to reset it once.

    ill be testing this router with the same setup for the full week and will report back. If all goes well ill post a detailed tutorial on what you need to do to get your router up and running.
  9. danielhaden

    danielhaden Network Guru Member

    The QOS, Quality Of Service options are very helpful with peer to peer.
    Using the latest versions of HyperWRT from Tofu and Thibor (more info at the forums of hyperwrt.org) you can set bittorrent's application port priority to lowest--but it will still go full speed if nothing else is using the connection. And you can use it at the same time as Skype or any VOIP.

    For multiple clients all downloading or using VOIP all simultaneously, you can list their MAC addresses on low (or better) priority. Just by listing their MAC addresses, you'll activate the bandwidth streaming feature, which has the same benefit as the Hawking Broadband Booster product. And, as usual with QOS, low doesn't always mean low as the speeds are all flexible. ;)

    One thing that strictly governs the speeds of QOS is that you should enter 83% of your connection speed (expressed in kbits, not kbytes) into the box at the top of the page. Some people need to use an 80% figure for a more "harsh" QOS.
  10. Juno

    Juno Network Guru Member

    This is a very interesting thread. I too just started experiencing the locked up router problem with my 54GS. I have been using bittorrent (azureus) regularly for about a year now and have never had a problem. For about the last month, my internet connection drops at least once a day. When this happens, I cannot even ping the router. I just cycle the power and I am good to go again. Since this has only been occuring for the last month, can it be attributed to the torrent client?

    I have also noticed a major performance decrease as of late with Azureus. I used to get down speeds anywhere from 50kbps to 220 kbps. Lately, my downloads start fast, only to die off to 0 kbps for both up and down within a minute. The only change was an update of Azureus from version 2.0.4 to 2.0.6. This problem occurs on all computers on my network. I have read in forums elsewhere that this may be due to Rogers throttling ports to block torrents. :(

    Anyhow, I tried assigning static IPs and port forwarding (used to rely on UPnP with DHCP assigned addresses...and it worked great). I also tried port triggering. No joy on either front. I tried to probe my port forwarded "listen port" from the grc site and it still showed as stealth!?! Should a forwarded port not show as open? The client shows everything is good and I get green smileys, just no traffic and eventual router lockups.

    I am going to try HyperWRT Thibor tonight, to see if that helps. Any other suggestions?

  11. NateHoy

    NateHoy Network Guru Member

    That could be, but if the fix involves only powercycling the router, and not your modem, too, then Rogers would keep those ports throttled.

    Azureus 2.0.6 might be capable of managing more ports, or it may have defaults for the number of ports to use set higher, or it may be more aggressive about re-connecting to "lost" peers with a new port.

    Given that the WRT54G (and I presume the WRT54GS) has a default to keep connections open for 5 days, and has a limit of 2,048 connections by default (if I recall), BitTorrent can chew through those connections FAST. The more simultaneous connections you keep open, as peers come and go, the more you chew up your connection pool in the router. When the pool gets empty, the router cannot allocate new connections, and things go PHHHHT!

    Aftermarket firmware (I use HyperWRT Tofu - HyperWRT Thibor is the equivalent for the GS models) sets the cleanup of unused ports to anywhere from 10 minutes to 30 minutes, rather than 5 days, so your connection pool gets cleaned more often, and the router stays up a LOT longer. With startup scripts, you can also modify that cleanup interval by changing that cleanup period. I use 1/2 hour, personally:

    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    The critical number there is the second one. 1800 seconds = 1/2 hour. If you have a firmware that supports startup scripts, give it a spin!
  12. NateHoy

    NateHoy Network Guru Member

    Unfortunately: ALL of the "consumer" grade routers appear to have this problem to a greater or lesser extent, and I suspect most of them are caused by the router not cleaning up connections frequently enough, or simply lacking the capacity to manage so many connections in the first place.

    Fortunately: Linksys was smart enough to GPL the source code for their router, and base it in Linux, so excellent geekazoids like Tofu, Thibor, Avenger, Brainslayer, and a host of other I'm not mentioning for the sake of brevity can improve upon the native firmware they include.

    Of course, now that Linksys has castrated the WRT54G V5 units... There's an "unfortunately" again, if you are unlucky enough to end up with one.
  13. pojo

    pojo Network Guru Member

    When I had this problem (on my 1.1) I was able to solve it by changing Azerus's settings to reduce the number of total connections. It's in Preferences -> Transfer and I've got it set to 75 max conn. per torrent, 400 max total (which is actually irrelevant due to other settings), 5 max upload slots per torrent. Then in Preferences -> Queue I have 4 max torrents total and 2 max downloading at once.

    The Azerus wiki has a guide to getting good settings that I found very helpful.
  14. Juno

    Juno Network Guru Member

    NateHoy - Powercycling brought functionality back to my router. I could not even ping it when it crashed. Torrents did not work any better after power cycling. Ports still throttled?

    I seem to have solved my problem for now. I completely removed Azureus and Java from my systems. I installed the latest HyperWRT (thibor) and forwarded a bunch of ports for both TCP and UDP. I tried Bittornado as a client and it seems to be working pretty good now - had two concurrent downloads each running at approx. 80 kbps down. Much better than the 0 kbps I was getting with Azureus :thumb: I don't know what happened with Azureus as it worked very well before. Unfortunately, I am not sure if it was the router firmware, the bittorrent client or changing port ranges that fixed the problem. I do not think it was the port range as I tried all different ports with Azureus as well. The client's use of the ports differs though. Azureus only requires one forwarded port whereas Bittornado requires a range (I forwarded 100 ports).

    Cheers :drinking:
  15. NateHoy

    NateHoy Network Guru Member

    Sounds to me like the ports were throttled on you, and teh fact that BitTornado supports multiple ports probably means that it can "switch out" ports when your ISP locks them, or load balance them so your ISP isn't aware that you are doing P2P.
  16. catharsis

    catharsis Guest

    Let me understand...

    Hi everybody
    I've read thousands of posts in this forum, but my question (following) hasn't got an answer, yet; could anyone clear my doubt?
    I'm interesting in buying a WRT54GS router, but I guess that buying a new one it will be a v.5 or more (s/n begining with CGN7-9), so it won't be upgradable with a Hyperwrt firmware, because it is a third party firmware. Is it true?
    If so, the only way to get an older version of this router is buying an used one (not in a computer shop, i mean). Is it correct?
    Thank you for any answers.
  17. Toink

    Toink Network Guru Member

    You can either buy a second hand (v4 and below) or buy a brand new WRT54GL which works well on 3rd party firmwares (I use Thibor's) and AzureUs
  18. GhaladReam

    GhaladReam Network Guru Member

    The WRT54GL isn't the only option either. There's the WRTSL54GS which takes Thibor, and has a USB port for external hard drives, or as a print server. Also, there are several other routers that support 3rd party firmwares that are just as capable as Linksys ones. Buffalo Technology makes the WHR-G54S and the WHR-HP-G54, to name a few... Both capable of taking 3rd party firmware.
  19. baboon99

    baboon99 Guest

    Azureues slow downs....

    I sorted this out using a TCP ip patch that fixed the half open sessions in windows xp and vista.
    I always notice the crap browsing when using p2p.........in XP
    But when I migrated to vista azureus was unusable.......patched tcp/ip and all sorted again.....
    Browsing is still a little slower but workable.
    If you wanna link to the patch let me know.....
    Hope this helps.....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice