WRT54GS OpenWRT RC4 Password Problem

Discussion in 'X-WRT - OpenWRT Firmware' started by rojones82, Aug 28, 2008.

  1. rojones82

    rojones82 Guest

    As the Subject suggests i have an old Linksys WRT54GS Router which i have aquired with White Russian RC4 on it, but i do not know the login details.

    I have tried following the procedures in the sticky on the openwrt site (but thats listed for RC6) with no real joy.

    I can get to the point where the DMZ flashes 3 times a seconds and then i can telnet to the device, but when i try the following commands i get the following outcomes.

    when im at the root@OpenWrt:/# prompt, i typed in passwd and it brings a menu to change the password, but no matter what i type (In accordance to the password convention) i get a generic error saying it failed.

    So i then Try the following command

    mount_root; passwd

    Which gets me to similar position to before except after typing this command there is a message stating "mounting none on /dev/pts failed: Device or resource busy" followed by the change password screen, i then type in a password again and confirm it, and it states "Password Changed" so i then try and log in to the Web Client with the details Username : root and my password and it doesnt work.

    I then go back to the telnet and type in passwd and enter and confirm my password again and now it doesnt say a generic error and yet again im unable to log in to the web client.

    At this point im happy to flash this thing back to original Firmware if i knew how from the telnet session if possible ?
  2. Bill_MI

    Bill_MI Network Guru Member

    Have you tried the tftp method? The resident boot loader can accept any standard Linksys *.bin file for THAT router in a small window after reset. Worth a try: http://wiki.openwrt.org/OpenWrtDocs/Installing/TFTP

    I've done this a lot on a WRT54GS v3. Be patient and methodical as I've found it best to send several seconds prior to the ping reply.

    Otherwise, I'm not familiar with the mode you're getting into since telnet is usually disabled once passwd is set. I think you'll find too many hurdles to flash from memory. If you can get the file into /tmp (RAM)... and make it into a "trx"... and have mtd... here's an old thread I use as reference: http://forum.openwrt.org/viewtopic.php?id=1797 Far far more risk this way.

    Good Luck!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice