WRT54GS router possible firmware problem

Discussion in 'Cisco/Linksys Wireless Routers' started by stevo_300, Jan 19, 2007.

  1. stevo_300

    stevo_300 Guest

    Hi there,

    I have a WRT54GS v5.1 router, i recently tried to upgrade the firmware on this from the 1.50.5 that was on it originally to 1.51, however after which the router has not worked. It started by not creating any connection to the computer at all, so i tried a hard reset (holding the button on the back for several seconds) but this was unsuccessful.

    Now it does occasionally create a connection with a PC via ethernet however its on the IP address, and when i try to browse to the management page all i get is a white screen saying 'Management Page, Firmware Upgrade'.

    I have been told that a possible problem could be that i have tried to put US firmware onto a UK device and this could be problem, since then I have tried using the management page to put firmware v 1.50.9 onto the device however the same problem persists.

    I apoligise I am new to the world of routers and networking so if anyone can provide any help on how to bring my router back to life i would be greatly appreciative.


  2. mjpartyboy

    mjpartyboy LI Guru Member

    I went from 1.50.5 (UK) to 1.50.9 (UK) and then 1.51.0 (US) without any problems like this, before updating the firmware it's best to reset the router to factory defaults, but I've had various wired and wireless connection and stability issues with both 1.50.9 and 1.51.0.

    I couldn't find instructions explicitly for the WRT54GS, but here's Linksys' help page for Management Mode on a WRT54G v5:


    Hopefully this helps.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice